Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 23 Sep 2017, 01:56
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Gramps de RSH?
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
oui

Joined: 20 May 2005
Posts: 3022
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Thu 26 Jan 2017, 18:55    Post subject:  Gramps de RSH?
Subject description: réponse à Pelo
 

http://www.murga-linux.com/puppy/viewtopic.php?p=940952#940952
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 12514
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 27 Jan 2017, 01:58    Post subject: Gramps fonctionne aussi sous Slaxen 6.3.2  

Gramps fonctionne aussi sous Slaxen 6.3.2, la version alpha en test par nous les pro. La 6.0 échoue, mais on va pas modifier l'ISO maintenant. J'ai bien noté pour la Lazy Puppy, j'ai la version Lucid, j'en resterai là.
En tout cas tes tutos me sont bien utiles oui. Il ya des d'autres logiciels que Gramps, en moins bien. C'est une passe temps bien agréable, la généalogie, mais je ne tombe que sur des laboureurs, et quelques soldats de la guerre de 14, qui ont eu une médaille. Même pas un voleur, pas de linuxeurs.
chemin.png
 Description   Lier les photos, si possible
 Filesize   68.23 KB
 Viewed   45 Time(s)

chemin.png


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.

Last edited by Pelo on Fri 24 Feb 2017, 08:48; edited 1 time in total
Back to top
View user's profile Send private message Yahoo Messenger 
Argolance


Joined: 06 Jan 2008
Posts: 2976
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Fri 27 Jan 2017, 07:42    Post subject:  

Bonjour,
Je ne sais pas si la question doit être posée ici mais j'ai téléchargé Gramps en utilisant cette commande trouvée sur l'impressionnant et très documenté tutoriel fait pas Cool ui:
Code:
wget http://smokey01.com/RSH/LazY-Puppy-201/lp201-sfs/single-apps/LP2_Gramps-3.4.1.sfs ~/

Le programme se lance correctement sur ToOpPy, mais la console renvoie:
Code:
1511: WARNING: Spell.py: line 60: Le vérificateur orthographique n'est pas installé
3170: WARNING: bottombar.gpr.py: line 90: MISE EN GARDE : le module pyexiv2 n'est pas chargé. Les métadonnées image ne sont pas disponibles.
3279: WARNING: geography.gpr.py: line 42: MISE EN GARDE : le module osmgpsmap n'est pas chargé. Les fonctionnalités Géographie ne seront pas disponibles.
Ces fonctionnalités semblent importantes.
Où trouver ces modules?

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
oui

Joined: 20 May 2005
Posts: 3022
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Fri 27 Jan 2017, 14:26    Post subject:  

bonjour Argolance,

tu as raison. ces deux fonctions sont DEVENUES importantes:

localiser ses ancètres et les anciens terrains liés au passé familial sur une carte, localiser les descendants, toute la tapée de cousins cousines que chacun a

et faire revenir la mémoire des gens en montrant leur portrait, ou l'authenticité des faits, en illustrant le travail de mémoire avec des copies de documents authentiques.

mais elles ne sont pas indispensables: les vieux généalogues fourraient tout ça dans un classeur et une boîte à photos, un numéro sur chaque pièce, et, bien rangées, elles rendaient les mêmes services.

c'est la même chose par ex. avec le dada des applications dont je ressens le besoin, Merkaartor, du nom du géographe germano-belge, professeur à l'université de Duisburg, qui a beaucoup influencé la cartographie moderne. La aussi, on peut, dans les nouvelles versions, localiser avec GPS, adjoindre des pièces agrémentant la carte travaillée etc.

toutefois il est à remarquer que, si c'est ça que nous voulons tous, il va falloir remanier énormément les outils de développement, et, surtout, d'installation. Car si tu tentes de te compiler de tels logiciels dans leur version la plus actuelle, tu dois alors te taper parfois des centaines de dépendances avant de recevoir le message "bien joué" qui te dit que vraiment tout est d'équerre et que tu jouis de toutes les possibilités.

dans des environnements tels que Puppy, on devra se contenter souvent de logiciel amputé, ou du logiciel-singe, qui ne sait rien faire d'autre que les fonctions de l'homme des cavernes...

cordialement
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 2976
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Fri 27 Jan 2017, 17:20    Post subject:  

Bonsoir,
oui wrote:
on devra se contenter souvent de logiciel amputé, ou du logiciel-singe, qui ne sait rien faire d'autre que les fonctions de l'homme des cavernes...
Tu vas un peu vite en besogne car en approfondissant un peu, il se trouve que les modules pyexiv2, osmgpsmap et autres dépendances signalées à l'installation sont disponibles via PPM! Wink

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
oui

Joined: 20 May 2005
Posts: 3022
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Sat 28 Jan 2017, 06:06    Post subject:  

c'est vrai, mais ce n'est pas vraiment à ceux-ci que je pensais:

de nombreux logiciels tournent encore sous des bibliothèques fondamentales obsolètes.

par exemple sous Kubuntu 17.04 qui est l'autre système d'exploitation que j'utilise, à côte de LazY Pup unicorn (precisement dans le but de disposer de bibliothèques recentes, dans les deux cas! Bien que nous soyons sur Unicorn depuis plusieurs annees maintenant, et, oui, Unicorn est encore et toujours l'un de nos plus recents systèmes puppyistes que Barry avait reellement choye un certain temps...), qupzilla est encore de la generation 1 et des poussières, dans la version test 17.4!, et le contrôle orthographique n'est pris en compte dans qupzilla qu'à partir de la version 2 !!! Quelle sera la taille du binaire de la version 2, deja disponible dans certains autres Linux? Pour moi, mystère.

Autre exemple, Xombrero a ete remis à jour, et tourne desormais avec les bibliothèques recentes dans 17.04. Midori, si je me rappelle bien, non. Vimprobable (encore installable sous 16.04 quand elle etait encore "test") ne se laisse plus du tout installer, car le dernier binaire fut installe sous les anciennes bibliothèque C ! Donc si tu devais avoir tout mise sur Vimprobable, ce qui est peu probable (bon jeu de mots, non?), et ben c'est tintin... La visualisation sur Kubuntu, qui etait defectueuse depuis 2 ou 3 ans, a ete reparee dans 17.04. Si tu as un ordi comme le mien, et que tu veux KDE (tu as vu, je l'utilise aussi VRAIMENT dans LazY Pup!), et bien cela redevient seulement possible avec 17.04 (c'est d'ailleurs une des raisons pourquoi je ne me contentais pas de (K)ubuntu ces dernières annees et que je faisais certains travaux sous un modeste mais excellent Puppy, qui, d'un autre côte, presentait d'autres perturbations non moins graves: Dans Xombrero, que j'utilise aussi comme navigateur principal sous LazY Pup, une defectuosite qui ne se presente que dans les Puppy's assez recent pour pratiquement TOUS les derives de Webkit, est lassante (les champs d'entree de donnees sont encadres d'un enorme bord noir! Un phenomène que l'on ne rencontre que dans les Puppy's et nulle part ailleurs à ma connaissance, donc provient sans doute de bilbliothèques typiquement Puppy que l'on recopie bêtement au lieu de conserver celles d'origine d'Ubuntu pour les Puppy's derives d'Ubuntu, ceux derives de Slackware, je ne peux les utiliser: les cercles sont ovales...)!

etc...

crdlmt
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 12514
Location: Mer méditerrannée (1 kms°)

PostPosted: Tue 31 Jan 2017, 00:44    Post subject: un des logiciels les plus élaborés tournant sur Puppy Linux  

nonobstant tout çà, Gramps est vraiment un des logiciels les plus élaborés tournant sur Puppy Linux. Si la géo localisation de nos morts ne fonctionne pas, on peut se servir du navigateur et de google Maps. De la à entrer en communication avec eux.. Quoique... je mets les vivants aussi dans ma base.
Attention , à la lecture du forum, à force de mettre en avant ce qu'on a pas et de ne pas parler de ce qui va bien, on donne l'impression que la Puppy ne sort rien des tuyaux et est agonisante, comme le dit souvent oui. Elle va passer dans l’au-delà, remplissons sa fiche vite fait. Oui, au boulot, tu sais tout d'elle.
Ne donnons pas des pretextes pour ne pas remplir les cases. Ces bases de données au format déjà créé pour le domaine auquel il s'applique sont du pain béni. Les databases c'est très bien, mais se coltiner la création de la mise en page c'est une vraie galère. Pour Gramps, d'autres l'ont faite pour nous. Merci à eux.
Exiv2 donne les propriétés de la Photo. Est-ce bien une fonction nécessaire ? Voir la section Graphics. Quand vous retouchez une photo vous perdez les données exiv, qui ont un bien faible intérêt, en section généalogie. Je conseille fortement de ne pas joindre les photos, mais de les lier, pour ne pas faire de la base un album photos volumineux.

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo


Joined: 10 Sep 2011
Posts: 12514
Location: Mer méditerrannée (1 kms°)

PostPosted: Tue 31 Jan 2017, 01:23    Post subject: Pour ceux qui trouvent que les SFS de RSH sont du pain béni,  

Pour ceux qui trouvent que les SFS de RSH sont du pain béni, il en a fait la liste ici. . On peut s'en servir sans la Lazy Puppy, bien que çà doit le faire un peu enrager d'avoir travaillé pour les concurrents. Mais c'est le principe de la communauté, C'est le libre.
Tant que faire se peut, je me sers de son SFS. Un vieux gramps prendra en compte les data d'un jeune Gramps, mais l'inverse n'est pas vrai.
Je fais tourner une version récente de Gramps sur XenialDog (En Puppy User testeur pro), il lui manque aussi :
root@xenial:~# gramps
.gramps.gen.utils.grampslocale.WARNING: ICU not loaded because No module named 'PyICU'. Localization will be impaired. Use your package manager to install PyICU

Mais bon.. Faisons avec ce que l'on a.

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo


Joined: 10 Sep 2011
Posts: 12514
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 01 Feb 2017, 08:59    Post subject: Slaxen 6.0 gramps-3.2.5-i486-1dj.txz
Subject description: Fournie gratis par Salix
 

Pour les Slaxenistes utilisant la version publique 6.0 la version Gramps de Salix ici vous ira très bien, pour débuter comme moi. Vous verrez après pour les fonctions de sophistication.
_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.

Last edited by Pelo on Sun 07 May 2017, 19:55; edited 1 time in total
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo


Joined: 10 Sep 2011
Posts: 12514
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 24 Feb 2017, 08:28    Post subject: pour la slaxen 6.3.2 un petit bricolage s'impose,  

pour la slaxen 6.3.2 un petit bricolage s'impose, pour éviter de monter le DEVX. Le sfs de RSH tourne alors pour faire le Curriculum Vitae de vos ancêtres, morts ou vifs.
J'y suis arrivé, donc c'est pas sorcier .
tessier.jpg
 Description   Elle est connue, elle...
 Filesize   43.53 KB
 Viewed   48 Time(s)

tessier.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0450s ][ Queries: 13 (0.0061s) ][ GZIP on ]