Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 21 Apr 2014, 04:15
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
2.14 Alpha: Remote Desktop Client won't run [Solved]
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Sun 28 Jan 2007, 05:26    Post subject:  2.14 Alpha: Remote Desktop Client won't run [Solved]
Subject description: Missing RDP lib?
 

Remote Desktop Client refuses to run under 2.14a - running from a terminal produces the following output:
Code:
sh-3.00# remotedesktopclient
Error in startup script: cannot open libpng.so.2.1.0.8: libpng.so: cannot open shared object file: No such file or directory
    while executing
"image create photo -file $imgLocation -format png"
    (procedure "screen" line 6)
    invoked from within
"screen"
    (file "/usr/sbin/remotedesktopclient" line 640)

I am using rarsa's improved remotedesktopclient GUI v0.3 to no avail. Any ideas? Original script worked ok, so I can see no reason why rarsa's improved script shouldn't function. It works fine in 2.13

Last edited by WhoDo on Wed 14 Feb 2007, 07:07; edited 2 times in total
Back to top
View user's profile Send private message 
Leon

Joined: 22 Jun 2005
Posts: 220
Location: Slovenia

PostPosted: Mon 29 Jan 2007, 06:27    Post subject: Re: 2.14 Alpha
Subject description: Missing RDP lib?
 

WhoDo wrote:
Remote Desktop Client refuses to run under 2.14a - running from a terminal produces the following output:
Code:
sh-3.00# remotedesktopclient
Error in startup script: cannot open libpng.so.2.1.0.8: libpng.so: cannot open shared object file: No such file or directory
    while executing
"image create photo -file $imgLocation -format png"
    (procedure "screen" line 6)
    invoked from within
"screen"
    (file "/usr/sbin/remotedesktopclient" line 640)

I am using rarsa's improved remotedesktopclient GUI v0.3 to no avail. Any ideas? Original script worked ok, so I can see no reason why rarsa's improved script shouldn't function. It works fine in 2.13

See topic about bugs in Pup 2.14ALPHA on Puppy Developer Forum:
http://www.puppyos.net/forum/?1169851092;2

Solution:
Download and install remotedesktopclient-0.3.pup.

Dotpup:
http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=2994
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 29 Jan 2007, 06:57    Post subject: Re: 2.14 Alpha
Subject description: Missing RDP lib?
 

Leon wrote:
WhoDo wrote:
I am using rarsa's improved remotedesktopclient GUI v0.3 to no avail. Any ideas? Original script worked ok, so I can see no reason why rarsa's improved script shouldn't function. It works fine in 2.13


Solution:
Download and install remotedesktopclient-0.3.pup.

Actually, Leon, that is what I'm running already (see quote). Thanks, anyway. Confused
Back to top
View user's profile Send private message 
HairyWill


Joined: 26 May 2006
Posts: 2949
Location: Southampton, UK

PostPosted: Mon 29 Jan 2007, 07:19    Post subject:  

I think that the file remotedesktopclient.png got left out of the iso by mistake. It should be at /usr/local/lib/X11/pixmaps.
update
[color="red]<wrong>No actually barry has recompressed it to a gif called rdp.gif.</wrong>From the creation date I think this was the original file, but there certainly isn't a remotedesktopclient.png in the iso.[/color]
So if you want to make it work either convert to png and rename
or try changing line 5ish of the remotedesktopclient script to refer to the correct file

_________________
Will
contribute: community website, screenshots, puplets, wiki, rss

Last edited by HairyWill on Tue 30 Jan 2007, 03:46; edited 1 time in total
Back to top
View user's profile Send private message 
Leon

Joined: 22 Jun 2005
Posts: 220
Location: Slovenia

PostPosted: Mon 29 Jan 2007, 07:35    Post subject: Re: 2.14 Alpha
Subject description: Missing RDP lib?
 

WhoDo wrote:
Leon wrote:
WhoDo wrote:
I am using rarsa's improved remotedesktopclient GUI v0.3 to no avail. Any ideas? Original script worked ok, so I can see no reason why rarsa's improved script shouldn't function. It works fine in 2.13


Solution:
Download and install remotedesktopclient-0.3.pup.

Actually, Leon, that is what I'm running already (see quote). Thanks, anyway. Confused


That's interesting. After I installed Puppy 2.14a I noticed that remotedesktopclient won't start. Then I installed remotedesktopclient-0.3.pup and now it starts OK.

Maybe remotedesktopclient-0.3.pup was not installed properly.

See if this file exists in your Puppy 2.14a:
/usr/local/lib/X11/pixmaps/remotedesktopclient.png
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 29 Jan 2007, 08:02    Post subject: Re: 2.14 Alpha
Subject description: Missing RDP lib?
 

Leon wrote:
That's interesting. After I installed Puppy 2.14a I noticed that remotedesktopclient won't start. Then I installed remotedesktopclient-0.3.pup and now it starts OK.

Maybe remotedesktopclient-0.3.pup was not installed properly.

See if this file exists in your Puppy 2.14a:
/usr/local/lib/X11/pixmaps/remotedesktopclient.png

Yep, it's there alright - as is the old rdp.gif, too.

It's got me beat. Darn thing works fine in Puppy 2.13 so I don't get it really. May be a libpng issue?
Back to top
View user's profile Send private message 
Leon

Joined: 22 Jun 2005
Posts: 220
Location: Slovenia

PostPosted: Mon 29 Jan 2007, 09:57    Post subject:  

Btw, I installed remotedesktopclient-0.3.pup to fresh frugal install of Puppy 2.14a.
Back to top
View user's profile Send private message 
PaulBx1

Joined: 16 Jun 2006
Posts: 2308
Location: Wyoming, USA

PostPosted: Mon 29 Jan 2007, 21:30    Post subject:  

The error seems to indicate a libpng issue; maybe a missing link.

I am running Puppy 211, and don't use remotedesktopclient, but I did a search for libpng and found these:

Code:
sh-3.00# ls -la /usr/lib/libpng*
lrwxrwxrwx    1 root     root           19 Oct 14 16:22 /usr/lib/libpng12.so.0 -> libpng12.so.0.1.2.8
-rwxr-xr-x    1 root     root       258172 Aug  7 14:57 /usr/lib/libpng12.so.0.1.2.8
lrwxrwxrwx    1 root     root           17 Oct 14 16:22 /usr/lib/libpng.so.3 -> libpng.so.3.1.2.8
-rwxr-xr-x    1 root     root       258172 Aug  7 14:57 /usr/lib/libpng.so.3.1.2.8


I find it strange that my libpng.so has a larger number (3.1.2.8 ) which usually implies a later revision, than you have when running 214a.

Do the same ls command, see what you have in 214a.
Back to top
View user's profile Send private message 
Leon

Joined: 22 Jun 2005
Posts: 220
Location: Slovenia

PostPosted: Tue 30 Jan 2007, 05:56    Post subject:  

PaulBx1 wrote:
The error seems to indicate a libpng issue; maybe a missing link.

I am running Puppy 211, and don't use remotedesktopclient, but I did a search for libpng and found these:

Code:
sh-3.00# ls -la /usr/lib/libpng*
lrwxrwxrwx    1 root     root           19 Oct 14 16:22 /usr/lib/libpng12.so.0 -> libpng12.so.0.1.2.8
-rwxr-xr-x    1 root     root       258172 Aug  7 14:57 /usr/lib/libpng12.so.0.1.2.8
lrwxrwxrwx    1 root     root           17 Oct 14 16:22 /usr/lib/libpng.so.3 -> libpng.so.3.1.2.8
-rwxr-xr-x    1 root     root       258172 Aug  7 14:57 /usr/lib/libpng.so.3.1.2.8


I find it strange that my libpng.so has a larger number (3.1.2.8 ) which usually implies a later revision, than you have when running 214a.

Do the same ls command, see what you have in 214a.

Puppy 2.14a:
Code:
sh-3.00# ls -la /usr/lib/libpng*
lrwxrwxrwx    1 root     root           19 Jan 26 13:48 /usr/lib/libpng12.so.0 -> libpng12.so.0.1.2.8
-rwxr-xr-x    1 root     root       258172 Aug  8 05:57 /usr/lib/libpng12.so.0.1.2.8
lrwxrwxrwx    1 root     root           11 Jan 26 13:48 /usr/lib/libpng.so -> libpng.so.3
lrwxrwxrwx    1 root     root           17 Jan 26 13:48 /usr/lib/libpng.so.3 -> libpng.so.3.1.2.8
-rwxr-xr-x    1 root     root       258172 Aug  8 05:57 /usr/lib/libpng.so.3.1.2.8
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Wed 14 Feb 2007, 06:22    Post subject:  

PaulBx1 wrote:
Do the same ls command, see what you have in 214a.


Here is my output:
Code:
sh-3.00# ls -la /usr/lib/libpng*
lrwxrwxrwx    1 root     root           19 Dec 11 19:52 /usr/lib/libpng12.so.0 -> libpng12.so.0.1.2.8
-rwxr-xr-x    1 root     root       258172 Aug  8  2006 /usr/lib/libpng12.so.0.1.2.8
lrwxrwxrwx    1 root     root           17 Dec 11 19:52 /usr/lib/libpng.so.3 -> libpng.so.3.1.2.8
-rwxr-xr-x    1 root     root       258172 Aug  8  2006 /usr/lib/libpng.so.3.1.2.8
sh-3.00#


Hmmm...looks like they're all different?

UPDATE: Ok, so I solved the problem by creating a symlink from libpng.so.3.1.2.8 called libpng.so.2.1.0.8 and now it runs as it should! Go figure!
Back to top
View user's profile Send private message 
HairyWill


Joined: 26 May 2006
Posts: 2949
Location: Southampton, UK

PostPosted: Wed 14 Feb 2007, 07:32    Post subject:  

I'm not sure how many people this problem is affecting but I've had the same problem in Muppy6 with remotedesktopclient-0.3.pup. I've got the same libpng libraries as WhoDo.
It seems silly for the functionality of this package to be blocked by a library error that it really doesn't need to be concerned about.
I suggest resaving the image /usr/localX11/pixmaps/remotedesktopclient.png in another format and amending the script.
/usr/sbin/remotedesktopclient then needs two changes one at line 8 to change the imagefilename ie:
Code:
set imgLocation "/usr/local/lib/X11/pixmaps/remotedesktopclient.gif"

and the other at line 294 to change the image format
Code:
set myimage [image create photo -file $imgLocation -format gif]

I can see that the libpng problem is something that needs to be addressed but at least this fix allows the dotpup to be functional

I did find that putting a symlink into /usr/lib for the libary solved the problem
Code:
ln -s libpng.so.3 libpng.so.2
but I have no idea of the differences between libpng.so.2 and .so3 so this may break something else later.
_________________
Will
contribute: community website, screenshots, puplets, wiki, rss
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0811s ][ Queries: 12 (0.0075s) ][ GZIP on ]