Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 10 Dec 2018, 11:31
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
LxPupSc - Woof-CE, Slackware-Current, LXDE experiment
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 31 of 72 [1074 Posts]   Goto page: Previous 1, 2, 3, ..., 29, 30, 31, 32, 33, ..., 70, 71, 72 Next
Author Message
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Wed 02 Nov 2016, 03:17    Post subject: 16.11.1 k4.8.6 powerdown problem  

There seems to be a problem with Powerdown (i.e. wmpoweroff) with the new 16.11.1 build - i.e. it doesn't powerdown - it reboots.
_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Wed 02 Nov 2016, 08:18    Post subject:  

Fixed with rebuild with later woof-ce-rationalise

iso reuploaded - new md5=ed380f7df3246cc8fed7be4eb8bd266d

BUILD_FROM_WOOF='rationalise;33e586f;2016-11-01 18:23:15 -0500'

Update the previous iso by renaming it to LxPupSc-16.11.1Ra.iso and apply the delta at: www.no_longer_available

If installing into an existing 16.11.1 savefolder/file you will probably need a pfix=clean boot to simulate an upgrade.

_________________
LxPup = Puppy + LXDE

Last edited by peebee on Sun 06 Nov 2016, 06:17; edited 3 times in total
Back to top
View user's profile Send private message Visit poster's website 
Marv


Joined: 04 May 2005
Posts: 1099
Location: SW Wisconsin

PostPosted: Wed 02 Nov 2016, 09:44    Post subject:  

Caught that one before I had even rebooted into 11.1. I had downloaded it and moved the files into the boot dir but not rebooted yet so I was still in 10.2. updated and running 11.1 now. All md5s ok.

Thanks,

_________________
Pups currently in kennel Very Happy LxPupSc and X-slacko-4.4 for my users; LxPupSc, LxPupSc64, LxPupBionic, upupbb and upupcc for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Fri 04 Nov 2016, 07:49    Post subject:  

a non-problem.....
_________________
LxPup = Puppy + LXDE

Last edited by peebee on Sun 06 Nov 2016, 06:15; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Marv


Joined: 04 May 2005
Posts: 1099
Location: SW Wisconsin

PostPosted: Fri 04 Nov 2016, 09:37    Post subject:  

I deleted, rebooted, and reinstalled my networked HP4500 and CUPS seems to be working normally for that. I am using my savefile updated and cleaned from 10.2R though. Haven't tried on a pristine install yet.

On an unrelated note, I did have doubletriggering (wake, then sleep again) issues on waking from lid suspend in 11.1. Hadn't seen those in a while. It was consistent, did it every time. I hadn't noticed it in 10.2R with the 4.8.1 kernel or any other of the pups I run and I suspend that way multiple times in a day. Bounced to a couple of other pups on that laptop to check that it wasn't hardware. Worked fine there. Then reverted LxPupSc to the 4.8.1 kernel. Worked fine there also. Then the puzzle. Went back to the stock kernel (4.8.6) in 11.1 and it is now working correctly there over multiple suspends. I thought it was kernel related but nooo, just another Marv mystery.

Cheers,

_________________
Pups currently in kennel Very Happy LxPupSc and X-slacko-4.4 for my users; LxPupSc, LxPupSc64, LxPupBionic, upupbb and upupcc for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6749
Location: hobart

PostPosted: Fri 04 Nov 2016, 15:50    Post subject:  

On fresh boot, running Puppy Package Manager, I get an error that it's already running.

On installing the devx, if I then click to uninstall, I get a message that the devx seems not currently loaded buti in the queue and do you want to remove it from the queue list? It is actually loaded.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Sun 06 Nov 2016, 06:09    Post subject:  

muggins wrote:
On fresh boot, running Puppy Package Manager, I get an error that it's already running.

On installing the devx, if I then click to uninstall, I get a message that the devx seems not currently loaded buti in the queue and do you want to remove it from the queue list? It is actually loaded.

PPM - yes I've seen that - goes away if you open PPM a 2nd time...

devx - is this with or without a savefolder? a savefolder is needed for .sfs loading and unloading to work correctly.

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Sun 06 Nov 2016, 06:14    Post subject: 16.11.2 interim delta  

Updated 11-nov-16

An interim delta to make 16.11.2 is available from:
https://sourceforge.net/projects/lxpup/files/Other/LxPupSc/interims/

Main change is slackware-current updates of Fri Nov 4 03:31:38 UTC 2016
but the woof-ce build process has been changing a bit so this is a test that all is OK.

I think my cups problem is a non-problem caused by my savefolder that I was updating being a bit long in the tooth.....

[11-nov-2016] kernel is now 4.8.7

_________________
LxPup = Puppy + LXDE

Last edited by peebee on Fri 11 Nov 2016, 09:44; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
muggins

Joined: 20 Jan 2006
Posts: 6749
Location: hobart

PostPosted: Sun 06 Nov 2016, 23:43    Post subject:  

Quote:
PPM - yes I've seen that - goes away if you open PPM a 2nd time


I've run /usr/local/petget/pkg_chooser.sh multiple times, from commandline, and the error appears, (as a guesstimate), 30% of the time.

I don't know if the problem is with this line:

Code:
# Do not allow another instance
sleep 0.3
[ "$(busybox ps | grep -E '/usr/local/bin/ppm|/usr/local/petget/pkg_chooser' | grep -v -E 'grep|geany|leafpad' | wc -l)" -gt 2 ] \
   && . /usr/lib/gtkdialog/box_splash -timeout 3 -bg red -text "$(gettext 'PPM is already running. Exiting.')" \
      && exit 0


And with the devx, yes, there is a save file.
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 2989

PostPosted: Mon 07 Nov 2016, 02:05    Post subject:  

muggins wrote:
Quote:
PPM - yes I've seen that - goes away if you open PPM a 2nd time


I've run /usr/local/petget/pkg_chooser.sh multiple times, from commandline, and the error appears, (as a guesstimate), 30% of the time.

I don't know if the problem is with this line:

Code:
# Do not allow another instance
sleep 0.3
[ "$(busybox ps | grep -E '/usr/local/bin/ppm|/usr/local/petget/pkg_chooser' | grep -v -E 'grep|geany|leafpad' | wc -l)" -gt 2 ] \
   && . /usr/lib/gtkdialog/box_splash -timeout 3 -bg red -text "$(gettext 'PPM is already running. Exiting.')" \
      && exit 0


Yes this is the "problem" line that does not allow 2 instances of PPM to run.
However in slow machines the first time may show as running while the second time (that is cached) is usually OK.
The patch below eliminates (the rare for me cases) that this happens.
She if this works for you.
Is a work around and does not address the core of the issue but should do for now
Code:
--- a/usr/local/petget/pkg_chooser.sh
+++ b/usr/local/petget/pkg_chooser.sh
@@ -19,6 +19,7 @@
 # Do not allow another instance
 sleep 0.3
 [ "$(busybox ps | grep -E '/usr/local/bin/ppm|/usr/local/petget/pkg_chooser' | grep -v -E 'grep|geany|leafpad' | wc -l)" -gt 2 ] \
+   && sleep 0.2 && [ "$(busybox ps | grep -E '/usr/local/bin/ppm|/usr/local/petget/pkg_chooser' | grep -v -E 'grep|geany|leafpad' | wc -l)" -gt 2 ]\
    && . /usr/lib/gtkdialog/box_splash -timeout 3 -bg red -text "$(gettext 'PPM is already running. Exiting.')" \
       && exit 0
 

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Mon 07 Nov 2016, 06:53    Post subject:  

muggins wrote:
And with the devx, yes, there is a save file.

Thanks @mav - should this change go into woof-ce??

I can confirm the problem reported by @muggins - applies to all sfs loads....investigating!!

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
mavrothal


Joined: 24 Aug 2009
Posts: 2989

PostPosted: Mon 07 Nov 2016, 15:59    Post subject:  

peebee wrote:

Thanks @mav - should this change go into woof-ce??

This was an old ugly hack.
I believe the attached should work better.
@muggins or anybody that frequently encounter this bogus "PPM is running" issue, please test.
pkg_chooser_test-3.pet
Description 
pet

 Download 
Filename  pkg_chooser_test-3.pet 
Filesize  9.41 KB 
Downloaded  110 Time(s) 

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6749
Location: hobart

PostPosted: Tue 08 Nov 2016, 06:52    Post subject:  

Thankyou Mavrothal,

your pet has fixed the problem.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Thu 10 Nov 2016, 04:22    Post subject:  

muggins wrote:
On installing the devx, if I then click to uninstall, I get a message that the devx seems not currently loaded buti in the queue and do you want to remove it from the queue list? It is actually loaded.

A woof-ce fix was required to fix this problem.

Interim delta to 16.11.2 now includes this fix and the ppm tweak.

Now 16.11.2 is:
BUILD_FROM_WOOF='rationalise;654b5df;2016-11-09 20:55:16 -0500'

11-nov-2016:
kernel is now 4.8.7

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Wed 16 Nov 2016, 04:46    Post subject:  

Browser updates - opera and firefox including firefox-50.0.1

The browsers provided as add-ons for LxPupSc 32bit pae

The versions of the browsers as of 16-nov-2016 with their md5sums are:

chromium-54.0.2840.59+pepper_23.0.0.207 :0d489514a27d726fc75314e95257a571

firefox-45.5.0esr :28db457bbd9adaab03fa4275b24f7a98

opera-stable_41.0.2353.56_i386 :22119cb2f6262e6224f0a10a24fb3633

palemoon-26.5.0 :96385e3356a1ee8929702aed217a5381

seamonkey-2.40 :60fc21e069abe4b801891c4d781f50f8

_________________
LxPup = Puppy + LXDE

Last edited by peebee on Tue 29 Nov 2016, 03:37; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 31 of 72 [1074 Posts]   Goto page: Previous 1, 2, 3, ..., 29, 30, 31, 32, 33, ..., 70, 71, 72 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1034s ][ Queries: 13 (0.0184s) ][ GZIP on ]