Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 29 Jul 2014, 21:16
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
How to get USB arvast WN 220 wifi to work?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
petertosh

Joined: 17 Jan 2007
Posts: 23

PostPosted: Wed 17 Jan 2007, 20:30    Post subject:  How to get USB arvast WN 220 wifi to work?  

Hi all,
sorry for my english, i'm french^^
I installed puppy 2.13 on my laptope. Everything work perfectly except the sound and the wifi^^

To connect my laptope to internet, i use a usb key arvast WN220
But when i click on connect, i choose connect to internet by network interface, and in "interfaces" there is: "puppy does not see any active ethernet interfaces"

And on driver modules, i don't fond the good driver Sad

Have you got an idea to help me? Wifi with linux is too complicate for a stupid french like me Laughing lol

Thanks a milion all^^
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Wed 17 Jan 2007, 21:34    Post subject:  

I think your device contains the Prism3 chipset. For USB devices this chipset is supported by the linux-wlan-ng driver "prism2_usb". It's quite likely that Puppy will automatically load this driver, run "lsmod" to check if it is listed. If not, you can load it manually like this -

modprobe prism2_usb

This driver uses a unique configuration utility, so the Network Wizard cannot be used. Setup instructions for this driver are here http://dotpups.de/dotpups/Wifi/drivers-for-Puppy-2.00-and-2.01/linux-wlan_README.txt
Back to top
View user's profile Send private message 
petertosh

Joined: 17 Jan 2007
Posts: 23

PostPosted: Thu 18 Jan 2007, 09:01    Post subject:  

Thank you, my driver is now loaded^^

Now, i just need to configure my network access, i'm going to find san explication in the forum Very Happy

Thanks again Wink
Back to top
View user's profile Send private message 
petertosh

Joined: 17 Jan 2007
Posts: 23

PostPosted: Thu 18 Jan 2007, 18:12    Post subject:  

hi again^^

Just a last question, i scann to find a network and i find the good one but i need to complete the "Network ID" and the "Frenquency".

How can i find this two parameters?

Thanks a lot^^
Back to top
View user's profile Send private message 
BlackAdder


Joined: 22 May 2005
Posts: 382

PostPosted: Fri 19 Jan 2007, 17:29    Post subject:  

petertosh,
You don't need to set either of those. The frequency is set if you have set a channel (so either set a channel or a frequency), and the network id is not an essential parameter to get your wifi talking.
Back to top
View user's profile Send private message 
petertosh

Joined: 17 Jan 2007
Posts: 23

PostPosted: Sat 20 Jan 2007, 13:53    Post subject:  

Perfect, it works Laughing

I did a mistake with the wep key Rolling Eyes

Thanks a milion^^
Back to top
View user's profile Send private message 
petertosh

Joined: 17 Jan 2007
Posts: 23

PostPosted: Sat 20 Jan 2007, 13:57    Post subject:  

Just a question, i don't understand the last sentense :
Quote:
A script is provided with these commands; /root/my-applications/bin/linux-wlan-connect
Just modify the script to include your wireless settings.


Is that mean if i don't create this script i'll lost my connexion for the next reboot?
Cause when i write "/root/my-applications/bin/linux-wlan-connect"
I have for answer
Quote:
No such file or directory


Do i need to do something more after connect me on internet?
thanks again
Back to top
View user's profile Send private message 
petertosh

Joined: 17 Jan 2007
Posts: 23

PostPosted: Sat 20 Jan 2007, 15:33    Post subject:  

Ok, i reboot the computer and lost my wireless connexion^^

What can i do to save it?

Thank you.
Back to top
View user's profile Send private message 
petertosh

Joined: 17 Jan 2007
Posts: 23

PostPosted: Sat 20 Jan 2007, 17:25    Post subject:  

i did everything :

Quote:
#wlanctl-ng wlan0 lnxreq_wlansniff enable=false channel xx
#wlanctl-ng wlan0 p2req_channel_info_results channel xx

wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
wlanctl-ng wlan0 lnxreq_hostwep decrypt=true encrypt=true
wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11PrivacyInvoked=true
wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11WEPDefaultKeyID=0
wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11ExcludeUnencrypted=true
wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11WEPDefaultKey0=01:23:45:67:89
wlanctl-ng wlan0 lnxreq_autojoin ssid=MY_ESSID authtype=opensystem


But like i said before, if i reboot thecomputer i lost everything and for the next boot i must to do all af this, not very pleasant Laughing Laughing
Is there is a solution? Writing a script or something else?

Thanks a lot.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Sat 20 Jan 2007, 18:33    Post subject:  

Quote:
A script is provided with these commands; /root/my-applications/bin/linux-wlan-connect
Just modify the script to include your wireless settings.

Oops ... this script is only available if the old driver dotpup was installed
http://dotpups.de/dotpups/Wifi/drivers-for-Puppy-2.00-and-2.01/linux-wlan-ng-0.2.5.pup
... but don't install this, because it's the driver for older versions of Puppy.

Let's create a new script now:
start a new document in geany. The first line needs to be this -

#!/bin/sh

Now add all those setup commands. Save this document, call it whatever you want - let's say "moi-wifi" in /root/my-applications/
Now we need to make the script executable, so do this -

chmod 755 /root/my-applications/moi-wifi

Now you can either run this script whenever you want to connect, or if you want to connect EVERY TIME you boot up, add "/root/my-applicaionts/moi-wifi" to the end of /etc/rc.d/rc.local

And a reminder; do not use the Network Wizard.
Back to top
View user's profile Send private message 
petertosh

Joined: 17 Jan 2007
Posts: 23

PostPosted: Sun 21 Jan 2007, 13:38    Post subject:  

Thank you, internet works perfectly^^

Thanks a lot^^
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0687s ][ Queries: 12 (0.0115s) ][ GZIP on ]