Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 25 Feb 2018, 12:09
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Bluetooth + streaming for tahrpup 6.x
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 7 of 9 [130 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Author Message
ktat

Joined: 07 Oct 2013
Posts: 19

PostPosted: Wed 22 Jun 2016, 03:57    Post subject:  

tempestuous wrote:


Open /etc/asound.conf in Geany, and replace "XX:XX:XX:XX:XX:XX" with the bluetooth MAC address of your bluetooth receiver (or headset), which you determined earlier.


I have got to this step, however, my asound.conf looks like this
Code:
defaults.pcm.card 1
defaults.pcm.device 0


I'm not sure where I should put my bluetooth MAC address.

Thanks.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Sun 26 Jun 2016, 22:49    Post subject:  

My bluez dotpet definitely provides a custom asound.conf file with the appropriate bluetooth-related entries, and this will definitely be installed to /etc
so it sounds like you may have overwritten this file, possibly by running the ALSA Sound Card wizard.

The simple fix would be to re-install the bluez dotpet.
Back to top
View user's profile Send private message 
ktat

Joined: 07 Oct 2013
Posts: 19

PostPosted: Sat 09 Jul 2016, 03:56    Post subject:  

Thank you for your help.

I couldn't find any file bluez.pet in the Puppy Package Manager. So I'm not sure if I've reinstalled the correct package.

What I did reinstall was bluez 4.101.

After installation and starting bluetoothd, the bluetooth icon appeared in the task bar. I was able to find my speaker, however, when I tried to connect to the audio sink a window popped up saying "Device added successfully but failed to connect".
I tried again, this time there was another error. In the bluetooth manager window it said "Connection failed: stream setup failed".

I went and took another look at /etc/asound.conf. The contents of this file has not changed since reinstalling bluez 4.101.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Sat 09 Jul 2016, 10:37    Post subject:  

ktat wrote:
I couldn't find any file bluez.pet in the Puppy Package Manager.

My software packages are not part of the PPM, and I don't wish them to be so.

ktat wrote:
What I did reinstall was bluez 4.101.

Yes, that's the correct dotpet to install, assuming you obtained it from the first post in this thread.
And if so, it definitely installs this asound.conf file -
Code:
#/etc/asound.conf

pcm.btheadset {
   type plug
   slave {
       pcm {
           type bluetooth
           device XX:XX:XX:XX:XX:XX
           profile "auto"
       }
   }
   hint {
       show on
       description "BT Headset"
   }
}
ctl.btheadset {
  type bluetooth
}
Back to top
View user's profile Send private message 
ktat

Joined: 07 Oct 2013
Posts: 19

PostPosted: Thu 14 Jul 2016, 22:29    Post subject:  

Thank you, again.

Following your instructions, I am now that much closer to having a fully portable OS that meets my needs.

I had, originally downloaded the file from the PPM, and so when you redirected me back to the start of this thread - all became much clearer.

I expect that I will need to have a different asound.conf for evey bluetooth device that I wish to connect. Or, can I just use the first device listed as a template - changing the MAC address and "description" for additional devices, then appending tem to the asound.conf file?
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Fri 15 Jul 2016, 01:37    Post subject:  

Mmm. Multiple bluetooth headsets?
ktat wrote:
can I just use the first device listed as a template - changing the MAC address and "description" for additional devices, then appending tem to the asound.conf file?

Yes, that might work, but with one caveat - you almost certainly cannot duplicate the words "pcm.btheadset" and "ctl.btheadset"
because then you would have more than one definition of the same device, which would confuse the system.

I think that when you add a second device's set of definitions to the asound.conf file, these should be listed as "pcm.btheadset2" and "ctl.btheadset2".

Also be aware that whenever you change the asound.conf file, you must reboot before the changes will come into effect.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Fri 15 Jul 2016, 02:58    Post subject:  

Well I just tried such a configuration now, even though I don't own a bluetooth headset or speaker.

For the second device I used a different "description" value; something meaningful like "Bose BT Soundbar".
Now in DeaDBeeF when I go to Edit > Preferences > Output plugin:
I can see 2 different bluetooth devices listed, as illustrated -
BT-multiple.jpg
 Description   
 Filesize   67.56 KB
 Viewed   484 Time(s)

BT-multiple.jpg

Back to top
View user's profile Send private message 
ktat

Joined: 07 Oct 2013
Posts: 19

PostPosted: Sat 16 Jul 2016, 03:02    Post subject:    

Thanks tempestuous, that is good to know.

Now I have another problem, in my pursuit of portability.

Unfortunately, my other laptop is a hp Pavilion g6. From my research, it would seem that it's wifi/bluetooth chip is notoriously difficult to get the bluetooth working (although my Fedora OS has no problem).

Here is what I have learned so far...

Code:
root# rfkill list
0: phy0: wlan
   Soft blocked: no
   Hard blocked: no

root# hciconfig dev
Can't get device info: No such device

lsusb
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)

lsusb -v
Bus 006 Device 002: ID 0cf3:311d Atheros Communications, Inc.
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass          224 Wireless
  bDeviceSubClass         1 Radio Frequency
  bDeviceProtocol         1 Bluetooth
  bMaxPacketSize0        64
  idVendor           0x0cf3 Atheros Communications, Inc.
  idProduct          0x311d
  bcdDevice            0.01
  iManufacturer           1 Atheros Communications
  iProduct                2 Bluetooth USB Host Controller
  iSerial                 3 Alaska Day 2006
  bNumConfigurations      1

dmesg | grep -i blue
Bluetooth: Core ver 2.18
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP socket layer initialized
Bluetooth: SCO socket layer initialized
Bluetooth: Patch file not found ar3k/AthrBT_0x01020200.dfu
Bluetooth: Loading patch file failed
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM ver 1.11
Bluetooth: BNEP (Ethernet Emulation) ver 1.3
Bluetooth: BNEP filters: protocol multicast
Bluetooth: BNEP socket layer initialized

lsmod | grep -i ath9
ath9k                  58216  0
ath9k_common             892  1 ath9k
ath9k_hw              326100  2 ath9k_common,ath9k
ath                    12076  3 ath9k_common,ath9k,ath9k_hw
mac80211              181284  1 ath9k
cfg80211              133384  3 ath,ath9k,mac80211

lsmod | grep -i blue
bluetooth             153589  12 bnep,ath3k,btusb,rfcomm
6lowpan_iphc            4320  1 bluetooth
rfkill                  5402  6 cfg80211,hp_wmi,bluetooth


No matter how much I "cycle" my wifi button, I'm not getting hci0 to show up in the rfill list
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Sat 16 Jul 2016, 03:35    Post subject:  

From an earlier post by rcrsn51, I understand that when you have a combined wifi/bluetooth interface, its driver needs to explicitly enable the bluetooth functionality.
In the case of your ath9k driver, that is achieved with the "btcoex_enable" parameter. (You can run "modinfo ath9k" to see what other parameters are available)

To enable the bluetooth function temporarily, unload/reload your ath9k driver with these 2 commands -
Code:
rmmod ath9k
modprobe ath9k btcoex_enable=1

Now run those bluetooth diagnostic commands again. If successful, you can move on to bluetooth configuration and pairing.

To make the driver's bluetooth function permanent, create a new text document in Geany, with this text -
Code:
options ath9k btcoex_enable=1

and save the text file as /etc/modprobe.d/bluetooth.conf
Back to top
View user's profile Send private message 
ktat

Joined: 07 Oct 2013
Posts: 19

PostPosted: Wed 03 Aug 2016, 02:24    Post subject:  

Thank you tempestuous.

I gave the above a try, however, it doesn't seem to have worked. This is what I entered and the output I received:

Code:
root# rmmod ath9k
root# modprobe ath9k btcoex_enable=1 blink=1   
root# rfkill list
1: phy1: wlan
   Soft blocked: no
   Hard blocked: no
root# hciconfig dev
Can't get device info: No such device


* before entering rfkill list, I clicked on the bluetooth icon to turn the daemon on.

So, following on from the earlier post by rcrsn51, I have attached the lsmod output for the Fedora OS and the Puppy OS. It would seem that the Fedora OS isn't using the btcoex option either, but still works. I also added the blink option to see if it did anything, the light on the keyboard now blinks - but this doesn't show up in the lsmod either??

I'm not sure where to go with this now.

By the way my system is 32bit so the file that rcrsn51 suggests to upload wouldn't be useful for me.
puppy_lsmod.txt.tar
Description 
tar

 Download 
Filename  puppy_lsmod.txt.tar 
Filesize  10 KB 
Downloaded  89 Time(s) 
fedora_lsmod.txt.tar
Description 
tar

 Download 
Filename  fedora_lsmod.txt.tar 
Filesize  10 KB 
Downloaded  83 Time(s) 
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Wed 03 Aug 2016, 11:24    Post subject:  

ktat wrote:
before entering rfkill list, I clicked on the bluetooth icon to turn the daemon on.

I don't think that's necessary, and may even be counterproductive while you are trying to enable the bluetooth functionality.

This sounds like a case of problematic inbuilt bluetooth devices, as I mentioned in the first post. Comparing the Puppy/Fedora lsmod results, I see one significant one which is absent in Puppy - hp_wireless
Apparently this kernel module supports the hardware wifi switch on HP laptops.
In Tahrpup6 I can see that the hp_wireless module was not enabled in the kernel configuration. So it's feasible you could lobby one of the Tahrpup developers (rcrsn51 springs to mind) to compile this module for you and provide it as a dotpet.
But before you do this, try the fixes mentioned here -
https://forums.gentoo.org/viewtopic-p-7499484.html#7499484
You will see that one of the suggested fixes is to cycle the wireless switch, which adds additonal weight to my suspicion that the hp_wireless module may be required.

And I still think the "btcoex_enable=1" parameter should be used.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Fri 05 Aug 2016, 05:29    Post subject:  

I have just downloaded the kernel source for Tahrpup 6.0.5 and can compile the hp_wireless driver shortly.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Fri 05 Aug 2016, 11:13    Post subject:  

Here is the hp-wireless driver (kernel module) compatible ONLY with the 3.14.56 PAE kernel in Tahrpup 6.0.5.
This driver is part of the official kernel source, but is not normally enabled in Puppy kernels.
hp-wireless supports the hardware wifi switch on modern HP laptops.

After installing this dotpet, reboot. Puppy should automatically load the new driver at bootup. You can check with the "lsmod" command.
hp-wireless-k3.14.56-PAE.pet
Description  for Tahrpup 6.0.5 with 3.14.56 PAE kernel
pet

 Download 
Filename  hp-wireless-k3.14.56-PAE.pet 
Filesize  1.64 KB 
Downloaded  101 Time(s) 
Back to top
View user's profile Send private message 
ktat

Joined: 07 Oct 2013
Posts: 19

PostPosted: Fri 12 Aug 2016, 04:39    Post subject:  

Thanks, again, for all your help with this problem.

I've installed the dotpet you provided and rebooted. I then ran the following:
Code:
root# lsmod | grep hp
hp_wmi                  4832  0
sparse_keymap           1532  1 hp_wmi
rfkill                  5402  4 cfg80211,hp_wmi,bluetooth
wmi                     5142  1 hp_wmi
hp_wireless             1064  0
root# rfkill list
0: phy0: wlan
   Soft blocked: no
   Hard blocked: no
root# hcitool dev
Devices:


I still have the following in my file system:
Quote:
To make the driver's bluetooth function permanent, create a new text document in Geany, with this text -
Code:
options ath9k btcoex_enable=1

and save the text file as /etc/modprobe.d/bluetooth.conf

From what I can tell, it's not working, is there something that I have missed?
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Fri 12 Aug 2016, 12:25    Post subject:  

ktat wrote:
is there something that I have missed?

You didn't mention whether you followed the advice in that gentoo forum link about cycling your hardware wireless switch.
Here's what I suggest you try -

1. boot up to Tahrpup (6.0.5)
2.
Code:
rfkill list

to check that phy0/wlan is displayed, but not hci0.
3. toggle your hardware wireless switch OFF - this should be possible now that you have the hp-wireless driver installed.
4.
Code:
rfkill list

to check that phy0/wlan is absent
5. toggle your hardware wireless switch ON
6.
Code:
rfkill list

to check that phy0/wlan AND hci0 are now displayed.
7.
Code:
hcitool dev

may still display no devices ... so unload/reload the bluetooth driver -
8.
Code:
rmmod btusb
modprobe btusb

9.
Code:
hcitool dev

will now hopefully show "hci0".
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 7 of 9 [130 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1421s ][ Queries: 13 (0.0281s) ][ GZIP on ]