Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 28 Mar 2020, 08:12
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Smallest Puppy with or that can run WINE 1.81 or newer
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [22 Posts]   Goto page: Previous 1, 2
Author Message
mouldy


Joined: 04 May 2005
Posts: 661

PostPosted: Wed 20 Apr 2016, 13:01    Post subject:  

Winetricks works, I installed IE6 yesterday with it. IE6 however doesnt work. Just that it runs into error I posted when I try to install IE8. It doesnt want to install IE8 whether I use commandline nor zenity. And doesnt work if I try to install IE8 into wine independent of winetricks. TaxAct doesnt see it unless winetricks installs it. Means I am locked into winetricks trying to download from an apparently non-functional link for IE8. I dont see how I can force it to download from a different site.
Back to top
View user's profile Send private message 
mouldy


Joined: 04 May 2005
Posts: 661

PostPosted: Wed 20 Apr 2016, 15:11    Post subject:  

Ok, whew, moved up to tar pup cause my connection was getting flaky in Slacko 5.7.

Installed 1.5.8 this time and after several tries got winetricks to install ie8. This version of WINE got IE directly from M$ site. Hey ie8 even sort of worked to surf (this is an improvement!) though crashy as heck. But when I tried to start TaxAct, crash bang boom immediately. I had hopes that IE8 might let the buttons work, since seemingly TaxAct only uses it for javascript for navigation.

So back to 1.9.7 one more time to see if it will download and install ie8 now. I doubt it. Suspect I will need to go back to maybe 1.8.1 to get both enough WINE functionality for TaxAct2015 and hopefully ability to download and install ie8 for its javascript from a reliable depository. Still dont know why it cant use javascript from firefox or chrome. But that would make it too easy I suppose.
Back to top
View user's profile Send private message 
mouldy


Joined: 04 May 2005
Posts: 661

PostPosted: Wed 20 Apr 2016, 15:46    Post subject:  

Be still my heart. I installed 1.9.7 over 1.5.8. Had to reinstall mono or whatever. This took FOREVER.

But it recognized existing ie8 that 1.5.8 downloaded directly from Microsoft. Dumb luck I think. I started TaxAct2015 and it ran and I could navigate at least first few pages. Didnt crash!!!! and shut down properly. So now to see if it will actually prepare a tax return.

Do all this and how much wanta bet they will change it next year so it needs IE9 or IE10 or something. Didnt they drop the IE name for their browser in latest versions?

Plenty time to download and burn me one of those free images of win10 from M$ so I can run it in VBox. Thats lot simpler than endless WINE and IE8 variations to find two that like each other and work properly.
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 6037
Location: King's Lynn, UK.

PostPosted: Wed 20 Apr 2016, 16:44    Post subject:  

@Mikeslr:-

Hey, Mike. You say you can't get winetricks to install? Could be something to do with the fact that you insist on using portable -WINE?

There's three things you need. I had to do this to get Photoshop CS2 up-and-running...

1) Install this Zenity-patched.pet. (Note; this is the 'patched' version.....which to all intents and purposes means Zenity now works again). Zenity enables use of the WineTricks GUI:-

http://www.filewatcher.com/m/zenity-2.20.1-patched-i486.pet.98382-0.html

2) Install CabExtract from the Wikka, here. CabExtract allows WineTricks to extract any required M$ data from the appropriate 'cabinet' files:-

http://puppylinux.org/wikka/cabextract

3) Finally, install this winetricks pet:-

http://puppylinux.org/wikka/winetricks


Now, in the case of a normal install of WINE (that's a 'FULL' install of WINE to a normal, frugal Pup), you'd install zenity & cabextract first, followed by the updated winetricks .pet. Then, you need to go into /usr/sbin, and locate winetricks amongst the gaggle of wine items down near the bottom. Either click straight on it from there (I drag it to the desktop and tart it up with an icon), or you can launch it from the terminal. (I think.) I've not tried that option. (EDIT: Yep.....you can. Just tried it. Be prepared for a few seconds delay before opening.)

However, in your case, I haven't got a clue how shinobar's set his portable WINE up. I know the only time I've tried it, it had a menu that was all in Japanese (!), and I had the devil's own job to uninstall it.

But winetricks very definitely will work, if you take the time to track down the necessary bits'n'bobs. I got the tips from here, if you remember:-

http://www.omgubuntu.co.uk/2013/01/photoshop-cs2-available-for-free-works-fine-in-wine

.....and tracked the necessary components down from there. This is with WINE 1.7.51, although I assume these should work with any of green_dome/version2013's WINE compilations.


Mike.

_________________
MY 'PUPPY' PACKAGES

Back to top
View user's profile Send private message 
mouldy


Joined: 04 May 2005
Posts: 661

PostPosted: Wed 20 Apr 2016, 19:56    Post subject: Hallelujah  

It worked. Got through both federal and state return, all outputted in pdf format ready to be printed on paper and mailed. Exhausted, do that in morning. I am not one to trust electronic filing. Plus need to do one last inspection of filled out forms when my brain is fresh.

Went pretty smooth. Only one glitch where it wouldnt accept one minor box I filled until I did it over like six times. All other boxes and buttons worked fine. Didnt crash or act like it was unstable in slightest.

But my gosh what a circus to get it to run via WINE. Doesnt help that I am serious procrastinator when it comes to taxes. I'll do it with virtual box windows next year unless of course it still works fine in same Tahrpup+WINE that I used this year, try that first.
Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1565

PostPosted: Wed 20 Apr 2016, 20:46    Post subject: Re: Hallelujah  

mouldy wrote:
But my gosh what a circus to get it to run via WINE. Doesnt help that I am serious procrastinator when it comes to taxes. I'll do it with virtual box windows next year unless of course it still works fine in same Tahrpup+WINE that I used this year, try that first.

Ha, thanks for the reminder. I still haven't done taxes yet either, didn't even really think about it. I don't think the government really gives a rats bottom when I do them because they always owe me money anyway - lol. I think I didn't do them until June or July last year, not a peep from the government of course, as they obviously don't want to tell me "we owe you money!". lol
Back to top
View user's profile Send private message 
version2013

Joined: 08 Sep 2013
Posts: 484
Location: Florida, USA

PostPosted: Wed 20 Apr 2016, 21:50    Post subject:  

mouldy wrote:
Winetricks works, I installed IE6 yesterday with it. IE6 however doesnt work. Just that it runs into error I posted when I try to install IE8. It doesnt want to install IE8 whether I use commandline nor zenity. And doesnt work if I try to install IE8 into wine independent of winetricks. TaxAct doesnt see it unless winetricks installs it. Means I am locked into winetricks trying to download from an apparently non-functional link for IE8. I dont see how I can force it to download from a different site.


I was using Lupu/Lucid Puppy and was getting a similar message with command "# winetricks mfc40"
...snip...
cannot verify web.archive's certificate...Self-signed certificate encountered.
To connect to web.archive.org insecurely, use `--no-check-certificate'.

I think I was able to download that file via command:
"# wget --no-check-certificate https://web.archive.org/web/http://activex.microsoft.com/controls/vc/mfc40.cab"

mouldy wrote:
Ok, whew, moved up to tar pup cause my connection was getting flaky in Slacko 5.7.

Installed 1.5.8 this time and after several tries got winetricks to install ie8. This version of WINE got IE directly from M$ site. Hey ie8 even sort of worked to surf (this is an improvement!) though crashy as heck. But when I tried to start TaxAct, crash bang boom immediately. I had hopes that IE8 might let the buttons work, since seemingly TaxAct only uses it for javascript for navigation.

So back to 1.9.7 one more time to see if it will download and install ie8 now. I doubt it. Suspect I will need to go back to maybe 1.8.1 to get both enough WINE functionality for TaxAct2015 and hopefully ability to download and install ie8 for its javascript from a reliable depository. Still dont know why it cant use javascript from firefox or chrome. But that would make it too easy I suppose.


When I started using Tahr Puppy, using winetricks I did not encounter the "cannot verify certificate" message.
I wonder if it has something to do with a newer openssl.

----------------------------
Lupu/Lucid Puppy
# openssl version
OpenSSL 0.9.8o 01 Jun 2010

Tahr Puppy
# openssl version
OpenSSL 1.0.1f 6 Jan 2014
---------------------------

mouldy wrote:
Be still my heart. I installed 1.9.7 over 1.5.8. Had to reinstall mono or whatever. This took FOREVER.

But it recognized existing ie8 that 1.5.8 downloaded directly from Microsoft. Dumb luck I think. I started TaxAct2015 and it ran and I could navigate at least first few pages. Didnt crash!!!! and shut down properly. So now to see if it will actually prepare a tax return.


To minimize space used in my pupsave file, I symlink a few things.

/root/.cache/wine
or
~/.cache/wine
Wine downloads to this directory the wine-gecko* and wine-mono* files.
Wine will look here when creating wineprefixes. If file is present, it will use it instead of re-downloading it.

/root/.cache/winetricks
or
~/.cache/winetricks
winetricks downloads files to this directory.
winetricks will look here for files. If file is present, it will use it instead of re-downloading it.

I move those directories (and their contents) to somewhere in "/mnt/home/". I then create symlinks back to where they originally were.
I use a frugal install of puppy linux.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 2 [22 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0656s ][ Queries: 12 (0.0246s) ][ GZIP on ]