Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 20 Nov 2018, 10:13
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to Install Brother Printers and Scanners
Post new topic   Reply to topic View previous topic :: View next topic
Page 11 of 14 [210 Posts]   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12, 13, 14 Next
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 12324
Location: Stratford, Ontario

PostPosted: Fri 08 May 2015, 12:40    Post subject:  

By "drivers", do you mean printer models in the Model list? Pick one. If it doesn't work, delete the printer and pick the other.
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Fri 08 May 2015, 15:36    Post subject:  

I'm referring to what you see in the attached.
Printer Drivers.png
 Description   
 Filesize   14.21 KB
 Viewed   269 Time(s)

Printer Drivers.png


_________________

Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Fri 08 May 2015, 17:57    Post subject:  

I'll be here when you have time to reply Wink
_________________

Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12324
Location: Stratford, Ontario

PostPosted: Fri 08 May 2015, 18:10    Post subject:  

Why do you need a reply? I told you what to do above.

This duplication of models names should not be a surprise. It was also present when you previously set up the printer using IP4CUPS. It comes from the Debian driver packages, which put their PPD files in two different locations.

BTW, why is your Brother section so empty? All standard Puppies come with the Gutenprint driver which supports a large collection of Brother models.

By insisting on using Carolina, you are making this situation more frustrating for everyone. This really isn't a Brother printer problem - it's a Carolina problem. They have their own forum section.
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Fri 08 May 2015, 18:34    Post subject:  

I'll reevaluate my choice to move away from X-Slacko once X-Slacko moves out of beta territory again. I'm watching over there Wink

As for the printer and prior statements, I actually wasn't sure.

Back in a bit, time to reboot the router for smoother Internets... oh joy...

_________________

Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Fri 08 May 2015, 19:51    Post subject:  

Printer is detected and installs using USB (which probably exonerates the cable) but still does not print a test page.

EDIT: (D'oh, hit the post-button too fast.) I should note that the printer is connected through a front panel USB port, *NOT* through a hub. Don't know if that matters or not.

_________________

Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Sat 09 May 2015, 12:04    Post subject:  

Please tell me you'll still help me even if I choose not to change my Pup...
_________________

Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12324
Location: Stratford, Ontario

PostPosted: Sat 09 May 2015, 12:22    Post subject:  

How? You have already seen the printer work correctly when you used IP4CUPS. Then something changed in your Carolina setup and it stopped working, even through USB.

This is now a problem for the Carolina team. It's their printing system.

BTW, do you have that idiotic printer-scanner SFS package installed?
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Sat 09 May 2015, 12:25    Post subject:  

I have not installed any sort of printer SFS. Nothing has changed from a default Carolina Vanguard install as far as printing is concerned. I will, however, be happy to post a list of packages I have installed as shown in the Uninstall Packages wizard.
_________________

Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12324
Location: Stratford, Ontario

PostPosted: Sat 09 May 2015, 12:29    Post subject:  

starhawk wrote:
I will, however, be happy to post a list of packages I have installed as shown in the Uninstall Packages wizard.

If you do, post it on the Carolina thread.
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Sat 09 May 2015, 12:33    Post subject:  

*sigh*

You are more or less forcing me to return this printer or change Pups. We both know that the Carolina devs cannot offer help of this nature, and that they will only refer me to you.

I will ask you to reconsider. Again, nothing has changed, in terms of printer support, from a default Carolina Vanguard install, barring the fact that I followed your directions to attempt to install a printer and was unsuccessful in doing so.

_________________

Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Sat 09 May 2015, 12:45    Post subject:  

I have confirmed that none of the drivers I have work.

EDIT: redownloaded and reinstalled. Here is the terminal output. The printer still doesn't print.

Code:
# debbi mfcj470dwlpr-3.0.0-1.i386.deb
mkdir: can't create directory '/var/spool/lpd/mfcj470dw': No such file or directory
chown: unknown user lp
chgrp: /var/spool/lpd/mfcj470dw: No such file or directory
chmod: cannot access `/var/spool/lpd/mfcj470dw': No such file or directory
Post-install script completed!
Done!
# debbi mfcj470dwcupswrapper-3.0.0-1.i386.deb
cups: restarted scheduler.
lpadmin -p MFCJ470DW -E -v usb:/dev/usb/lp0 -P /usr/share/cups/model/Brother/brother_mfcj470dw_printer_en.ppd
Post-install script completed!
Done!
#


Please advise.

_________________

Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Sat 09 May 2015, 14:20    Post subject:  

If you will not assist me further with this printer, please recommend a replacement.

My budget is $80, not one penny higher. I will be shopping online at Staples. I am largely brand-agnostic as far as the printer itself, but it must be a wirelessly-networked multifunction (printer, scanner, and copier; I don't care either way about fax capability) and it absolutely must (for my mother) support a scan-directly-to-Evernote feature.

Here is the relevant search URL --> http://www.staples.com/Printers/cat_CL167883?fids=4225024860&sby=0&min=0&max=80

_________________

Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Sat 09 May 2015, 15:13    Post subject:  

I will once again reiterate that this logically cannot be an issue with the base Carolina Vanguard install. The printer worked absolutely fine before I redid my savefile, as several printed images and documents (as well as an earlier post in this very thread) can attest to.

To forestall the inevitable "you must've done something different there" comment, I will point out that I actually archive everything I install (dotPETs, DEBs, TXZs, etc), so that, should I need to redo my savefile in the future, everything is there and I don't have to hunt anything down and I cannot possibly forget anything.

I can tell you to a 1000% certainty that the only difference between the two savefiles, is that I found I did not need to install a libevent TXZ this time in order to make Chromium work; however, I fail to see how that could affect CUPS.

That said, again --
Quote:
If you will not assist me further with this printer, please recommend a replacement.

My budget is $80, not one penny higher. I will be shopping online at Staples. I am largely brand-agnostic as far as the printer itself, but it must be a wirelessly-networked multifunction (printer, scanner, and copier; I don't care either way about fax capability) and it absolutely must (for my mother) support a scan-directly-to-Evernote feature.

Here is the relevant search URL --> http://www.staples.com/Printers/cat_CL167883?fids=4225024860&sby=0&min=0&max=80

_________________

Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Sat 09 May 2015, 17:59    Post subject:  

aaaaaaaaand nevermind on the 'just get another printer' bit. It's past the return period, so like it or not I'm stuck with this thing.

Do please help me get it working.

_________________

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 11 of 14 [210 Posts]   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12, 13, 14 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1539s ][ Queries: 13 (0.0470s) ][ GZIP on ]