Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 14 Aug 2018, 19:59
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
tahrpup 6.0.5 CE
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 33 of 119 [1772 Posts]   Goto page: Previous 1, 2, 3, ..., 31, 32, 33, 34, 35, ..., 117, 118, 119 Next
Author Message
666philb


Joined: 07 Feb 2010
Posts: 3177
Location: wales

PostPosted: Thu 15 Jan 2015, 13:44    Post subject:  

i'm putting together a new iso of all fixes so far. This is just a bug-fix build, chiefly for new users so that they get a more complete iso.
it will basically be as similar as possible to tahrpup 6.0 with the service pack, fixed kernel and all bug-fixes so far.

it needs to be the same because tahrpup 6.0 and the new iso will be using the same updates from quickpet.

testing iso (not final)
http://distro.ibiblio.org/puppylinux/puppy-tahr/iso/testing/tahr-6.0.1_noPAE_testing2.iso
b80d49be9b18b8cda350aed0b6a7a50d
http://distro.ibiblio.org/puppylinux/puppy-tahr/iso/testing/devx_tahr_6.0.1.sfs
61e193fa9e05fab21a0ff1c03c724ed4

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331

Last edited by 666philb on Fri 16 Jan 2015, 20:24; edited 1 time in total
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1485
Location: france

PostPosted: Thu 15 Jan 2015, 15:46    Post subject:  

Hi,
Tas doesn't work because ffmpeg and some libraries lack.
I put together ffmpeg_2.5.2, libass5, libfdk-aac, libx265 in a pet and a sfs and it works fine.
ffmpeg is needed by pmusic and it's ok also for pmusic and a lot of other things.
Pet (32 MB)
SFS
Philippe

Last edited by augras on Fri 15 May 2015, 04:15; edited 2 times in total
Back to top
View user's profile Send private message 
SFR


Joined: 26 Oct 2011
Posts: 1660

PostPosted: Thu 15 Jan 2015, 16:17    Post subject:  

augras wrote:
Tas doesn't work because ffmpeg and some libraries lake.

Hi Philippe

You mean "Take a Shot!", right? If so, did you try v1.9?
Changelog wrote:
Version 1.9:
- compatibility with avconv

I just checked in VBox with TahrPup-6.0.1 and it's still fine here...

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3424
Location: Worcestershire, UK

PostPosted: Thu 15 Jan 2015, 16:40    Post subject:  

666philb wrote:
i'm putting together a new iso of all fixes so far. This is just a bug-fix build, chiefly for new users so that they get a more complete iso.
it will basically be as similar as possible to tahrpup 6.0 with the service pack, fixed kernel and all bug-fixes so far.

it needs to be the same because tahrpup 6.0 and the new iso will be using the same updates from quickpet.

testing iso (not final)
http://distro.ibiblio.org/puppylinux/puppy-tahr/iso/testing/tahr-6.0.1.iso
3cf39d490b725eeaf9a56067b605d95
http://distro.ibiblio.org/puppylinux/puppy-tahr/iso/testing/devx_tahr_6.0.1.sfs
21b7a6ff8e392a4e31d8974391485f37


Hi 666philb

Is the new iso pae or no-pae? I'm not aware that there is any way to tell is there? Never seen this aspect in any system reports......

Thanks
peebee

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
666philb


Joined: 07 Feb 2010
Posts: 3177
Location: wales

PostPosted: Thu 15 Jan 2015, 18:01    Post subject:  

hi peebee,

it's noPAE... pupsys-info can show PAE, noPAE.... on the kernel info section

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3424
Location: Worcestershire, UK

PostPosted: Thu 15 Jan 2015, 18:47    Post subject:  

666philb wrote:
hi peebee,

it's noPAE... pupsys-info can show PAE, noPAE.... on the kernel info section


Thanks - can confirm that Broadcom wl driver built for new 3.14.20-nopae kernel build works.

# freememapplet_tray is not working
Segmentation fault when run in terminal

Cheers
peebee

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Thu 15 Jan 2015, 22:23    Post subject:  

Hello 666PhilB
Quote:
... pupsys-info can show PAE, noPAE.... on the kernel info section
This post IN NO WAY intends to enter into a discussion of PAE vs anything.

But, with @Shinobar's BIOS unlock for the few pesky PentiumMs AND THOSE MEMBERS REPORTING that it does work, would it reduce your build efforts should you include it. Couple other distro developers have produced PUPs which have the Intel "fix" exposing the hidden PAE. This patch allows PUPs to run on PCs with or without the PAE feature exposed from the processor.

This needs no reply. But, if you want to see for yourself, you might take a look in an effort to reduce your workload (of build, test, and support of 2 versions) to the community while at the same time providing a distro which addresses most every x86 PC in the world.

Hope this helps.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1485
Location: france

PostPosted: Fri 16 Jan 2015, 03:31    Post subject:  

SFR wrote:

You mean "Take a Shot!", right? If so, did you try v1.9?
Changelog wrote:
Version 1.9:
- compatibility with avconv

I just checked in VBox with TahrPup-6.0.1 and it's still fine here...

Greetings!


Yes, it's Take a shot. And i tried tas1.8 with no success. Where did you find a v1.9 ?
Have a good day,
Philippe

EDIT : i get it http://www.murga-linux.com/puppy/viewtopic.php?t=84528
thancks for this utility SFR.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3177
Location: wales

PostPosted: Fri 16 Jan 2015, 06:38    Post subject:  

gcmartin wrote:
Hello 666PhilB
Quote:
... pupsys-info can show PAE, noPAE.... on the kernel info section
This post IN NO WAY intends to enter into a discussion of PAE vs anything.

But, with @Shinobar's BIOS unlock for the few pesky PentiumMs AND THOSE MEMBERS REPORTING that it does work, would it reduce your build efforts should you include it. Couple other distro developers have produced PUPs which have the Intel "fix" exposing the hidden PAE. This patch allows PUPs to run on PCs with or without the PAE feature exposed from the processor.

This needs no reply. But, if you want to see for yourself, you might take a look in an effort to reduce your workload (of build, test, and support of 2 versions) to the community while at the same time providing a distro which addresses most every x86 PC in the world.

Hope this helps.


whilst it works for some there were others where it didn't work (from personal experience) so a noPAE option is definitely needed

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3424
Location: Worcestershire, UK

PostPosted: Fri 16 Jan 2015, 08:23    Post subject:  

Additional:

# freememapplet_tray is not working
Segmentation fault when run in terminal
after a reboot and savefile creation

==============

new ppm - auto uninstall - doesn't run the puninstall.sh script in the same way that the classic step by step uninstall does....

==============

only place I can find no-pae mentioned in pup-sysinfo is in the kernel log
the sys-specs - kernel report does not indicate

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
666philb


Joined: 07 Feb 2010
Posts: 3177
Location: wales

PostPosted: Fri 16 Jan 2015, 08:39    Post subject:  

thanks peebee,

i noticed the freememapplet_tray problem ... i'm doing a build now using an earlier woofCE to see if it's something that's crept in there.

regarding the PPM , it's still in testing and you should post your findings here http://murga-linux.com/puppy/viewtopic.php?t=96710

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
radky

Joined: 02 May 2010
Posts: 813

PostPosted: Fri 16 Jan 2015, 09:23    Post subject:  

peebee wrote:
only place I can find no-pae mentioned in pup-sysinfo is in the kernel log
the sys-specs - kernel report does not indicate

peebee,

The PAE status report was added to PupSysInfo-2.5.2 (07 Oct 2014), and will be included as well in version 2.5.3 (available soon).

Sys-Specs -> Base Report
Sys-Specs -> Kernel report
File -> Hardware Reports -> Summary and Complete

_________________
PupMates
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3177
Location: wales

PostPosted: Fri 16 Jan 2015, 20:45    Post subject:  

new iso uploaded

i used a woof before '/initrd/pup_rw' became a symlink and freememapplet_tray seems to be working properly now.

deleted some superfluous right click entries and fixed others
added ndiswrapper and also a 'depmod -a' on first boot to enable it
i'm considering adding ca-certificates to the build as some apps need them.

testing iso (not final)
http://distro.ibiblio.org/puppylinux/puppy-tahr/iso/testing/tahr-6.0.1_noPAE_testing2.iso
b80d49be9b18b8cda350aed0b6a7a50d
http://distro.ibiblio.org/puppylinux/puppy-tahr/iso/testing/devx_tahr_6.0.1.sfs
61e193fa9e05fab21a0ff1c03c724ed4[/url]

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331

Last edited by 666philb on Sat 17 Jan 2015, 13:40; edited 1 time in total
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1485
Location: france

PostPosted: Sat 17 Jan 2015, 05:32    Post subject:  

Hi,
SFR wrote:
augras wrote:
Tas doesn't work because ffmpeg and some libraries lake.

Hi Philippe

You mean "Take a Shot!", right? If so, did you try v1.9?
Changelog wrote:
Version 1.9:
- compatibility with avconv

I just checked in VBox with TahrPup-6.0.1 and it's still fine here...

Greetings!

Of course you are right ! Tas1.9 works fine without ffmpeg.

I keep ffmpeg : a lot of things need it.
Philippe
Back to top
View user's profile Send private message 
gyro

Joined: 28 Oct 2008
Posts: 1542
Location: Brisbane, Australia

PostPosted: Sat 17 Jan 2015, 11:21    Post subject:  

666philb wrote:
i used a woof before '/initrd/pup_rw' became a symlink and freememapplet_tray seems to be working properly now.
Couldn't possibly be that "freememapplet_tray" is a version that pre dates 'initrd/pup_rw' becoming a symlink?
("freememapplet_tray" did have to be patched at that time.)
gyro
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 33 of 119 [1772 Posts]   Goto page: Previous 1, 2, 3, ..., 31, 32, 33, 34, 35, ..., 117, 118, 119 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0694s ][ Queries: 13 (0.0140s) ][ GZIP on ]