Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 18 Sep 2019, 18:38
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Carolina: Vanguard Edition Release 2 December 2014
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 41 [615 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 39, 40, 41 Next
Author Message
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Sun 14 Dec 2014, 21:42    Post subject: Carolina: Vanguard Edition  

I tested on another ACER desktop:

video-info-glx 1.5.3 Sun 14 Dec 2014 on Vanguard-Carolina 1.3 Linux 3.18.0 i686
2.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 1Cool
oem: Intel(R)Ironlake Desktop Graphics Chipset Accelerated VGA BIOS
product: Intel(R)Ironlake Desktop Graphics Controller Hardware Version 0.0

X Server: Xorg Driver: intel
X.Org version: 1.11.0
dimensions: 1920x1080 pixels (507x285 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Desktop x86/MMX/SSE2
OpenGL version string: 2.1 Mesa 7.10.3

Intel(R) Core(TM) i3 CPU 540 @ 3.07GHz
Core 0: @1200 1: @1200 2: @1200 3: @1200 MHz

So I have 2 that work with intel (G31 and Ironlake)and 2 that don't
work (Ivybridge and HD 4000).

@Marv
I did that last test by booting the live dvd puppy pfix=nox,ram
I may try again with a flash drive install.
Thanks
Back to top
View user's profile Send private message 
Moat


Joined: 16 Jul 2013
Posts: 966
Location: Mid-mitten

PostPosted: Sun 14 Dec 2014, 22:39    Post subject:  

Frugal install to SD card (via USB card adapter) on this old 2005-ish HP-DV500 hand-me-down laptop;

Code:
-Computer-
Processor      : 2x Genuine Intel(R) CPU           T2050  @ 1.60GHz
Memory      : 2063MB (206MB used)
Machine Type      : Physical machine
Operating System      : Puppy Linux
User Name      : root (root)
Date/Time      : Sun Dec 14 21:08:59 2014
-Display-
Resolution      : 1280x800 pixels
OpenGL Renderer      : Mesa DRI Intel(R) 945GM  x86/MMX/SSE2
X11 Vendor      : The X.Org Foundation
-Audio Devices-
Audio Adapter      : HDA-Intel - HDA Intel


Outstanding! I echo what others have said about low CPU use/snappiness - Carolina seems to have always been superior in that regard, and this one is even better (!?!!) - a fresh install bouncing between 0-1% @ idle. Unheard of in Puppy.

I copied over and re-named (just adding "v" to the front of the name) my previous 1.3 version savefile... aside from missing the Faenza icons on my wbar (resolved by mounting the previous main .sfs and copying the Faenza folders over to /usr/share/icons), all seems to be running just fine. Any reason using my old savefile like this might not be a good idea?

Interesting, I noticed a number of new services enabled... things like "Allusbserial", "martian" and "Nozomi" - will have to do a little Googling and determine which of those can be safely disabled.

No wireless access ATM, so will test that when I get the chance.

The best just keeps getting better and better... Cool

Bob
Carolina_Vanguard.jpg
 Description   Carolina Vanguard running previous savefile
 Filesize   110.09 KB
 Viewed   678 Time(s)

Carolina_Vanguard.jpg

Back to top
View user's profile Send private message 
Moat


Joined: 16 Jul 2013
Posts: 966
Location: Mid-mitten

PostPosted: Mon 15 Dec 2014, 00:49    Post subject:  

Moat wrote:
No wireless access ATM, so will test that when I get the chance.


Posting now from McD's WiFi - Frisbee connected perfectly!

Bob
Back to top
View user's profile Send private message 
Keisha

Joined: 18 Nov 2014
Posts: 469

PostPosted: Mon 15 Dec 2014, 03:36    Post subject: Carolina Vanguard not working with Intel IvyBridge graphics  

Carolina Vanguard on Intel IvyBridge graphics doesn't work here either, same symptoms as billtoo reports.
Back to top
View user's profile Send private message 
Minnesota

Joined: 11 Sep 2008
Posts: 326

PostPosted: Mon 15 Dec 2014, 07:00    Post subject: Master PDF Editior
Subject description: Will not run
 

Nice!
Crisp and looks good!

Tried to run Master PDF Editor from the menu. It looks at me, did not run.
Found the script, tried to run it. Gives error line five. Sorry beyond me.

Thanks.
Back to top
View user's profile Send private message 
Moat


Joined: 16 Jul 2013
Posts: 966
Location: Mid-mitten

PostPosted: Mon 15 Dec 2014, 07:10    Post subject: Re: Master PDF Editior
Subject description: Will not run
 

Minnesota wrote:
Tried to run Master PDF Editor from the menu. It looks at me, did not run.


Same here. Running from the terminal, looks like missing elements of GLIBC... or symlinks?

Code:
# master-pdf-editor
/opt/MasterPDFEditor/master-pdf-editor: /opt/MasterPDFEditor/lib/libc.so.6: version `GLIBC_2.18' not found (required by /usr/lib/libstdc++.so.6)
/opt/MasterPDFEditor/master-pdf-editor: /opt/MasterPDFEditor/lib/libc.so.6: version `GLIBC_2.17' not found (required by /usr/lib/libstdc++.so.6)


Bob
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1383
Location: Australia

PostPosted: Mon 15 Dec 2014, 08:10    Post subject:  

Billtoo wrote:
Unfortunately I haven't a clue what I'm looking for Smile


I suppose errors, firmware not found/not loading. Usually quite obvious with a quick glance through. But still, you should be able to get dmesg out with
Code:
dmesg > /root/dmesg.txt

That puts the output to a text file in root. What I usually do then if I don't have access to Xorg is save the pupsave and access it in another pup like Marv suggested.

Marv wrote:
Try dmesg | grep drm and dmesg | grep i915. To save them you may be able to redirect them to files on the boot partition and get at them from another pup.


Thanks for piping in Marv, I was busy today.

Moat wrote:
aside from missing the Faenza icons on my wbar


Yeah, I was scrimping a bit there, worried about size going over 500MB so I removed them to make way for the new icons. Figured if anyone wanted them back they could just put them back like you did.

Moat wrote:
Interesting, I noticed a number of new services enabled... things like "Allusbserial", "martian" and "Nozomi


Hmm, thanks for the heads up. I think the kernel put a bunch of services like the ones you mentioned in to /etc/init.d. I wasn't sure which were essential Puppy services and which were superfluous, so please do share the results of your research Smile

Moat wrote:
Posting now from McD's WiFi - Frisbee connected perfectly!
Sweet! I think these positive reports might give me a dose of endorphins Wink

Billtoo wrote:
So I have 2 that work with intel (G31 and Ironlake)and 2 that don't work (Ivybridge and HD 4000).


Keisha wrote:
Carolina Vanguard on Intel IvyBridge graphics doesn't work here either, same symptoms as billtoo reports.


Thanks for the new reports guys. I'm suspecting Xorg, but would like to do more research before putting up a Xorg update pet. What distros/Puplets do your graphics cards work with?

Minnesota wrote:
Nice!
Crisp and looks good!

Tried to run Master PDF Editor from the menu. It looks at me, did not run.
Found the script, tried to run it. Gives error line five. Sorry beyond me.

Thanks.


No worries! It's an easy fix. Geoff posted the fix here.

Skype needs a fix too.

They needed a glibc work around in the original Carolina, but obviously glibc has been updated in Vanguard so the work around isn't needed and in fact breaks the application.

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1383
Location: Australia

PostPosted: Mon 15 Dec 2014, 09:53    Post subject:  

Thinking about the Intel issue... questions I'd like answers to, can't seem to find them by searching:

    1. What .ko do the cards in question use?
    2. What .firmware do the cards in question use?
    3. Xorg.conf of working configs and of the config in Vanguard
    4. /var/log/Xorg.0.log of working setups and Vanguard
    5. Does the kernel parameter "nomodeset" do anything?
    6. Does XorgWizard ever get upgraded? Does it need to be to keep up with hardware? For example I notice "evdev" gets used in newer pups, but Carolina/Vanguard continues to use "kbd"
    7. Yes, I think we all know by now I would like to see a dmesg of problem hardware, but I understand people have lives Smile


These questions aren't direct to any one person or even only to those with the hardware in question, I'm just hoping passerbys might chip in and add their two pence.

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Mon 15 Dec 2014, 10:59    Post subject:  

battleshooter wrote:

Thanks for the new reports guys. I'm suspecting Xorg, but would like to do more research before putting up a Xorg update pet. What distros/Puplets do your graphics cards work with?


Carolina 1.3 works on the ivybridge computer, also dual booting the 64
bit versions of Mint 17 and Xubuntu 14.10.

video-info-glx 1.5.3 Mon 15 Dec 2014 on Carolina 1.3 Linux 3.2.13-ski i686
2.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
oem: Intel(R) Sandybridge/Ivybridge Graphics Chipset Accelerated VGA BIOS
product: Intel(R) Sandybridge/Ivybridge Graphics Controller Hardware Version 0.0

X Server: Xorg Driver: vesa
X.Org version: 1.11.0
dimensions: 1920x1080 pixels (602x343 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 2.1 Mesa 7.10.3

Intel(R) Core(TM) i5-3550 CPU @ 3.30GHz
Core 0: @1600 1: @1600 2: @1600 3: @1600 MHz

It's using the vesa driver on bootup, I just exited to the prompt now and ran xorgwizard,
chose the intel driver and chose the correct resolution then xwin, it is still using the vesa driver.

It's far from snappy but it is working.
Back to top
View user's profile Send private message 
Moat


Joined: 16 Jul 2013
Posts: 966
Location: Mid-mitten

PostPosted: Mon 15 Dec 2014, 11:05    Post subject:  

battleshooter wrote:
Geoff posted the fix here.

Skype needs a fix too.

They needed a glibc work around in the original Carolina, but obviously glibc has been updated in Vanguard so the work around isn't needed and in fact breaks the application.


DoH! Right in front of me. In one ear (eye?)........

Geoffrey's fix for Master PDF Editor works Smile... but his fix for Skype is spitting something out about QT incompatibility -

Code:
# skype
Fatal: Cannot mix incompatible Qt library (version 0x40800) with this library (version 0x40802)
/usr/bin/skype: line 6: 26375 Aborted                 /usr/share/skype/skype
#


Question

FWIW...

Bob
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Mon 15 Dec 2014, 12:57    Post subject:  

battleshooter wrote:

7. Yes, I think we all know by now I would like to see a dmesg of problem hardware, but I understand people have lives Smile[/list]

These questions aren't direct to any one person or even only to those with the hardware in question, I'm just hoping passerbys might chip in and add their two pence.


Got it, I attached it to a PM, you'll need to rename the file dmesg.txt

Last edited by Billtoo on Mon 15 Dec 2014, 13:31; edited 1 time in total
Back to top
View user's profile Send private message 
Keisha

Joined: 18 Nov 2014
Posts: 469

PostPosted: Mon 15 Dec 2014, 13:19    Post subject:  

battleshooter wrote:
Thinking about the Intel issue... questions I'd like answers to, can't seem to find them by searching:

    1. What .ko do the cards in question use?
    2. What .firmware do the cards in question use?
    3. Xorg.conf of working configs and of the config in Vanguard
    4. /var/log/Xorg.0.log of working setups and Vanguard
    5. Does the kernel parameter "nomodeset" do anything?
    6. Does XorgWizard ever get upgraded? Does it need to be to keep up with hardware? For example I notice "evdev" gets used in newer pups, but Carolina/Vanguard continues to use "kbd"
    7. Yes, I think we all know by now I would like to see a dmesg of problem hardware, but I understand people have lives Smile


These questions aren't direct to any one person or even only to those with the hardware in question, I'm just hoping passerbys might chip in and add their two pence.


Tried, but in tar.gz format the answers plus four relevant screencaps are 335K and this forum only allows 256K upload attachments. PM me your email addy and I'll send it that way.
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 14307
Location: Gatineau (Qc), Canada

PostPosted: Mon 15 Dec 2014, 13:23    Post subject:  

Hello, battleshooter.

You did get me "sold" on your product Smile.

However, your new Carolina girl leaves me out in the cold Smile after (giving
me the) boot-up, exactly at
Code:
root login on "tty1"


I mean: the boot process goes well and then the computer freezes badly
at that point.

BTW, if it's any help, my computer's an AMD Sempron 3100+ from 2007.
Or could it be the 3.18 kernel?

Best regards.

musher0

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
yerc1

Joined: 09 Jan 2009
Posts: 118

PostPosted: Mon 15 Dec 2014, 14:03    Post subject:  

battleshooter wrote:

I suspect it's Xorg. So far it's only working on Fatdog for you right? How did exton's build work out?

vlina needs "puppy acpi=off pfix=nox" then to pick vesa within xorgwizard else the display is garbled. I think vlina detects the intel video correctly but does not have the new driver required. Fatdog and PuppEX don't have a problem with the display.

exton's remaster of Puppy Tahr 6 with kernel 3.17 doesn't play nice with the touchpad either.

Quote:
No, amixer is correct. The script isn't working because your
1. Volume keys aren't being mapped out
2. I suspect you main sound card is not being mapped to default (Is it being found at all? Does sound actually work)

Sound works and I can adjust volume in alsamixer. I don't have to do anything in vlina for sound to work.
The amixer error message might have something do with vlina detecting only one sound card, idk?
Fatdog/PuppEX detect two sound cards but I have to pick the second card for sound to work.

Quote:
One more thing, md5sum checked out right?

Yep

One more thing, vlina suggested that I add pci=biosirq kernel option for the atheros wireless. The dmesg output attached is generated within vlina running with that boot parameter.

I attached Fatdog's dmesg output for comparison purposes.

thanks heaps.
dmesg_fatdog.txt.tar.gz
Description 
gz

 Download 
Filename  dmesg_fatdog.txt.tar.gz 
Filesize  13.74 KB 
Downloaded  567 Time(s) 
dmesg_vlina.txt.tar.gz
Description 
gz

 Download 
Filename  dmesg_vlina.txt.tar.gz 
Filesize  9 KB 
Downloaded  601 Time(s) 

Last edited by yerc1 on Mon 15 Dec 2014, 14:15; edited 1 time in total
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 1189
Location: SW Wisconsin

PostPosted: Mon 15 Dec 2014, 14:14    Post subject:  

battleshooter wrote:
Thinking about the Intel issue... questions I'd like answers to, can't seem to find them by searching:

    1. What .ko do the cards in question use?
    2. What .firmware do the cards in question use?
    3. Xorg.conf of working configs and of the config in Vanguard
    4. /var/log/Xorg.0.log of working setups and Vanguard
    5. Does the kernel parameter "nomodeset" do anything?
    6. Does XorgWizard ever get upgraded? Does it need to be to keep up with hardware? For example I notice "evdev" gets used in newer pups, but Carolina/Vanguard continues to use "kbd"
    7. Yes, I think we all know by now I would like to see a dmesg of problem hardware, but I understand people have lives Smile


These questions aren't direct to any one person or even only to those with the hardware in question, I'm just hoping passerbys might chip in and add their two pence.


Attached are xorg.conf and Xorg.0.log files from working (Tahr based LxPupTahr 14.10.1) and vlina. Omitted the dmesg for now. Lots to chew upon already Exclamation I had to boot vlina with a minimal save file from 1.2 to extract the sore tooth but I cleaned it as much as I could first. When I worked toward updating the Xorg in X-slacko toward the Tahr version all with 3.14.20 kernels with mixed sucess I pretty much concluded that Xorg/Mesa/xorgwizard/drivers were an 'all or none' proposal.
Xorg_comparisons.tar.gz
Description 
gz

 Download 
Filename  Xorg_comparisons.tar.gz 
Filesize  8.12 KB 
Downloaded  598 Time(s) 

_________________
Pups currently in kennel Very Happy LxPupSc and X-slacko-4.4 for my users; LxPupSc, LxPupSc64, LxPupBionic and upupdd for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 41 [615 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 39, 40, 41 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0723s ][ Queries: 13 (0.0066s) ][ GZIP on ]