Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 00:24
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Muppylinux-004 (+ 005 for testing)
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 5 of 7 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Author Message
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Tue 28 Nov 2006, 23:10    Post_subject:  

I updated the servicepack for Muppy 005 again.
It includes basically internal fixes, also corrects the 3DCC.

I will create Muppy 006 this weekend with all fixes included.

Mark
Back to top
View user's profile Send_private_message Visit_website 
vabene06

Joined: 25 Apr 2006
Posts: 36

PostPosted: Wed 29 Nov 2006, 05:12    Post_subject:  

Hey MU,
my problem with the language-selection at start may come from my remaster of muppy-5 (with kde, scribus etc.) I will try to make a new und proper one.
Vabene
Back to top
View user's profile Send_private_message 
Arcflup

Joined: 28 Nov 2006
Posts: 12
Location: UK

PostPosted: Wed 29 Nov 2006, 05:27    Post_subject:  

MU wrote:

You also can type in a console:
setrox1


And setrox2 switches back, cool.
Back to top
View user's profile Send_private_message 
vabene06

Joined: 25 Apr 2006
Posts: 36

PostPosted: Wed 29 Nov 2006, 14:57    Post_subject:  

Hey MU,
i made a check, everything works now - only the german language not (umlaute). when i do a Muppylocale i got an error. /root/.gtkrc.mine -unexpexted identifier "gtk-icon-theme-name", expected keyword - e.g. `style. After resseting i have to chose a language when muppy starts up

Vabene
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 29 Nov 2006, 15:17    Post_subject:  

Quote:
i got an error. /root/.gtkrc.mine -unexpexted identifier "gtk-icon-theme-name"


you can ignore that error.
This entry is needed for Gtk2, but Gtk1 does not know what to do with it, and ignores it.

Do you get the menu to choose the language then?

You also could modify /etc/profile manually, set this value there:
LANG=de_DE.UTF-8

then restart X.
Success?
Mark

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 29 Nov 2006, 15:21    Post_subject:  

the language-selection is in /etc/rc.d/rc.muppy2:

Code:

# set language

if [ ! -f "/mnt/home/pup_save.3fs" ];then

dialog --no-cancel --menu "Language - Sprache\n
\n


Do you have /mnt/home/pup_save.3fs ?

Would be nice to clear what is wrong, but as a quick workaround you could replace the line with
if [ "1" == "0" ];then

This is never true, so no more check Wink
Mark
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 29 Nov 2006, 15:27    Post_subject:  

ahh, and set a unicode-font in "styling" - Gtk-themechooser (on the desktop).
You can use bitstream vera.

This should be set by my dotpup however...

Mark
Back to top
View user's profile Send_private_message Visit_website 
Sage

Joined: 04 Oct 2005
Posts: 4818
Location: GB

PostPosted: Wed 29 Nov 2006, 15:48    Post_subject:  

pakt: Whilst the purists wrestle with detail, glad to note that I get TWO sets of two barks AND music - wunderbar! Actually, this is extremely helpful as a guide to soundcard problems - or not.
Being a bit of a wag myself, decided to d/l some 'bark' sound files with a view to incorporating them into a serial port or wireless link to my doorbell.
Back to top
View user's profile Send_private_message 
KevOB

Joined: 21 Oct 2006
Posts: 38
Location: Wellington NZ

PostPosted: Wed 29 Nov 2006, 17:44    Post_subject:  

MU great work, thanks. There is real use for a grown up puppy.

As others have reported, MUT and Pmount do not work on my homebrew sempron 2400 with 1Gb ram. (Automounting would be nice.)

Open Office - I downloaded the file previously and it is still there in /mnt/home but Open Office installer insists on downloading it again.

Gnucash - could you, or some else please consider packaging this. It's a serious accounting program - as distinct from a cheque book manager.

DVDtool - this requires each VOB file to be separately processed. If they all could be selected and the output to one file I could throw out DGIndex. which I use to extract sound from DVD's. or remastering
DVD tool is better as it can go straight to a 44.1k wav or MP3 so the multiple selection would make it a winner.

DVD::RIP - Could this be considered too please.

Kevin
Back to top
View user's profile Send_private_message 
vabene06

Joined: 25 Apr 2006
Posts: 36

PostPosted: Wed 29 Nov 2006, 18:01    Post_subject:  

Hallo again,
Mu i changed the line in rc.muppy2, the language-settings at startup disappears. ok. thats done. but still no german umlaute. i have no /mnt/home/pup_save...
My Muppy-Version is on an flash-ide-drive (it is very quick), called /dev/hdd.

i have a remasterd cd too. i will try this with your servicepack.
Vabene
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 29 Nov 2006, 18:18    Post_subject:  

Open Office

In Muppy 005, it must be called OpenOffice-2.04_212.sfs, as 005 is based on Puppy 2.12.
Important is "_212.sfs" in the end.
If it is different, it will not be mounted automatically after the next reboot.

Concerning the MUT-issue:
I could not burn a CD yet, hope I can do it tomorrow.
Maybe then I can reproduce the error.

Concerning the other programs, are there dotpups already? If not, please request them in the additional softwareforum Smile

-------
vabene, if you installed on a flash-drive,, is the pup_save.3fs on the same drive?
Maybe for this reason you have no /mnt/home?
Then I must modify the check for such a case.

Can you please post the content of your file:
/etc/rc.d/PUPSTATE

Mark
Back to top
View user's profile Send_private_message Visit_website 
vabene06

Joined: 25 Apr 2006
Posts: 36

PostPosted: Wed 29 Nov 2006, 18:50    Post_subject:  

Hallo Mu,

tested a little more, but i can not write german umlaute. But i can read them? Maybe there is something with the keyboard?
Here is my pupstate
PUPMODE=13
PDEV1='hdd'
DEV1FS='vfat'
PUPSFS='pup_212.sfs'
PUPSAVE='vfat,hdd,/pup_save.3fs'
PMEDIA='ideflash'
SATADRIVES=''
#these directories are unionfs layers in /initrd...
SAVE_LAYER='/pup_ro1'
PUP_LAYER='/pup_ro2'

Vabene
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 29 Nov 2006, 19:01    Post_subject:  

thanks vabene, this will help me to optimize the script Smile

To write german, you must choose german keyboardlayout.
If you did not do it at first start, it is in Setup - Mouse/Keyboardwizard.

To test rox, you could do this:
extract this file in /root/:

http://dotpups.de/tests/Umlaut-test.tgz

Then click on the home-icon on your desktop to open /root in Rox.
Now you should see a file testäöü.txt

Mark
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 29 Nov 2006, 19:25    Post_subject:  

I just see, the Umlaut-issue is not solved yet so good.
First, you must not run setrox1 from a consolewindow, as the consolewindow supports no UTF-8. Rox would "inherit" the no-UTF settings from the console.
I simply draged both scripts on my desktop from /usr/local/bin , that works.

Second:
If I create testäöü.txt in XFileExplorer, it is displayed correct in Rox1 and Rox2.
But if I create such a file in leafpad or geany, only Rox2 shows it correct, in Rox1 I get strange characters (picture):



Sad

So more tests are required, without a guarantee to find a final solution with rox1 Confused

Mark
Back to top
View user's profile Send_private_message Visit_website 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Wed 29 Nov 2006, 20:12    Post_subject:  

in my dotpup handler script, i needed to put this line in the script to prevent something from converting utf8 to the default charset:

export OUTPUT_CHARSET="utf-8"

i don't know if that would help your problem or not
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 5 of 7 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0753s ][ Queries: 12 (0.0052s) ][ GZIP on ]