Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 25 Aug 2019, 02:03
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
slacko-6.0 beta 2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 49 of 56 [836 Posts]   Goto page: Previous 1, 2, 3, ..., 47, 48, 49, 50, 51, ..., 54, 55, 56 Next
Author Message
partsman

Joined: 06 Jun 2012
Posts: 358
Location: OHIO,USA

PostPosted: Thu 20 Nov 2014, 13:23    Post subject:  

When installing supertux2 from PPM It wouldn't run still needed to install openal even though PPM showed openal-soft was installed !
I chose to install openal-1.13.pet to solve this however a symlink to openal-soft may be a better approach Confused

_________________
Anyone can build a fast processor. The trick is to build a fast system. (Seymour Cray) Wink
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4858
Location: Blue Springs, MO

PostPosted: Thu 20 Nov 2014, 14:52    Post subject:  

ttuuxxx wrote:
Close but it only has 256-color drawing, not enough colours:)
ttuuxxx
You can always add more layers to get more colors. That is what I did with mtpaint anyhow. Any more than 256 makes it difficult to get to the colors anyhow.
_________________
Check out my github repositories. I may eventually get around to updating my blogspot.
Back to top
View user's profile Send private message Visit poster's website 
MochiMoppel


Joined: 26 Jan 2011
Posts: 1884
Location: Japan

PostPosted: Fri 21 Nov 2014, 04:34    Post subject:  

X crashes when using Gnumeric

Slacko 5.7 and 5.9.3 use the same Gnumeric version (1.10.17), so the problem must be with the new Slacko. Can somebody confirm?

To reproduce:
1) Type anything into a cell and press Enter
2) Select this cell and press Ctrl+C (to copy)
3) Select another cell and press Crl+V (to paste)

This may already crash X, latest when selecting another cell X crashes. Typing xwin will restart X, but changes made in Gnumeric are lost.

Copy & Paste via context menu works normal.
Back to top
View user's profile Send private message 
LazY Puppy


Joined: 21 Nov 2014
Posts: 2007
Location: Germany

PostPosted: Sun 23 Nov 2014, 00:04    Post subject:  

Hi.

I'm currently examining the Slacko 5.9.3 and found some issues.

1.) using pkeys as boot parameter and boot is failing (puppy sfs not found)
2.) using plang as boot parameter and boot is failing (puppy sfs not found)
3.) can't connect to the internet using my GPRS Mobile USB-Modem (it is detected and ready for use - as the messages say; menus are updated but nothing else happens after this; no menu entries, no option to connect - works always in Lucid and Precise)

RSH

P.S.

Booting pkeys and plang tested in combination and as single used options - failed all the way. Failed also using 'fr' (french). Other languages not tested.
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 3056

PostPosted: Sun 23 Nov 2014, 01:44    Post subject:  

LazY Puppy wrote:
1.) using pkeys as boot parameter and boot is failing (puppy sfs not found)
2.) using plang as boot parameter and boot is failing (puppy sfs not found)
<snip>
Booting pkeys and plang tested in combination and as single used options - failed all the way. Failed also using 'fr' (french). Other languages not tested.

Looks fine here, alone or in combination. Few lang tested (including french - pic).

Anything special in your setup? The only relevant change I can find is this relating to VFAT booting devices, but this is also in slacko-5.7 Confused
French.png
 Description   
 Filesize   61.45 KB
 Viewed   1411 Time(s)

French.png


_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
SFR


Joined: 26 Oct 2011
Posts: 1727

PostPosted: Sun 23 Nov 2014, 06:22    Post subject:  

LazY Puppy wrote:
1.) using pkeys as boot parameter and boot is failing (puppy sfs not found)

The use of pkeys while booting off USB drive is causing such problems due to absence of some modules (which usually were in initrd.gz) that should be compiled into vmlinuz.
http://www.murga-linux.com/puppy/viewtopic.php?p=789977#789977
http://www.murga-linux.com/puppy/viewtopic.php?p=790324#790324
Does it also happens while booting off USB, in your case?

LazY Puppy wrote:
2.) using plang as boot parameter and boot is failing (puppy sfs not found)

Can't recreate - works for me (USB & CD)...

LazY Puppy wrote:
3.) can't connect to the internet using my GPRS Mobile USB-Modem (it is detected and ready for use - as the messages say; menus are updated but nothing else happens after this; no menu entries, no option to connect - works always in Lucid and Precise)

PGPRS' files have been lost in action. Wink
https://github.com/puppylinux-woof-CE/woof-CE/issues/498
___________

MochiMoppel wrote:
Can somebody confirm?

Just checked in VBox & QEmu and can not recreate this behaviour...
Anything relevant in the output?
Code:
gnumeric > /tmp/gnumeric.log 2>&1

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
MochiMoppel


Joined: 26 Jan 2011
Posts: 1884
Location: Japan

PostPosted: Sun 23 Nov 2014, 07:06    Post subject:  

SFR wrote:
Just checked in VBox & QEmu and can not recreate this behaviour...
Anything relevant in the output?
Code:
gnumeric > /tmp/gnumeric.log 2>&1

Looks relevant, but not pleasant:
Code:
gnumeric: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

Thanks for checking.
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 3056

PostPosted: Sun 23 Nov 2014, 08:08    Post subject:  

SFR wrote:
LazY Puppy wrote:
1.) using pkeys as boot parameter and boot is failing (puppy sfs not found)

The use of pkeys while booting off USB drive is causing such problems due to absence of some modules (which usually were in initrd.gz) that should be compiled into vmlinuz.
http://www.murga-linux.com/puppy/viewtopic.php?p=789977#789977
http://www.murga-linux.com/puppy/viewtopic.php?p=790324#790324
Does it also happens while booting off USB, in your case?


Makes sense. With the new kernel setup (no modules in initrd.gz) booting from a vfat usb drive with non-english will fail since it can not read the filesystem and find the files.
It needs a new kernel with CONFIG_NLS_CODEPAGE_{850,852} and CONFIG_NLS_ISO8859_2 set to"y" instead of "m".
Maybe when/if Mick appears.

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
LazY Puppy


Joined: 21 Nov 2014
Posts: 2007
Location: Germany

PostPosted: Sun 23 Nov 2014, 09:19    Post subject:  

Quote:
relating to VFAT

Quote:
Does it also happens while booting off USB, in your case?

Yes, I'm booting generally from a VFAT Partition. Also generally from USB. This time External 500GB USB HDD.

As I was running into this I did use my modified version of the initrd.gz.

Had immediately tested with the original one after running into this.

Equal Results.

As soon as I enter pkeys or plang, it won't find the puppy sfs.

I can set DE keyboard later by using setxkbmap de, but need to do it each time after restarting X.

Just for your interest.
My modifications on initrd.gz to make me able to configure Slacko 5.9.3 at boot up and auto-start by an external .cfg File


Thanks,

RSH
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 3056

PostPosted: Sun 23 Nov 2014, 11:33    Post subject:  

LazY Puppy wrote:
Yes, I'm booting generally from a VFAT Partition. Also generally from USB. This time External 500GB USB HDD.

As I was running into this I did use my modified version of the initrd.gz.

Since you are playing with the initrd then it should be easy to use the tahpup kernel (3.14.20) that has the modules built in and should be OK. Is fairly easy to exchange them

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
lolox

Joined: 02 Dec 2014
Posts: 1

PostPosted: Wed 03 Dec 2014, 07:29    Post subject:    

Hello !
I am a happy puppy Linux user since v. 4.2.1. I switched to slacko 5.4 in 2012 and I am now running 5.7.

I installed the 5.9.3 test release found at ibiblio on my old laptop (a 2007 hp/compaq nc6120) hdd. Everything worked fine (I noticed that a bug modifying time & date at boot was fixed. Good job : a firewall does not authorize me to use ntpdate at work ; I compiled htpdate to synchronize time & date at start) until I tried to upgrade from slacko 5.7 by copying my slackosave.sfs file in the 5.9.3 directory (I used to do this successfully to upgrade to 5.5, 5.6 and 5.7) and to reboot. When X started, I got a black screen showing only the bottom menu bar. The menu is there with all my software, but only a few SDL apps like Dosbox seem to work. I cannot even open a terminal, so it is difficult to tell what is going wrong.

My slackosave is large, 4.5Gb, too large to boot from a USB stick formatted with fat16 or fat32, but works fine with ext2 or ext3+grub and slacko 5.7. Maybe is it the source of my problem ? Have I to reinstall all my software in slacko 5.9.3 ? Should I try to install 5.9.1 and upgrade to 5.9.3 from 5.9.1 ?
Back to top
View user's profile Send private message 
LazY Puppy


Joined: 21 Nov 2014
Posts: 2007
Location: Germany

PostPosted: Wed 03 Dec 2014, 22:44    Post subject:  

Maybe this is of some kind of interest.

http://murga-linux.com/puppy/viewtopic.php?t=96571

I have reached my current goals so far.

Btw: booting from ext2 and it goes straight into DE desktop and DE keyboard layout.

When will the lost PGPRS files be included or are they ready for download somewhere?

_________________
RSH

"you only wanted to work your Puppies in German", "you are a separatist in that you want Germany to secede from Europe" (musher0) Laughing

No, but I gave my old drum kit away for free to a music store collecting instruments for refugees! Wink
Back to top
View user's profile Send private message 
LazY Puppy


Joined: 21 Nov 2014
Posts: 2007
Location: Germany

PostPosted: Fri 05 Dec 2014, 18:07    Post subject:  

SFR wrote:
PGPRS' files have been lost in action. Wink
https://github.com/puppylinux-woof-CE/woof-CE/issues/498

Since the PGPRS Files have been lost in action may I suggest a small tweak to its GUI for next release of Slacko (5.9.4?, 6.0?).

Instead of using a entry widget to enter the modem device manually and to enter the APN manually also, just using a comboboxentry to give the user option to choose the modem device from a list as well as to choose the APN from a list.

For one of the main providers in Germany it would be: internet.t-d1.de

_________________
RSH

"you only wanted to work your Puppies in German", "you are a separatist in that you want Germany to secede from Europe" (musher0) Laughing

No, but I gave my old drum kit away for free to a music store collecting instruments for refugees! Wink
Back to top
View user's profile Send private message 
LazY Puppy


Joined: 21 Nov 2014
Posts: 2007
Location: Germany

PostPosted: Sat 13 Dec 2014, 00:44    Post subject:  

http://murga-linux.com/puppy/viewtopic.php?p=814542#814542
LazY Puppy wrote:
Hi.

While doing some work on this I have found a issue in precise 5.7.1.

The file /etc/DISTRO_SPECS in main sfs is different to the file /DISTRO_SPECS in initrd.gz. The one in initrd.gz is missing this:
Code:
#multiarch distros, such as Ubuntu, will have this. ex: /usr/lib/i386-linux-gnu, so DISTRO_ARCHDIR=i386-linux-gnu
DISTRO_ARCHDIR='i386-linux-gnu'

Hi.

Since you are already changing things in WoofCE may I add another suggestion to the one posted above, to avoid the above quoted issue in precise 5.7.1 happening in Slacko or any future WoofCE Puppy.

Just remove /etc/DISTRO_SPECS from inside of the main sfs and copying the one from inside of the initrd.gz to /pup_new/etc/ right before performing the switch_root.

_________________
RSH

"you only wanted to work your Puppies in German", "you are a separatist in that you want Germany to secede from Europe" (musher0) Laughing

No, but I gave my old drum kit away for free to a music store collecting instruments for refugees! Wink
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 3056

PostPosted: Sat 13 Dec 2014, 03:07    Post subject:  

LazY Puppy wrote:

Since you are already changing things in WoofCE may I add another suggestion to the one posted above,

The idea of CE (community edition) is not that the community suggests and one or 2 persons are materializing the suggestions, but rather that the suggestions are implemented by the community and contributed to the project in a form of a patch(set) in a pull request.
This way more work gets done and every one is properly credited for their contribution (in the git log)

So please, if you or anybody else wants to implement this (I know you -plural- can do it), patches are welcome Wink

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 49 of 56 [836 Posts]   Goto page: Previous 1, 2, 3, ..., 47, 48, 49, 50, 51, ..., 54, 55, 56 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1848s ][ Queries: 13 (0.0451s) ][ GZIP on ]