Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Jan 2018, 15:32
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Light-Debian-Core-Live-CD-Wheezy + Porteus-Wheezy
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 257 of 283 [4236 Posts]   Goto page: Previous 1, 2, 3, ..., 255, 256, 257, 258, 259, ..., 281, 282, 283 Next
Author Message
Satori

Joined: 14 Jan 2013
Posts: 47

PostPosted: Thu 30 Oct 2014, 23:23    Post subject: hardware clock gets changed  

Hiyas...

I've been keeping an eye on this project and test the releases as they come out, I beleive a jessie variation will finally give me
a reason to switch from dpup. Yes, I did try the jessie you were testing, if it only had SMP then I would have made it a main stay.

But...

I switch between various puppies, including yours, on a dell E6510 laptop. I'm finding that after rebooting from DebianDog
that the computer's hardware clock is off by a few hours, means I have to go to the bios and muck with it there.

Anyone else have this problem?

DebianDog kernel 3.14, Porteus boot, most recent DebianDog release (downloaded Oct. 15)

(almost ready for prime time)

Last edited by Satori on Fri 31 Oct 2014, 00:14; edited 1 time in total
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 979

PostPosted: Thu 30 Oct 2014, 23:40    Post subject:  

Yes, it has to do with how the real time clock is setup. Debian expects it to be UTC (Greenwich mean time) and Windows and others expect it to be local time. Hang on and I'll add the setting to change to this message.

edit: What you need to do is find the file /etc/adjtime. Open it up and in that file change UTC to LOCAL. You may need to reset the timezone again and restart to get it all straight.
Back to top
View user's profile Send private message 
Satori

Joined: 14 Jan 2013
Posts: 47

PostPosted: Fri 31 Oct 2014, 00:45    Post subject:  

hmmmm....

that may be the solution, however it seems that after editing adjtime, the next reboot will
regen the file with UTC in it.

happens on both savefile and in change folder usage.
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 979

PostPosted: Fri 31 Oct 2014, 02:30    Post subject:  

Are your other changes surviving reboot?

It worked for me, dual booting with Windows XP.

Maybe some others will be able to figure it out.
Back to top
View user's profile Send private message 
Locky


Joined: 01 Mar 2006
Posts: 24

PostPosted: Fri 31 Oct 2014, 03:58    Post subject:  

Thanks for the quick reply Toni!

After a bit of mucking around I have decided to go with the DebianDog Wheezy live-boot-3x- version with the following options

append initrd=/live/initrd.img boot=live toram=01-filesystem.squashfs

If I want to include another squashfs file what is the syntax to append to the above line?

What I really would like to do is get openbox working like crunchbang as I have become accustomed to the interface and I find it very easy to work with. To that end I have been experimenting with modifying the openbox config and playing with the scripts etc from crunchbang according to the following link...

http://crunchbanglinux.org/wiki/adding_crunchbang_features_in_another_distro

I also tried to add the crunch bang repo and added a few of the meta packages via apt-get which, unsurprisingly, broke the system.

What are the key system directories/files not to touch? Updating the kernel via apt-get is a no no obviously and anything to do with boot settings... any other tips? It is probably better to work from the ground up rather than a hit and miss apt/get approach but it would be nice to know Very Happy

regs
Locky
Back to top
View user's profile Send private message 
saintless


Joined: 11 Jun 2011
Posts: 3882
Location: Bulgaria

PostPosted: Fri 31 Oct 2014, 04:11    Post subject:  

Hi, Satori!
Thank you, Dan!
Satori wrote:
hmmmm....

that may be the solution, however it seems that after editing adjtime, the next reboot will
regen the file with UTC in it.

happens on both savefile and in change folder usage.

Just tested with both DebianDog versions and it works for me also as Dan suggested saving the change in /etc/adjtime after reboot (with save file and save folder). What I can suggest to test is:
Try setting up again time zone with:
Code:
dpkg-reconfigure tzdata

And try also this command:
Code:
hwclock --localtime

Check if /etc/localtime is not a symlink for some reason (found this problem here):
Quote:
Worked it out thanks to jamzed. for some reason I had /etc/localtime as a symlink... the IT Guy here set up the server using Turnkey 12 so maybe that was the problem.

Code:
# mv /etc/localtime /etc/localtime.old
# cp /usr/share/zoneinfo/Australia/Adelaide /etc/localtime
# date
Thu May 23 09:36:17 CST 2013


Toni

_________________
Farewell, Nooby, you will be missed...
Back to top
View user's profile Send private message MSN Messenger 
saintless


Joined: 11 Jun 2011
Posts: 3882
Location: Bulgaria

PostPosted: Fri 31 Oct 2014, 04:37    Post subject:  

Hi, Locky!
Locky wrote:

After a bit of mucking around I have decided to go with the DebianDog Wheezy live-boot-3x- version with the following options

append initrd=/live/initrd.img boot=live toram=01-filesystem.squashfs

If I want to include another squashfs file what is the syntax to append to the above line?

Sorry to say this but live-boot-3x and live-boot-2x are bad choice if copy to ram is often used. The problem is there is no command to load second squashfs module in RAM. The choice is only one module in RAM.
Or using only toram parameter - will copy to RAM all the content of USB/HDD partition containing /live folder.
You can remaster always the changes in one module but it is not good solution.

If Copy to RAM is important for you then choose porteus-boot. It will copy to ram only the squashfs modules inside /live and its subfolders. The boot parameter for porteus-boot is copy2ram. More information about porteus boot codes here:
http://murga-linux.com/puppy/viewtopic.php?p=774456#774456

Quote:
I also tried to add the crunch bang repo and added a few of the meta
packages via apt-get which, unsurprisingly, broke the system.

This is exactly the problem we work on the last few pages Smile Making DebianDog packages safe (and I hope) compatible with standard Debian system. What I can suggest for safe testing is to use new save file or no persistent. After installing few programs from crunch bang repo use RemasterCow (Create module from changes) with no-dpkg-registration activated to create separate module. Then you can load, test and unload this module till you find the problem and rebuild it fixed and safe for the system.

Quote:
What are the key system directories/files not to touch? Updating the kernel via apt-get is a no no obviously and anything to do with boot settings... any other tips? It is probably better to work from the ground up rather than a hit and miss apt/get approach but it would be nice to know Very Happy

Updating the kernel if it is from official debian repo is not a problem. We have included utility to create new initrd files for porteus boot and live-boot-2x. You can read more here:
http://murga-linux.com/puppy/viewtopic.php?p=774460#774460
System files not to touch is difficult to answer. Be careful with the files in /etc and its subfolders in general. Use google typing "the file location and debian" for searching more information about the file.

Maybe Fred will add something specially for OpenBox later.

Toni

_________________
Farewell, Nooby, you will be missed...
Back to top
View user's profile Send private message MSN Messenger 
anikin

Joined: 10 May 2012
Posts: 980

PostPosted: Fri 31 Oct 2014, 08:03    Post subject: Re: hardware clock gets changed  

Hi everyone,
Satori wrote:
I switch between various puppies, including yours, on a dell E6510 laptop. I'm finding that after rebooting from DebianDog
that the computer's hardware clock is off by a few hours, means I have to go to the bios and muck with it there.

Anyone else have this problem?
This issue will occur on any machine that dual boots with Windows. What's happening is a clash of cultures, two great schools of thought - Microsoft vs nix. Linux uses UTC, while localtime is standard for Windows. The following piece is from antix.
Quote:
How to set the correct date and time?

There are 3 possible issues:

1) wrong timezone 2) wrong selection of UTC versus local time 3) BIOS clock set wrong

The first issue is addressed with sudo dpkg-reconfigure tzdata. Do this first. You should also be able to just check the current value with cat /etc/timezone.

Once you are sure the timezone is correct, you can work on setting your BIOS clock. Do this with the hwclock command. First do a man hwclock and then run hwclock --show to see what it is set to. It always reports in localtime which is why you need to first make sure your timezone is set correctly.

Use hwclock --localtime or hwclock --utc depending on whether you want your hardware clock to be set to localtime or utc. Most pure Linux systems use utc. Most dual boot systems use localtime.

Then, after you get your date command working via the sudo command you posted, you can use hwclock --systohc to set the hardware clock so it matches your system time. Again, you need the timezone and localtime/utc choice set correctly first (although if you want to assume they are set correctly already then this is the only command you need to run to get your changes to the date command to stick. If you assumed incorrectly then you will likely get mysteriously screwed by DST a few times per year).

Finally, if you are having problems with hwclock drift or if you are a perfectionist then you can install the ntp package which will use time servers on the net to keep your clock exactly on time. But you have to first go through the steps above before ntp will work correctly.
Back to top
View user's profile Send private message 
saintless


Joined: 11 Jun 2011
Posts: 3882
Location: Bulgaria

PostPosted: Fri 31 Oct 2014, 08:51    Post subject:  

Thank you, Anikin!

Your post added in HowTo thread.

Toni

_________________
Farewell, Nooby, you will be missed...
Back to top
View user's profile Send private message MSN Messenger 
Satori

Joined: 14 Jan 2013
Posts: 47

PostPosted: Fri 31 Oct 2014, 11:12    Post subject:  

the recommended hwclock procedures fail on DebianDog Wheezy/Porteus boot. adjfile's LOCAL always changes to UTC, and hwclock --localtime has no effect.

however, it does work on DebianDog Jessie. It shows and keeps as LOCAL in the adjtime file.

I have noticed that dpup shows hwclock -s in local time, while debiandog shows the clock in UTC .
Back to top
View user's profile Send private message 
saintless


Joined: 11 Jun 2011
Posts: 3882
Location: Bulgaria

PostPosted: Fri 31 Oct 2014, 12:22    Post subject:  

Hi, Satori.

I don't know if this can help but I've noticed small difference in Jwm and OpenBox version (same in Wheezy and Jessie).
Jwm has ntp installed and running.
OpenBox does not have ntp installed.
Maybe worth testing depending what version you use to install:
Code:
apt-get install ntp

or uninstall:
Code:
apt-get purge ntp

To see if this makes any difference.

hwclock -s shows nothing for me. I guess my hardware is too old.

BTW I think SMP kernel for Jessie version is not hard to install. If you like to go this way we can help you.

Toni
Back to top
View user's profile Send private message MSN Messenger 
dancytron

Joined: 18 Jul 2012
Posts: 979

PostPosted: Fri 31 Oct 2014, 12:45    Post subject:  

Changing the adjtime file from UTC to LOCAL works for me.

I am using Open Box version. I believe I am one ISO behind the latest. Using the latest kernel and porteus type boot with change folder and save only manually or on exit.

Maybe ntp in JWM version is resetting the adjtime file?
Back to top
View user's profile Send private message 
saintless


Joined: 11 Jun 2011
Posts: 3882
Location: Bulgaria

PostPosted: Fri 31 Oct 2014, 14:04    Post subject:  

dancytron wrote:
Maybe ntp in JWM version is resetting the adjtime file?

I have no problem to change UTC to LOCAL in adjtime and it is saved after reboot with DebianDog-Wheezy-Jwm (all boot methods).
But my hardware is very old and maybe this makes a difference. Or something specific in hardware or dual boot setup creates the problem for Satori.
Or maybe some kind of conflict (like another folder with the same name /live is left on different partition or second save file with the same name...).

Toni
Back to top
View user's profile Send private message MSN Messenger 
Satori

Joined: 14 Jan 2013
Posts: 47

PostPosted: Fri 31 Oct 2014, 14:35    Post subject:  

Hiyas...

my mistake... "hwclock -s" sets the system time from the clock, "hwclock -r" reads the hardware clock.

tried running debiandog with updated NTP (says it's at current version), without NTP and reinstalling NTP...
all have no effect on changing UTC to LOCAL.

if a DebianDog Jessie with SMP can be provided, then I'm sure you'll make a LOT of people happy as it looks like pretty mature to me.

Wheezy uses gLib 2.11 which google chrome barfs on, but Jessie uses gLib 2.18 which chrome likes.
I've become dependent on chrome, plus other apps that need a newer gLib.
Back to top
View user's profile Send private message 
saintless


Joined: 11 Jun 2011
Posts: 3882
Location: Bulgaria

PostPosted: Fri 31 Oct 2014, 15:37    Post subject:  

Fred made jessie version upgrade only for testing and it does not include many later improvements. When Jessie becomes stable we will upgrade official DebianDog to Jessie.
I will make separate testing module for Jessie with kernel-3.14-686-pae. Check the thread for download link in the next few days.

Toni

_________________
Farewell, Nooby, you will be missed...
Back to top
View user's profile Send private message MSN Messenger 
Display posts from previous:   Sort by:   
Page 257 of 283 [4236 Posts]   Goto page: Previous 1, 2, 3, ..., 255, 256, 257, 258, 259, ..., 281, 282, 283 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.2481s ][ Queries: 13 (0.0775s) ][ GZIP on ]