Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 20 Nov 2014, 17:23
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Broadcom B43 Wi-fi not working in Slacko 5.7.0 PAE iso?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
darrenforster99

Joined: 25 Sep 2007
Posts: 8

PostPosted: Sat 30 Aug 2014, 03:45    Post subject:  Broadcom B43 Wi-fi not working in Slacko 5.7.0 PAE iso?  

I've used Puppy Linux for years now as it's the only Linux I've ever managed to get my wi-fi card working properly in without having to go and mess around with the windows driver for this card.

However I recently lost my old puppy linux disc and downloaded and created a new one. In the past I've used both Slacko and Lucid with no problems, but this new Puppy seems very different and unfortunately no longer seems to have the drivers for my broadcom wi-fi card, which is a shame because that's the card that's in my Compaq Presario v5000 series laptop.

Is it possible to get it working again simply like with a PET or something? Is there another version of Puppy Linux that still includes this driver all set up and ready to go like the old versions used to.

I presume the driver has been removed because my laptop has now got so old it's too old even for Linux (I think the laptop is about 10-12 years old now).
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1511
Location: Malvern, Worcs, UK

PostPosted: Sat 30 Aug 2014, 06:46    Post subject: Re: Broadcom B43 Wi-fi not working in Slacko 5.7.0 PAE iso?  

darrenforster99 wrote:
I've used Puppy Linux for years now as it's the only Linux I've ever managed to get my wi-fi card working properly in without having to go and mess around with the windows driver for this card.

However I recently lost my old puppy linux disc and downloaded and created a new one. In the past I've used both Slacko and Lucid with no problems, but this new Puppy seems very different and unfortunately no longer seems to have the drivers for my broadcom wi-fi card, which is a shame because that's the card that's in my Compaq Presario v5000 series laptop.

Is it possible to get it working again simply like with a PET or something? Is there another version of Puppy Linux that still includes this driver all set up and ready to go like the old versions used to.

I presume the driver has been removed because my laptop has now got so old it's too old even for Linux (I think the laptop is about 10-12 years old now).


Hi Darren

Are you sure that your laptop is pae capable? You might be better off with the 4g/nopae variant of Slacko5.7.....

Please run dmesg in a terminal and see if there are any lines mentioning b43 that give clues as to what might be wrong.

If the problem is just missing firmware then you should be able to transfer this from another puppy with working wifi.

Also run lsmod in a terminal and see if either b43 or wl drivers are loaded (or any other that maybe wifi).

Cheers
peebee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
bigpup


Joined: 11 Oct 2009
Posts: 5356
Location: Charleston S.C. USA

PostPosted: Sat 30 Aug 2014, 15:39    Post subject:  

You can try this:

I have noticed a post or 2 about the firmware not being unpacked from the /lib/modules/all-firmware to /lib/firmware.
In /lib/modules/all-firmware
Look for the name that will match your device.
Just unpack it.
Place it into /lib/firmware

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0472s ][ Queries: 12 (0.0045s) ][ GZIP on ]