Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 25 Nov 2014, 19:12
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
possible solution for iwlwifi wireless connection trouble
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
stray_dog

Joined: 18 Mar 2014
Posts: 52

PostPosted: Sun 10 Aug 2014, 08:35    Post_subject:  possible solution for iwlwifi wireless connection trouble  

If you have a machine that uses the iwlwifi driver & notice connecting to wifi is slow - or you experience disconnects - it may be because of a bug in the driver itself. Typing this into a console solves it easily for me:

modprobe iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1 power_level=1

Just wanted to post this in case it could help somebody. Ok, that's all. Thank you.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Sun 10 Aug 2014, 08:51    Post_subject:  

Thanks. I have added this hint to the documentation for PWF.

Would you not need to preface this command with "rmmod iwlwifi"? This would unload/reload the driver.
Back to top
View user's profile Send_private_message 
stray_dog

Joined: 18 Mar 2014
Posts: 52

PostPosted: Sun 10 Aug 2014, 09:38    Post_subject:  

Awesome. Hope it helps some.

Yea that rmmod iwlwifi first might be a good idea, I haven't tried that yet, or tried some of the other options with modprobe yet. When I did this without the rmmod, the difference was immediate & very noticeable, so it did 'some'thing for me. I'll try to experiment & report back.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Sun 10 Aug 2014, 09:46    Post_subject:  

It may be that modprobe is smart enough to unload the previous instance of the driver before reloading it. Maybe someone else can comment on this.
Back to top
View user's profile Send_private_message 
stray_dog

Joined: 18 Mar 2014
Posts: 52

PostPosted: Sun 10 Aug 2014, 10:17    Post_subject:  

Yea, could be. I'm unsure. I think I've read that if you want to use a different driver, rmmod [old driver] needs to happen first. Maybe it's changing the parameters of the driver, rather than loading it again. I think it's also possible to create a *.conf file inside /et/modprobe.d directory and add this line to that:

options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1 power_level=1

or if you have a conf file already, you could try "modprobe -C iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1 power_level=1" which is supposed to override the default configuration directory/file. Since I've been booting up without a save file lately, I haven't really tried anything to keep persistent changes.
Back to top
View user's profile Send_private_message 
stray_dog

Joined: 18 Mar 2014
Posts: 52

PostPosted: Mon 11 Aug 2014, 19:24    Post_subject:  

Ok so the results of experimenting a little more with this seem to be:

If you're running in ram only or have no save file,
Code:
modprobe iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1 power_level=1
produces a result for me that's great.

If I rmmod iwlwifi and then do the above, results are not so great unless I reboot. So, for those of you who've got an install on a hard drive, or use a save file (I have neither yet) that might work.

If you like to keep a save file, that's cool, I just tried out creating a file in etc/modprobe.d directory called iwlwifi.conf where I just had a line that read "options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1 power_level=1" ... saved it, Then shut down & created a save file (onto my bootable usb), rebooted, and my connections were as fast as trying the first suggestion.

The other suggestion about *if* you already have a config file & to use modprobe -C ... yeah, that's wrong, all wrong. You'll probably get a fatal error if you try it as previously written. According to the modprobe man page, it should be:

modprobe [-C config-file]

so there shouldn't be any modulenames or anything in there. I haven't tried this yet, but I hope to soon. The manual page says "this option is passed through install or remove commands to other modprobe commands in the modprobe_options environment variable" ... which I don't know anything about, but may be an explanation as to why running
Code:
modprobe iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1 power_level=1
produced an immediate result for me without any reboot & saving.

I guess what I mean is, if you're messing with options, you may not need a reboot like if you were unloading drivers and loading new ones.
Back to top
View user's profile Send_private_message 
stray_dog

Joined: 18 Mar 2014
Posts: 52

PostPosted: Fri 22 Aug 2014, 21:45    Post_subject:  

Okay so after searching the internet some and trying stuff myself some, I really can't say for sure that this will help anyone. For some people out there, disabling n worked, for other people, disabling bt coexistence worked, for some folks setting power level worked, for some folks all of it worked. For me it looked like it was immediate, but in the meantime even if I do some of this stuff, I still experience weirdness so I'll keep looking into it. Later I'll try to post links & also maybe there's firmware issues involved which I know nothing about yet. Ok, that's it for now. Must sleep.
Back to top
View user's profile Send_private_message 
Pelo


Joined: 10 Sep 2011
Posts: 3335
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 08 Sep 2014, 04:27    Post_subject: iwlwifi > frisbee > peasyWifi
Sub_title: Iwlwifi alias iwlagn.. could you advise...
 

Frisbee, and now peasy wifi are nice tool for wireless connection. I notice yr formula, to try it.
My purpose was to inform about size of iwlwifi in lib 8MB and to remind that Baobab is a fine tree size analyser.
As i am not a pure linuxian, but as iwlwifi is my driver, why on older puppies, iwlagn is listed, not iwlwifi ?
I thinK there is an alias to create, but i don't know how-to-do ....
Slacko 5.5.
2minutes later : modprobe iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1 power_level=1
I come back to confirm result. I will delete the screen shot.

It seems to be efficient, really. Why, i don't know. It's your matter, dear teachers. But merci Smile Smile
"Pour certains, la désactivation n agit, pour d'autres, c'est la désactivation de la coexistence bt, pour d'autres c'est le paramétrage du niveau de puissance, ou tout à la fois pour certains autres. çà reste encore étrange dans mon esprit, je vais creuser." says stray_dog, in english.
Information transfered to frenchies, on their forum francophone francophones, cliquez.

_________________
Puppy, il ne lui manque que la parole !
Back to top
View user's profile Send_private_message YIM 
stray_dog

Joined: 18 Mar 2014
Posts: 52

PostPosted: Mon 08 Sep 2014, 20:01    Post_subject:  

Hello, Pelo!
Quote:
but as iwlwifi is my driver, why on older puppies, iwlagn is listed, not iwlwifi ?
I think it's because when the kernel changed from older to newer, the driver got a new name.

Quote:
It seems to be efficient, really. Why, i don't know.
Great! I am happy it helped for you! I'm not sure either, but this is what I've found so far. If you type "modinfo iwlwifi" in the console/command line, it will give you many parameters that can be set in real time without reboot. Some parameters are for enabling or disabling use of wifi n, some for bluetooth, some for power level of the card, etc. So if you want, you can turn one thing on or off, or many, to test what gets the best result for you. It will tell you what your choices are. Then you can try them all, or just try one thing at a time. For me, I found the best result was trying them all at one time. But I have found on this network lately, that I can keep n enabled and still have a good result for me.

The way I found this was searching & finding many people on different distros having similar troubles, Arch, Ubuntu, etc. So I thought oh good, this is not a Puppy problem, this is something that came from the kernel/drivers/firmware & how this works. The best mention I saw was here: https://bbs.archlinux.org/viewtopic.php?id=134920 where they give options for Arch Linux & mention there's a bug in the driver here https://bbs.archlinux.org/viewtopic.php?id=134871 with a patch here http://lkml.iu.edu//hypermail/linux/kernel/1201.3/00938.html but for the Arch people I think they needed to recompile their kernel after the patch. I don't know how to do that stuff or understand yet how it works in Puppy.

These pages were interesting to me:
http://git.kernel.org/cgit/linux/kernel/git/iwlwifi/iwlwifi-next.git
http://www.murga-linux.com/puppy/posting.php?mode=reply&t=95236
http://wireless.kernel.org/en/users/Drivers/iwlwifi
They may be to you too. As the kernel changes in the future, there will definitely be changes to this driver and how it works. For now though, we can try different parameters and see what works best.

If I need a fast stable connection for live audio/video, what works best for me is to do "modprobe iwlwifi bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1 power_level=1" and then use the stay-connected.pet but edit it so the sleep rate is like 5 instead of 30. That works really really well for me. Mais oui, bien sur.
Back to top
View user's profile Send_private_message 
Pelo


Joined: 10 Sep 2011
Posts: 3335
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 01 Oct 2014, 10:55    Post_subject: magical formula kept beside me  

magical formula kept beside me.
hermouet.jpg
 Description   
 Filesize   55 KB
 Viewed   56 Time(s)

hermouet.jpg


_________________
Puppy, il ne lui manque que la parole !

Edited_time_total
Back to top
View user's profile Send_private_message YIM 
stray_dog

Joined: 18 Mar 2014
Posts: 52

PostPosted: Wed 01 Oct 2014, 19:37    Post_subject:  

Yay, Pelo! I'm glad!
Back to top
View user's profile Send_private_message 
stray_dog

Joined: 18 Mar 2014
Posts: 52

PostPosted: Tue 04 Nov 2014, 06:59    Post_subject:  

Oh - one other thing that may help. I think I saw someone else post about this in another thread. It can be a hardware problem. Check the order in which your antennas are attached to your wifi card. If the antenna attachments are out of order, it can produce this wifi connection trouble.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0827s ][ Queries: 13 (0.0076s) ][ GZIP on ]