Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 19:34
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
LxPup : a Puppy with LXDE as its desktop environment
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 18 of 31 [460 Posts]   Goto page: Previous 1, 2, 3, ..., 16, 17, 18, 19, 20, ..., 29, 30, 31 Next
Author Message
Chris_W

Joined: 27 Jun 2013
Posts: 26
Location: Wellington, New Zealand

PostPosted: Wed 30 Apr 2014, 16:46    Post subject:  

PeeBee,

Booted Up this morning to try your tweak. But it seems I was premature in signalling success. Got the 'Error No such file or directory' message again before I could apply the change, and neither /root/.config/autostart nor /root/.config/lx-autostart are present.

I haven't looked into these scripts at all, but after all my install configuring and a few reboots, I only once clicked on shutdown - which was after I thought the problem was beat.
Don't know if there is anything specifically different in the shutdown script from the reboot one?

I guess it's tricky to divine the failure mechanism here, but I suspect timing issues. Is it possible to add some logging to these scripts so I can collect results that might give more clues on failure mechanism?

I'm happy to run test scripts, tweak stuff - but my understanding of scripting is currently pretty slight (happy to learn tho).

Also, it looks like I now need to re-install again (based on your advice to do this if I lose these directories). If I were to take a copy of the root/.config/autostart directory next time I'm set up, would this allow me to simply replace it, next time I lose it? - or is there more to it - like variables being changed, etc...

cheers Chris_W
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 401
Location: SW Wisconsin

PostPosted: Wed 30 Apr 2014, 17:31    Post subject:  

Chris_W wrote:
PeeBee,

Booted Up this morning to try your tweak. But it seems I was premature in signalling success. Got the 'Error No such file or directory' message again before I could apply the change, and neither /root/.config/autostart nor /root/.config/lx-autostart are present.

I haven't looked into these scripts at all, but after all my install configuring and a few reboots, I only once clicked on shutdown - which was after I thought the problem was beat.
Don't know if there is anything specifically different in the shutdown script from the reboot one?

I guess it's tricky to divine the failure mechanism here, but I suspect timing issues. Is it possible to add some logging to these scripts so I can collect results that might give more clues on failure mechanism?

I'm happy to run test scripts, tweak stuff - but my understanding of scripting is currently pretty slight (happy to learn tho).

Also, it looks like I now need to re-install again (based on your advice to do this if I lose these directories). If I were to take a copy of the root/.config/autostart directory next time I'm set up, would this allow me to simply replace it, next time I lose it? - or is there more to it - like variables being changed, etc...

cheers Chris_W


Yes, you need to get the lx-autostart back before trying the tweak. Couple of things to try prior to reinstalling if you haven't yet. Fschecking the save file may 'get' the needed lx-autostart back. Putting the kernel command pfix=fsck in the menu.lst entry (in grub4dos for me) and then rebooting or booting from a cd etc not using the save file and running e2fsck on the save file may do it. I have also just made a backup copy of it to use when 'lost'. Very interested in knowing if the change works for you once it is back.

_________________
Pups currently in kennel Very Happy X-slacko 2.3n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.14.20 kernel). All lean and steady pups.
Back to top
View user's profile Send private message 
Chris_W

Joined: 27 Jun 2013
Posts: 26
Location: Wellington, New Zealand

PostPosted: Wed 30 Apr 2014, 17:58    Post subject:  

Thanks Marv,

At work now, but will try these things later. Will prob boot from another usb & see if I can use that to do the fscheck on the save file, etc.

cheers Chris_W
Back to top
View user's profile Send private message 
Chris_W

Joined: 27 Jun 2013
Posts: 26
Location: Wellington, New Zealand

PostPosted: Thu 01 May 2014, 06:30    Post subject:  

PeeBee, Marv,

OK - so I booted an old pup, to look at my Lxpup 14.03 save file, and low and behold, root/.config/lx-autostart was there! Perhaps I was hasty checking this morning...
I made a backup copy of lx-autostart, shut down, and then booted from the LxPup 14.03 pup.
It came up with the 'Error No such file or directory' message, so I copied lx-autostart back in and renamed to autostart....

I then removed the previous .pet patch and applied the new one, and rebooted ........

It came up with the 'Error No such file or directory' message again.
On replacing autostart, powering down & booting, same result.

Should I try reinstalling, applying the fix .pet, and then testing it?
Any other tests you'd like me to try?


cheers Chris_W
Back to top
View user's profile Send private message 
Chris_W

Joined: 27 Jun 2013
Posts: 26
Location: Wellington, New Zealand

PostPosted: Thu 01 May 2014, 06:40    Post subject:  

ps. I also just booted from a copy of the save file & then had a look at the state of the save file as it had been shut down.

The lx-autostart folder was in place. So I'm thinking the problem is not in the shutdown scripts, just the startup.


Chris_W
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1546
Location: Worcestershire, UK

PostPosted: Thu 01 May 2014, 08:23    Post subject:  

Chris_W wrote:
ps. I also just booted from a copy of the save file & then had a look at the state of the save file as it had been shut down.

The lx-autostart folder was in place. So I'm thinking the problem is not in the shutdown scripts, just the startup.


Chris_W


Hi Chris

Can you check that /root/Startup/z-lxde-startup.sh exists and that it is set to executable please?

Can you then click on it to run it manually and check that folder lx-autostart is replaced by autostart with same contents in /root/.config

Are you running off usb? Which filesystem is it formatted as?

Thanks
peebee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
Marv


Joined: 04 May 2005
Posts: 401
Location: SW Wisconsin

PostPosted: Thu 01 May 2014, 10:55    Post subject:  

Chris_W wrote:
ps. I also just booted from a copy of the save file & then had a look at the state of the save file as it had been shut down.

The lx-autostart folder was in place. So I'm thinking the problem is not in the shutdown scripts, just the startup.

Chris_W

My guess is that the lx-autostart folder is in the save file but there is also a whiteout file for it (.wh). Did you try e2fscking the save file?

_________________
Pups currently in kennel Very Happy X-slacko 2.3n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.14.20 kernel). All lean and steady pups.
Back to top
View user's profile Send private message 
Chris_W

Joined: 27 Jun 2013
Posts: 26
Location: Wellington, New Zealand

PostPosted: Thu 01 May 2014, 17:43    Post subject:  

PeeBee, Marv,

Marv is right.
When I boot up from another pup, and mount the pup save file for this one (or it's backup) I do see the .wh.lx-autostart file in the root/.config folder.

So I guess that means that on loading up into the layered file system, the folder simply just gets cancelled out. And the startup script will simply run, 'not seeing' it...

Marv, I didn't try fscking or e2fscking the save file. I guess when I saw what I was looking for, it didn't appear to be necessary (not to mention those two progs being completely new to me).

PeeBee, I have checked that root/Startup/z-lxde-startup.sh exists and that it is set to executable.

I then assumed that the obvious thing to do is to remove the .wh file from the pup save, shutdown the 'other' pup, and run up 14.03 pup, to see what happens...

Doing that now.... (remembering that this is with the .pet applied with the extra sleep in it)....

And - it all started up fine, including Retrovol.

So I guess that's a win for the new scripting - well done guys!

So now I understand that if one does ever lose root/.config/autostart,
1. shutdown,
2. boot from a different pup (or save file),
3. mount the save file in question, and look to see if root/.config/lx-autostart & its .wh.lx-autostart exist.
4. If they do, delete the .wh file, unmount, and
5. restart using the corrected save file.

cheers - Chris_W
Back to top
View user's profile Send private message 
Chris_W

Joined: 27 Jun 2013
Posts: 26
Location: Wellington, New Zealand

PostPosted: Fri 02 May 2014, 06:25    Post subject:  

PeeBee, Marv

Bad news, back to seeing the same error again - with new script & all.
I can easily fix it now, but it seems it is not removing the possibility of this happening after a session where I use the machine for browsing for an hour then shutdown.

cheers Chris_W
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 401
Location: SW Wisconsin

PostPosted: Fri 02 May 2014, 09:29    Post subject:  

Chris_W wrote:
PeeBee, Marv

Bad news, back to seeing the same error again - with new script & all.
I can easily fix it now, but it seems it is not removing the possibility of this happening after a session where I use the machine for browsing for an hour then shutdown.

cheers Chris_W


Hi Chris,

Try adding pfix=fsck to the syslinux.cfg file on your usb stick (I think that is how you were booting) and see if that changes anything on reboots. It will either be in the append line or if the file is only one line after pfix=usbflash. If using grub4dos, it is in the appropriate menu item in menu.lst.

Thanks for persevering,

Marv

_________________
Pups currently in kennel Very Happy X-slacko 2.3n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.14.20 kernel). All lean and steady pups.
Back to top
View user's profile Send private message 
Chris_W

Joined: 27 Jun 2013
Posts: 26
Location: Wellington, New Zealand

PostPosted: Fri 02 May 2014, 18:31    Post subject:  

Hi Marv

After powering up to no error (I'd deleted the .wh file last night) a session editing spreadsheets, using firefox etc (often enough to create the error after a reboot), I read your post, so added that in.
syslinux.cfg now reads:

default vmlinuz initrd=initrd.gz pmedia=usbflash
pfix=fsck


I then restarted from the menu, but unfortunately still got the same error.

cheers Chris_W
Back to top
View user's profile Send private message 
Chris_W

Joined: 27 Jun 2013
Posts: 26
Location: Wellington, New Zealand

PostPosted: Sat 03 May 2014, 01:07    Post subject:  

Marv,

I had a bit more time, so I booted from another save file, and edited the one I've been used to get it's lx-autostart etc how it should be.

I noticed that on bootup I was getting a message about an unrecognised parameter, so re-read your message, and took the carriage return out of the syslinux.cfg so it all appeared on one line.

I then rebooted with the main save file (which it checked per your change), and everything started correctly. To test it (a little) I opened a bunch of spreadsheets, calculator, firefox - but I can't connect it to the internet here, so couldn't do too much.
On reboot, it came up fine.
However, I'll run it a few sessions over the next few days, to see if it still comes up ok.

cheers Chris_W
(noting potential success here ... hopefully)
Back to top
View user's profile Send private message 
Chris_W

Joined: 27 Jun 2013
Posts: 26
Location: Wellington, New Zealand

PostPosted: Sat 03 May 2014, 06:53    Post subject:  

Marv, PeeBee,

After about 45mins uptime with firefox open to a few pages, then a reboot, back to the same error.
Wondering if it as something to do with layered filesystem -> save file interaction at shutdown.. Also thought it might be to do with auto pup saves during use, but can't see evidence for it...


Chris_W
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 401
Location: SW Wisconsin

PostPosted: Sat 03 May 2014, 08:25    Post subject:  

Chris_W wrote:
Marv, PeeBee,

After about 45mins uptime with firefox open to a few pages, then a reboot, back to the same error.
Wondering if it as something to do with layered filesystem -> save file interaction at shutdown.. Also thought it might be to do with auto pup saves during use, but can't see evidence for it...


Chris_W


I'm almost certain it does have to do with a 'zero date' whiteout file that isn't taken care of at shutdown.
I'm assuming that the .wh.lx-autostart is back in the save file when the error occurs?
Running with basically exactly what you have on a Pentium M era laptop I haven't seen that error since the scripts were changed so I'll pull the pfix=fsck from my bootup menu, do some reboots, double check the relevant scripts in my OS against the pet and scratch my head a bit. Might be a day or two since we have sun and a bit of warmth for the first time in weeks and I might be able to scritch the garden.

_________________
Pups currently in kennel Very Happy X-slacko 2.3n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.14.20 kernel). All lean and steady pups.
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 401
Location: SW Wisconsin

PostPosted: Sat 03 May 2014, 09:30    Post subject:  

Marv wrote:
Chris_W wrote:
Marv, PeeBee,

After about 45mins uptime with firefox open to a few pages, then a reboot, back to the same error.
Wondering if it as something to do with layered filesystem -> save file interaction at shutdown.. Also thought it might be to do with auto pup saves during use, but can't see evidence for it...


Chris_W


I'm almost certain it does have to do with a 'zero date' whiteout file that isn't taken care of at shutdown.
I'm assuming that the .wh.lx-autostart is back in the save file when the error occurs?
Running with basically exactly what you have on a Pentium M era laptop I haven't seen that error since the scripts were changed so I'll pull the pfix=fsck from my bootup menu, do some reboots, double check the relevant scripts in my OS against the pet and scratch my head a bit. Might be a day or two since we have sun and a bit of warmth for the first time in weeks and I might be able to scritch the garden.


Edit:

Chris. Open /root/Startup/z-lxde-startup.sh and comment out or delete line 11. That line is:
Quote:
rm -rf $XDG_CONFIG_HOME/lx-autostart

Clean up the nasty lil .wh.lx-autostart file in your savefile and reboot. Let me know.

PeeBee, this leaves lx-autostart as a visible file in .config and maybe maybe finally gets rid of the offending .wh file.

_________________
Pups currently in kennel Very Happy X-slacko 2.3n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.14.20 kernel). All lean and steady pups.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 18 of 31 [460 Posts]   Goto page: Previous 1, 2, 3, ..., 16, 17, 18, 19, 20, ..., 29, 30, 31 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1014s ][ Queries: 13 (0.0101s) ][ GZIP on ]