Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 03:25
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
HP Laserjet Professional M1132 MFP setup
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
nappy501

Joined: 29 Sep 2012
Posts: 7

PostPosted: Sat 06 Oct 2012, 11:30    Post subject:  HP Laserjet Professional M1132 MFP setup
Subject description: How do I get this printer to work
 

Hi Everyone,

I am new to Puppy from OpenSuse.

I am running Puppy 5.3.3, I did a search on the site and tried to install via CUPS. My printer was found, but I didn't know which printer to choose as mine wasn't listed. Which printer should I choose?

I have also tried installing hplip_print-3.12.9.pet. I think it has installed, but I don't know what to do now.

Any pointers gratefully received.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9356
Location: Stratford, Ontario

PostPosted: Sat 06 Oct 2012, 13:16    Post subject: Re: HP Laserjet Professional M1132 MFP setup
Subject description: How do I get this printer to work
 

nappy501 wrote:
I am running Puppy 5.3.3, I did a search on the site and tried to install via CUPS. My printer was found, but I didn't know which printer to choose as mine wasn't listed.

That sounds like you have learned how to run the CUPS printer setup wizard.

Quote:
I have also tried installing hplip_print-3.12.9.pet. I think it has installed, but I don't know what to do now.

This package supports (sort of) your model. So the m1132 should now appear in the CUPS Models list. Did you not see it? If you have already installed the printer using a different model, you will need to delete that printer and start again.

Once you can find your m1132 in CUPS, please report back.
Back to top
View user's profile Send private message 
rik

Joined: 15 Apr 2014
Posts: 2

PostPosted: Tue 15 Apr 2014, 03:54    Post subject:  

well, reopening this topic.

tried everything on PuppyPrecise 5.6.1 and Slacko 5.7
installed and deleted various pets :
-foo2xxx_rcrsn
-hplibs
-install_hp_plugin
-foo2xxx_udev
-hpijs_legacys
-hpliblite
-qt.sfs
-devx.sfs
etc.etc.

I dont know what not.
The best is not to install anything.
In that case Cups recognizes the printer and print a testpage succesfully.

That is,,,is says so.
But in reality nothing is printed.

??
I could only find this tread on the internet.
It seems to have been solved by the poster, but how?
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9356
Location: Stratford, Ontario

PostPosted: Tue 15 Apr 2014, 05:41    Post subject:  

You will notice that nappy501 never showed the courtesy of a reply.

When you run CUPS and select your M1132, it says "requires proprietary plugin".
Quote:
Driver Plugin Information:

This printer REQUIRES a downloadable driver plug-in. Use hp-setup to install the printer, and to download and install the plug-in. In general, required driver plugins are required for printing support. Driver plug-ins are released under a proprietary (non-open) license and are not part of the HPLIP tarball release.


It's been my experience that you need a full Linux like Ubuntu to get this kind of printer working.
Back to top
View user's profile Send private message 
rik

Joined: 15 Apr 2014
Posts: 2

PostPosted: Tue 15 Apr 2014, 12:39    Post subject:  

Owzo.
That's a pity.
Crying or Very sad
Back to top
View user's profile Send private message 
ThoriumBlvd


Joined: 04 Oct 2013
Posts: 159
Location: N.E. USA

PostPosted: Sun 04 May 2014, 00:21    Post subject:
Subject description: p1102w version
 

Yes, theres a small command-line binary plug-in routine to run while connected to internet. Its called "hp plug-in".

But I also have a question about this 11xx series. It appears that Slacko 14 does not appear on the hp page concerning the printer (my case p1102w) and further that USB is not supported in previous Slacko's. The driver required is at least 3.12.x and 3.14 is availible. As far as I can tell Cups is v. 1.4.8 on my Slacky-pup (5.5XL). Do we have pet package(s) to deal with these obstacles?

I would presume a manual install otherwise.

Important to note I'm shopping, and found the 1102w at an affordable price (abt US$100). Deal-breakers here?

_________________
.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9356
Location: Stratford, Ontario

PostPosted: Sun 18 May 2014, 20:24    Post subject:
Subject description: p1102w version
 

ThoriumBlvd wrote:
Important to note I'm shopping, and found the 1102w at an affordable price (abt US$100). Deal-breakers here?

Please read the main post at the top of this section. It discusses the foo2xxx driver package which supports your Laserjet Pro P1102W.

The newest version of foo2xxx also supports some of the Laserjet Pro M series. This might have solved rik's problem.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0555s ][ Queries: 12 (0.0043s) ][ GZIP on ]