Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 23:52
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Gnome 2.14 mini for Puppy 2.11 (english)
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [14 Posts]  
Author Message
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sun 05 Nov 2006, 05:51    Post subject:  Gnome 2.14 mini for Puppy 2.11 (english)  

I just tried it in Muppy004, so it should work in Puppy 2.11.

This is a repackaged dotpup of my experimental Minignome from this thread:
http://www.murga.org/~puppy/viewtopic.php?t=9599

The old dotpup would overwrite files in Puppy 2.11, so I removed those.
To run Gnome, install only these 2 dotpups:
http://dotpups.de/dotpups/WindowManagers/Gnome-2.14-for-Puppy-2.11/Gnome-2.14.2.pup (9 MB)

http://dotpups.de/dotpups/WindowManagers/Gnome-2.14-for-Puppy-2.11/desktop-file-utils-0.11.pup (36 kb)

This is not a "full" gnome, only the panel and nautilus-filemanager.
However it might allow you to run many modern additional Gnome-programs.

Some of those also might require these dotpups:
http://dotpups.de/dotpups/WindowManagers/Gnome-2.14-for-Puppy-2.11/optional/

I can not test the Webbrowser Epiphany, as I removed Seamonkey from Muppy (it is needed by Epiphany).
If you want to try it in Puppy 2.11:
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/Gnome-2.14/Webbrowser-Epiphany/Epiphany-2.14.2.pup (500 kb)
Optional languagefiles for epiphany:
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/Gnome-2.14/Webbrowser-Epiphany/LOCALE/Epiphany-2.14.2-LOCALE.pup (1 MB)


********************************************************
additional programs:
the project-management program "Planner":
http://www.murga.org/~puppy/viewtopic.php?t=12445

Mark

Last edited by MU on Mon 06 Nov 2006, 08:35; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Mon 06 Nov 2006, 08:30    Post subject:  

I uploaded the dotpup again.
Fixed an error with the Gnome-windowlist (taskbar).

If you had installed it already, there is no need to download again, the fix is very simple:
simply replaces the first line in
/usr/local/Gnome-2.14.2/Gnome
from
#!/bin/sh
to
#!/bin/bash

Mark
Back to top
View user's profile Send private message Visit poster's website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15122
Location: Paradox Realm

PostPosted: Mon 06 Nov 2006, 11:47    Post subject:  

Very Happy

They said it could not be done . . .
installed the first two dopups and got this


installed the second two and the Epithany browser and got this


It is of course impossible to run Gnome from Puppy
and I am posting this from Epithany

Believe in Puppy
Great job Mark
I like the impossible . . .

Very Happy

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15122
Location: Paradox Realm

PostPosted: Mon 06 Nov 2006, 11:58    Post subject:  

OK here is Gnome running under xfce . . .



Do I delete that file

PS.

Good news I saw John Murga on the forum
will he fix it?

Hope so

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Mon 06 Nov 2006, 12:04    Post subject:  

Yes, those 2 applets seem not to work, you can choose to remove them from the panel.
Have not found out, why.

But the rest works, that's pretty cool, right? Cool

Ok, some minor things might be enhanced.
My Epiphany-startscript uses a bad trick to run Dbus.
This could be enhanced.
For example you could modify the .xinitrc to run JWM by the dbus-daemon.
Must to dig into my old testfiles to look how I realized that with Icewm already.
And the menu is not as structured as it should be.

But these issues might be solved with some tweaks, and already now it is usable Smile

Thanks for testing it Lobster.

Mark
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Mon 06 Nov 2006, 12:24    Post subject:  

I think Epiphany should have a iconbar, too?
Wait, have Puppy 2.11 here... yes, works.

Here is a old screenshot from my first tests some weeks ago:
http://dotpups.de/pics/puppy/epiphany-2.14.jpg

--------------------
And in XFCE your icons in Nautilus are lost.

The reason I think:
the file /root/.gtkrc-2.0 must contain such a line:
gtk-icon-theme-name="gnome"

Or it should include a second file:
include "/root/.gtkrc.mine"

Then .gtkrc.mine should have the line above.
Xfce has its own themes, so it might have overwritten these files, what makes the Nautilusicons disappear.

------------------
Hm, here the taskbar does not work if I run it from the menu, though I use the updated dotpup with my bugfix. Running "Gnome" from a console it works.
Why not? Will require more tests...

In Muppy 004 it works, maybe my dotpup for Puppy 2.11 misses another file.
I'll try to solve it this weekend.

Mark
Back to top
View user's profile Send private message Visit poster's website 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Mon 06 Nov 2006, 14:26    Post subject:  

this may not be the problem for this case, but if you have a file or folder in the working dir called (for example) "myapp", and you "which myapp" or "pidof myapp" or "killall myapp", it will not work properly

this can cause bugs that are hard to find ... i think this is a problem that most distros do not seem to have (i think it is caused by Busybox)

bash does behave a little differently when running as sh (sh is a symlink to bash), and yes, executing a shell script or opening a shell as sh or as bash can cause bugs that are hard to diagnose.
Back to top
View user's profile Send private message 
shankargopal

Joined: 03 Dec 2005
Posts: 295

PostPosted: Thu 08 Mar 2007, 06:23    Post subject:  

Hi MU

THanks for what looks like a great dotpup. However, when I try to install on my 2.14, I am told that some files already exist (libgconf, etc.). All kinds of things are installed on this system, including many of your earlier dotpups, so not sure what to do. Should I ask it to overwrite?

Thanks
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Thu 08 Mar 2007, 16:52    Post subject:  

this could be dangerous, but also might work without problem.
Create a backup of pup_save.2fs first Exclamation Exclamation

The dotpup might have to be repackaged for Puppy 214.
The last version I tested was Puppy 212, when I had built Muppy007 from it.

Mark
Back to top
View user's profile Send private message Visit poster's website 
raffy

Joined: 25 May 2005
Posts: 4798
Location: Manila

PostPosted: Thu 08 Mar 2007, 20:19    Post subject: 2.11 for education and eXe in it  

(This may or may not be related to mini-Gnome, so pardon it it is not.)

EduPup is based on 2.11, and it already has Python. Does it already have these mini-gnome components?

It will be great to have eXelearning.org dotpup for 2.11. Smile Then EduPup will be useful not only for kids but to teachers as well.

Cheers!

_________________
Puppy user since Oct 2004. Want FreeOffice? Get the sfs (English only).
Back to top
View user's profile Send private message 
minoruhackerguy

Joined: 27 Nov 2007
Posts: 31

PostPosted: Sat 01 Mar 2008, 03:01    Post subject:  

YO! Thank you so much for making such an awesome Dotpup. I'm running it in Puppy 2.15ce, and so far I don't see many issues. There is a few Issue that I'm having problems with. Geany won't work now... :-/ (Error says Segmentation Fault.) I'll re-install the dotpup for it and tell you if it works. Also, the puppybackground bug started after I installed it. *though, that may be unrelated*

I'm using icewm with gnome.
Desktop(800x600).jpg
 Description   I went for a Mac OS X style, but I'm in the middle of changing it.
 Filesize   33.23 KB
 Viewed   1098 Time(s)

Desktop(800x600).jpg

Back to top
View user's profile Send private message Visit poster's website AIM Address 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sat 01 Mar 2008, 04:18    Post subject:  

for geany look, that there is no
/usr/lib/libvte.so

I don't remember if that is part of gnome, but it crashed some versions of geany.
I don't know what program could need it.
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
minoruhackerguy

Joined: 27 Nov 2007
Posts: 31

PostPosted: Tue 04 Mar 2008, 20:09    Post subject:  

Thank for the help Guys. Wink I wiil check out your suggestions.

--edit--
Alright! Everything works fine now. *I just typed in 'geany -t', opened up preferences and un-ticked the terminal option'*

Thanks for you're help. *bows*
Back to top
View user's profile Send private message Visit poster's website AIM Address 
Insomniacno1

Joined: 24 Jul 2009
Posts: 75

PostPosted: Sun 29 Jun 2014, 07:38    Post subject:  

Hi, any chance you could get this to work with Wary 5.5, I really don't like Rox. Since I like to have my filsystem on the left side and can easily access drives.

I know this is an old thread but hope for a response:)

JBJ
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [14 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0803s ][ Queries: 13 (0.0051s) ][ GZIP on ]