Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 00:13
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
mtpaint 3.44.89- October 2014
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 4 of 15 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 13, 14, 15 Next
Author Message
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Mon 06 Jan 2014, 14:24    Post_subject:  

I was checking mtpaint 3.44.51 with Precise and Quirky and I found that
the theme was causing the boxes to be black. The entries
can't be easily seen. The solution is simple ---> change the GTK theme.

Previous versions have the same problem.




___________________________________
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Mon 13 Jan 2014, 18:41    Post_subject:  

The setting window has the problem as well when there is indexed colors.

The problem in the settings window goes away if RGB colors id chosen.




++++++++++++++++++++++++++++++++++++++++++
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Mon 13 Jan 2014, 18:42    Post_subject:  

New version 3.44.53 available in first post.

____________________________________
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Thu 16 Jan 2014, 21:19    Post_subject:  

New version 3.44.54 available.
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Tue 21 Jan 2014, 20:41    Post_subject:  

New version 3.44.55 available.

Also for first time I have a 64 bit version available.
It was compiled in Fatdog630 and the package was
put together in Precise Puppy
_______________________________________
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Sat 08 Feb 2014, 16:37    Post_subject:  

version 3.44.56 available

I have made a debian version available as well. It will run in
Ubuntu Lucid.

It will probably run in more recent versions of Ubuntu
if links are made for missing dependencies however I haven't checked.
______________________________________________
Back to top
View user's profile Send_private_message 
wjaguar

Joined: 21 Jun 2006
Posts: 291

PostPosted: Sun 02 Mar 2014, 11:54    Post_subject: mtPaint 3.44.57  

Versions 3.44.47-56 have a bug: in Preferences->Paths, path boxes don't get set from file selector.
Fixed in version 3.44.57 on Github.
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Sat 08 Mar 2014, 13:33    Post_subject:  

New version 3.44.57

- debian version has proper icon now

_____________________________________
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Mon 17 Mar 2014, 17:03    Post_subject:  

version 3.44.59

- I have also changed the mtpaint handbook package because
I found that yaf-splash warning message didn't work in puppy
4.3.1 perhaps others. FIXED

Remember that mtpaint handbook can't be installed while mtpaint is running.

___________________________________________________________
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1021
Location: South of Belgium

PostPosted: Fri 21 Mar 2014, 01:30    Post_subject:  

Hi don570 Very Happy !
a ton of thanks keeping this update job !
cheers,
charlie
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Thu 27 Mar 2014, 19:24    Post_subject:  

I made a Tahr Ubuntu debian version available in first post. It should run in
other recent Ubuntu versions, but I haven't tested in anything other than
Tahr

________________________________________________
Back to top
View user's profile Send_private_message 
sszindian


Joined: 24 Apr 2010
Posts: 613
Location: Pennsylvania U.S.

PostPosted: Fri 28 Mar 2014, 20:23    Post_subject: 3.44.59  

Mtpaint-3.44.59.pet

When you open a graphic folder, right/click on a graphic, and select 'open with' then select Mtpaint, all you get is a 'Screen Flicker' but the graphic does NOT open. Previous Mtpaint version worked fine!
(Installed in Slacko-5.6.5.5)

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Sat 29 Mar 2014, 12:49    Post_subject:  

I will test mtpaint package on slacko 5.7 this weekend.

I will post previous package 3.44.57 in meantime.

________________________________________
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1021
Location: South of Belgium

PostPosted: Sat 29 Mar 2014, 14:26    Post_subject:  

Quote:
When you open a graphic folder, right/click on a graphic, and select 'open with' then select Mtpaint, all you get is a 'Screen Flicker' but the graphic does NOT open.

... 3.44.59 works OK on wheezy 3.5.2.5 an 3.5.2.11
charlie
Back to top
View user's profile Send_private_message 
wjaguar

Joined: 21 Jun 2006
Posts: 291

PostPosted: Sun 30 Mar 2014, 03:41    Post_subject: Re: 3.44.59  

sszindian wrote:
select 'open with' then select Mtpaint, all you get is a 'Screen Flicker' but the graphic does NOT open

A classic case of mixed-up libraries.
Your system has libpng14.so.14 linked into GTK+2, and libjpeg.so.8 linked into libtiff. And this build of mtPaint links to libpng12.so.0 and libjpeg.so.62. So both versions get loaded, and then neither PNGs nor JPEGs work.
Running " ldd `which mtpaint` | grep 'libjpeg\|libpng' " will demonstrate the problem.

Slacko therefore needs a separate build of mtPaint (using libpng 1.4.x and libjpeg 8 ).
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 4 of 15 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 13, 14, 15 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0736s ][ Queries: 13 (0.0075s) ][ GZIP on ]