Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 14:07
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
How to use iwl3945 wifi in Slacko 5.7?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
jstrazza

Joined: 20 Mar 2014
Posts: 3

PostPosted: Fri 21 Mar 2014, 15:28    Post_subject:  How to use iwl3945 wifi in Slacko 5.7?  

I have an hpc6400 laptop with 4 GB of RAM, 320 GB hard drive and a duo core 1.86 CPU

Computer has windows/7 dual boot with pclinuxOS. The wireless works fine on both platforms.

I boot puppy Linux slacko 5.7 from a USB drive, but cannot get the wireless to work. The wireless shows iwl3945. I used the YUM multi-boot manager on the windows platform (sorry) to create the USB stick. It allows me to boot several different versions of Linux from the USB stick

When using the simple network setup, it says wlan0 not found. It appears that I need to use the pet repository to get the driver for this card and install it.

I am not able to attach error logs at this time and I am sure that they would be helpful.

I also tried the other two network setup options with similar results. There is a switch on the laptop to turn on and off the wireless, but it is on.

The machine works fine with the wired internet connection.

I am using the non-PAE version of slacko.

Can you provide me with some ideas about how to resolve this issue?

Thanks, John
Back to top
View user's profile Send_private_message 
ardvark


Joined: 01 Jul 2013
Posts: 1010
Location: USA

PostPosted: Fri 21 Mar 2014, 16:11    Post_subject:  

Hi...

Welcome to the forums Smile

If your wireless chipset is internal (or onboard,) please open a terminal and post the output of...

Code:
lspci -nn


or if it's a USB adapter...

Code:
lsusb


Last but not least...

Code:
dmesg


the portion that pertains to your wireless adapter.

Also, did you try using Frisbee to connect to your network?

Thanks! Smile

_________________
Our Lord and Savior Jesus Christ loves and cares about you most of all!

PLEASE READ! You don't have to end up here!
Back to top
View user's profile Send_private_message 
Marv


Joined: 04 May 2005
Posts: 350
Location: SW Wisconsin

PostPosted: Fri 21 Mar 2014, 17:56    Post_subject: Re: How to use iwl3945 wifi in Slacko 5.7?  

jstrazza wrote:
I have an hpc6400 laptop with 4 GB of RAM, 320 GB hard drive and a duo core 1.86 CPU

Computer has windows/7 dual boot with pclinuxOS. The wireless works fine on both platforms.

I boot puppy Linux slacko 5.7 from a USB drive, but cannot get the wireless to work. The wireless shows iwl3945. I used the YUM multi-boot manager on the windows platform (sorry) to create the USB stick. It allows me to boot several different versions of Linux from the USB stick

When using the simple network setup, it says wlan0 not found. It appears that I need to use the pet repository to get the driver for this card and install it.

I am not able to attach error logs at this time and I am sure that they would be helpful.

I also tried the other two network setup options with similar results. There is a switch on the laptop to turn on and off the wireless, but it is on.

The machine works fine with the wired internet connection.

I am using the non-PAE version of slacko.

Can you provide me with some ideas about how to resolve this issue?

Thanks, John


Not a new issue. This is a hack, there are more elegant ways but try the following:

Create the following directory:
/lib/firmware/iwlegacy

Go to the following directory:
/lib/modules/all-firmware/iwlwifi/lib/firmware

Copy and paste the file iwlwifi-3945-2.ucode into the iwlegacy directory you created in the first step. (should also work if you just paste it into /lib/firmware).

Might need a reboot. Try it.

_________________
tweaked 412 based boxpup, well honed 'lina-lite-005, alphaOS 321 Wink , X-slacko 2.2n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.17 kernel). All lean and steady pups.
Back to top
View user's profile Send_private_message 
ardvark


Joined: 01 Jul 2013
Posts: 1010
Location: USA

PostPosted: Fri 21 Mar 2014, 18:30    Post_subject: Re: How to use iwl3945 wifi in Slacko 5.7?  

Marv wrote:

Not a new issue. This is a hack, there are more elegant ways but try the following:

Create the following directory:
/lib/firmware/iwlegacy

Go to the following directory:
/lib/modules/all-firmware/iwlwifi/lib/firmware

Copy and paste the file iwlwifi-3945-2.ucode into the iwlegacy directory you created in the first step. (should also work if you just paste it into /lib/firmware).

Might need a reboot. Try it.


Hi...

I saw a similar fix here but I wasn't sure that it would work in this case. Wink

Regards...
Back to top
View user's profile Send_private_message 
jstrazza

Joined: 20 Mar 2014
Posts: 3

PostPosted: Fri 21 Mar 2014, 23:03    Post_subject: Re: How to use iwl3945 wifi in Slacko 5.7?  

Marv wrote:
jstrazza wrote:
I have an hpc6400 laptop with 4 GB of RAM, 320 GB hard drive and a duo core 1.86 CPU

Computer has windows/7 dual boot with pclinuxOS. The wireless works fine on both platforms.

I boot puppy Linux slacko 5.7 from a USB drive, but cannot get the wireless to work. The wireless shows iwl3945. I used the YUM multi-boot manager on the windows platform (sorry) to create the USB stick. It allows me to boot several different versions of Linux from the USB stick

When using the simple network setup, it says wlan0 not found. It appears that I need to use the pet repository to get the driver for this card and install it.

I am not able to attach error logs at this time and I am sure that they would be helpful.

I also tried the other two network setup options with similar results. There is a switch on the laptop to turn on and off the wireless, but it is on.

The machine works fine with the wired internet connection.

I am using the non-PAE version of slacko.

Can you provide me with some ideas about how to resolve this issue?

Thanks, John


Not a new issue. This is a hack, there are more elegant ways but try the following:

Create the following directory:
/lib/firmware/iwlegacy

Go to the following directory:
/lib/modules/all-firmware/iwlwifi/lib/firmware

Copy and paste the file iwlwifi-3945-2.ucode into the iwlegacy directory you created in the first step. (should also work if you just paste it into /lib/firmware).

Might need a reboot. Try it.
Back to top
View user's profile Send_private_message 
jstrazza

Joined: 20 Mar 2014
Posts: 3

PostPosted: Fri 21 Mar 2014, 23:18    Post_subject: It works
Sub_title: Wifi
 

Marv, I did the simple fix and it worked! I saved the file, rebooted and it is all good. Thanks, John
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0615s ][ Queries: 12 (0.0034s) ][ GZIP on ]