Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 23 Nov 2014, 23:06
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Using Crossover (from Codeweavers) in Puppy
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [14 Posts]  
Author Message
cicerosc

Joined: 15 Feb 2007
Posts: 17

PostPosted: Sun 16 Mar 2014, 10:20    Post subject:  Using Crossover (from Codeweavers) in Puppy  

I am having trouble getting Crossover to run on Puppy (in this case LxPUP 14.03. After making sure I had devx installed, the crossover install program seems to install ok, but whenever I run it I get:

You seem to be missing the GTK+ Python modules.
If this is the case you may try running one of the following commands as root:

Debian / Ubuntu: apt-get install python-gtk2
Fedora: yum install pygtk2
Mandriva: urpmi pygtk2.0
SUSE: zypper install python-gtk

I have tried downloading some python pets but with no success. Has anyone gotten past this problem?

Thanks
Back to top
View user's profile Send private message 
ardvark


Joined: 01 Jul 2013
Posts: 1091
Location: USA

PostPosted: Sun 16 Mar 2014, 11:02    Post subject:  

Hi...

Can you find these packages in the Puppy Package Manager?

Regards...

_________________
Our Lord and Savior Jesus Christ loves and cares about you most of all!

PLEASE READ! You don't have to end up here!
Back to top
View user's profile Send private message 
cicerosc

Joined: 15 Feb 2007
Posts: 17

PostPosted: Sun 16 Mar 2014, 13:39    Post subject:  

It is possible I missed them but I searched all the puppy and slacko repositories without finding exact equivalents. I downloaded a number of different python packages that appeared to be similar without changing the fact that I got the same error message.
Back to top
View user's profile Send private message 
ardvark


Joined: 01 Jul 2013
Posts: 1091
Location: USA

PostPosted: Sun 16 Mar 2014, 14:15    Post subject:  

Hi...

If you were running Precise Puppy, installing this package (plus necessary dependencies) might solve the problem but I'm not sure how installing a .deb package would work in LxPup.

Regards...
Back to top
View user's profile Send private message 
cicerosc

Joined: 15 Feb 2007
Posts: 17

PostPosted: Sun 16 Mar 2014, 14:35    Post subject:  

Thank you for the suggestion AARDVARK! Yes that does look promising, but yes also I gather I cannot install that (readily) in LXPUP.... ;-(
Back to top
View user's profile Send private message 
ardvark


Joined: 01 Jul 2013
Posts: 1091
Location: USA

PostPosted: Sun 16 Mar 2014, 14:56    Post subject:  

cicerosc wrote:
Yes that does look promising, but yes also I gather I cannot install that (readily) in LXPUP.... ;-(


There may be options, though, so I wouldn't say you're dead in the water. One is to try the utility called deb2pet offered here. It's also possible you might be able to get a .deb installer program like gdebi to work on your version of Puppy.

Another option would be to replace (your current Puppy version) or add Precise Puppy 5.6.1 or 5.7.1 to your system. Smile

Regards...
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Tue 18 Mar 2014, 19:05    Post subject:  

Quote:
I am having trouble getting Crossover to run on Puppy


I ran Crossover routinely on lucid--not suggesting you use lucid but that it should be possible. That was my pet of integer.pm. Yes, the devx needs to be installed. Doesn't Slacko 5.7 have python-gtk in the Puppy Package Manager? What happens if you just download and click the python-gtk2.deb ardvark found? Puppy will usually just install deb files, but maybe Slacko is different. Ah, if clicking it doesn't work in pcmanfm, then start rox and use that to click the deb file.

The only thing is that Slacko is by design more lean than Precise (and Lucid) so there may be something else.
Back to top
View user's profile Send private message 
cicerosc

Joined: 15 Feb 2007
Posts: 17

PostPosted: Wed 19 Mar 2014, 08:42    Post subject:  

Thank you for the suggestions! I will check them out.
Back to top
View user's profile Send private message 
cicerosc

Joined: 15 Feb 2007
Posts: 17

PostPosted: Wed 19 Mar 2014, 14:59    Post subject:  

Well I believe I successfully installed the deb file referenced about, but I am still getting the same error.

When I install crossover, the terminal shows this:

reinstall
cxassoc:warning: unable to find 'update-desktop-database' in '/bin:/usr/bin:/sbin:/usr/sbin:/usr/local/bin:/usr/X11R7/bin:/root/my-applications/bin:/usr/games:/opt/gnome/bin'

however it proceeds to say that it installed successfully in the graphical installer, and it adds crossover to the menu just fine.

Perhaps there is some implication of the install output that I don't understand?

once installed, every time I run Crossover I still get:

You seem to be missing the GTK+ Python modules.
If this is the case you may try running one of the following commands as root:

Debian / Ubuntu: apt-get install python-gtk2
Fedora: yum install pygtk2
Mandriva: urpmi pygtk2.0
SUSE: zypper install python-gtk

thanks for any suggestions
Back to top
View user's profile Send private message 
ardvark


Joined: 01 Jul 2013
Posts: 1091
Location: USA

PostPosted: Wed 19 Mar 2014, 17:41    Post subject:  

Hi...

Just as a lark, burn a copy of Precise 5.6.1 or 5.7.1 and run it live. See if the Puppy Package Manager has the same file I referenced to (and install it from there) and if not, install it again from the link I provided. Then try to install Crossover again. Running it live would allow you to experiment without having to make any changes to your system. If it does work and if this version of Puppy works well with your system, you can choose whether to install it to your hard drive.

I'd be curious to see what happens. Wink

Regards...
Back to top
View user's profile Send private message 
cicerosc

Joined: 15 Feb 2007
Posts: 17

PostPosted: Wed 19 Mar 2014, 21:16    Post subject:  

Thank you Aardvark. I actually mad a stab at doing that yesterday, only to find that precise did not support my external usb modem (Ralink driver if I recall) so I ran into a brick wall there. But i will give it another try, perhaps on another machine, and let you know the result.. Thank you again for your input!
Back to top
View user's profile Send private message 
ardvark


Joined: 01 Jul 2013
Posts: 1091
Location: USA

PostPosted: Thu 20 Mar 2014, 03:06    Post subject:  

cicerosc wrote:
Thank you Aardvark. I actually mad a stab at doing that yesterday, only to find that precise did not support my external usb modem (Ralink driver if I recall) so I ran into a brick wall there. But i will give it another try, perhaps on another machine, and let you know the result.. Thank you again for your input!


You're welcome, glad to help. Smile

Regards...
Back to top
View user's profile Send private message 
cicerosc

Joined: 15 Feb 2007
Posts: 17

PostPosted: Thu 20 Mar 2014, 15:41    Post subject:  

Aardvark thanks again for your help. Using the Precise version of the lxpup iso, and downloading a package I think was called bpython-gtk, I have successfully got crossover running.

Thanks for the help!
Back to top
View user's profile Send private message 
ardvark


Joined: 01 Jul 2013
Posts: 1091
Location: USA

PostPosted: Fri 21 Mar 2014, 09:07    Post subject:  

cicerosc wrote:
Aardvark thanks again for your help. Using the Precise version of the lxpup iso, and downloading a package I think was called bpython-gtk, I have successfully got crossover running.

Thanks for the help!


Excellent, glad to hear this! Smile

And you're more than welcome. Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [14 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0694s ][ Queries: 12 (0.0042s) ][ GZIP on ]