Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 28 Aug 2014, 09:24
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
LxPup : a Puppy with LXDE as its desktop environment
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 15 of 23 [342 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, ..., 21, 22, 23 Next
Author Message
Terry H

Joined: 29 Mar 2009
Posts: 83
Location: Pickering, ON Canada

PostPosted: Wed 12 Mar 2014, 21:24    Post subject:  

peebee wrote:
01micko has announced Slacko5.7(RC) ( aka Slacko5.6.8 ) with k3.4.82 for its non-pae 4g version

LxPup14.03 has been updated to the new base:
LxPup-14.03-s57-4g-080314.iso

No other significant changes.

Cheers
peebee


Updated my LXPup to the latest base. New frugal instal, without existing savefile. All good. The Intel 4965 Wifi working,

Great work. Thank you.
Back to top
View user's profile Send private message 
cicerosc

Joined: 15 Feb 2007
Posts: 17

PostPosted: Sat 15 Mar 2014, 08:30    Post subject: Crossover
Subject description: Installing Crossover
 

I am having trouble installing Crossover. I searched and found a post that said that integer.pm needed to be installed, and I did that using the pet that was supplied here: http://www.murga-linux.com/puppy/viewtopic.php?p=601735&sid=0d08378ba766f9b2bb43a726f0cde754

I searched the pearl directory and it does appear to be there, but I keep getting this error. Can you help me figure out what is wrong? I REALLY like this LXDE Pup! THANKS!!

Can't locate integer.pm in @INC (@INC contains: /opt/cxoffice/lib/perl /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5 .) at /opt/cxoffice/lib/perl/CXUtils.pm line 141.
BEGIN failed--compilation aborted at /opt/cxoffice/lib/perl/CXUtils.pm line 141.
Compilation failed in require at /opt/cxoffice/lib/cxupgrade line 86.
BEGIN failed--compilation aborted at /opt/cxoffice/lib/cxupgrade line 86.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1393
Location: Malvern, Worcs, UK

PostPosted: Sat 15 Mar 2014, 08:43    Post subject: Re: Crossover
Subject description: Installing Crossover
 

cicerosc wrote:
I searched the pearl directory and it does appear to be there, but I keep getting this error. Can you help me figure out what is wrong? I REALLY like this LXDE Pup! THANKS!!

Hello

First thought is - do you have the devx installed?

If you are using the Slacko flavour of LxPup then see below.

Cheers
peebee

_________________
LxPup-14.03 = Puppy + LXDE

Last edited by peebee on Sat 15 Mar 2014, 16:55; edited 1 time in total
Back to top
View user's profile Send private message 
cicerosc

Joined: 15 Feb 2007
Posts: 17

PostPosted: Sat 15 Mar 2014, 08:52    Post subject:  

Thank you for replying so quickly! No, I never installed devx, so that is no doubt my problem. I am looking in the SFS manager though and do not see that listed. I am hit and miss with linux - is devx an alternate name for one of the other packages listed there?
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1393
Location: Malvern, Worcs, UK

PostPosted: Sat 15 Mar 2014, 09:32    Post subject:  

cicerosc wrote:
Thank you for replying so quickly! No, I never installed devx, so that is no doubt my problem. I am looking in the SFS manager though and do not see that listed. I am hit and miss with linux - is devx an alternate name for one of the other packages listed there?

Hi

At work at the moment so not sitting in front of Puppy....

Which flavour of LxPup are you running??

You can download the devx directly for the Slacko5.7 flavours from:
http://ftp.nluug.nl/ftp/pub/os/Linux/distr/puppylinux/puppy-slacko-5.7/

you need to know whether you are running the pae or non-pae version.

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
cicerosc

Joined: 15 Feb 2007
Posts: 17

PostPosted: Sat 15 Mar 2014, 10:08    Post subject:  

Thanks again! I downloaded from there - thanks. It looks like I have shot myself in the foot by running an install and installing to a full partition. Now it looks like I am not able to use any SFS files at all as I am getting an error even trying to load the Audacious SFS. I can't remember the exact error message but it said something about support being experimental and then failed. I guess I will pull the plug on playing and use the system as is. Thanks for your answers so far! ---- EDIT WELL DUH I USED THE BOOTMANAGER to tell the SFS files to load at boot and it appears I am golden on Crossover. THANKS!!!!

EDIT 2 : Well I spoke too soon. Now I am getting "You seem to be missing the GTK+ Python modules.If this is the case you may try running one of the following commands as root:

Debian / Ubuntu: apt-get install python-gtk2
Fedora: yum install pygtk2
Mandriva: urpmi pygtk2.0
SUSE: zypper install python-gtk

Of course when I look in the package manager, it seems to say that python is already installed -- looking further..... but unable to get past this error. Oh Well....
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1393
Location: Malvern, Worcs, UK

PostPosted: Sat 15 Mar 2014, 16:59    Post subject: devx  

The Sfs Manager logic means that the devx is not offered if the distro name and version have been changed (as is the case for LxPup).

Therefore for LxPup, the devx has to be located and directly downloaded if required. I'll put links into the 1st post.

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
cicerosc

Joined: 15 Feb 2007
Posts: 17

PostPosted: Sun 16 Mar 2014, 14:41    Post subject:  

Before I give up completely on running Crossover in LXPup, I started a tread over here in general to discuss running Crossover. http://www.murga-linux.com/puppy/viewtopic.php?p=765349#765349

http://www.murga-linux.com/puppy/viewtopic.php?t=92650

The first suggestion (probably unhelpful) Wink was that if I were running Precise puppy I could install http://packages.ubuntu.com/precise/python-gtk2

I don't suppose there is an equivalent accessible in LXPUP? Smile No problem if not; I don't want to lead off on a wild goose chase! Really at this point just noting the problem in the event that something comes up that would deal with this python issue (or it could purely be limited to Crossover)

The main reason I find Crossover useful is in its archiving system, which makes it easier to set up a bottle on one machine and then move it to other machines.

Last edited by cicerosc on Sun 16 Mar 2014, 15:56; edited 1 time in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1393
Location: Malvern, Worcs, UK

PostPosted: Sun 16 Mar 2014, 15:32    Post subject:  

cicerosc wrote:
Before I give up completely on running Crossover in LXPup, I started a tread over here in general to discuss running Crossover. http://www.murga-linux.com/puppy/viewtopic.php?p=765349#765349

http://www.murga-linux.com/puppy/viewtopic.php?t=92650

The first suggestion (probably unhelpful) Wink was that if I were running Precise puppy I could install http://packages.ubuntu.com/precise/python-gtk2

I don't suppose there is an equivalent accessible in LXPUP? Smile No problem if not; I don't want to lead off on a wild goose chase! Really at this point just noting the problem in the event that something comes up that would deal with this python issue (or it could purely be limited to Crossover)

The main reason I find Crossover useful is in its archiving system, which makes it easier to set up a bottle on one machine and then move it to other machines.


Searching for python in PPM shows pygtk-2.24.0 from the slackware14.0 repository however it has further missing dependencies.....pycairo and pygobject

You might want to try CompizPup which is a derivative of LxPup and from memory has much of this python stuff built-in as its needed for the Compiz Configuration Manager....however I am planning soon to update CompizPup.....

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
cicerosc

Joined: 15 Feb 2007
Posts: 17

PostPosted: Sun 16 Mar 2014, 15:48    Post subject:  

Ha! Had not heard of Compizpup! Will check that out as a test, and then I will wait for the update! thanks! UPDATE: Well my old computer does not like Compiz ;-( Apparently time for me to drink some wine until you add something to the main LXPup that requires more python support!

HMMM - I had not noticed that you had a 14.02 version based on Precise. I will try that and see if I can access that python package he referred me to...

Edit - you know Linux would be no fun if everything worked, would it? The Precise version won't recognize the modem that the slacko version recognizes without a hitch - ARGH!

UPDATE EDIT - using the precise version of the lxpup iso, and downloading a package I think was called bpython-gtk i have successfully got crossover running. Still not sure I like this as much as the slacko version, but maybe I'll get used to it. but thanks for the help!
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Thu 20 Mar 2014, 18:35    Post subject:  

This had been about the Help in LxPup. Peebee has a better fix on p.16. Here is still the Firefox 28 for anyone who wants it.

http://diddywahdiddy.net/Puppy500/Firefox-28-Lxpup.pet

Last edited by playdayz on Sat 22 Mar 2014, 20:08; edited 2 times in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1393
Location: Malvern, Worcs, UK

PostPosted: Thu 20 Mar 2014, 18:49    Post subject:  

playdayz wrote:
Thanks for this peebee. It's nice to have some variety. I have always liked LxpanelX and LXDE in general. One thing I noticed was that the Help is not working, because openbox uses a different method than slacko with jwm--openbox uses the traditional gvfs method of gnome. These 3 pets will make the help work, including mtpaint and gnumeric, which do not work in Slacko. For anyone who might not know, this means Help entries work from the programs' menus, and the links work in the Help -> About each program. The pets also add Firefox 28 because I couldn't get it to work with the default Firefox and I wanted the most recent FF anyway.

1. Download and install the 3 pets.
2. Menu -> Desktop -> Preferred Applications -> Click, Customize, Internet, Firefox
3. Run Firefox once from the menu
4. Test help in Abiword, gnumeric, mtpaint, etc.

http://diddywahdiddy.net/Puppy500/Firefox-28-Lxpup.pet
http://diddywahdiddy.net/Puppy500/gvfs-1.12.3.pet
http://diddywahdiddy.net/Puppy500/libsoup-2.38.1.pet

I should say I am using 14.03 pae, but I think this should work in any of 14.02/3.


Hi Playdayz

Thanks for that.

gvfs-1.12.3 is already built-in to LxPup14.03 so maybe that pet isn't needed??

libsoup isn't included however....I'll add it to the next version whenever that appears.

Would be good to not have to update Firefox....

Cheers
peebee
Screenshot_2014-03-20_230330.png
 Description   
 Filesize   21.51 KB
 Viewed   387 Time(s)

Screenshot_2014-03-20_230330.png


_________________
LxPup-14.03 = Puppy + LXDE

Last edited by peebee on Fri 21 Mar 2014, 02:37; edited 1 time in total
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Thu 20 Mar 2014, 19:19    Post subject:  

peebee said:
Quote:
gvfs-1.12.3 is already built-in to LxPup14.03 so maybe that pet isn't needed??
Embarassed

Probably only libsoup is needed then. I will experiment. Add: Yes, it seems so.

The rest is handled by peebee's fix on p.16.

Last edited by playdayz on Sat 22 Mar 2014, 20:10; edited 1 time in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1393
Location: Malvern, Worcs, UK

PostPosted: Fri 21 Mar 2014, 02:36    Post subject:  

playdayz wrote:
peebee said:
Quote:
gvfs-1.12.3 is already built-in to LxPup14.03 so maybe that pet isn't needed??
Embarassed

Probably only libsoup is needed then. I will experiment. Add: Yes, it seems so. Probably someone can figure out how to use the default Firefox. An experimenter could just add the libsoup pet (or add it from the PPM) and then see if the Help works. One might compare the default /usr/bin/firefox to the one in the pet. Micko wrote a very fancy /usr/bin/firefox that somehow seems to shave the url off when the help starts a link, but this is here for anyone who wants the latest FF anyway. The FF 28 pet also contains the enabling pieces for the help in mtpaint and gnumeric.


I'll have a play/experiment....

What happens if a different browser is set as default - I always install and set chromium as my default for instance - does help then stop working again??

Thanks
peebee

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Fri 21 Mar 2014, 11:16    Post subject:  

Again, please refer to Peebee's method for activating the Help throughout LxPup.

People do know that Firefox ESR is on version 24 now, right?

Last edited by playdayz on Sat 22 Mar 2014, 20:11; edited 2 times in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 15 of 23 [342 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, ..., 21, 22, 23 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0982s ][ Queries: 13 (0.0089s) ][ GZIP on ]