Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 17:39
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge » Multi-session live-CD/DVD
TkDVD won't add a session to my multisession DVD
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11120
Location: Arizona USA

PostPosted: Thu 02 Nov 2006, 11:07    Post subject:  TkDVD won't add a session to my multisession DVD  

What I'm trying to do is add a session to the DVD, that is not generated by Puppy's "Save" script, so it shows up in the disk's TOC with the title I want. TkDVD offers a checkbox in the Advanced Options page: "Add session to disk," but when I try to use it to add a session to my multisession DVD it says the disk is read only. I'm pretty sure this worked before, when I tried it in an earlier version of Puppy. Can anyone tell my what I need to do to add a large file as a session, to a multisession DVD?
_________________
Puppy Help 101 - an interactive tutorial for Lupu 5.25
Back to top
View user's profile Send private message 
Ted Dog


Joined: 13 Sep 2005
Posts: 2367
Location: Heart of Texas

PostPosted: Thu 02 Nov 2006, 15:53    Post subject:  

Code:
growisofs -M /dev/dvd -R -D /mnt/somedirectory/thelargefile
will put it on root of DVD
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11120
Location: Arizona USA

PostPosted: Fri 03 Nov 2006, 00:37    Post subject:  

That works, Ted, but I should have said "folder" or "directory" instead of "file." Embarassed I tried saving a folder containing several hundred mp3 files. The files were saved, but not the folder they had been in. Now I have several hundred mp3 files in the / directory of the DVD, named 01-01, 01-02, ...., instead of a folder named with the title of the book, and containing those mp3 files. Laughing

Do you know why TkDVD won't do what I want? If it's a bug I'll send the developer a bug report.

How is UDF coming along? Wouldn't UDF support make it easy to do what I want?
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11120
Location: Arizona USA

PostPosted: Fri 03 Nov 2006, 17:28    Post subject:  

I tried it again, with a different folder containing 244 mp3 files and adding the -J option to growisofs. The same thing happened. Now it's a big mess with the mp3 files from 2 books mixed up. Laughing How does multisession Puppy save a session so it shows up as a folder when you mount the disk?
_________________
Puppy Help 101 - an interactive tutorial for Lupu 5.25
Back to top
View user's profile Send private message 
Ted Dog


Joined: 13 Sep 2005
Posts: 2367
Location: Heart of Texas

PostPosted: Sat 04 Nov 2006, 04:07    Post subject: -J = junk my DVD unexpectively  

I hope that is a TEST DVD! You turned on MS mode naming methods with the -J option, It can self distruct any multisession in the future... AHHHHH!!!!
No really, this option caused us problems in the past.

Code:
growisofs -M /dev/dvd -D -R -new-dir-mode 0755 -graft-points NameOfDirectoryOnDVD=/mnt/PathToSourceDirectory
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11120
Location: Arizona USA

PostPosted: Sat 04 Nov 2006, 11:20    Post subject:  

It's my test DVD, Ted. Very Happy Thanks for the code. I'll try it today.
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11120
Location: Arizona USA

PostPosted: Sat 04 Nov 2006, 13:39    Post subject:  

Your recipe worked perfectly, Ted. Using -J in the previous try didn't ruin my test DVD so I copied all 244 of the mp3 files from the DVD to /tmp, then used /tmp as the source directory in your recipe so I had to change /mnt in your recipe to /tmp. Also, either the name of the directory-to-be-created on DVD has to be exactly the same as the name of the source directory, or you can't use spaces in the name of the directory on the DVD.
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11120
Location: Arizona USA

PostPosted: Sun 05 Nov 2006, 20:02    Post subject:  

I found that I had to add -l (lower-case L) before it would work with long directory names:
Code:
growisofs -M /dev/dvd -D -R -l -new-dir-mode 0755 -graft-points Name_Of_Directory(OnDVD)=/(PathTo)/Source_Directory

Alas, no spaces or commas allowed in either the source or destination directory name. Sad
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge » Multi-session live-CD/DVD
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0603s ][ Queries: 12 (0.0041s) ][ GZIP on ]