Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 20 Aug 2014, 06:45
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Puppy Arcade 11
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Author Message
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Wed 05 Mar 2014, 11:10    Post_subject:  Puppy Arcade 11
Sub_title: ..released March 5th, 2014
 

Puppy Arcade 11
a retro gaming live cd


Plays games from the following systems:

Amiga (500, 1000, 2000, CD32, CDTV), Apple (68k, 128k, 512k, SE, MacOS, Plus), Atari (400, 400 XL, 800, 800XL, 130XE, 5200, Falcon, Lynx, ST, others), Amstrad (CPC, Plus, VEB, others), Arcades (many), Colecovision, Commodore (64, 128, VIC20, PET, others), Doom, GameBoys (GB, GBC, GBA), GameGear, Genesis/MegaDrive, Intellivision, Master System, MS DOS, MSX, MSX2, N64, NDS, NeoGeo, NeoGeo Pocket, NeoGeo CD, NES/Famicom, PC Engine/TurboGrafix, PC-FX, PlayStation, ScummVM, SNES, Wonderswan, Virtual Boy, ZX Spectrum (16k, 48k, 128k, +2, +2A, +3) and more!

Homepage: http://scottjarvis.com/page105.htm

Download:

The 'main' release is the first one (k2.6.25.16).. The others should be considered experimental.

For older hardware (~2008):

    Puppy Arcade 11, k2.6.25.16:
    http://akita.scottjarvis.com/puppy-arcade-11-k2.6.25.16.iso
    Kernel 2.6.25.16, from Puppy 4.2, 2008
    (md5: 13dfecb18315a89f6368f01edcaec80d, size: 179mb)

    NOTES:

    About installing BIOS files and other stuff:

    Generally do this before creating a save file, as it will work faster, until I update the package manager. Also, BIOS files seem to download (wrongly) to /root after a save file has been created - so go there to install them..

    About not finding save files:

    I have noticed that you need to remove the 'pmedia=usbflash' option from the menu.lst GRUB boot menu file, to get Puppy to recognise the save file...


Not so old hardware (~2011 - 2013):




Test builds (issues may need fixing):



Summary:

- includes Rom-Loader, a multi-emulator frontend and rom browser
- includes a ROM info database with over 18,000 games supported
- includes detailed descriptions for most of the 18,000 supported games
- Rom-Loader can download and display box art for each of your ROMs
- choose your preferred emulator for each system in Rom-Loader
- Rom-Loader supports joypad-only rom-browsing and playing for both players 1 and 2
- Rom-Loader supports custom emulators and emulator settings per ROM
- users can customise the layout and themes of Rom-Loader per system
- simple keyboard controls for nearly all emulators setup by default
- ATI, Nvidia and MESA/Xorg75 driver packages available in the package manager
- most emulators can be accessed directly in Menu->Fun->[emulator]
- nearly all emulators updated, many other changes from the previous version
- Dreamcast, PS2, Saturn, Gamecube emulators (and others) available here , or here

More info:

Read the Puppy Arcade 11 README file, it's huge (also included in the download).

Screenshots:

Rom-Loader, menu menu:


Rom-Loader, rom-browser page:




Rom-Loader, rom-browser page, ROM menu:


Rom-Loader, recent ROMs:


Rom-Loader, Settings pages:

Choose your preferred emulators:


BIOS installer:


Enable joypad for all emulators:




Rom-Loader GUI settings:


Themes:


Emulator Config Files:

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search

Edited_times_total
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Wed 05 Mar 2014, 11:10    Post_subject:  

FAQ:

Q: How do I...
A: Read the README

Q: What if I want to ...
A: Read the README

Q: How can I...
A: Read the README


About Box Art:

Puppy Arcade is setup to download box art for all ROMs in a folder, as soon as you enter that folder... If Rom-Loader freezes after loading the list of roms, you can change the box art download settings in the rom-Loader settings page. After the rom list has loaded, any missing box art will be downloaded each time you select/highlight a rom.


About joypad-only navigation:

This can be setup through the Rom-Loader settings page.. Read and follow the instructions in the 'Joypad Controls' tab.

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search

Edited_times_total
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Wed 05 Mar 2014, 13:05    Post_subject: donations welcome...  

I started university recently, so I can't work full-time the the moment and I am currently living off my student loans and some cover work - so if you really like Puppy Arcade and use it often, a donation would be much appreciated - it took a lot of time and work to put all the bits together!

I will support users who need help, but I will not be on the forum much for a few weeks, maybe a month or two.. I have lots of Uni work to catch up on, cos I've been Puppy Arcadin' it instead of doing assignments..

I hope you enjoy falling behind with your work or studies while using Puppy Arcade as much as I have while making it.

Cheers.

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search

Edited_time_total
Back to top
View user's profile Send_private_message 
ally


Joined: 19 May 2012
Posts: 835
Location: lincoln

PostPosted: Wed 05 Mar 2014, 13:23    Post_subject:  

mirrored to share the load...

http://archive.org/download/Puppy_Linux_Puppy_Arcade/puppy-arcade-11-k2.6.25.16.iso

readme

http://archive.org/download/Puppy_Linux_Puppy_Arcade/puppy-arcade-11-readme.txt

Smile
Back to top
View user's profile Send_private_message Visit_website 
elbutano13

Joined: 06 Mar 2014
Posts: 2

PostPosted: Thu 06 Mar 2014, 05:09    Post_subject:  

Hi. This is my first post here so, first of all, Thanks and congratulations for all your work.

I've been triying to install this new version since yesterday on my Asus eeepc 900, but alway get stucked on the "Loading Kernell Modules" line.
I've readed a lot of other pages that recommend to install typing the "nopcmcia" and thigs like like that but ii doesnt work either.

I also downloaded the iso file twice but same results. Any idea someone?
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Thu 06 Mar 2014, 05:40    Post_subject:  

I'll do a version with an updated kernel soon ... That should fix it..

But note, the 2.6.25.16 has more gfx drivers available than most other puppy kernels - and they are all in the repo already...

Puppy Arcade k2.6.25.16 currently does not support ext4, but that might change in the newer kernel release.. We will see..

If anyone wants to beat me to it, and they know a Puppy kernel with good support for modern netbooks and laptops, then here is the thread about changing kernels: http://www.murga-linux.com/puppy/viewtopic.php?t=60180 .. (If you choose a 3.x kernel, you will need to edit the initrd.gz file, and a few scripts - search for '2.6' in initrd and other system scripts, and replace it with 3.1 or 3.2 or whatever... )

I do mention on the homepage and in the README that Puppy Arcade is aimed at older hardware ... Users of newer hardware can generally run things like GameEx, RomCollectionBrowser, OpenEmu and so on without problems - and these things are much more 'flashy' than Puppy Arcade (but they don't support as many systems 'out of the box')..

So, make note people:

The k2.6.25.16 is aimed at older hardware!

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
elbutano13

Joined: 06 Mar 2014
Posts: 2

PostPosted: Thu 06 Mar 2014, 05:46    Post_subject:  

Ok, Thank you so much, ill be looking forward to the next releases.
Back to top
View user's profile Send_private_message 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 790
Location: USA

PostPosted: Thu 06 Mar 2014, 16:54    Post_subject:  

At first I thought my hardware was too new for the 2.6.25.16 kernel, but it is just fine. The only thing I am missing is drivers for rt2870-based wifi dongles.
_________________
Desktop: Intel 945PSN Motherboard, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 160GB WD HDD and 500GB WD HDD, Windows 7
I am looking for a working Atari ST that can be bought for less than $100.
Back to top
View user's profile Send_private_message 
doaN

Joined: 07 Mar 2014
Posts: 1

PostPosted: Fri 07 Mar 2014, 04:05    Post_subject:  

Hello and congrats for your work, this look amazing.

What about a Raspberry Pi version ?

Cheers!
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Fri 07 Mar 2014, 08:16    Post_subject:  

Quote:
Hello and congrats for your work, this look amazing.

What about a Raspberry Pi version ?

Cheers!

Thanks..

That would be nice, but I don't have a Pi.. And nowhere near enough time to make it happen..

But "Rom-Loader" is the main program - it is just a collection of shell scripts that rely on basic system tools (cut, sed, grep, etc), and also on gtkdialog .. There is a puppy available for the pi, it should be more than possible to get rom-loader working on it - but compiling all the emulators will be a lot of work..

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Fri 07 Mar 2014, 08:19    Post_subject:  

bark_bark_bark wrote:
At first I thought my hardware was too new for the 2.6.25.16 kernel, but it is just fine. The only thing I am missing is drivers for rt2870-based wifi dongles.

For wifi on puppy, I always use an *old* Belkin USB wifi adapter, it works on all puppies, unlike newer adapters - it's probably me, but I don't have much luck with most other wifi devices/adapters .. But if you mean 3G mobile wifi dongle, then I have no clue how to help... They mostly don't work (well) where I live and so I have no intention of wasting money on one..

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Fri 07 Mar 2014, 09:16    Post_subject:  

I have added two more kernel versions, download links in the main post.
These build should be considered experimental:

    puppy-arcade-11-k2.6.32.59.iso uses the wary 5.5 kernel from 2013
    puppy-arcade-11-k2.6.32-smp.iso uses the wary 5.1.4.1 smp kernel from 2011

These versions will probably need nvidia and ati drivers re-compiled, but there are packages available for these kernel versions in the wary53 repos.. To re-compile them, you will need the latest akita_devx (in the akita repo), and also the kernel sources (should be at ibiblio, or in the quirky/wary repos somewhere).

I also built other versions - all of which had the same problem; audio was not working, alsa could not find a mixer device. The suggested fix is to re-compile alsa and its 'drivers' .. I don't really know much about alsa at all..

I will upload a k3.2.13 test version, which *does not* have audio.. Anyone who knows how to fix it can do so, and post here - I will upload a working k3.2.13 after that..

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 790
Location: USA

PostPosted: Fri 07 Mar 2014, 10:20    Post_subject:  

sc0ttman wrote:
bark_bark_bark wrote:
At first I thought my hardware was too new for the 2.6.25.16 kernel, but it is just fine. The only thing I am missing is drivers for rt2870-based wifi dongles.

For wifi on puppy, I always use an *old* Belkin USB wifi adapter, it works on all puppies, unlike newer adapters - it's probably me, but I don't have much luck with most other wifi devices/adapters .. But if you mean 3G mobile wifi dongle, then I have no clue how to help... They mostly don't work (well) where I live and so I have no intention of wasting money on one..


Isn't there a driver here on the forums?

_________________
Desktop: Intel 945PSN Motherboard, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 160GB WD HDD and 500GB WD HDD, Windows 7
I am looking for a working Atari ST that can be bought for less than $100.
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Fri 07 Mar 2014, 10:59    Post_subject:  

bark_bark_bark wrote:
At first I thought my hardware was too new for the 2.6.25.16 kernel, but it is just fine. The only thing I am missing is drivers for rt2870-based wifi dongles... Isn't there a driver here on the forums?

maybe here Extra drivers for k2.6.25.16

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Fri 07 Mar 2014, 11:05    Post_subject:  

Here is a TEST build of puppy-arcade-11-k3.2.13:

http://akita.scottjarvis.com/puppy-arcade-11-k3.2.13-alpha.iso
(size: 184mb, md5: 506a010e35ed4e4af1732de0ac8ac442)

This one has no sound, ALSA reports no mixer device can be found.

If anyone can fix this, either tell us how, or upload the fixed version online,
and I will add the fixed version to the main post.

The kernel is from Carolina, search the 'Derivatives' thread to find it.

To compile drivers, you will need the akita_devx sfs file (in the akita repo)
and also the kernel sources sfs file (for k3.2.13, see Carolina thread..)

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0977s ][ Queries: 12 (0.0070s) ][ GZIP on ]