Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 14:39
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
X-precise-2.4 Final
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 18 of 24 [348 Posts]   Goto page: Previous 1, 2, 3, ..., 16, 17, 18, 19, 20, 21, 22, 23, 24 Next
Author Message
Geoffrey


Joined: 30 May 2010
Posts: 1516
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Fri 14 Feb 2014, 06:32    Post subject:  

Moat wrote:
Geoffrey wrote:
Here is Whisker, it's a xfce panel plugin that is a replacement applications menu.


A big thanks for this one, Geoffrey! Very Happy

Although I'm on Carolina 1.1, your Whisker menu .pet installed and is working, seemingly, perfectly. (Aside from the "XPrecise" title that I'm sure I'll be able to change via a config file somewhere)

I can't believe it, actually - I just tonight discovered Whisker menu while reading a Distrowatch-linked review of MakuluLinux Xfce. Saw this super-nice menu in the screenshot, did a little Googling to see what Whisker's all about (easily tweakable, Favorites and Recently Used entries... and a handy search feature! Smile ), and thought "dang... this would be a perfect addition to Carolina". Next visit was to here at the Puppy forums, and BAM! - here it is!! Shocked Very Happy

Although there's absolutely nothing wrong with Xfce's simple, functional LXDE/JWM-like menu system, I always thought it was just a bit behind the "higher-class" functionality and look of the rest of Xfce, in general. Whisker menu just sets it off perfectly. Good stuff!!

Bob


Thanks Bob, I have had it for a week or so, first in Carolina to try it out, it did need a few changes made to make it compatible,

it's certainly more configurable than what we have at present.

As for the " XPrecise " title, that is hard coded with no way to change it, but I do have one for carolina,

I'll post that at some point when I sort out what I'm doing in regard to the favorites.

You'll find that the screen lock won't work in carolina with the one I posted, all you need do though is in preferences set it to run " Xlock ".

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1516
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Fri 14 Feb 2014, 17:20    Post subject:  

Electrum

Here are the packages for Electrum bitcoin client, this is a Python+Qt application.

You may not need all the packages if you have previously installed any of the Qt apps.



87K ecdsa-0.10.linux-i686.pet

714K Electrum-1.9.7.linux-i686.pet

723K libdb5.1_5.1.25-11build1_i386.pet

7.9M libicu48_4.8.1.1-3ubuntu0.1_i386.pet

28K mime-support_3.51-1ubuntu1_all.pet

14K slowaes-0.1a1.linux-i686.pet

2.6M python2.7_2.7.3-0ubuntu3.4_i386.pet

1.7M python2.7-minimal_2.7.3-0ubuntu3.4_i386.pet

48K python-cairo_1.8.8-1ubuntu3_i386.pet

224K python-gobject-2_2.28.6-10ubuntu1_i386.pet

819K python-gtk2_2.24.0-3_i386.pet

28K python-minimal_2.7.3-0ubuntu2.2_i386.pet

2.9M python-qt4_4.9.1-2ubuntu1_i386.pet

69K python-sip_4.13.2-1_i386.pet

31K python-xdg_0.19-3ubuntu2_all.pet

3.0M libqtcore4_4.8.1-0ubuntu4.6_i386.pet

5.1M libqtgui4_4.8.1-0ubuntu4.6_i386.pet

728K libqt4-network_4.8.1-0ubuntu4.6_i386.pet

8.6M libqtwebkit4_2.2.1-1ubuntu4_i386.pet

35M total



Bleachbit

" BleachBit quickly frees disk space and tirelessly guards your privacy. Free cache, delete cookies,
clear Internet history, shred temporary files, delete logs, and discard junk you didn't know was there.
"



90K bleachbit-1.0.pet

261K bleachbit_NLS-1.0.pet (OPTIONAL)

723K libdb5.1_5.1.25-11build1_i386.pet

28K mime-support_3.51-1ubuntu1_all.pet

2.6M python2.7_2.7.3-0ubuntu3.4_i386.pet

1.7M python2.7-minimal_2.7.3-0ubuntu3.4_i386.pet

48K python-cairo_1.8.8-1ubuntu3_i386.pet

224K python-gobject-2_2.28.6-10ubuntu1_i386.pet

819K python-gtk2_2.24.0-3_i386.pet

28K python-minimal_2.7.3-0ubuntu2.2_i386.pet

6.4M total



Comix

" Comix is a user-friendly, customizable image viewer. It is specifically designed to handle comic books, but also serves as a generic viewer.
It reads images in ZIP, RAR or tar archives (also gzip or bzip2 compressed) as well as plain image files. It is written in Python and uses GTK+ through the PyGTK bindings.
"



290K Comix-4.0.4.pet

723K libdb5.1_5.1.25-11build1_i386.pet

28K mime-support_3.51-1ubuntu1_all.pet

2.6M python2.7_2.7.3-0ubuntu3.4_i386.pet

1.7M python2.7-minimal_2.7.3-0ubuntu3.4_i386.pet

48K python-cairo_1.8.8-1ubuntu3_i386.pet

224K python-gobject-2_2.28.6-10ubuntu1_i386.pet

819K python-gtk2_2.24.0-3_i386.pet

283K python-imaging_1.1.7-4_i386.pet

28K python-minimal_2.7.3-0ubuntu2.2_i386.pet

680K Sample 2011cbr.cbr (OPTIONAL SAMPLE COMIC FILE)

680K Sample 2011cbz.cbz (OPTIONAL SAMPLE COMIC FILE)

7.9M total

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1516
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Sat 15 Feb 2014, 01:02    Post subject:  

Edit: ̶I̶ ̶f̶o̶u̶n̶d̶ ̶t̶h̶i̶s̶ ̶t̶o̶ ̶n̶o̶t̶ ̶l̶e̶t̶ ̶m̶e̶ ̶c̶h̶a̶n̶g̶e̶ ̶i̶c̶o̶n̶ ̶t̶h̶e̶m̶e̶s̶ ̶a̶n̶d̶ ̶r̶e̶s̶t̶a̶r̶t̶x̶ ̶ ̶i̶s̶ ̶n̶e̶e̶d̶e̶d̶ ̶w̶h̶e̶n̶ ̶c̶h̶a̶n̶g̶i̶n̶g̶ ̶t̶h̶e̶m̶e̶s̶,̶ ̶ ̶l̶o̶o̶k̶s̶ ̶l̶i̶k̶e̶ ̶i̶t̶'̶s̶ ̶s̶o̶m̶e̶t̶h̶i̶n̶g̶ ̶t̶o̶ ̶w̶r̶e̶s̶t̶l̶e̶ ̶w̶i̶t̶h̶,̶ ̶m̶a̶y̶ ̶n̶o̶t̶ ̶b̶e̶ ̶w̶o̶r̶t̶h̶ ̶u̶s̶i̶n̶g̶ ̶b̶u̶t̶ ̶I̶'̶l̶l̶ ̶l̶e̶a̶v̶e̶ ̶i̶t̶ ̶p̶o̶s̶t̶e̶d̶.̶ ̶
Edit2 I recompiled the theme turning off some features that were causing problems, all seems good now.
Create strikethrough text HERE

Oxygen-Gtk Theme

Contains the GTK style and Oxygen theme engine.

" Oxygen-Gtk is a port of the default KDE widget theme (Oxygen), to gtk. "


1.2M oxygen-gtk2-1.4.3-i486.pet

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE

Last edited by Geoffrey on Sat 15 Feb 2014, 19:36; edited 2 times in total
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1516
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Sat 15 Feb 2014, 01:17    Post subject:  

Qt configuration

Set the Qt applications to use GTK+ theme settings.


127K qt4-qtconfig_4.8.1-0ubuntu4.5_i386.pet

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
can8v

Joined: 15 Jul 2006
Posts: 584
Location: Yuba City, CA

PostPosted: Sat 15 Feb 2014, 02:58    Post subject:  

rg66 wrote:

I've had no luck finding Handbrake, one that works anyway. I tried a 0.99 deb but had lots of missing libs.

rg,
can you please send me a link to the 0.9.9 deb of handbrake that you tried. I would like to see if I can hunt down the missing libs. I have a feeling I have already hunted down most of them for Acid Rip, which I got out of the Ubuntu repository. Also the ppm has oodles of gstreamer libs and plugins, but no gstreamer, is that right?
-can8v
Back to top
View user's profile Send private message Visit poster's website 
can8v

Joined: 15 Jul 2006
Posts: 584
Location: Yuba City, CA

PostPosted: Sat 15 Feb 2014, 02:59    Post subject:  

rg66 wrote:

I've had no luck finding Handbrake, one that works anyway. I tried a 0.99 deb but had lots of missing libs.

rg,
can you please send me a link to the 0.9.9 deb of handbrake that you tried. I would like to see if I can hunt down the missing libs. I have a feeling I have already hunted down most of them for Acid Rip, which I got out of the Ubuntu repository. Also the ppm has oodles of gstreamer libs and plugins, but no gstreamer, is that right?
-can8v
Back to top
View user's profile Send private message Visit poster's website 
rg66


Joined: 23 Jul 2012
Posts: 622
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Sat 15 Feb 2014, 03:51    Post subject:  

@can8v

This is the link to the deb I found, ppm will show what's missing. The dl link is near the bottom of the page.

http://www.deb-multimedia.org/dists/unstable/main/binary-i386/package/handbrake-gtk

_________________
X-slacko-2.3 - X-precise-2.4 - Carolite-1.2 - Carolina-1.2
X-slacko new repo
X-precise/X-slacko
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1516
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Sat 15 Feb 2014, 20:43    Post subject:  

Xfce Theme Manager

Mix and match, create you own theme mixing icons themes, wallpapers, gtk styles and borders, cursors, fonts and adjust panel size, saved to a custom theme.



130K Xfce-Theme-Manager-0.3.4.pet




Xfce Composite Editor

Adjust transparency and shadows, used in conjunction with Xfce Theme Manager.



8.8K xfce4_composite_editor-0.2.0.pet

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1516
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Sun 16 Feb 2014, 06:19    Post subject:  

Hotshots 2.1.0

Latest release, HotShots is an application for capturing screens and saving them in a variety of image formats

as well as adding annotations and graphical data (arrows, lines, texts, ...).

Version 2.1.0
* Features:
- Speed up launch time
- Add option for mouse cursor in snapshot
- Add User defined action on click/double-click tray icon
- Editor: add group alignment (vertical/horizontal)
- Editor: add rescale background image panel
- Change Windows grabbing code on windows platform
* Bugs
- Editor: correct invalid save/restore position for text item




HotShots-2.1.0.pet

libqxt-a5a0614e4cc4.pet

libqtcore4_4.8.1-0ubuntu4.6_i386.pet

libqtgui4_4.8.1-0ubuntu4.6_i386.pet

libqt4-network_4.8.1-0ubuntu4.6_i386.pet

libqt4-xml_4.8.1-0ubuntu4.6_i386.pet

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1516
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Sun 16 Feb 2014, 18:21    Post subject:  

Yad 0.26.0

Compiled in XPrecise.

" (yet another dialog) is a fork of Zenity with many improvements, such as custom buttons, additional dialogs, pop-up menu in notification icon and more. "

102K yad-0.26.0-i486.pet

9.7K yad_DOC-0.26.0-i486.pet

59K yad_NLS-0.26.0-i486.pet

170K total

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
laika


Joined: 15 Jan 2007
Posts: 115

PostPosted: Tue 18 Feb 2014, 17:27    Post subject: Nice, Nice, Nice
Subject description: enthusiastic rave for X-precise
 

Oh my, this may be the pup that I've been waiting for. Booted it for the first time 15 minutes ago, put the panel on top, changed resolution, and somehow got online tethered to my phone after copying Klink over and installing it. (Klink is a .deb from the Android/Google app store that gets me online through my smartphone.)

Beautiful, snappy, uncluttered... haven't found anything to not like about X-precise-2.2 so far. I may change out Geany in favor of Leafpad, but that's nothing.

Thanks for making this pup available!
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1516
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Tue 18 Feb 2014, 19:40    Post subject:  

A few more Qt applications, remember once the Qt framework packages are installed there is no need to download them again,
then when adding applications they will be of a small size, most being a little over 1mb or less.




Beediff

" BeeDiff (beediff) is a program with graphical user interface (GUI) for comparing and merging files.
User have the possibilty to work with two text files, each in separate panel. Panels are side by side.
All differences of both texts are highlighted in colors.
Operation buttons (such as merge and remove) are located directly inside the compared texts in appropriate positions.
The program is user-friendly, very simple, and efficient.
"




122K beediff-1.9.pet

3.0M libqtcore4_4.8.1-0ubuntu4.6_i386.pet

5.1M libqtgui4_4.8.1-0ubuntu4.6_i386.pet

8.2M total




Focuswriter

" Focus Writer is a lightweight basic text writer, designed to be free of the distractions of complex word processing applications. "



1.1M focuswriter-1.4.5.pet

3.0M libqtcore4_4.8.1-0ubuntu4.6_i386.pet

5.1M libqtgui4_4.8.1-0ubuntu4.6_i386.pet

728K libqt4-network_4.8.1-0ubuntu4.6_i386.pet

223K libqt4-dbus_4.8.1-0ubuntu4.6_i386.pet

112K libqt4-xml_4.8.1-0ubuntu4.6_i386.pet

11M total




Jade


" Jade is a cross-platform diagram editor built on the Qt framework. It is similar in scope to Microsoft Visio or Gnome dia. It is released under the GNU General Public License version 3.0 "

Quote:

Features

Draw lines, rectangles, circles, text and more
Export diagrams to PNG or SVG
Print to printer or directly to PDF
Items library includes simple chart, electric, and logic elements




425K jade-1.0.2.pet

3.0M libqtcore4_4.8.1-0ubuntu4.6_i386.pet

5.1M libqtgui4_4.8.1-0ubuntu4.6_i386.pet

173K libqt4-svg_4.8.1-0ubuntu4.6_i386.pet

8.6M total




FileSynq

" FileSynq is an easy to use, small Qt program specially designed to help you synchronize 2 folders. "

Quote:

Features

Analyze and syncronize 2 Folders
Save and open projects
Shows current progress
Is able to exclude filetypes
Open source (GPL)
Tested on Linux




73K FileSynq-0.1.pet

3.0M libqtcore4_4.8.1-0ubuntu4.6_i386.pet

5.1M libqtgui4_4.8.1-0ubuntu4.6_i386.pet

112K libqt4-xml_4.8.1-0ubuntu4.6_i386.pet

8.2M total

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE

Last edited by Geoffrey on Wed 26 Mar 2014, 02:31; edited 1 time in total
Back to top
View user's profile Send private message 
spearmint

Joined: 19 Feb 2014
Posts: 3

PostPosted: Wed 19 Feb 2014, 07:38    Post subject: Thanks for X-precise  

Hi!
I'm a total linux newbie and I've been searching for a light distro to install on my 10y old laptop. This laptop has only 512mb of RAM.
I've tried Xubuntu, Lubuntu,old Mint and Ubuntu versions,but none worked. I've discovered Puppy and it worked great. The main issue is that the interface looked like dog poo from 1995. I wasted hours trying to put it better. Yesterday I discovered X-Precise and is just the way I wanted Puppy Linux to be out of the box. I didn't had to change anything in the interface, theme or icons. Is just awesome.
I'll now be testing X-Precise for a few days running it from the CD, but if all goes well I may just install it on the HD.

Memory in use right now (only with Firefox open) : 168Mb
CPU usage. 50%
I may have to try Opera to see if it is lighter.

Thank you for all the hard work releasing X-Precise.
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 231

PostPosted: Wed 19 Feb 2014, 08:53    Post subject: unable to contact settings server  

Hi, I did a frugal install of x-precise 2.2 NON PAE on HDD sda9 in /puppy-x-precise on an old Athlon 32-bit CPU with 2GB RAM, and got an issue (below) which I'm unable to figure out, can someone offer some advice, please?

On this machine I can network boot Precise 5.7.1 just fine. But frugal booting x-precise 2.2 NON-PAE has an issue; it goes through puppy's first time setup wizard then it displays a window that says "unable to contact settings server" and X drops to the console command line. So does restarting X with xwin.
I did go through Xorgconfig and reselected the ATI driver and rebooted. Again x-precise went through the first-time setup wizard, then dropped to the console command line with the same message "unable to contact settings server".

Thanks in advance for any help.
Back to top
View user's profile Send private message 
rg66


Joined: 23 Jul 2012
Posts: 622
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Wed 19 Feb 2014, 10:09    Post subject:  

@ spearmint

Glad you like it, 50% CPU seems quite high. With firefox running I'm only at 10% although I'm using a dual core at 3Ghz and 2GB RAM.

@ step

Unfortunately, X-precise and X-slacko do not work with P3 or AMD Athlon processors. I think it's a d-bus issue but can't seem to find the problem and have been unable to fix it. They need at least a P4, sorry.

_________________
X-slacko-2.3 - X-precise-2.4 - Carolite-1.2 - Carolina-1.2
X-slacko new repo
X-precise/X-slacko
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 18 of 24 [348 Posts]   Goto page: Previous 1, 2, 3, ..., 16, 17, 18, 19, 20, 21, 22, 23, 24 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1266s ][ Queries: 13 (0.0139s) ][ GZIP on ]