Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 16:14
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects » Localization Project
official (momanager) language packs
Moderators: Lobster, MU, raffy
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 11 of 14 Posts_count   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12, 13, 14 Next
Author Message
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Sun 05 Jan 2014, 08:46    Post_subject:  

Bert wrote:
Are you talking about these gettext-tools?

I was talking about gettext-tools in slacko's package manager.
Don't know whether it is the same or not. Embarassed

Bon appétit Laughing Laughing Laughing
Back to top
View user's profile Send_private_message 
mariojrmatos


Joined: 03 Jan 2014
Posts: 7
Location: OFC: PT and NL | DMA: Worldwide

PostPosted: Tue 21 Jan 2014, 14:01    Post_subject:  MoManager
Sub_title: Thank you!
 

Great work, L18L.

Thanks to Barry, you, Bert and vicmz I was able to release the first pt_PT translation for Puppy. (see why).

I can't express my gratitude... Wink

__________________
Puppy Linux em português de Portugal (pt_PT) | Puppy Linux em português do Brasil (pt_BR: brevemente)
Back to top
View user's profile Send_private_message Visit_website 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Thu 23 Jan 2014, 08:06    Post_subject: Re: MoManager
Sub_title: Thank you!
 

mariojrmatos wrote:
I can't express my gratitude...

Yes you can
You have done it right now
Thank you and welcome.

Very Happy
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3346
Location: Ontario

PostPosted: Tue 18 Feb 2014, 16:38    Post_subject:  

I was using momanager in Quirky tahr , it worked well however I realized
that the .desktop file is not appropriate for language packs.
It requires translations of the name so that non-English speakers
can understand the function of program.
Barry Kauler needs to be notified of this problem.

Code:

[Desktop Entry]
Encoding=UTF-8
Name=MoManager create non-English Puppy
Name[fr]=MoManager - pour traduire
Name[de]=MoManager - Übersetzung kontrollieren
Icon=chooselocale.xpm
Comment=MoManager create non-English translations
Exec=momanager
Terminal=false
Type=Application
Categories=X-Utility-development
GenericName=MoManager

Back to top
View user's profile Send_private_message 
Botanic


Joined: 05 Sep 2007
Posts: 241
Location: Toulouse, France

PostPosted: Sat 22 Feb 2014, 06:09    Post_subject: FR language pack issue  

Hello guys,
I just installed Slacko with a full install, then downloaded the lang_pack_fr and loaded it, but nothing happened.
I tried launching Momanager from the console and it complains that PUPMODE = 3 (full install) thus aborting.

Maybe the correct way was to install it when I ran it the first time, before doing the full install? Is there a way to do it now? (I just spent the all day yesterday to set it up!! ^^)

_________________
Puppy 2.16 on HP Vectra VL400 - PIII 800 MHz - 320M RAM
Wary on Acer Aspire X3200 - Phenom X4 - 2.2GHz - 4G RAM
Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Sat 22 Feb 2014, 09:39    Post_subject: Re: FR language pack issue  

Botanic wrote:
I just installed Slacko with a full install, then downloaded the lang_pack_fr and loaded it, but nothing happened.
What did you expect to happen after restarting x server?

Botanic wrote:
I tried launching Momanager from the console and it complains that PUPMODE = 3 (full install) thus aborting.
... Is there a way to do it now? (I just spent the all day yesterday to set it up!! ^^)

Does your /usr/sbin/momanager contain this line:
Code:
#131219 enable quirky6.0: no check on pupmode
?
Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Sat 22 Feb 2014, 10:06    Post_subject: MoManager .desktop  

don570,
my translation which is used in langpack_de is

MoManager bringt Puppy deutsch bei

and this means that
MoManager teaches Puppy German

I cannot see any problem with this.
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3346
Location: Ontario

PostPosted: Sat 22 Feb 2014, 16:21    Post_subject:  

The version that Barry Kauler uses (in Woof) has a desktop that is pure
English. So he should be warned.


The people who make language packs have made changes to their
desktop files obviously.
_________________________________________
Back to top
View user's profile Send_private_message 
vicmz


Joined: 15 Jan 2012
Posts: 1117

PostPosted: Sat 22 Feb 2014, 17:42    Post_subject:  

It's OK to have a translated .desktop file to let users know what's about, maybe it's just not in Barry Kauler's plans. When he said Momanager is English-only, he was serious. Why would a translator need translations? A Puppy translator must have an excellent knowledge of English and how Puppy Linux works.
_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send_private_message 
vicmz


Joined: 15 Jan 2012
Posts: 1117

PostPosted: Sat 22 Feb 2014, 18:55    Post_subject:  

Slacko 5.6.5.6 has an old version of Momanager. I can't create or update translation files, I can't run newer versions of Momanager either. It says a library is missing, when I install that library it says I need libraries.
Screenshot_2014-02-22_194803.png
 Description   
 Filesize   142.73 KB
 Viewed   201 Time(s)

Screenshot_2014-02-22_194803.png

Screenshot_2014-02-22_194854.png
 Description   
 Filesize   12.82 KB
 Viewed   192 Time(s)

Screenshot_2014-02-22_194854.png


_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Sun 23 Feb 2014, 05:36    Post_subject:  

don570 wrote:
The people who make language packs have made changes to their desktop files obviously.

Yes, and the people who use language packs are seeing the translations of their installed language packs only.
Who does not have French langpack_fr installed is not seeing French translation of "MoManager create non-English Puppy ".
Who does not have German langpack_de installed is not seeing German translation of "MoManager create non-English Puppy ".

I do not thank that Barry is using MoManager
He has coded it.
He has coded it in a genious way.
And we users (of MoMager) extend it, that's it. That's the way how free software works.
Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Sun 23 Feb 2014, 06:45    Post_subject:  

vicmz wrote:
Slacko 5.6.5.6 has an old version of Momanager. I can't create or update translation files, I can't run newer versions of Momanager either. It says a library is missing, when I install that library it says I need libraries.

Trying to reproduce your observation
I am running slack05.6.5.6 pfix=ram now
devx_slacko_5.6.5.6.sfs loaded on-the-fly

I did choose 1st entry of "Scripts that do not have a mo file"
and rc.shutdown.po was opened in geany.
msgfmt works:
Code:
# msgfmt
msgfmt: no input file given
Try `msgfmt --help' for more information.
#

Thus builtin MoManager (official from #130807) works for me.

Which one of the unofficial MoManagers are you trying to use?
Did you load devx_slacko_5.6.5.6?

I am planning to post another version of MoManager soon (found a bug in my implementation "Actual" vs "Check needed")

Thanks for posting.
Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Sun 23 Feb 2014, 14:01    Post_subject: MoManager
Sub_title: new version 20140223
 

What's new
- no more special handling for Quirky
- bug fixed with "up-to-date" and "check-needed"


The picture is showing all is up-to-date

Note,
if all #~ in po file are removed, ex:
Code:
#: ui_Classic.sh:34 ui_Ziggy.sh:65
msgid "Quirky Package Manager"
msgstr "Quirky Paketmanager"

#~ msgid "Puppy Package Manager"
#~ msgstr "Puppy Paketmanager"
...and it will be good for Puppy and Quirky


Please give some feedback before I am going to submit it to woof.


EDIT
download recent MoManager from http://www.murga-linux.com/puppy/viewtopic.php?t=81259&start=169 which can find fuzzy translations
_______________________________________________
momanager_quirky_up-to-date.png
 Description   
 Filesize   59.59 KB
 Viewed   182 Time(s)

momanager_quirky_up-to-date.png

momanager-20140223.pet
Description 
pet

 Download 
Filename  momanager-20140223.pet 
Filesize  35.77 KB 
Downloaded  135 Time(s) 

Edited_time_total
Back to top
View user's profile Send_private_message 
vicmz


Joined: 15 Jan 2012
Posts: 1117

PostPosted: Sun 23 Feb 2014, 15:34    Post_subject:  

L18L wrote:

Trying to reproduce your observation
I am running slack05.6.5.6 pfix=ram now
devx_slacko_5.6.5.6.sfs loaded on-the-fly

I did choose 1st entry of "Scripts that do not have a mo file"
and rc.shutdown.po was opened in geany.
msgfmt works:
Code:
# msgfmt
msgfmt: no input file given
Try `msgfmt --help' for more information.
#

Thus builtin MoManager (official from #130807) works for me.

Which one of the unofficial MoManagers are you trying to use?
Did you load devx_slacko_5.6.5.6?


In RAM mode and devx loaded buitin Momanager works, but the same with the langpack installed gives errors trying to update strings. For example, I chose quicksetup from the list of existing translations, clicked 'edit' and got what you can see in the screenshots above. This means a new langpack would have to be created from the beginning, not a practical solution.

The unofficial FFMM versions I tried (to be able to use POedit and make translations faster, builtin Momanager does not allow these) were 20131110 and 20140104, they load but the window never shows up, only a window button on the taskbar is visible.

_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Sun 23 Feb 2014, 16:51    Post_subject:  

vicmz wrote:
The unofficial FFMM versions I tried (to be able to use POedit and make translations faster, builtin Momanager does not allow these) were 20131110 and 20140104, they load but the window never shows up, only a window button on the taskbar is visible.
That was because slacko's gtkdialog does not display with --geometry parameter.

Anyhow please try recent momanager-20140223 that is really a "release candidate" for woof-CE.

Thank you

EDIT

vicmz,
I am now in slacko5.5.6 using momanager-140223
Nothing special with my quickset.po
(maybe there is something faulty in your langpack_es?)
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 11 of 14 Posts_count   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12, 13, 14 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects » Localization Project
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0995s ][ Queries: 13 (0.0082s) ][ GZIP on ]