Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 11:04
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Lucid Puppy 5.2.8 - Updated ISO Version 005 - APR 05 2012
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 185 of 190 Posts_count   Goto page: Previous 1, 2, 3, ..., 183, 184, 185, 186, 187, 188, 189, 190 Next
Author Message
musher0


Joined: 04 Jan 2009
Posts: 4256
Location: Gatineau (Qc), Canada

PostPosted: Sun 05 Jan 2014, 18:53    Post_subject:  

rerwin wrote:
mikeb,
Well, lupu is ancient as far as some of its applications go. But I am attempting to upgrade the pieces the folks in this thread and elsewhere call to my attention. And I have made several small internal improvements that I plan eventually to provide to the woof-CE project. Barry's comment seems triggered by an expectation that lupu is part of the evolution of puppy that he has provided.

Lupu is frozen in time except for selected upgrades, often plucked from recent puppy developments. I maintain it for those of us happy to stick with it because is does not evolve, but serves our needs over the years.

(...)

Richard


Hello Richard, and all.

"Frozen in time"... might not be so bad... Considering that the older Ubuntu Precise
will be supported until April 2017 and that the newer Ubuntu Raring's support ends
this month (Jan. 2014)... whoever chooses one of your updated Lucid Puppies --
even now -- might be making a good choice, even if all the programs are not
absolutely up to date.

Just a thought. BFN.

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
rerwin


Joined: 24 Aug 2005
Posts: 1529
Location: Maine, USA

PostPosted: Tue 07 Jan 2014, 00:09    Post_subject: Lucid Pup 5.2.8.6 update 20140106  

I have partially uploaded the set of lucid pups 5.2.8.6, 20140106. So far, the set has lupu, lupumin, lupuplus, lupulibre and lupusuper2 (including its nvidia drivers). The details are in the history posting:
http://www.murga-linux.com/puppy/viewtopic.php?p=726108#726108

The download site is:
http://www.mediafire.com/folder/dc28t2rkua3kw/Disk_Images-5.2.8.6

The new nvidia graphics drivers are reported here:
http://www.murga-linux.com/puppy/posting.php?p=747734&mode=topicreview&postorder=DESC#747734

The remainder of the versions will be uploaded as I get the time to build them. My intent is that this will be the final 5.2.8.6 update for awhile, other than adding updates for libreoffice (Feb. & Apr.). But please report any new problems with 5.2.8.6.

Please try the lupusuper2 version; I propose that users migrate to it because it includes support for xz compression, which allows click-mounting of- and access to SFS files produced by recent puppies. Particularly, report anything that no longer works in that version, as a consequence of the kernel upgrade. If there is no downside, we could promote lupusuper2 as the primary lucid pup.

Thank you for all of your help in getting lupu to this point.
Richard

EDIT: Uploaded lupusuper4. (21040106)

EDIT 1/9/2014: Uploaded corrected version of lupusuper2, as 20140109. The original (20140106) contains the wrong files in /etc/modules, DOTconfig and firmware.dep. The latter prevents use of the "all-firmware" "tarballs", although the impact is less than normal for other puppies; In the lupusupers, almost all of the actual firmware resides in /lib/firmware, so is unaffected by firmware.dep and the tarballs (and directory equivalents).

Since I needed to bump the version date, I added the 3 packages shinobar posted in the "5.2.8.6" thread, for defaults-chooser, ffconvert and grub4dos. (Lupusuper4 has the same problem.) If lupusuper2 is to be the long-term primary offering, I want it to be perfect.

EDIT 1/11/2014: Re-uploaded lupusuper4, to correct DOTconfig, firmware.dep and DISTRO_SPECS. (21040109)

EDIT 1/13/2014: Uploaded lupusuper1 and lupusuper3 20140109.

EDIT 1/14/2014: Uploaded lupu3hd 20140109, completing the set.
Richard

Edited_times_total
Back to top
View user's profile Send_private_message 
gcmartin

Joined: 14 Oct 2005
Posts: 4368
Location: Earth

PostPosted: Tue 07 Jan 2014, 04:05    Post_subject: If it last for longer than xxx hours, seek medical help  

Erroneous post.
_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send_private_message 
bigpup


Joined: 11 Oct 2009
Posts: 5237
Location: Charleston S.C. USA

PostPosted: Tue 07 Jan 2014, 04:44    Post_subject:  

Lupusuper2
manual frugal install on USB flash drive.
Save to entire USB drive not a save file.

Initial personalize settings
All setup changes worked.

Wireless setup with SNS OK.
This was a problem in other versions of Lucid.

Used the included Nvidia driver sfs to get working Nvidia graphics driver.
Loaded it with the SFS-Load-On-The Fly.
Used Quickpet->Drivers->click here to test your graphics card to identify which Nvidia driver SFS file to load.

The Nvidia driver SFS files are ok for someone that knows how to use them, but the Quickpet->drivers->Nvidia wants to get driver from the repository.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send_private_message 
rerwin


Joined: 24 Aug 2005
Posts: 1529
Location: Maine, USA

PostPosted: Fri 10 Jan 2014, 00:02    Post_subject: lupusuper2 reuploaded  

As I detail in my edit to my previous posting, I have corrected and updated the lupusuper2 ISO file.
http://www.mediafire.com/download/nsks62pj51g5qyy/lupusuper2-5.2.8.6-k3.2.48-20140109.iso

I took bigpup's advice and omitted the additional development and nvidia SFS files, to keep the ISO file small. But I also uploaded the development packages, devx and kernel source for lupusuper2, to join the nvidia files as "Supplemental SFS Packages.
Richard

Edited_time_total
Back to top
View user's profile Send_private_message 
EdD

Joined: 09 Dec 2013
Posts: 166
Location: Southside Virginia

PostPosted: Sat 11 Jan 2014, 12:40    Post_subject:  

Here's some input from a total noob:

I was running Lucid 5.2.8.6 on a Dell optiplex 780, Intel Core 2 Duo CPU E7500 @ 2.93GHz, 4g RAM, w/ATI RV620 LE Radeon HD 3450.

There being no compatible ati driver, it was using vesa. I got & installed (full hd install) the sulu from rerwin's posting , the iso dated 1/6/14, which also selected vesa for me on 1st boot. After downloading and burning the updated iso of 1/09/14, I installed it to a 16g sandisk cruiser flash drive. On rebooting to bring up the flash drive, I got a black screen total crash before X could start.

So, I powered off, and rebooted the hard drive and got a failed X start with a multi-colored trash screen. After another reboot, got vesa again in X and ran xorgwizard to select the first ati driver from the "choose" list in wizard, which was listed as simply ati in the wizard. That one will drive a maximum resolution of 1280x 1024 @60.

A problem for this card is that the suggested driver in the quickpet downloads from ibiblio, which takes over 30 minutes, then needs the configuration pet which comes with missing library linglut.so.3. finding and downloading the library is a chore, but worse, when exiting to prompt, as directed by the .pet dialog and running aticonfig --initial the return states no such command supported.

Not wanting to turn this into a beginner's help thread here, I'll post to the proper subforum in a new topic with ati fglrx in the title.

Using upup raring on the Dell right now to post this. Just some input from a noob user on the ati/radeon drivers in the sulu current version.

Thanks,
Ed
Back to top
View user's profile Send_private_message 
rerwin


Joined: 24 Aug 2005
Posts: 1529
Location: Maine, USA

PostPosted: Sat 11 Jan 2014, 16:17    Post_subject:  

Quote:
There being no compatible ati driver, it was using vesa. I got & installed (full hd install) the sulu from rerwin's posting , the iso dated 1/6/14, which also selected vesa for me on 1st boot. After downloading and burning the updated iso of 1/09/14, I installed it to a 16g sandisk cruiser flash drive. On rebooting to bring up the flash drive, I got a black screen total crash before X could start.
The first iso you tried was probably "lupu" while the second has to be lupusuper2, which uses a different kernel so requires its own version of the video driver.

The repo containing the ati video driver does not contain the version for the "sulu2" kernel, k3.2.48. The drivers listed by QuickPet are for the regular "lupus" and lupu3hd. I have yet to learn how to build the ATI driver. But it is time I get to it.

For now, please stick with the vesa driver. I have an nVidia card in my development PC that does not work with the default "nv" driver. Every time I boot without a pupsave file (pfix=ram or equivalent), I get a black screen that gradually lightens a little bit. Disturbing to see. I then press ctrl-alt-bksp and enter "xorgwizard" (w/o quotes) to select <vesa> and my monitor resolution. (Apparently, LCD monitors do not report their information for the wizard.) I would hope that technique would work for your ATI video card.

The problem with the driver repo is that I cannot maintain it and rely on playdayz (originator of lucid pup) to update it. Future drivers there will contain the kernel version they support. It is crucial to select only drivers for the kernel your version of lupu/sulu contains, which is included in the names of the lupusupers.
Richard

UPDATE: lupusuper4 has been corrected and uploaded. The checksum for lupusuper2 has been corrected.
Back to top
View user's profile Send_private_message 
EdD

Joined: 09 Dec 2013
Posts: 166
Location: Southside Virginia

PostPosted: Sat 11 Jan 2014, 17:50    Post_subject:  

rerwin wrote:
Quote:
There being no compatible ati driver, it was using vesa. I got & installed (full hd install) the sulu from rerwin's posting , the iso dated 1/6/14, which also selected vesa for me on 1st boot. After downloading and burning the updated iso of 1/09/14, I installed it to a 16g sandisk cruiser flash drive. On rebooting to bring up the flash drive, I got a black screen total crash before X could start.
The first iso you tried was probably "lupu" while the second has to be lupusuper2, which uses a different kernel so requires its own version of the video driver.

The repo containing the ati video driver does not contain the version for the "sulu2" kernel, k3.2.48. The drivers listed by QuickPet are for the regular "lupus" and lupu3hd. I have yet to learn how to build the ATI driver. But it is time I get to it.

For now, please stick with the vesa driver. I have an nVidia card in my development PC that does not work with the default "nv" driver. Every time I boot without a pupsave file (pfix=ram or equivalent), I get a black screen that gradually lightens a little bit. Disturbing to see. I then press ctrl-alt-bksp and enter "xorgwizard" (w/o quotes) to select <vesa> and my monitor resolution. (Apparently, LCD monitors do not report their information for the wizard.) I would hope that technique would work for your ATI video card.

The problem with the driver repo is that I cannot maintain it and rely on playdayz (originator of lucid pup) to update it. Future drivers there will contain the kernel version they support. It is crucial to select only drivers for the kernel your version of lupu/sulu contains, which is included in the names of the lupusupers.
Richard

UPDATE: lupusuper4 has been corrected and uploaded. The checksum for lupusuper2 has been corrected.


Yes, you're right. the first I was using was a lupu, using the vesa default. SMplayer didn't seem to like vesa and crashed, taking gnome Mplayer along (or maybe vice-versa), so I installed sulu2 dated 1/06/14. My genius plan was to install the driver and see if SMplayer worked better. I now see that vesa was used as a default for a reason. Gotta control my genius impulse. Wink

Thanks for the explanation about the ati driver. I have another ati card, which I'll try to see if one of the included ati drivers supports it. If that fails, what I think I should do is a new, clean install of the latest super2 or the super4 and use vesa, as you suggest.. ATI is new to me. All the machines I used before now had Nvidia.

I hadn't been using a save file on the full installs because I didn't want the partition mounted since I was changing versions fairly often. The save file will save me some trouble until I get a driver or a card that solves the issue.

Richard, thanks for all your work, and my sympathies to playdayz in his troubles.

Regards,
Ed
Back to top
View user's profile Send_private_message 
Pelo


Joined: 10 Sep 2011
Posts: 3224
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 13 Jan 2014, 06:31    Post_subject:  Lucid 5.2.8 Version 006
Sub_title: LTS it is !
 

LTS it is ! Very good job. Permanently improved, you keep the best.
The best choice.
Musher0 says "whoever chooses one of your updated Lucid Puppies --
even now -- might be making a good choice, even if all the programs are not absolutely up to date. " Fully agreed. More than agreed, it's the right way of doing, as there is nobody to Cook the huge repositories from Precise to 'PET'isize them (ready-made meals).
The young hens go bald Twisted Evil
Back to top
View user's profile Send_private_message YIM 
mikeb


Joined: 23 Nov 2006
Posts: 8365

PostPosted: Mon 13 Jan 2014, 08:20    Post_subject:  

Quote:
The young hens go bald

I agree even though I have not a clue what this means.

I know about 'crushing the mushroom' but that's it

mike
Back to top
View user's profile Send_private_message 
keniv

Joined: 06 Oct 2009
Posts: 200
Location: Scotland

PostPosted: Tue 14 Jan 2014, 11:36    Post_subject:  

Hello All,

I have been given a Dell L attitude D531 laptop. I tried to run the latest version of Lucid Puppy 5286 which I have with a number of versions of 528 on a flash drive (fat32) booting with grub4dos, I booted with pfix=ram with a view to producing a new savefile for the Dell. I set the personal settings, set up the wifi and then shutdown. I get an error before I get to the option to make a savefile. The only thing that I've tried that gets me anywhere from here is to hold down the power button to power off. I then tried the same with 528.005 with the same result. I then tried the original 528. This time I got a normal savefile option. I made a savefile, rebooted and installed an number of pets. I have also used the 'on the fly' to install an sfs. All of this works fine. I found the 002 update for 528 and installed this so I suppose I am running 528.002. Using 528 with the update does not cause any shutdown problems. The shutdown problem seems to have been caused by something done in upgrading from 002 to 005. I would like to use 5286. Has anybody got any ideas as to a solution to the shutdown problem? Also when I do the search for a video driver I am told to install Xorg_High which I have done. However, I am not sure if I have the best driver. I have attached the output from open glx.

5.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
oem: ATI ATOMBIOS product: RS690 01.00

X Server: Xorg Driver: radeon
X.Org version: 1.7.6
dimensions: 1280x800 pixels (338x211 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 (RS690 791F) 20090101 x86/MMX+/3DNow!+/SSE2 NO-TCL
OpenGL version string: 1.5 Mesa 7.7.1

Mobile AMD Sempron(tm) Processor 3600+
Core 0: 797 MHz

To me this looks as if it might be alright but I would appreciate it if someone with more expertise could cast an eye over it and tell me if this is the best driver or not.

Regards,

Ken.
Back to top
View user's profile Send_private_message 
rerwin


Joined: 24 Aug 2005
Posts: 1529
Location: Maine, USA

PostPosted: Tue 14 Jan 2014, 12:03    Post_subject:  

Quote:
I tried to run the latest version of Lucid Puppy 5286 which I have with a number of versions of 528 on a flash drive (fat32) booting with grub4dos,
keniv,
Although I have no personal experience with flash drive installations, I am concerned that you have multiple lupu 528s available at boot time. Keep in mind that if there are multiple lupu_528.sfs files visible (mounted or not) at boot time, you have no control over which one gets used. So, it is unclear which version of 528 you are running with.

To remove that mystery, look at /etc/rc.d/PUPSTATE to see the value of the path in the PUPSFS parameter.

To avoid the ambiguity, I temporarily rename all but one of the lupu_528.sfs files to something else.
Richard
Back to top
View user's profile Send_private_message 
keniv

Joined: 06 Oct 2009
Posts: 200
Location: Scotland

PostPosted: Tue 14 Jan 2014, 12:42    Post_subject:  

Quote:
I am concerned that you have multiple lupu 528s available at boot time. Keep in mind that if there are multiple lupu_528.sfs files visible (mounted or not) at boot time, you have no control over which one gets used. So, it is unclear which version of 528 you are running with.

To remove that mystery, look at /etc/rc.d/PUPSTATE to see the value of the path in the PUPSFS parameter.


I think this is the relevent bit from /etc/rc.d/PUPSTATE .

Code:
PUPSFS='sdb1,vfat,/528/luci_528.sfs'
PUPSAVE='sdb1,vfat,/528/lucisave-528dell.3fs'


I have attached part of my grub menu.lst.

Code:
title Luci 528 RAM mode
  root=(hd0,0)
  kernel /528/vmlinuz pmedia=usbflash psubdir=528 pfix=ram
  initrd /528/initrd.gz
 
title Lupu 52864
  root=(hd0,0)
  kernel /52864/vmlinuz pmedia=usbflash psubdir=52864 pfix=fsck
  initrd /52864/initrd.gz


I assumed that this would cause only the lupu_528.sfs file within the particular folder, say 528, to be booted. Is this not the case? If a different lupu_sfs file was booted with a pre-existing different savefile, say the savefile in the 528 folder booted with the lupu_528.sfs in the 52864 folder, would this not cause an update of the savefile. I've never seen this happen. Just to avoid the possibility of this would I be better to burn a cd of 5286 and boot from this. I could then attempt a shutdown and if it worked make a savefile onto the hdd.

Regards,

Ken
Back to top
View user's profile Send_private_message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Wed 15 Jan 2014, 14:43    Post_subject:  

Here is a version of Firefox 26 that incorporates information from this discussion of Avoiding Tracking

Firefox pet -> http://www.murga-linux.com/puppy/viewtopic.php?p=751375#751375

Avoiding Tracking Discussion -> http://www.murga-linux.com/puppy/viewtopic.php?p=745686#745686
Back to top
View user's profile Send_private_message 
mikeb


Joined: 23 Nov 2006
Posts: 8365

PostPosted: Wed 15 Jan 2014, 15:06    Post_subject:  

Multiple Lupu disease. There may be no cure.

I have 4 but 3 are my creations so not officially puppies.... perhaps this is a cure. I must try throwing away my crutches and embrace the world and all it wants to offer but restrcts my access to.

mikael.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 185 of 190 Posts_count   Goto page: Previous 1, 2, 3, ..., 183, 184, 185, 186, 187, 188, 189, 190 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1654s ][ Queries: 13 (0.0510s) ][ GZIP on ]