Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 09:00
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
glibc upgrade
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 4 of 4 Posts_count   Goto page: Previous 1, 2, 3, 4
Author Message
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Sat 27 Jul 2013, 03:38    Post_subject:  

.
_________________
The Arch Way

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 900
Location: USA

PostPosted: Sat 27 Jul 2013, 13:40    Post_subject:  

Slitaz can't be the lite Arch Linux, as Arch Linux is crap, unstable, bloated, and uses systemd (which is bloatware itself).

Slitaz, at least doesn't require your system to break when a major upgrade is done (but Arch does).

_________________
......
Back to top
View user's profile Send_private_message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Sat 27 Jul 2013, 13:58    Post_subject:  

.
_________________
The Arch Way

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 900
Location: USA

PostPosted: Sat 27 Jul 2013, 17:28    Post_subject:  

@simargl

Maybe rather than being a troll here and f***ing up the forum saying how puppy linux is shit and attacking those who say they have problems with your alphaOS, maybe you can be constructive. This is why forums are set up.

Now don't get me wrong alphaOS is okay, but you you don't take kindly to suggestions. A common request that is made is support for broadcom BCM4313 and you completely ignore them. A good developer would take into consideration of those with very good suggestions.

PS: For those with broadcom, the only to get it to work in alphaOS is to switch the alphaOS kernel with one from Precise/Slacko, which does take some work.

PS 2: I sense that another user "rivalry" is coming. There is already one with gcmartin vs. Q5sys. I don't want one to start but sadly trolls are a cancer that infect every community and they have to deal with that from time to time.

_________________
......
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Sat 27 Jul 2013, 20:51    Post_subject:  

Back to glibc upgrade discussion...(I hope)...Neutral
Back to top
View user's profile Send_private_message 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 900
Location: USA

PostPosted: Sat 27 Jul 2013, 22:51    Post_subject:  

I believe a glibc upgrade can provide benefits.
_________________
......
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Fri 02 Aug 2013, 02:10    Post_subject:  

The fixes posted on page 3 will only work with 4-series.
They will not work with Wary.
Edit: see below

Edited_time_total
Back to top
View user's profile Send_private_message 
watchdog

Joined: 28 Sep 2012
Posts: 639

PostPosted: Fri 02 Aug 2013, 04:24    Post_subject:  

Dewbie wrote:
The fixes posted on page 3 will only work with 4-series.
They will not work with Wary.


In my wary 5.5 install pmount is not broken after glibc upgrade and all seems to work. Glibc upgrade breaks only locale in wary and the fix is to put in /etc/profile:

Code:
export LC_ALL=C
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Fri 02 Aug 2013, 04:42    Post_subject:  

watchdog wrote:
Quote:
the fix is to put in /etc/profile:
Code:
export LC_ALL=C

Thanks...which line does it go in?
Back to top
View user's profile Send_private_message 
watchdog

Joined: 28 Sep 2012
Posts: 639

PostPosted: Fri 02 Aug 2013, 06:08    Post_subject:  

Dewbie wrote:
watchdog wrote:
Quote:
the fix is to put in /etc/profile:
Code:
export LC_ALL=C

Thanks...which line does it go in?


I have put the line at the end before the end of the file. I have to say that in my install I upgraded jwm by compiling the 688 snapshot. There are more recent upgrades at:

http://www.murga-linux.com/puppy/viewtopic.php?search_id=750318331&t=83949

EDIT: I confirm. I did some trials with a fresh install. Installing:

1)libc6_2.11.3-4_i386.deb
2)dbus (PPM)
3)dbus-glib (PPM)
4)service-pack_5.5TO5.5.1_wary5.pet
5)jwm upgrade at snapshot 688

and putting "export LC_ALL=C" in /etc/profile as described and rebooting, pmount works ootb.
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Sat 03 Aug 2013, 01:47    Post_subject:  

OK, thanks...followed your directions, but no luck.

Quote:
They will not work with Wary.

I tested with the Warys that I have (5.1.1 / 5.1.4.1 / 5.2.2), assuming that it applied to all of them.
Would've helped if I was more specific. Rolling Eyes

I edited the SFSes, stripped out all 2-series SeaMonkeys and replaced them with BK's SeaMonkey 1.1.18 from 5.1.4.1.
So no need for the dbus stuff.

And obviously the service pack wouldn't apply either.
Plus, yours might have newer libs.
Back to top
View user's profile Send_private_message 
watchdog

Joined: 28 Sep 2012
Posts: 639

PostPosted: Sat 03 Aug 2013, 03:21    Post_subject:  

I have resurrected my wary 5.3 install with glibc upgrade and I got pmount working after installing jwm2-755-w5c.pet from the link above, correcting locale by "export LC_ALL=C" in /etc/profile and rebooting. I have not earlier versions of wary.
Back to top
View user's profile Send_private_message 
KentC


Joined: 16 Sep 2012
Posts: 61

PostPosted: Sat 21 Dec 2013, 22:23    Post_subject:  

thank you guys, tested in 4.31 with the vi edit recommended, and this works in terminal as a nice tool. I will go ahead and add this to puppylinux431.com Smile

Appreciate the efforts to make the good stuff better.


Kent C.
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Sat 28 Dec 2013, 02:02    Post_subject:  

Uh-oh, just uncovered a strange bug Shocked :

I converted libc6_2.11.3-4_i386.deb to a .pet using dejan555's deb2pet.

This caused /lib/libc.so.6 to link to /lib/libc-2.10.1.so.
(instead of /lib/libc-2.11.3.so, as it did in the original .deb)

Consequently, Pmount worked.
(The upgrade usually breaks it--hoses the locale.)
But SlimBoat didn't.

On the other hand, this is not a problem with the older libc6_2.11.2-10_i386.deb.
(/lib/libc.so.6 links to /lib/libc-2.11.2.so, whether .deb or .pet.)

So if you're upgrading these libs in pre-4.3 Puppies (which won't install Debian packages natively), then convert the older .deb to a .pet and use that one instead.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 4 of 4 Posts_count   Goto page: Previous 1, 2, 3, 4
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0734s ][ Queries: 13 (0.0058s) ][ GZIP on ]