Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 12:13
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Could not find any audio device (SOLVED)
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
marcos90

Joined: 07 Sep 2011
Posts: 78

PostPosted: Thu 28 Nov 2013, 12:37    Post_subject:  Could not find any audio device (SOLVED)  

Lucid Puppy latest version .
I got this http://br.msi.com/product/mb/C847IS-P33.html#/?div=Detail of motherboard .
The hardware audio device is an onboard Realtek® ALC887

It is pretty new , but unfortunatly , no linux drivers or support are offered. Is there some generic audio driver for cases like this ? I've tried that Audio Wizard Analyze setup , but no luck , it says "No supported pnp or Pci card not found " . Probe Legacy ISA won't worked either .

Edited_time_total
Back to top
View user's profile Send_private_message 
ardvark


Joined: 01 Jul 2013
Posts: 1092
Location: USA

PostPosted: Thu 28 Nov 2013, 15:17    Post_subject:  

Hi....

Well, a shot in the dark here, I'm not sure if it will work but if you're running Lucid 5.2.8, I found this thread here. Download and install the .pet offered by Semme (second post.) The "004 update" he mentioned *I THINK* can be found here (first post.)

Again, I'm not sure if this will work, so if you want to try this, it might be a good idea to back up all the files you wish to save. Wink

Regards...

_________________
Our Lord and Savior Jesus Christ loves and cares about you most of all!

PLEASE READ! You don't have to end up here!
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Thu 28 Nov 2013, 17:58    Post_subject:  

Try typing 'retrovol' in terminal and tick the settings.

If that doesn't work then try installing an old copy of Audacity 1.3.9
(I hope it works in Lucid Puppy??)

because it automatically searchs for a driver and sets it up.
Use Audacity to open a wav file from the Reference folder
and hear how it plays.
__________________________________________
Back to top
View user's profile Send_private_message 
marcos90

Joined: 07 Sep 2011
Posts: 78

PostPosted: Thu 28 Nov 2013, 19:26    Post_subject:  

ardvark wrote:
Hi....
Well, a shot in the dark here, I'm not sure if it will work but if you're running Lucid 5.2.8, I found this thread here. Download and install the .pet offered by Semme (second post.) The "004 update" he mentioned *I THINK* can be found here (first post.)
Again, I'm not sure if this will work, so if you want to try this, it might be a good idea to back up all the files you wish to save. Wink
Regards...


Thanks for all the replys guys , but unfortunatly , still doesn't detect the device , I followed, downloaded , and installed , all the steps , including this litle guy "004" Very Happy , but nothing happened . Sad

don570 wrote:
Try typing 'retrovol' in terminal and tick the settings.
If that doesn't work then try installing an old copy of Audacity 1.3.9
(I hope it works in Lucid Puppy??)
because it automatically searchs for a driver and sets it up.
Use Audacity to open a wav file from the Reference folder
and hear how it plays.
__________________________________________

I've typed , but it look liked was aborted :
"sh-4.1# retrovol
ALSA lib conf.c:1016:(parse_value) card is not a string
ALSA lib conf.c:1685:(snd_config_load1) _toplevel_:2:20:Invalid argument
ALSA lib conf.c:3467:(snd_config_hook_load) /etc/asound.conf may be old or corrupted: consider to remove or fix it
ALSA lib conf.c:3326:(snd_config_hooks_call) function snd_config_hook_load returned error: Invalid argument
ALSA lib conf.c:3713:(snd_config_update_r) hooks failed, removing configuration
retrovol: hcontrol.c:573: snd_hctl_load: Assertion `hctl->count == 0' failed.
Aborted"

I've installed correctly Audacity 1.3.12 , but no luck with the audio drivers , when I open Audiocity , it gives a follow message :

Error Initializing Audio
Could not find any audio devices .
Error: Unanticipated host error
Back to top
View user's profile Send_private_message 
OscarTalks

Joined: 05 Feb 2012
Posts: 926
Location: London, England

PostPosted: Thu 28 Nov 2013, 22:22    Post_subject:  

Have you checked to see if the audio device on the motherboard has been disabled in the BIOS settings?
_________________
Oscar in England

Back to top
View user's profile Send_private_message 
ardvark


Joined: 01 Jul 2013
Posts: 1092
Location: USA

PostPosted: Thu 28 Nov 2013, 23:15    Post_subject:  

Hi...

Another option, if possible, is to try other versions of Puppy to see if any one of them can successfully detect (and use) your chipset.

Regards...
Back to top
View user's profile Send_private_message 
marcos90

Joined: 07 Sep 2011
Posts: 78

PostPosted: Thu 28 Nov 2013, 23:39    Post_subject:  

OscarTalks wrote:
Have you checked to see if the audio device on the motherboard has been disabled in the BIOS settings?

Yes , I did checked into Bios setup , and it was enabled . Usually , I use this motherboard with Windows 7 with no problems with audio .

ardvark wrote:
Hi...
Another option, if possible, is to try other versions of Puppy to see if any one of them can successfully detect (and use) your chipset.
Regards...

I've tested with puppy lucid 5.25 and it was the same results . I guess I will gona have to change to Ubuntu or other distro , but need to test to see if gonna work . Too bad this happened , because I love Puppy Lucid . It's very simple and very reliable OS .
Back to top
View user's profile Send_private_message 
ardvark


Joined: 01 Jul 2013
Posts: 1092
Location: USA

PostPosted: Fri 29 Nov 2013, 00:03    Post_subject:  

marcos90 wrote:
I've tested with puppy lucid 5.25 and it was the same results . I guess I will gona have to change to Ubuntu or other distro , but need to test to see if gonna work . Too bad this happened , because I love Puppy Lucid . It's very simple and very reliable OS .


You could also try Precise 5.6.1 or 5.7.1 or perhaps Slacko. Smile

Regards...
Back to top
View user's profile Send_private_message 
marcos90

Joined: 07 Sep 2011
Posts: 78

PostPosted: Fri 29 Nov 2013, 00:13    Post_subject:  

ardvark wrote:
marcos90 wrote:
I've tested with puppy lucid 5.25 and it was the same results . I guess I will gona have to change to Ubuntu or other distro , but need to test to see if gonna work . Too bad this happened , because I love Puppy Lucid . It's very simple and very reliable OS .


You could also try Precise 5.6.1 or 5.7.1 or perhaps Slacko. Smile

Regards...
Precise 5.6.1 or 5.7.1 or perhaps Slacko.

I1ve tested now with latest Lubuntu 13.04 , and the sound device was recognized normal , and the sound is perfect Smile . The problem is this OS is too big ( 700MB) , and I don't know if can be instaled on Usb pen drive . I'will gonna try later Precise . Thanks for the replies .
Back to top
View user's profile Send_private_message 
ardvark


Joined: 01 Jul 2013
Posts: 1092
Location: USA

PostPosted: Fri 29 Nov 2013, 07:22    Post_subject:  

marcos90 wrote:
I'will gonna try later Precise .


Let us know how it turns out. Smile

Regards...
Back to top
View user's profile Send_private_message 
marcos90

Joined: 07 Sep 2011
Posts: 78

PostPosted: Fri 29 Nov 2013, 12:42    Post_subject:  

ardvark wrote:
marcos90 wrote:
I'will gonna try later Precise .

Let us know how it turns out. Smile
Regards...


Thanks . It worked with Precise 5.7.1 . But I got another question . Precise 5.7.1 won't find my old lupusave-pupsaved.3fs at boot process , Aren't they compatible ? Or I'll gonna have to install all the apps and others drivers again ? PuppyLucid and Precise looks like the same to me .
Back to top
View user's profile Send_private_message 
cacri

Joined: 09 Jan 2013
Posts: 2

PostPosted: Fri 29 Nov 2013, 19:03    Post_subject:  

Slacko has a SFSConverter...check the Utility menu
Back to top
View user's profile Send_private_message 
ardvark


Joined: 01 Jul 2013
Posts: 1092
Location: USA

PostPosted: Sat 30 Nov 2013, 02:28    Post_subject:  

cacri wrote:
Slacko has a SFSConverter...check the Utility menu


Is there a .pet for this that would work in other versions?

Regards...
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Sat 30 Nov 2013, 15:23    Post_subject:  

SFS files are treated like any archive or ISO. So they will mount
and you can drag any important data to your hard disk. IT SHOULD
open automatically once you click on the SFS
Back to top
View user's profile Send_private_message 
puppyluvr


Joined: 06 Jan 2008
Posts: 3227
Location: Chickasha Oklahoma

PostPosted: Sat 30 Nov 2013, 21:14    Post_subject:  

Very Happy Hello,
Change "lupu" to "precise" in the savefile name.
Or make a save with precise and rename your old save
to whatever it is named.
Dont try to "convert" it thats something different.
A save is a modified .sfs labeled .2fs or .3fs or 4fs
relating to ext2/3/4 while the .sfs converter converts bwtween
squashfs versions 3 and 4.

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0887s ][ Queries: 12 (0.0052s) ][ GZIP on ]