Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 31 Aug 2014, 00:25
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
SlimBoat browser
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 5 of 8 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Author Message
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Fri 02 Aug 2013, 04:01    Post_subject:  

Currently running SlimBoat 1.1.36 (official build) on Wary 5.1.1.
Had to add Extract-txz-modified.pet and libc6_2.11.2-10_i386.deb.

WARNING: libc6_2.11.2-10_i386.deb breaks Pmount.
(Fix is here.)

Also tested with Wary 5.1.4.1 and 5.2.2; same applies.
Will not work with 4-series.
It's very quick, even on a P2 / 350 with dial-up. Smile

Also found a bug:
It locks up when clicking on, then canceling, download links.
Has to be closed out and relaunched; nothing major...

Edit:
I'm comparing notes behind the scenes with another forum member.
He was able to get QtWeb to do the same thing, and suspects a WebKit bug...
SlimBoat-Wary-config.png
 Description   
 Filesize   19.93 KB
 Viewed   1156 Time(s)

SlimBoat-Wary-config.png


Edited_times_total
Back to top
View user's profile Send_private_message 
OscarTalks

Joined: 05 Feb 2012
Posts: 865
Location: London, England

PostPosted: Sat 10 Aug 2013, 07:30    Post_subject:  

@ Dewbie
Have you managed to get Flash Player working in SlimBoat in Wary?

@ Everyone
It seems there are some people who like SlimBoat so here is version 1.1.38 as .SFS and .PET packages

Released 07th August 2013

To download from Data File Host:-
Use the small grey "DOWNLOAD" button
If you see a larger "Download Now" button it is a Windows .exe downloader and an advert so ignore it.

Edit:- DOWNLOAD LINKS REMOVED
See below for newer version

_________________
Oscar in England


Edited_time_total
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Sun 11 Aug 2013, 21:30    Post_subject:  

OscarTalks wrote:
Quote:
@ Dewbie
Have you managed to get Flash Player working in SlimBoat in Wary?

No...despite having Flash in /usr/lib/mozilla/plugins, I'm getting a message indicating that it doesn't see Flash.

Dragging and symlinking Flash to /usr/local/slimboat/plugins makes no difference either.
(SlimBoat is installed in /usr/local.)

@OscarTalks: Where do you install SlimBoat in your .pet and SFS?
(Easier to ask than to download, as I have dial-up...)
Back to top
View user's profile Send_private_message 
OscarTalks

Joined: 05 Feb 2012
Posts: 865
Location: London, England

PostPosted: Fri 16 Aug 2013, 17:05    Post_subject:  

@ Dewbie,

My SlimBoat packages place the main slimboat folder in /usr/lib as this seems to be the convention for browsers in Puppy. I believe other locations would be perfectly OK also though.

I have still not been able to get the Flash Player to work in Wary/Racy or Slacko. I did email the developers about it some while ago and they said that they were not sure why, but that it is not a path issue.

_________________
Oscar in England

Back to top
View user's profile Send_private_message 
capoverde


Joined: 28 Jun 2006
Posts: 233
Location: Sanremo (Italy) with fine seaview

PostPosted: Fri 16 Aug 2013, 17:28    Post_subject:  

Downloaded Slimboat 1.1.38, Italian localization, just minutes ago directly from their website. Running it in Puppy Precise 5.6.1 right now and posting with it, after searching the forum to see whether someone else had already tested it - and Xman had!

Just for caution, I chose to place Slimboat in a separate folder rather than in the usual /usr system folder, to be able to get rid of it easily if not OK.

Very fast and responsive, seems to have no problem on YT: if I get it right, it does decode Flash videos perfectly (they should be the ones evidenced by the rotating-balls-circle logo while loading). Also doing fine on a HD video in Vimeo, both in Flash and HTML5 (it's clearly marked there).

A very pleasant surprise was to find a specific link for Puppy Linux in their Downloads page (in English only, no such link in the Italian page): followed their suggestions and all worked perfectly in less than half a minute i. e., after downloading and extracting the Gstreamer libs in place.

Of course a deeper and longer testing is needed, but seems interesting, although not really lightweight - 58 MB against SeaMonkey's 51 (full package).
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Sun 18 Aug 2013, 03:00    Post_subject:  

OscarTalks wrote:
Quote:
I have still not been able to get the Flash Player to work in Wary/Racy or Slacko. I did email the developers about it some while ago and they said that they were not sure why, but that it is not a path issue.

This is what I'm getting in Wary 5.1.1, in Help / Configuration Information.
Notice the 0 next to Flash Download Control; everything else is a 1.
What number are you getting here with Puppies that will run Flash?
(In Tools / Options / Download Control, my Enable Plugins box is checked.)
Config-info-flash.png
 Description   
 Filesize   6.82 KB
 Viewed   1081 Time(s)

Config-info-flash.png

Back to top
View user's profile Send_private_message 
OscarTalks

Joined: 05 Feb 2012
Posts: 865
Location: London, England

PostPosted: Sun 18 Aug 2013, 05:35    Post_subject:  

Dewbie wrote:
What number are you getting here with Puppies that will run Flash?


Flash Player runs OK in the Debian and Ubuntu based Puppies.
I looked in Dpup Wheezy and the "Flash Download Control" number is also a ZERO so I guess that's not the problem.

I indicated to the developers that it is difficult for the Puppy community to make a lot of noise about SlimBoat as a Puppy browser if it doesn't fully work in Slacko or Wary.

I was told that they compile it in Ubuntu 10.04 which is why the glibc in Wary is too old. I asked about a specific build for Wary and they didn't rule it out, but I guess it is low priority for them unless perhaps more people contact them and request it. It seems BarryK may be moving away from Wary as an official Puppy now also, but when you add in the Flash/Slacko issue plus the fact that I have found a couple of websites that don't render properly or even cause the browser to crash completely it makes it a semi-showstopper for me which is a pity because I do quite like SlimBoat and it seems others do too.

I have continued to post my packages in this thread because it is not too difficult to do and it seems that some people are using them, but I have thought about knocking it on the head and may do so at some point in the future. There are several other good browsers out there to choose from.

_________________
Oscar in England

Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Mon 19 Aug 2013, 20:28    Post_subject:  

OscarTalks wrote:
Quote:
I indicated to the developers that it is difficult for the Puppy community to make a lot of noise about SlimBoat as a Puppy browser if it doesn't fully work in Slacko or Wary.

Indeed; Slacko's still the main Puppy.
It would be helpful if SlimBoat indicated on its website *which* Puppy versions it works with...

Also, most post-4-series Puppies can still get YouTube this way.

(See my post over here about an apparent WebKit bug that also affects SlimBoat.)
Back to top
View user's profile Send_private_message 
OscarTalks

Joined: 05 Feb 2012
Posts: 865
Location: London, England

PostPosted: Sat 26 Oct 2013, 09:39    Post_subject:  

SlimBoat version 1.1.42
Released 14th October 2013

Information:-
http://www.slimboat.com

Download .PET and/or .SFS packages from my Yandex Disk here:-
http://yadi.sk/d/zTshLczR4wHj8

EDIT:-
Newer version released - see below.

_________________
Oscar in England


Edited_time_total
Back to top
View user's profile Send_private_message 
Marv


Joined: 04 May 2005
Posts: 338
Location: SW Wisconsin

PostPosted: Thu 14 Nov 2013, 11:10    Post_subject:  

currently running version 1.1.42 sucessfully in LxPup 13.10c which is slacko based. Flashplayer now (plugin in /usr/lib/mozilla in LxPup) works. I have installed the additional library files needed by opera per this thread http://www.murga-linux.com/puppy/viewtopic.php?p=680845#680845. Prior to that, flashplayer did not work either in Opera or SlimBoat. SlimBoat is installed to a directory on my boot partition. Gtk themes found ok, both in LxPup and alphaOS 12.1. Bookmarks exported from opera in html format, imported to SlimBoat sucessfully. Works on several sites I use that now break Opera. I'll continue to use it and try it on some of the other older pups on this laptop.

Thanks for this thread,

_________________
tweaked 412 based boxpup, well honed 'lina-lite-005, alphaOS 321 Wink , X-slacko 2.1, Lxpup 14.07, and not to forget trusty Carolina/Carolite (now with 3.15 kernel). All lean and steady pups.
Back to top
View user's profile Send_private_message 
OscarTalks

Joined: 05 Feb 2012
Posts: 865
Location: London, England

PostPosted: Thu 14 Nov 2013, 19:45    Post_subject:  

Hello Marv,

Good work! Thanks for letting us know about that. I wondered about how best to approach this and rather than trying to include symlinks to libs in different locations in different puppies I thought it best to include a copy of those libraries in the private /usr/lib/slimboat/libs directory. This makes SlimBoat "self-contained" in that it will still work even if other browsers are removed.

Flash Player now works in Slacko which is a great leap forward. Tested in 5.6 and 5.5

Also, version 1.1.43 has just been released so I have packaged as .pet and .sfs and uploaded to my Yandex Disk here:-
http://yadi.sk/d/zTshLczR4wHj8

EDIT:- Duplicating the libs did not work so trying "Plan B" - see below.

_________________
Oscar in England


Edited_times_total
Back to top
View user's profile Send_private_message 
Marv


Joined: 04 May 2005
Posts: 338
Location: SW Wisconsin

PostPosted: Thu 14 Nov 2013, 21:03    Post_subject:  

Good, I'll move my libs. Two more little things re Slimboat.

Lots of complaints about the bookmarks bar/menu font size. Played with dpi, lots of things to no avail. Can be set with qtconfig but the qt4 pkg is HUGE. Simple solution is to manually edit the font size in /root/.config/Trolltech.conf. It persists through 'Application style' changes ok and much improves the overall look IMHO. Page font size easily set in Tools>Options>Appearance and with Ctrl+ and Ctrl-.

Haven't yet nicely 'portablized' the 'profile' directory to the boot partition so it is shared by all pups. I have it kludged with symlinks but they are pretty fragile. I've asked the SlimBoat forum about that.

All in all it's come a long way since I last used it.

_________________
tweaked 412 based boxpup, well honed 'lina-lite-005, alphaOS 321 Wink , X-slacko 2.1, Lxpup 14.07, and not to forget trusty Carolina/Carolite (now with 3.15 kernel). All lean and steady pups.
Back to top
View user's profile Send_private_message 
OscarTalks

Joined: 05 Feb 2012
Posts: 865
Location: London, England

PostPosted: Thu 14 Nov 2013, 21:41    Post_subject:  

Hmm, looks like I need to think again about this. Putting those libs in there has made it work in Slacko but broken it it the Debian and Ubuntu Pups.
_________________
Oscar in England

Back to top
View user's profile Send_private_message 
Marv


Joined: 04 May 2005
Posts: 338
Location: SW Wisconsin

PostPosted: Thu 14 Nov 2013, 21:53    Post_subject:  

I use opera also so I have them in /usr/lib as well. Not currently running any Deb or Ubuntu derivs..... Does it see other/older libs in /usr/lib in those? /usr/lib must have priority? Run it from terminal and see?

Edit: Created directory data on boot partition. Symlinked to it in /root/.local/share. Firstrun of SlimBoat creates its 'FlashPeak' directory in the common boot partition. Shared by all pups with that symlink.

Here is what is now in my /root/.config/Trolltech.conf under [Qt]:
Code:
font="Sans Serif,16,-1,5,50,0,0,0,0,0"
GUIEffects=none
embedFonts=true
resolveSymlinks=false
style=Cleanlooks
wheelScrollLines=3
filedialog="@ByteArray(\0\0\0\xbe\0\0\0\x3\0\0\0\x1e\0\0\0\xff\0\0\0\0\0\0\0\x2\0\0\0]\0\0\xe\0\x1\0\0\0\x6\x1\0\0\0\x1\0\0\0\x2\0\0\0\x5\x66ile:\0\0\0\ffile:///root\0\0\0\x3\0\0\0\n\0/\0r\0o\0o\0t\0\0\0l\0/\0r\0o\0o\0t\0/\0.\0l\0o\0\x63\0\x61\0l\0/\0s\0h\0\x61\0r\0\x65\0/\0\x64\0\x61\0t\0\x61\0/\0\x46\0l\0\x61\0s\0h\0P\0\x65\0\x61\0k\0/\0S\0l\0i\0m\0\x42\0o\0\x61\0t\0/\0q\0u\0i\0\x63\0k\0s\0\x65\0\x61\0r\0\x63\0h\0\0\0,\0/\0m\0n\0t\0/\0h\0o\0m\0\x65\0/\0O\0p\0\x65\0r\0\x61\0_\0\x43\0o\0m\0m\0o\0n\0\0\0l\0/\0r\0o\0o\0t\0/\0.\0l\0o\0\x63\0\x61\0l\0/\0s\0h\0\x61\0r\0\x65\0/\0\x64\0\x61\0t\0\x61\0/\0\x46\0l\0\x61\0s\0h\0P\0\x65\0\x61\0k\0/\0S\0l\0i\0m\0\x42\0o\0\x61\0t\0/\0q\0u\0i\0\x63\0k\0s\0\x65\0\x61\0r\0\x63\0h\0\0\0~\0\0\0\xff\0\0\0\0\0\0\0\x1\0\0\0\0\0\0\0\0\x1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\x1\xec\0\0\0\x4\x1\x1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\x64\xff\xff\xff\xff\0\0\0\x81\0\0\0\0\0\0\0\x4\0\0\0\xff\0\0\0\x1\0\0\0\0\0\0\0?\0\0\0\x1\0\0\0\0\0\0\0@\0\0\0\x1\0\0\0\0\0\0\0n\0\0\0\x1\0\0\0\0\0\0\0\x1)"

Font size seems to be capped at 12 or so by toolbar heights...

_________________
tweaked 412 based boxpup, well honed 'lina-lite-005, alphaOS 321 Wink , X-slacko 2.1, Lxpup 14.07, and not to forget trusty Carolina/Carolite (now with 3.15 kernel). All lean and steady pups.

Edited_time_total
Back to top
View user's profile Send_private_message 
slavvo67

Joined: 12 Oct 2012
Posts: 372
Location: The other Mr. 305

PostPosted: Thu 14 Nov 2013, 22:00    Post_subject: Slimboat
Sub_title: Cache Files
 

I noticed the cache files have been building up so I decided to delete them. Most browsers let you view the cache but I didn't see any instruction on how to do so with Slimboat. Does anyone know of a resolve to this? ~Thanks

By the way, I'm using Pemasu's Slimboat pet 1.1.19 in Upup Precise 3.8.2. No problems. I also used the newer version with no issues 1.1.42 but I didn't care for it as much.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 5 of 8 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1074s ][ Queries: 13 (0.0179s) ][ GZIP on ]