Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 28 Aug 2014, 21:16
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
qt 5 for development?
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
amrset

Joined: 14 Oct 2013
Posts: 3

PostPosted: Mon 14 Oct 2013, 13:08    Post subject:  qt 5 for development?
Subject description: Would like to develop Qt 5 apps with puppy as the environment
 

Hello,

I really like the idea of Puppy Linux - I'd like to develop Qt 5 apps with Puppy. I'd also like to have a C++11 compiler and an Intel threading libraries available as well. Once I'm done with the apps, I'd like to have them run on Puppy as well. No - these will not be cloud related apps.

I'm capable of spinning my own, I'm looking at woof, but any pointers would be great!

I'm happy to share as well Smile

Thanks,
-Roy
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 270

PostPosted: Mon 14 Oct 2013, 14:47    Post subject:  

What people did with Qt 4 was build an sfs file that contained all the needed libraries (somewhat stripped down for size). That way, if you wanted to run Qt applications, all you needed to do was download and mount the sfs file on to any version of puppy. So, I think that would be the first task, rather than trying to make a new puppy version.
Back to top
View user's profile Send private message 
amrset

Joined: 14 Oct 2013
Posts: 3

PostPosted: Mon 14 Oct 2013, 15:07    Post subject:  

Sounds good,

looking through the puppy documentation online, I didn't see how one my go about that. Could you point me in the right direction?

Thank you,
-Roy
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 270

PostPosted: Mon 14 Oct 2013, 18:34    Post subject:  

I've never actually made an sfs from scratch, but this is from the wiki.

http://puppylinux.org/wikka/HowtoMakeSFSPackage

There is a script called editsfs that will let you edit an existing sfs file. There is another one by RSH that lets you combine .pet or .deb files into an sfs. I've used these, they are pretty self-explanatory.

http://www.murga-linux.com/puppy/viewtopic.php?t=47469

http://208.109.22.214/puppy/viewtopic.php?t=81511&sid=d1f2cb4d7cd4d824e495b184c2ab2386
Back to top
View user's profile Send private message 
amrset

Joined: 14 Oct 2013
Posts: 3

PostPosted: Mon 14 Oct 2013, 18:53    Post subject:  

Cool, Thanks!

I'm walking my way through old posts and pages - I'll start with PaDS - then if I have trouble, go back to making a pets first, then converting it/them to a sfs.

Sound like the right track?

So I see Barry is "retiring" from the project -- it looks like there is still a healthy ecosystem around puppy - am I correct? (just want to make sure it's worth spending my time on : )

Thanks for the help,
-Roy
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 270

PostPosted: Tue 15 Oct 2013, 10:48    Post subject:  

Yes, I think you are on the right track.

I am kind of surprised I am the only one responding. I think if you get something roughed out for people to download and test you'll get a lot more response.

I think Puppy will be around for a long time even without Barry, although maybe in a more scattered way than with his leadership.

There is also a dir2sfs script around that would be useful.

Good luck
Back to top
View user's profile Send private message 
simargl7

Joined: 05 Oct 2013
Posts: 18

PostPosted: Tue 15 Oct 2013, 11:02    Post subject:  

>>> What people did with Qt 4 was build an sfs file that contained all the needed libraries
>>> (somewhat stripped down for size). That way, if you wanted to run Qt applications, all you
>>> needed to do was download and mount the sfs file on to any version of puppy.


This simply is not possible, because Puppy based on:
Ubuntu has libpng12
Slackware has libpng14
Arch (previous Archpup, now Alphaos (not real Puppy?!)) has libpng16 at the moment.

Even if that is only difference (and obviously is not), using same Qt is impossible
because of different library (dependencies) versions in a distro compared to the other
one where Qt was compiled.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0505s ][ Queries: 12 (0.0043s) ][ GZIP on ]