Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 12:39
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
QtWeb 3.8.5
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
mechmike

Joined: 29 Nov 2005
Posts: 103
Location: Pelham, AL

PostPosted: Sat 14 Sep 2013, 23:37    Post_subject:  QtWeb 3.8.5
Sub_title: Could someone make a .pet for this?
 

There's an updated version (3.8.5) of QtWeb out:

http://qtweb.net/download.html

Would love to have a new .pet for this! Many thanks!
Back to top
View user's profile Send_private_message Visit_website 
musher0


Joined: 04 Jan 2009
Posts: 4245
Location: Gatineau (Qc), Canada

PostPosted: Sun 15 Sep 2013, 09:17    Post_subject:  

Hello, mechmike.

You don't need a pet. Simple as pie:

Simply download the zip archive,
unzip it, say, under /opt,
make it executable, and that's it.

Optional:
drag the QtWeb executable in /opt as a link to ~/my-applications/bin
make a QtWeb.desktop file in /usr/share/applications using the SeaMonkey.desktop file as a template.

The problem is elsewhere.
With what version of Puppy will you be using QtWeb?

In wary 5.5, for example, forget it, it's a no-go, because wary 5.5 is missing too many libraries that QtWeb requires to run.

Now if some Puppyist had the extreme patience on this beautiful Sunday
morning to go library hunting and create a supplemental pet package for
this new QtWeb... it would be nice. Smile

Maybe try this new QtWeb on other Puppy versions to see what gives?

BFN.
QtWeb-libs.jpg
 Description   Top of the list of libs missing in wary 5.5, that would allow to run the new QtWeb.
 Filesize   30.49 KB
 Viewed   821 Time(s)

QtWeb-libs.jpg


_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
mechmike

Joined: 29 Nov 2005
Posts: 103
Location: Pelham, AL

PostPosted: Sun 15 Sep 2013, 19:35    Post_subject: I did attempt to get it going, plus did a little research...  

I tried to make it work. I downloaded it, and followed the directions in BK's blog:

# unzip QtWeb-elf386.zip
# chmod 755 QtWeb
# ./QtWeb

The last command aborts, so your theory about missing dependencies definitely has some merit. I am no command line whiz by any means but am trying to learn as I go.

I tried it on Precise 5.7.1 plus on the previous Precise build. I have two USB drive installs of Puppy, plus a full install of 5.7.1 on a Dell Latitude 131L laptop.

The previous .pet (http://bkhome.org/blog2/?viewDetailed=00329) worked pretty well.
Back to top
View user's profile Send_private_message Visit_website 
cygnus_odile

Joined: 30 Jul 2013
Posts: 6
Location: Tokyo, Japan

PostPosted: Sun 22 Sep 2013, 19:39    Post_subject: a build 108 pet found!
Sub_title: a pet of QtWeb b108 -- featured as same as ver. 3.8.5
 

I've found a pet of build-108, showing ver. as 3.8.4, but featured as same as version 3.8.5.

-- compiled from source of build 108 (Sep 11), on Puppy Linux 431JP2012.
-- Qt-library statically combined.
-- having same features as 3.8.5, e.g., Shift-JIS encoding supported.

pet url : http://insurance.tf-bank.net/50MB/dl/1379019111.pet

WebPage(Japanese): http://nnit.web.fc2.com/puppy/puppy_p16.htm

You can download pet and rename it, e.g., QtWeb-b108.pet.
Back to top
View user's profile Send_private_message 
perdido

Joined: 09 Dec 2013
Posts: 79

PostPosted: Mon 09 Dec 2013, 12:52    Post_subject: Re: a build 108 pet found!
Sub_title: a pet of QtWeb b108 -- featured as same as ver. 3.8.5
 

Thanks for the link, it runs fine in Puppy Precise 5.7.1

There is a problem with the Import Bookmarks menu in QtWeb 3.8.4 when using the menu File > Import Bookmarks

The import bookmarks dialog box does not see the file to be imported, in my case it was the bookmarks.html file I exported from Firefox. The dialog box looks in /root/ by default - so that is where I told Firefox to create the file named bookmarks.html

The solution to this was to manually type in the file name (mine was named bookmarks.html ) into the "File name:" window of the "Open File" dialog box, then hit <Enter> on your keyboard. It then imports the bookmarks file into the QtWeb bookmarks.



cygnus_odile wrote:
I've found a pet of build-108, showing ver. as 3.8.4, but featured as same as version 3.8.5.

-- compiled from source of build 108 (Sep 11), on Puppy Linux 431JP2012.
-- Qt-library statically combined.
-- having same features as 3.8.5, e.g., Shift-JIS encoding supported.

pet url : http://insurance.tf-bank.net/50MB/dl/1379019111.pet

WebPage(Japanese): http://nnit.web.fc2.com/puppy/puppy_p16.htm

You can download pet and rename it, e.g., QtWeb-b108.pet.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0531s ][ Queries: 13 (0.0043s) ][ GZIP on ]