Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 20 Apr 2014, 23:21
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Lighthouse 64 602 Beta2 with GIMP-2.8.4 (6-29-2013)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 25 of 32 [466 Posts]   Goto page: Previous 1, 2, 3, ..., 23, 24, 25, 26, 27, ..., 30, 31, 32 Next
Author Message
gcmartin

Joined: 14 Oct 2005
Posts: 3634
Location: Earth

PostPosted: Thu 19 Sep 2013, 17:24    Post subject: Re: Gtkam - Sony HDR-CX380?  

edoc wrote:
Any idea how I get Gtkam, or some other app, to recognize a Sony HDR-CX380 camcorder?

It's not listed in Gtkam - I tried MTP and it failed as well.

I tried all of the USB options and it "could not initialize".

It would be nice to be able to pull clips off the SD card via a USB cable while in the camera rather than always having to remove the SD card and mount it on my laptop.
WDYT?
This is just an idea.

Idea
It may be that the camcorder does not provide the necessary functions to make its storage available over the USB cable (although for Windows, it might with its camcorder app that came with the camcorder). If that's the case, Puppy would need to have a software program/feature to mimic what the Windows app does to enable the views of the camcorder's storage.

Sometimes for some things that can be made to run in Wine, a Windows program could be adapted to run. But, because it would need direct access to the I/O subsystem, this Wine approach may not get the view it would need to make camcorder storage available for your manipulation.

There may be solution, though, that others can offer.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4309
Location: Southeast Georgia, USA

PostPosted: Thu 19 Sep 2013, 22:16    Post subject:  

Thanks for that gcmartin, I look forward to additional input as well.

Meanwhile, another anomaly has popped up ...

I can view a video clip on the camcorder, and via a HDMI cable, on a large screen TV and all is well.

If I copy the clip (it's .MTS) from the SD card to my laptop (LH64-602b & VLC) or share it via Dropbox with someone using a Microsoft-infested PC the same clip stutters on both machines.

EDIT

From VLC:

Stream 0:
Video
H264 MPEG-4 AVC (part 10) (h264)
Resolution: 1440x1080
Frame Rate: 59.940060
Decoded Format: Planar 4:2:0 YUV

Stream 1:
Audio A52 (aka AC3) (a52)
Stereo
48000hz
256k

Stream 2:
Subtitle
Codec: BD subtitles (bdpg)

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4309
Location: Southeast Georgia, USA

PostPosted: Fri 20 Sep 2013, 11:40    Post subject:  

Someone on the SONY Forum tried to blame the Player & said I needed to dumb-down (reduce) the recording frame rate because the Player couldn't handle it.

I reminded him that I paid for that frame rate and expected SONY to make converters or drivers available to Apple,Linux, & MS users so that we may use our recordings without hassle.

In the meanwhile, is it true that VLC cannot handle their MTS H264 MPEG-4 AVC (part 10) (h264) Resolution: 1440x1080 Frame Rate: 59.940060 Decoded Format: Planar 4:2:0 YUV output?

BTW: Their same MTS file doesn't render without stuttering on a Microsoft PC either.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4309
Location: Southeast Georgia, USA

PostPosted: Fri 20 Sep 2013, 12:42    Post subject:  

Our son just tested the file on VLC 2.0.6 (stock from the VLC site) in Microsoft Win7 and it handled the SONY .MTS file OK.

The same version in LH64-602b stutters when playing the same file.

He's using the same HP Pavilion g7 laptop that I am.

WDYT?

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
meeki


Joined: 23 Jul 2012
Posts: 123
Location: Portland OR

PostPosted: Fri 20 Sep 2013, 16:36    Post subject:  

hey edoc,

tried to compile openshot but it became a nightmare. It wants a bunch of kde stuff too!

I'll give it another go in a few days.
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4309
Location: Southeast Georgia, USA

PostPosted: Fri 20 Sep 2013, 17:02    Post subject:  

meeki wrote:
hey edoc,

tried to compile openshot but it became a nightmare. It wants a bunch of kde stuff too!

I'll give it another go in a few days.


Thanks for trying!

Avidemux is still not playing nicely and support is abysmal.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Tue 24 Sep 2013, 20:03    Post subject:  

@all,
I've been having difficulty concentrating lately. I have another dentist appt. tomorrow, and medication management with my nurse practitioner on Oct 2nd. I will try to review any posts I've missed as soon as I am able. I really appreciate others' assistance here, when I'm not able to respond in a timely fashion.

@edoc,
VLC is stuttering for me also, not every video, but quite often. I think that using renice +19 on vlc, via htop or qps process viewer helps a little bit. I plan to try updating ffmpeg or the kernel, but I don't know if it will help. I also get stuttering with mplayer, so I don't think VLC is the primary cause of this bug.

@Q5sys,
gam_server is from Slackware64 14.0, gamin-0.1.10-x86_64-5.txz
You can rename gam_server, then kill the process, like this:
Code:
mv /usr/libexec/gam_server /usr/libexec/gam_server-disable
killall -9 gam_server
Let me know if this works, and I will upload spacefm re-compiled to work without gamin (--enable-inotify)

-TaZoC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send private message Visit poster's website 
Q5sys


Joined: 11 Dec 2008
Posts: 1046

PostPosted: Tue 24 Sep 2013, 20:48    Post subject:  

tazoc wrote:


@Q5sys,
gam_server is from Slackware64 14.0, gamin-0.1.10-x86_64-5.txz
You can rename gam_server, then kill the process, like this:
Code:
mv /usr/libexec/gam_server /usr/libexec/gam_server-disable
killall -9 gam_server
Let me know if this works, and I will upload spacefm re-compiled to work without gamin (--enable-inotify)

-TaZoC


Seems to work for me, obviously SpaceFM doesnt work anymore. I'm just curious why it would be running so hard and locking up the system.

btw, take your time in doing things. Health comes first. Take care of yourself!

_________________



My PC is for sale
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4309
Location: Southeast Georgia, USA

PostPosted: Tue 24 Sep 2013, 21:16    Post subject:  

Check out that medical stuff, hopefully only seasonal allergies or a reaction to something you are eating that you need to avoid.

VLC only stutters when served 60i or 60p HD-quality video from the camcorder.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Tue 24 Sep 2013, 22:06    Post subject: spacefm without gamin  

Here is the spacefm file manager re-compiled to use inotify (kernel support) instead of gamin.

This Pet is only for Lighthouse64 602 and does not include the other pkg data, icons, menu entries, etc., as they are already included in 602.

http://www.lhpup.org/testing/L64-602/spacefm-LH64-602update.pet

Re: High core usage:
http://freebsd.1045724.n5.nabble.com/How-to-prevent-gam-server-from-running-td5487726.html
Quote:
<gam_server> is not a "system-level" service per se : it is not started via a well-defined /etc/rc.d/xxx or /usr/local/etc/rc.d script.

Contrary to that, it is a "user-level" service started on-demand by other mechanisms, most often desktop related. Like polkit stuff.

Therefore, it is not <gam_server> per se which is responsible for intensive CPU consumption, but rather whatever mechanism services higher in the stack that are launching it on their behalf to monitor files/directories activity.
So maybe this change to spacefm will help, at least if spacefm was responsible. There are other KDE services which may use gamin:
polkit, akonadi, nepomuk, strigi, virtuoso, as well as apps like dolphin and konqueror.

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send private message Visit poster's website 
peterw

Joined: 19 Jul 2006
Posts: 57
Location: UK

PostPosted: Wed 25 Sep 2013, 16:16    Post subject: Wireless connection with r8180 card
Subject description: wpa_supplicant issues with r8180 card
 

Hi All

I apologise if this topic is in the wrong section, but it is about Lighthouse which I really like apart from my connection problem.

I would like suggestions on how to attach “my wpa_supplicant” to network wizard or how to get it to work with my wireless card. And maybe I can also suggest an update to wpa_supplicant for new releases.

The following points explain the situation:

1. My laptop has a r8180 wireless card which works very well with all 32 bit versions of puppy, connecting with wpa to my router. However, with 64 bit versions (Lighthouse and Fatdog) they can see my router but they cannot reliably connect. It keeps on dropping out and is unusable.

2. I have tried to connect Lighthouse to different routers and get the same problem.

3. Various other USB wireless adaptors, with for instance rt73 chips, work fine, but it is a nuisance having them hanging out of the laptop.

4. I think I read somewhere that r8180 has had problems in the past.

5. It seems to be a wpa_supplicant problem. When I compare the sizes of 32 bit versions to the 64 bit version on Lighthouse the former has 789kB, whilst the later has only 353kB. And if I am interpreting the data right the 32 bit puppies versions are much newer.

6.1 To test whether it could be a wpa_supplicant issue I have downloaded the latest wpa_supplicant-2.0 source code, unpacked it, did minimal changes to the defconfig file and did the make and make install. I have then replaced the wpa_supplicant, wpa_cli and wpa_passphrase in /usr/sbin with my newly created ones. Amended /etc/network-wizard/wireless/wpa_profiles/wpa_supplicant.conf to include my ssid and psk.

6.2 Trying Network Wizard did not work, which is not surprising.

6.3 However, the following terminal commands did.
rm /var/run/wpa_supplicant/*
wpa_supplicant -i wlan0 -D wext -c /etc/network-wizard/wireless/wpa_profiles/wpa_supplicant.conf -dd.
It automatically gave me my IP, etc.

7. What I have done is very crude. The size of wpa_supplicant has increased to 2520kB. I am sure that more knowledgeable people can point out what I have done wrong.

Thanks for any help
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 3634
Location: Earth

PostPosted: Thu 26 Sep 2013, 19:29    Post subject: WIFI issue when username and password is required in LH602  

Just ran into a LightHouse 602 Wifi setup issue on a laptop.

Scenario
It seemingly is hurdled in FATDOG but not sure how to solve this in Lighthouse. The FATDOG solution lies in its available use of WGA_GUI appl where a username and password can be entered to authenticate on some networks which require, both, to authenticate LAN use allowing the PC to be given an IP personality for navigation.

Frisbee, when used, ONLY will show the "password" requirement request-box, with no ability to enter the accompanying username. when the appropriate network is selected.

Question
  1. Is there an equivalent to WGA_GUI or is it available as a PET for use with such networks? (looking for a setup dialogue which will present the username and password boxes when the network is selected)
  2. AND, if used, will subsequent use of Frisbee then show a configuration for what was setup by the other configuration tool (assuming "suplicant" is standard in the system for the network toolset)?
Any help or further steering would be appreciated. Thanks in advance

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
peterw

Joined: 19 Jul 2006
Posts: 57
Location: UK

PostPosted: Sun 29 Sep 2013, 05:28    Post subject: Wireless Setup
Subject description: r8180 module difficulties and wpa_supplient
 

Hi gcmartin

Thank you for helping. I need to update you on progress or lack of it.

I have retried Fatdog and got "similarish" results in that using it as is, I got nowhere. When I tried connecting it gave me an almost immediate "Can't Connect" even though it can see my network. When I compiled the latest version of wpa_suppliment in it, it did try for much longer but still failed to connect.

I have been messing about with Lighthouse but have not got much further. Frisbee has a useful system to collect diagnostic information but I have not got far with coming to grips with what it is telling me.

I decided that I would buy one of the nano sized usb wifi sticks (they are very cheap) and hope that it has not got a r8180 IC system inside it. It should arrive within 3 days and it should overcome my problem of large usb sticks hanging out of the laptop.

This r8180 module on 64 bit systems is a niggle that I keep coming back to. Every time I learn a little more about Linux. The beauty of Puppy is that it is so easy to install various versions and try them. If you muck them up it is very easy to go back to a square one situation by copying the initrd and vmlinuz files across and deleting the save file before starting again.

Thanks
peterw
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4309
Location: Southeast Georgia, USA

PostPosted: Sun 29 Sep 2013, 16:28    Post subject: VLC problem with mp4 file  

I'm getting the following error from VLC 2.0.6 when trying to play a mp4 file recorded with a camcorder.

Quote:

http://nevils-station.com/images/misc1/ehbcvlc1.jpg


Anyone know how to fix it, please?

The video plays fine at first then this window pops up, the audio drops out, then the video gets all scrambled.

The video plays perfectly from the camcorder into a large screen HDTV TV via a HDMI cable.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4309
Location: Southeast Georgia, USA

PostPosted: Mon 30 Sep 2013, 13:05    Post subject: Re: lamp
Subject description: uploading
 

Q5sys wrote:

There's a new version of Openshot under development right now that will completely blow away the old version. The new functionality it'll have will be amazing, including being able to offload rendering to another machine.
Because Jon's focusing on v2 development, I think work on v1.x is stalled except for minor bug fixes here and there.


Any news re. OpenShot for LH64-602b?

I am desperate for a Linux video editor that works.

Avidemux has proved a dead-end.

Thanks!

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 25 of 32 [466 Posts]   Goto page: Previous 1, 2, 3, ..., 23, 24, 25, 26, 27, ..., 30, 31, 32 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1133s ][ Queries: 13 (0.0134s) ][ GZIP on ]