Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 22:34
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
X-precise-2.4 Final
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 6 of 24 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, ..., 22, 23, 24 Next
Author Message
rg66


Joined: 23 Jul 2012
Posts: 512
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Sun 08 Sep 2013, 01:20    Post_subject: Re: 2.1 Delta Md5  

KJ wrote:
What am I doing wrong? I have D/Led the 2.1 delta twice and Gtkhash shows the MD5 as a8e69f7d0d34c8565ac775289f64fbc9 not c406bbdce626a5da8d2025cb268d5642 as X-precise-2.1.iso-md5.txt indicates. MD5 for main X-precise-2.0.iso checks good. Thanks... KJ


Delta md5 is a8e69f7d0d34c8565ac775289f64fbc9
ISO md5 is c406bbdce626a5da8d2025cb268d5642

I dl'ed the delta and made an ISO and everything checks out.

_________________
Carolite-1.2 / Carolina-1.2 / X-precise-2.4 / X-slacko-2.1
Carolina
X-precise/X-slacko
Back to top
View user's profile Send_private_message 
rg66


Joined: 23 Jul 2012
Posts: 512
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Sun 08 Sep 2013, 01:28    Post_subject: Re: acpid  

Marv wrote:
Running fine, terminal preferences now work. Acpid in 2.1 needed the following changes to get suspend on lid closure for me. In /root/Startup/9acpid, change line 4 from acpid to /usr/sbin/acpid. This will start the full acpid, not the busybox via the symlink in /sbin. In /etc/acpi/lid.sh, replace * with LID in line 8.


Thanks Marv, I just got my pae laptop running again so I'll check out suspend on lid closure and your changes.

Edit: That seems to do the trick. Shutdown by power button also works now, thanks again. I'll wait a few days for more bugs then do another delta

_________________
Carolite-1.2 / Carolina-1.2 / X-precise-2.4 / X-slacko-2.1
Carolina
X-precise/X-slacko
Back to top
View user's profile Send_private_message 
rg66


Joined: 23 Jul 2012
Posts: 512
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Sun 08 Sep 2013, 05:28    Post_subject:  

@pchan and 666philb

I failed to get compiz working from the repo but I did get it working using the Carolina packages, not all effects seem to work though.

Download and install:

http://smokey01.com/carolina/pet_packages-carolina/Python-2.7.2-i486.pet
http://smokey01.com/carolina/pet_packages-carolina/GConf-3.2.3-i486.pet
http://smokey01.com/carolina/pet_packages-carolina/Pyrex-0.9.9.pet
http://smokey01.com/carolina/pet_packages-carolina/compiz-0.8.8-i486.pet

Install compiz last and give it a try. There will be three entries in Control Panel > Desktop: compizconfig, emerald theme manager and enable/disable compiz.

_________________
Carolite-1.2 / Carolina-1.2 / X-precise-2.4 / X-slacko-2.1
Carolina
X-precise/X-slacko
Back to top
View user's profile Send_private_message 
pchan

Joined: 12 Oct 2012
Posts: 86

PostPosted: Sun 08 Sep 2013, 06:28    Post_subject:  

rg66 ,

A great thanks! You are my puppy linux saviour.

Yes, compiz worked now in my 10 inch acer aspire one d257 netbook.
(connected to an external 15 inch lcd screen)

I did notice that the enhanced zoom failed to work though. Compiz enhanced Zoom is a very useful feature for those with weak eye sight

(Features like this cannot be found in windows xp/7 even until now. The closest windows software that I know off is "zoomit." But it is not as perfect as the compiz enhanced zoom.)

I am sure when many people with weak eye sight come to know about the Compiz enhanced Zoom, they will appreciate it very much.

Anyway, compiz other features are also great and does make everything so much more inspiring and lively.
Back to top
View user's profile Send_private_message 
rg66


Joined: 23 Jul 2012
Posts: 512
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Wed 11 Sep 2013, 13:13    Post_subject:  

X-precise v2.1.1 has been released.

Acpi fixes, delta only at 500kb. http://www.carolina-linux.com/rg66/X-precise/iso/X-precise-2.1.iso___X-precise-2.1.1.iso.delta
If you don't want to make a new iso I've made an update pet, see below.

Many thanks to Marv for help with the acpid script and for testing.

I've uploaded a non-pae delta for testing (24MB), you will need to make a v2.1.1 iso first. If there are no major issues I will upload an iso. http://www.carolina-linux.com/rg66/X-precise/iso/X-precise-2.1.1.iso___X-precise-2.1.1-non-pae.iso.delta

md5sum: http://carolina-linux.com/rg66/X-precise/iso/md5sum_all.txt
X-precise-2.1.1-update.pet
Description 
pet

 Download 
Filename  X-precise-2.1.1-update.pet 
Filesize  1.05 KB 
Downloaded  138 Time(s) 

_________________
Carolite-1.2 / Carolina-1.2 / X-precise-2.4 / X-slacko-2.1
Carolina
X-precise/X-slacko
Back to top
View user's profile Send_private_message 
mikeslr


Joined: 16 Jun 2008
Posts: 783
Location: Union New Jersey USA

PostPosted: Thu 12 Sep 2013, 20:42    Post_subject: X-precise-2.1.1 PAE working on Asprire One D270
Sub_title: Intel's PowerVR SGX 545-based GMA 3600 AKA CedarView
 

Hi rg66,

Thank you again for continuing work on a great Pup. I reported on the Puppy on Laptop thread that it works on the Acer Aspire One D270 because of the importance of that information to those burdened by any of the chips listed in the above sub-heading. When computers bearing them came to market, drivers were developed only by Ubuntu Precise Pangolin. As far as I can tell, Ubuntu hasn't for subsequent releases. And pleas for assistance together with silence from "major" distribution suggest that perhaps Puppy is the only distribution generating operating systems which handle them.
Like most netbooks, the D270 is sold with only 1 Gb of RAM. It can support a maximum of 2 Gbs. So I'll be interested in finding out if the non-Pae kernel will work. Which kernel did you use?
Because it enabled me to search for, as well as listen to, streaming radio, one of my favorite apps under Carolina was Clementine. If I recall correctly, it had Qt as a dependency. It was based on Amarok, which after a long period of inaction has just release version 2.8. In the interim, I suspect that those who developed Clementine found other things to do. I'm guessing and would be interested in what actually happened, is happening.
While there are other apps for playing radio streams, finding them when you're on vacation and the ones you like may not be available is another story.
Suggestions on how to get Clementine working, or an alternative for finding and playing radio stream would be welcome.

mikesLr
Back to top
View user's profile Send_private_message 
rg66


Joined: 23 Jul 2012
Posts: 512
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Sat 14 Sep 2013, 01:00    Post_subject:  

@mikeslr

Good to hear your liking X-precise, it makes all the effort worth while.

The kernel in non-pae is 3.2.48

Did you try installing clementine from the repo? Looking at it and all the deps in ppm did my head in so I didn't try. I really miss a dedicated repo like Carolina has.

Mplayer does play streaming audio, open Mplayer > File > Open location and paste a url. As an example, I pasted http://www.bbc.co.uk/radio/listen/live/r1_aaclca.pls and it played no probs.

_________________
Carolite-1.2 / Carolina-1.2 / X-precise-2.4 / X-slacko-2.1
Carolina
X-precise/X-slacko
Back to top
View user's profile Send_private_message 
mikeslr


Joined: 16 Jun 2008
Posts: 783
Location: Union New Jersey USA

PostPosted: Sat 14 Sep 2013, 21:12    Post_subject: non-pae doesn't support Acer D270's graphics  

Hi rg66,

I built the non-pae iso and installed it on the Acer Aspire One D270. Didn't boot to desktop, hanging on a grey screen. Don't feel bad. As I said above the PAE-enabled version works fine. I don't think the graphics chip was supported before the 3.6 kernel, maybe even later.
I'll try the clementines again and take careful notes as to what Pups say are missing/going wrong.
Keep up the good work. Rome wasn't built in a day. Then, again, neither was Detroit.

mikesLr
Back to top
View user's profile Send_private_message 
rg66


Joined: 23 Jul 2012
Posts: 512
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Mon 16 Sep 2013, 13:39    Post_subject:  

FYI

I'm currently working on X-slacko-1.0 based on slacko 5.6, that should be released in a day or two. A non-pae version is also in the plans.

X-precise and non-pae 2.2 will come out sometime after that. There are only a few small changes, nothing important as of yet.

_________________
Carolite-1.2 / Carolina-1.2 / X-precise-2.4 / X-slacko-2.1
Carolina
X-precise/X-slacko
Back to top
View user's profile Send_private_message 
pchan

Joined: 12 Oct 2012
Posts: 86

PostPosted: Tue 17 Sep 2013, 05:51    Post_subject:  

Hi rg66,

I am glad that you are going to create x slacko.

At least there will be more choices.

Precise is great but I just couldn't understand how to correctly use the pakage manager.

I tried to download filezilla using pakage manager and even agreed to download all the dependencies pakage manager suggested. Unfortunately it didn't work. There was no menu entry in the first place. I searched /user/share/ but I just can't find a way to start filezilla.

Finally, I downloaded filezilla from lucid repo. After installing it, everything went smoothly. I was happy to see a menu entry. i could launched filezilla easily and very quickly, I could download and upload files from my Android tablet.

The same thing happened with bleachbit. After downloading bleachbit with all the dependencies, I couldn't get it to work.

In the case of mousepad, i decided not to download all the dependencies pakage manager suggested because it is just a simple text editor. I received a warning from pakage manager. But nevertheless, mousepad worked.

So, i think precise is great because it has some compatibility with ubuntu precise. However, using pakage manager can be quite a hassle. It is better to go to your xprecise link and download apps for manual installations. Unfortunately, apps in quirky / precise are very limited.

Since lucid is also from ubuntu, I may be wrong but it looks like apps from lucid will stand better chance of working with puppy precise.

I like to continue using precise puppy even though i am struggling with pakage manager. I do like slacko and i find that slacko has always been stable. Slack always proved to be a good base for puppy linux. Apps are also quite easy to find thanks to 01micko.

Looking forward to slacko with some saluki/carolina flavor.
Back to top
View user's profile Send_private_message 
dawg

Joined: 09 Aug 2009
Posts: 113
Location: still here

PostPosted: Wed 18 Sep 2013, 07:03    Post_subject:  

This is most excellent to have a Lina-flavoured (Xfce, Thunar, Adrive) "regular" Puppy! (I had thought about it myself at some point, in fact, but I've been away...)

Looking forward to the Slacko version, as for some reason, I'm not fond of Ubuntu puppies; maybe it's the Ubuntu repositories' short "expiration dates", and perhaps also some Barry's "quirks".
And I've been wondering what's with the sudden, somewhat recent growing-in-size of the flagship puppies, as Puppy used to be tiny (100-120 MB).
But I digress...

Thanks for all your efforts, rg66 ! Looking forward to your releases!

PS: If possible, maybe you could make some sort of a "multi-Puppy Lina conversion pack". You know - a PET or SFS to install onto the "regular" puppies as new versions get released, thereby converting them to "Lina/Saluki" easily and quickly. But I realize this might not be such an easy task due to some differences among the distros (I guess?).

COME TO THINK OF IT, I've been wondering before, how come the flagship Puppies haven't adopted the Xfce/Thunar yet, as it is more "familiar" to Windows users and other non-Puppy Linux users, and thereby easier to transition to!
Maybe it used to be the size "issue", but it is now time for this "upgrade"?
I don't hate JWM/Rox, but it's kind of "1995" (i.e. not very "attractive").

_________________
I used to only like Puppy as a friend, but now I think our relationship is starting to develop into something more... Very Happy
Back to top
View user's profile Send_private_message 
ICQ 
rg66


Joined: 23 Jul 2012
Posts: 512
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Wed 18 Sep 2013, 10:28    Post_subject:  

@ dawg

Thanks, It's good to hear a few people are enjoying X-precise.

X-slacko is just about ready to release, just have to go over it and see what I missed/forgot and add adrive support. Should be out within the next 24 hrs.

I'm not sure why there are few Xfce puppies, it's a lot easier for Windows users to migrate to linux. Lxde is ok but I don't really like jwm/rox. As you can tell by my avatar, I'm a huge Xfce fan.

As far as a "conversion pack" goes, I was thinking of something like that but It might be a lot harder than it seems to have it work on different puppies. You never know, I might have a go at it one of these days.

_________________
Carolite-1.2 / Carolina-1.2 / X-precise-2.4 / X-slacko-2.1
Carolina
X-precise/X-slacko
Back to top
View user's profile Send_private_message 
yr1945

Joined: 17 Apr 2010
Posts: 140

PostPosted: Wed 18 Sep 2013, 10:42    Post_subject:  

X-precise -vs- X-slacko.... is there a benefit of one Xfce puppy over the other... or, is it just a preference?

Since it's introduction, I have been using X-precise as my main distro...
Back to top
View user's profile Send_private_message 
rg66


Joined: 23 Jul 2012
Posts: 512
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Wed 18 Sep 2013, 11:27    Post_subject:  

yr1945 wrote:
X-precise -vs- X-slacko.... is there a benefit of one Xfce puppy over the other... or, is it just a preference?

Since it's introduction, I have been using X-precise as my main distro...


I'm not sure if there is too much difference other than the repo and a few apps. I've never tried woof but I would assume it uses Ubuntu or Slackware packages for building precise or slacko.

I decided to do X-slacko because it seems quite popular and I'm hoping the repo will be better. I'm currently using X-precise as my main OS but will switch to X-slacko when it's finished and pick the one I like the best.

_________________
Carolite-1.2 / Carolina-1.2 / X-precise-2.4 / X-slacko-2.1
Carolina
X-precise/X-slacko
Back to top
View user's profile Send_private_message 
kickstart


Joined: 09 Mar 2011
Posts: 86

PostPosted: Thu 19 Sep 2013, 11:40    Post_subject:  

Over the last couple of years I have been trying various breeds of Puppy to find one that suits both me and my laptop so I can kick my Microsoft dependency into touch.
I really like X-precise 2.1.1 so far plus every other PAE enabled Pup I have tried has produced an unusual amount of processor activity at times, even with no applications running. With X-precise the processor is quieter with far less heat being thrown out by the fan.

However there is one glitch. I can’t double click and drag windows using the touchpad, neither can I drag the sliders on the scroll bar. Everything is fine using a mouse. When I try to use flSynclient to try and change touchpad parameters I get the error message “Couldn’t find synaptics properties. No synaptics driver loaded?” Does anyone know if there is a pet available to install the driver? I have looked but can’t find one.

Incidentally in the non-PAE version the touchpad works normally but the synaptic driver error still comes up when trying to use flSynclient.

I have just noticed X-slacko is available so I will give it a try this evening.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 6 of 24 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, ..., 22, 23, 24 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0984s ][ Queries: 13 (0.0084s) ][ GZIP on ]