Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 21 Nov 2014, 08:29
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
wifi on dell mini broadcom-5.10.27.14-k2.6.25.16.pet
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
linuxnovo

Joined: 21 Sep 2009
Posts: 27

PostPosted: Fri 23 Aug 2013, 01:08    Post subject:  wifi on dell mini broadcom-5.10.27.14-k2.6.25.16.pet
Subject description: error on installing pet, no wl driver
 

Sad help.....I am booting puppy 4.31 on a dell mini 9 from a usb. There is no battery or hard drive on this unit. Each boot is fresh.

I am writing on this unit using a usb wireless card which makes a wlan0 which will contact the internet. I want to use the internal wireless. Without the wireless usb there is no wlan0.

When I install the pet noted above which should install the wl diriver. It does install but tries to edit a file with an editor and gives the error unable to open file.

also, I used the following commands:

rmmode b43 this gives no error
rmmode ssb this gives no error
rmmode wl error no such module
modeprobe wl no such module.

I hope someone can help.

I
Back to top
View user's profile Send private message 
ardvark


Joined: 01 Jul 2013
Posts: 1086
Location: USA

PostPosted: Fri 23 Aug 2013, 03:50    Post subject:  

Hi...

Please open a terminal and type in...

Code:
lspci


and post the contents. If you are unable to copy and paste using the default terminal, you can open the Puppy Package Manager and install "sakura" (another terminal,) which will give you this ability. Smile

Thanks...

_________________
Our Lord and Savior Jesus Christ loves and cares about you most of all!

PLEASE READ! You don't have to end up here!
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 634

PostPosted: Fri 23 Aug 2013, 10:17    Post subject:  

Puppy 4.31 has kernel 2.6.30.5 so you are using the wrong pet. If you are sure that wl driver for puppy 4.31 is needed I have a copy of it compiled by me. Post the result of:

Code:
lspci


as you have been adviced. If you need wl.ko for puppy 4.31 then I can post it.
Back to top
View user's profile Send private message 
linuxnovo

Joined: 21 Sep 2009
Posts: 27

PostPosted: Sat 14 Sep 2013, 10:53    Post subject: Sorry about late reply  

Thanks for the interest. I have been out of the picture for a while due to other work. The relevant lspci is the line:

14e4:4315 (rev 01)

Yes, the kernel is as you indicated watchdog

Would much like the appropriate .pet if you could manage it.

linuxnovo
Back to top
View user's profile Send private message 
jrb


Joined: 11 Dec 2007
Posts: 1040
Location: Smithers, BC, Canada

PostPosted: Sat 14 Sep 2013, 14:32    Post subject: pup-431bcm4312v3.iso
Subject description: special puppy for wl wifi
 

Hi linuxnovo,

This problem was solved some time ago. See http://www.murga-linux.com/puppy/viewtopic.php?p=375735#375735 and follow the link to http://www.wisdom-seekers.com/puppy/pup-431bcm4312v3.iso.

Cheers, J
Back to top
View user's profile Send private message 
linuxnovo

Joined: 21 Sep 2009
Posts: 27

PostPosted: Sat 14 Sep 2013, 20:38    Post subject: broadcom wl
Subject description: am using the iso you indicated
 

Thanks for the 4.31 iso. I found it on my own and am running it. The wifi works! However, I need to modify the 4.31 that I am using because it has slime built in which I am interested in using. So I will have to remaster the 4.31 that I am using to be able to use the slime, emacs and lisp which I am interested in learning.

This seems to be a project in itself. linuxnovo
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 634

PostPosted: Sun 15 Sep 2013, 03:59    Post subject:  

Try this pet and let me know if it works. Install it and reboot.

https://docs.google.com/file/d/0B9iMb4UZBeFkNktFSlRhbVg0TFE/edit?usp=sharing
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5281
Location: Australia

PostPosted: Sun 15 Sep 2013, 06:14    Post subject:  

watchdog wrote:
Puppy 4.31 has kernel 2.6.30.5 so you are using the wrong pet.

Correct ... But there's no need to reinvent the wheel.
I posted a comprehensive collection of third-party drivers for Puppy 4.3x when it was released in 2009 -
"Extras for Puppy 4.3 with 2.6.30.5 kernel"

The vendor-supplied Broadcom "wl" driver is near the bottom of the first page -
http://www.murga-linux.com/puppy/viewtopic.php?p=346454#346454
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0557s ][ Queries: 12 (0.0034s) ][ GZIP on ]