Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 10:56
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Install BarryK's SoftMaker Office 2008 .pet in older Puppies
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Wed 05 Oct 2011, 23:39    Post_subject:  Install BarryK's SoftMaker Office 2008 .pet in older Puppies
Sub_title: 2.14X / 3.01 / 4.x; also Wary 5.x
 

Edit: 9/17/2013:
I wrote (via e-mail):

Quote:
Are registration keys still available for SoftMaker Office 2008 (free version)?
Thank you.

SoftMaker replied:
Quote:
No, but you can use FreeOffice instead:
www.freeoffice.com
Best regards
SoftMaker Team


(special thanks to sickgut)

With 4.x and Wary 5.x Puppies, SoftMaker Office 2008 installs, but won't launch from Menu.
Dependency check shows nothing is needed.
However, launching from terminal generates gtkdialog error.

I've only tested this with one computer.
(Compaq Deskpro PII / 350MHz)
So results may vary, depending on hardware.

GTK / libs were installed all at once, followed by reboot.

Links to required packages:

deb2pet.rpm2pet-0.0.4.pet
glib-2.22.2-p4.pet
gtkdialog4-246-w5.pet
libc6_2.11.2-10_i386.deb
softmakeroffice-2008-bk.pet

This SoftMaker Office 2008 .pet can be installed either before or after dependencies are installed.

I've tested with below-listed Puppies:

Classic Pup 2.14xRC5:
* Install softmakeroffice-2008-bk.pet.
* Click Menu / Refresh menu.
Extra details in my post here.
ttuuxxx said next 2.14x (after Top9) will have glib-2.28.8.
I don't know if this will affect anything.

Puppy Linux 3.01 / 4.1.2:
(haven't tested 4.2.x; probably the same)
Must install dependencies in following order:
* Install glib-2.22.2-p4.pet.
* Install deb2pet.rpm2pet-0.0.4.pet.
* Right-click libc6_2.11.2-10_i386.deb, then left-click Convert to pet.
* Install newly created libc6_2.11.2-10_i386.pet.
* Install gtkdialog4-246-w5.pet.
* Save and reboot.
* Install softmakeroffice-2008-bk.pet.
* Click Menu / Shutdown / Restart JWM.
This might turn Puppy-Podcast-Grabber into a zombie.
("Kill" might not kill it.)
So try this: Menu / Shutdown / Restart X server.

Puppy Linux 4.3.1:
Must install dependencies in following order:
* Install libc6_2.11.2-10_i386.deb; 4.3.1 installs .debs as-is.
* Install gtkdialog4-246-w5.pet.
* Save and reboot.
* Install softmakeroffice-2008-bk.pet.
See above; same Puppy-Podcast-Grabber problem.

Wary 5.1.1:
* Install gtkdialog4-246-w5.pet.
* Save and reboot.
* Install softmakeroffice-2008-bk.pet.

Edited_times_total
Back to top
View user's profile Send_private_message 
tuxtoo


Joined: 14 Dec 2010
Posts: 116
Location: North Yorkshire, UK

PostPosted: Sat 14 Jul 2012, 17:58    Post_subject: Wary language fix  

I noticed on Barry’s Blog http://bkhome.org/blog/?viewDetailed=02435, one of the comments says;

“Also, it comes with language English (US) and spellchecker English (US). I can't see any option to change this or download appropriate language file and dictionary for (in my case) English (UK).”

I tried Barry’s cut-down version using the live CD of Wary-512. Installing 'softmakeroffice-2008-bk.pet' and 'gtkdialog4-246-w5.pet' worked fine but had the same problem with selecting the English (UK) language.

I have a HD install (Wary-512) with the full version of SMO-2008 and I noticed that Barry’s version has a missing file, namely- ‘language.cfn’ from /usr/share/office2008/spell. So I have made a dotpet to install this missing file.
SMO-bk_lang_fix.pet
Description  UK English fix for softmakeroffice-2008-bk.pet for Wary. Not sure for other versions.
pet

 Download 
Filename  SMO-bk_lang_fix.pet 
Filesize  4.85 KB 
Downloaded  362 Time(s) 
Back to top
View user's profile Send_private_message Visit_website 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Sat 14 Jul 2012, 23:30    Post_subject:  

BarryK has uploaded corrected versions of Softmaker Office 2008, which include the missing English (UK) language file:
softmakeroffice-2008-1-x86.pet
softmakeroffice_DOC-2008-1-x86.pet
softmakeroffice_NLS-2008-1-x86.pet
Back to top
View user's profile Send_private_message 
tuxtoo


Joined: 14 Dec 2010
Posts: 116
Location: North Yorkshire, UK

PostPosted: Sun 15 Jul 2012, 09:21    Post_subject:  

Dewbie wrote:
BarryK has uploaded corrected versions of Softmaker Office 2008, which include the missing English (UK) language file:
softmakeroffice-2008-1-x86.pet
softmakeroffice_DOC-2008-1-x86.pet
softmakeroffice_NLS-2008-1-x86.pet


Thanks Dewbie. I missed that one.
Back to top
View user's profile Send_private_message Visit_website 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Sun 15 Jul 2012, 18:39    Post_subject:  

Please note:
I haven't changed the SoftMaker Office 2008 link in the first post.
It's still the older version, minus the UK language pack.
I'm leaving it as-is to avoid any confusion.
Back to top
View user's profile Send_private_message 
darry1966

Joined: 26 Feb 2012
Posts: 430
Location: New Zealand

PostPosted: Tue 10 Sep 2013, 22:34    Post_subject: Re: Install BarryK's SoftMaker Office 2008.pet in older Puppies
Sub_title: 2.14X / 3.01 / 4.x; also Wary 5.x
 

Dewbie wrote:
(special thanks to sickgut)

With 4.x and Wary 5.x Puppies, SoftMaker Office 2008 installs, but won't launch from Menu.
Dependency check shows nothing is needed.
However, launching from terminal generates gtkdialog error.

I've only tested this with one computer.
(Compaq Deskpro PII / 350MHz)
So results may vary, depending on hardware.

GTK / libs were installed all at once, followed by reboot.

Links to required packages:

deb2pet.rpm2pet-0.0.4.pet
glib-2.22.2-p4.pet
gtkdialog4-246-w5.pet
libc6_2.11.2-10_i386.deb
softmakeroffice-2008-bk.pet

This SoftMaker Office 2008 .pet can be installed either before or after dependencies are installed.

I've tested with below-listed Puppies:

Classic Pup 2.14xRC5:
* Install softmakeroffice-2008-bk.pet.
* Click Menu / Refresh menu.
Extra details in my post here.
ttuuxxx said next 2.14x (after Top9) will have glib-2.28.8.
I don't know if this will affect anything.

Puppy Linux 3.01 / 4.1.2:
(haven't tested 4.2.x; probably the same)
Must install dependencies in following order:
* Install glib-2.22.2-p4.pet.
* Install deb2pet.rpm2pet-0.0.4.pet.
* Right-click libc6_2.11.2-10_i386.deb, then left-click Convert to pet.
* Install newly created libc6_2.11.2-10_i386.pet.
* Install gtkdialog4-246-w5.pet.
* Save and reboot.
* Install softmakeroffice-2008-bk.pet.
* Click Menu / Shutdown / Restart JWM.
This might turn Puppy-Podcast-Grabber into a zombie.
("Kill" might not kill it.)
So try this: Menu / Shutdown / Restart X server.

Puppy Linux 4.3.1:
Must install dependencies in following order:
* Install libc6_2.11.2-10_i386.deb; 4.3.1 installs .debs as-is.
* Install gtkdialog4-246-w5.pet.
* Save and reboot.
* Install softmakeroffice-2008-bk.pet.
See above; same Puppy-Podcast-Grabber problem.

Wary 5.1.1:
* Install gtkdialog4-246-w5.pet.
* Save and reboot.
* Install softmakeroffice-2008-bk.pet.


For Puppy Linux 3.01, probaly series 4 as well I have found you can use Glib-2.28.8 from Wary puppy herehttp://distro.ibiblio.org/quirky/pet_packages-wary5/glib-2.28.8-w5c.pet. Better for compiling stuff.
Back to top
View user's profile Send_private_message 
mikeb


Joined: 23 Nov 2006
Posts: 8257

PostPosted: Wed 11 Sep 2013, 07:00    Post_subject:  

Quote:
deb2pet.rpm2pet-0.0.4.pet
glib-2.22.2-p4.pet
gtkdialog4-246-w5.pet
libc6_2.11.2-10_i386.deb


whats going on here...I have softmaker office running as it comes in standard puppy 2 and newer... none of the above should be needed? Its built to run on pretty much anything.

baffled

Mike
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Wed 11 Sep 2013, 14:45    Post_subject:  

mikeb wrote:
Quote:
whats going on here...I have softmaker office running as it comes in standard puppy 2 and newer... none of the above should be needed? Its built to run on pretty much anything.

baffled

Mike

Now I'm baffled...
You are referring to the 2008 version, correct?

And are you referring to BarryK's .pet?
(still available in Wary repo)

Or SoftMaker's official Linux build?
(which is no longer available)

Or ttuuxxx's .pet?
(also no longer available)

(If BarryK's version ran out of the box, no way would I have gone through all that...)
Back to top
View user's profile Send_private_message 
mikeb


Joined: 23 Nov 2006
Posts: 8257

PostPosted: Wed 11 Sep 2013, 15:49    Post_subject:  

Hmm ok well my bafflement is that I have run softmaker 2008 (the free one) and more recently the charity release they gave out 'as is' on any puppy I tried. Launched from the menu in the usual way though the newer version needed the desktop files moving.
So perhaps I am curious as to what exactly has done to it to make it so incompatible/in need of serious system core library changes....from what I see it revolves around gtkdialog 4 though why thats involved is a slight mystery.


regards
mike

Edited_time_total
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Fri 13 Sep 2013, 05:05    Post_subject:  

mikeb wrote:
Quote:
So perhaps I am curious as to what exactly has done to it to make it so incompatible/in need of serious system core library changes....from what I see it revolves around gtkdialog 4 though why thats involved is a slight mystery.


What I don't get is this:
BarryK's SoftMaker Office 2008 .pet installs and runs out of the box in Classic Pup 2.14xRC5.
But it needs the gtkdialog upgrade in Wary 5.1.1, which was released almost a year later.

Edited_times_total
Back to top
View user's profile Send_private_message 
mikeb


Joined: 23 Nov 2006
Posts: 8257

PostPosted: Fri 13 Sep 2013, 10:05    Post_subject:  

Quote:
Classic Pup 2.14xRC5.

I believe ttuuxxx did update core libraries in this so mainly the kernel and Xorg are left as original.
Quote:
But it needs the gtkdialog upgrade in Wary 5.1.1,

so we stil have the 'why gtkdialog 4' mystery!

I also used the same package built as sfs 4 for Lucid and that works just the same so good for any recent puppy.

Well at least we have something available for older pups that does not need any updates.

By the way softmaker is modular unlike libreoffice so I made a textmaker only sfs which came to just 11MB.... probably similar to abiword + dependancies.

mike

Edited_time_total
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Fri 13 Sep 2013, 22:42    Post_subject:  

mikeb wrote:
Quote:
so we still have the 'why gtkdialog 4' mystery!

Ahhh...I just remembered! Very Happy
BarryK wrote, here:
Quote:
SoftMaker Office 2008 is free, but requires registration to use. I have made it into a PET package. This is fully integrated into Puppy, I worked on it all morning to make it so. Mime handling with ROX-Filer also.

The first time that you run it, my special 1st-start script runs, which takes you to the SoftMaker site to obtain the license-key.

That 1st-start script involves a (gtk)dialog box.
And the gtkdialog version in later Wary builds is newer.

Edited_time_total
Back to top
View user's profile Send_private_message 
mikeb


Joined: 23 Nov 2006
Posts: 8257

PostPosted: Sat 14 Sep 2013, 03:14    Post_subject:  

Hmm using gtkdialog v3 would have been friendlier.

As you know though a premade profile solves the registration need Smile

mike

edit though registering does get you free fonts now and then and discounts on software...

A link to their download/registration page should be all thats needed...
http://www.freeoffice.com/en/download

Just to clarify for anyone reading this thread the later free version is a cut down of the 2012 edition and thats what is offered on the site and the registration is for.
Back to top
View user's profile Send_private_message 
mikeb


Joined: 23 Nov 2006
Posts: 8257

PostPosted: Tue 08 Oct 2013, 18:59    Post_subject:  

A present for you

gtkdialog4 built on puppy 4.12.

All that may be needing adding is a matching libgio from the glib package if not already there.

So for the sake of 2 tiny mods to the sources we can have gtkdialog4 on our older pups.... seems to be compatible with gtkdialog3 scripts which is nice so could probably simply drop in as a replacement for that too.... so happy with gtk 2.12 and glibc 2.61 basically.

mike
gtkdialog4-pup4.tar.gz
Description 
gz

 Download 
Filename  gtkdialog4-pup4.tar.gz 
Filesize  90.18 KB 
Downloaded  146 Time(s) 
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Tue 08 Oct 2013, 21:17    Post_subject:  

Thanks for posting, Mike. Smile
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1022s ][ Queries: 13 (0.0047s) ][ GZIP on ]