Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Aug 2014, 23:40
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Samsung Printer/Scanner Drivers - Updated 2013
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 5 [68 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 9040
Location: Stratford, Ontario

PostPosted: Wed 20 Feb 2013, 05:58    Post subject:  

Which Puppy are you using?

I notice "direct hp" in your list. That indicates that you have an HP printer installed. But then you should also see a "direct usb://" entry for that printer.

This is not a CUPS or Samsung problem. Something has gone wrong with your USB detection.

Boot off your Live CD using "puppy pfix=ram" and check for printers.
Back to top
View user's profile Send private message 
Spaccafumo


Joined: 15 Jan 2009
Posts: 33
Location: Sulmona - Italy

PostPosted: Wed 06 Mar 2013, 01:27    Post subject: Samsung ML-2010R
Subject description: Working driver.
 

This driver works with laser monocrome printer
Samsung ML-2010R:

Before copying it in '/usr/share/cups/model' i found very useful to reinstall cups by this file: 'cups-install-v0.3.pup'. I am not able to upload it now. Maybe because it weighs more then 18 mb.
Samsung-ML-2010-gdi.ppd.gz
Description 
gz

 Download 
Filename  Samsung-ML-2010-gdi.ppd.gz 
Filesize  5.39 KB 
Downloaded  403 Time(s) 
Back to top
View user's profile Send private message 
irishrm


Joined: 14 Mar 2009
Posts: 210

PostPosted: Thu 16 May 2013, 17:53    Post subject:  

Just wanted to say thanks to rcrsn 51 for his Samsung printer pet.

Purchased a Samsung 2162 printer and had it installed in three different puppies in no time.

Thanks again for the help, much appreciated.

irishrm.
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 123

PostPosted: Wed 29 May 2013, 05:02    Post subject: ML-2165W  

Thanks for maintaining this pet. I'm new to CUPS and linux printers. I downloaded and installed your latest pet, then started CUPS and clicked Find new printers. It immediately found my ML-2165W, which is wifi-connected. I was amazed at how easy it went. Then I clicked to make it the default printer and Print Test Page. I do get some print out, but it isn't a test page, just these five lines
Code:

SPL ERROR - FALSE
   POSITION : 0x1  (1)
   SYSTEM : h6fw)5.57/xl_tbl
   LINE : 403
   VERSION : SPL 5.57 01-12-2012

I'm not sure what it means, I'd guess it is some sort of internal test page. Note: in CUPS I did click Print Test Page, not Self Test Page.
What am I doing wrong?

I run puppy saluki 023, some more info
Code:

# /etc/init.d/cups restart
cups: restarted scheduler.
# lpinfo -v
network socket
network http
network ipp
network lpd
network socket://192.168.0.40
direct scsi
network pdf-writer
network smbc
network smb
# ls /usr/share/cups/model
gutenprint  uld-samsung
#
# ls /usr/share/cups/model/gutenprint/
5.0  5.2
# ls -R /usr/share/cups/model/gutenprint/
/usr/share/cups/model/gutenprint/:
5.0  5.2

/usr/share/cups/model/gutenprint/5.0:

/usr/share/cups/model/gutenprint/5.2:
# ls /usr/share/cups/model/uld-samsung/*2160*
/usr/share/cups/model/uld-samsung/ML-2160.ppd.gz
#


A cryptic (for me) "[Job 6] Unable to open input" stands out in the CUPS error log
Code:

I [29/May/2013:10:22:25 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=7286)
I [29/May/2013:10:22:25 +0200] [Job 5] Adding start banner page "none".
I [29/May/2013:10:22:25 +0200] [Job 5] Adding end banner page "none".
I [29/May/2013:10:22:25 +0200] [Job 5] File of type application/postscript queued by "anonymous".
I [29/May/2013:10:22:25 +0200] [Job 5] Queued on "CUPS-PDF" by "anonymous".
I [29/May/2013:10:22:25 +0200] [Job 5] Started filter /usr/lib/cups/filter/pstops (PID 7287)
I [29/May/2013:10:22:25 +0200] [Job 5] Started backend /usr/lib/cups/backend/pdf-writer (PID 7288)
I [29/May/2013:10:22:26 +0200] [Job 5] Completed successfully.
I [29/May/2013:10:22:28 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=7311)
I [29/May/2013:10:22:49 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=7451)
I [29/May/2013:10:26:02 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=11663)
I [29/May/2013:10:26:14 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=11723)
I [29/May/2013:10:26:21 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=11760)
I [29/May/2013:10:26:21 +0200] Started "/usr/lib/cups/daemon/cups-deviced" (pid=11761)
E [29/May/2013:10:26:21 +0200] [cups-deviced] Bad line from "pdf-writer": Error: /usr/lib/cups/backend/pdf-writer - ps2pdf is not available!
I [29/May/2013:10:26:28 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=11826)
I [29/May/2013:10:26:56 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=11998)
I [29/May/2013:10:26:56 +0200] Started "/usr/lib/cups/daemon/cups-driverd" (pid=11999)
I [29/May/2013:10:27:01 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=12018)
I [29/May/2013:10:27:01 +0200] Setting Samsung_ML-2160_Series_192.168.0.40 device-uri to "socket://192.168.0.40" (was "file:/dev/null".)
I [29/May/2013:10:27:01 +0200] Setting Samsung_ML-2160_Series_192.168.0.40 printer-is-accepting-jobs to 1 (was 0.)
I [29/May/2013:10:27:01 +0200] Setting Samsung_ML-2160_Series_192.168.0.40 printer-state to 3 (was 5.)
I [29/May/2013:10:27:01 +0200] Saving printers.conf...
I [29/May/2013:10:27:01 +0200] New printer "Samsung_ML-2160_Series_192.168.0.40" added by "anonymous".
I [29/May/2013:10:27:07 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=12071)
I [29/May/2013:10:27:54 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=12346)
I [29/May/2013:10:27:54 +0200] Saving printers.conf...
I [29/May/2013:10:27:54 +0200] Printer "Samsung_ML-2160_Series_192.168.0.40" modified by "anonymous".
I [29/May/2013:10:27:59 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=12383)
I [29/May/2013:10:27:59 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=12384)
I [29/May/2013:10:28:10 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=12436)
I [29/May/2013:10:28:10 +0200] Saving printers.conf...
I [29/May/2013:10:28:10 +0200] Saving classes.conf...
I [29/May/2013:10:28:10 +0200] Default destination set to "Samsung_ML-2160_Series_192.168.0.40" by "anonymous".
I [29/May/2013:10:28:15 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=12488)
I [29/May/2013:10:28:15 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=12489)
I [29/May/2013:10:28:19 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=12508)
I [29/May/2013:10:28:24 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=12542)
I [29/May/2013:10:28:26 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=12543)
I [29/May/2013:10:28:30 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=12562)
I [29/May/2013:10:28:48 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=12683)
I [29/May/2013:10:28:48 +0200] [Job 6] Adding start banner page "none".
I [29/May/2013:10:28:48 +0200] [Job 6] Adding end banner page "none".
I [29/May/2013:10:28:48 +0200] [Job 6] File of type application/postscript queued by "anonymous".
I [29/May/2013:10:28:48 +0200] [Job 6] Queued on "Samsung_ML-2160_Series_192.168.0.40" by "anonymous".
I [29/May/2013:10:28:48 +0200] [Job 6] Started filter /usr/lib/cups/filter/pstops (PID 12684)
I [29/May/2013:10:28:48 +0200] [Job 6] Started filter /usr/lib/cups/filter/pstospl (PID 12685)
I [29/May/2013:10:28:48 +0200] [Job 6] Started backend /usr/lib/cups/backend/socket (PID 12686)
E [29/May/2013:10:28:48 +0200] [Job 6] Unable to open input
I [29/May/2013:10:28:50 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=12688)
I [29/May/2013:10:28:53 +0200] [Job 6] Completed successfully.
I [29/May/2013:10:29:00 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=12758)
I [29/May/2013:10:41:06 +0200] Listening to ::1:631 (IPv6)
I [29/May/2013:10:41:06 +0200] Listening to 127.0.0.1:631 (IPv4)
I [29/May/2013:10:41:06 +0200] Listening to /var/run/cups/cups.sock (Domain)
I [29/May/2013:10:41:06 +0200] Remote access is disabled.
I [29/May/2013:10:41:06 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [29/May/2013:10:41:06 +0200] Using default TempDir of /var/spool/cups/tmp...
I [29/May/2013:10:41:06 +0200] Configured for up to 100 clients.
I [29/May/2013:10:41:06 +0200] Allowing up to 100 client connections per host.
I [29/May/2013:10:41:06 +0200] Using policy "default" as the default!
I [29/May/2013:10:41:06 +0200] Full reload is required.
I [29/May/2013:10:41:06 +0200] Saving job cache file "/var/cache/cups/job.cache"...
I [29/May/2013:10:41:06 +0200] Loaded MIME database from '/etc/cups': 35 types, 37 filters...
I [29/May/2013:10:41:06 +0200] Loading job cache file "/var/cache/cups/job.cache"...
I [29/May/2013:10:41:06 +0200] Full reload complete.
E [29/May/2013:10:41:06 +0200] Unable to open listen socket for address ::1:631 - Address family not supported by protocol.
I [29/May/2013:10:41:06 +0200] Listening to 127.0.0.1:631 on fd 3...
I [29/May/2013:10:41:06 +0200] Listening to /var/run/cups/cups.sock on fd 5...
I [29/May/2013:10:41:06 +0200] Resuming new connection processing...
I [29/May/2013:10:41:15 +0200] Scheduler shutting down normally.
I [29/May/2013:10:41:15 +0200] Saving job cache file "/var/cache/cups/job.cache"...
I [29/May/2013:10:41:19 +0200] Listening to ::1:631 (IPv6)
I [29/May/2013:10:41:19 +0200] Listening to 127.0.0.1:631 (IPv4)
I [29/May/2013:10:41:19 +0200] Listening to /var/run/cups/cups.sock (Domain)
I [29/May/2013:10:41:19 +0200] Remote access is disabled.
I [29/May/2013:10:41:19 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [29/May/2013:10:41:19 +0200] Using default TempDir of /var/spool/cups/tmp...
I [29/May/2013:10:41:19 +0200] Configured for up to 100 clients.
I [29/May/2013:10:41:19 +0200] Allowing up to 100 client connections per host.
I [29/May/2013:10:41:19 +0200] Using policy "default" as the default!
I [29/May/2013:10:41:19 +0200] Full reload is required.
I [29/May/2013:10:41:19 +0200] Loaded MIME database from '/etc/cups': 35 types, 37 filters...
I [29/May/2013:10:41:19 +0200] Loading job cache file "/var/cache/cups/job.cache"...
I [29/May/2013:10:41:19 +0200] Full reload complete.
I [29/May/2013:10:41:19 +0200] Cleaning out old temporary files in "/var/spool/cups/tmp"...
E [29/May/2013:10:41:19 +0200] Unable to open listen socket for address ::1:631 - Address family not supported by protocol.
I [29/May/2013:10:41:19 +0200] Listening to 127.0.0.1:631 on fd 4...
I [29/May/2013:10:41:19 +0200] Listening to /var/run/cups/cups.sock on fd 6...
I [29/May/2013:10:41:19 +0200] Resuming new connection processing...
I [29/May/2013:10:41:24 +0200] Started "/usr/lib/cups/daemon/cups-deviced" (pid=17236)
E [29/May/2013:10:41:24 +0200] [cups-deviced] Bad line from "pdf-writer": Error: /usr/lib/cups/backend/pdf-writer - ps2pdf is not available!
I [29/May/2013:10:57:43 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=23125)
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9040
Location: Stratford, Ontario

PostPosted: Wed 29 May 2013, 07:17    Post subject:  

The CUPS printing system in Saluki is incomplete and out of date. You need to use a different Puppy.

IIRC, Saluki has a separate printer SFS package here. Have you installed it? The messages in your error log suggest otherwise.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9040
Location: Stratford, Ontario

PostPosted: Thu 30 May 2013, 08:06    Post subject:  

@step: No reply?
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 123

PostPosted: Fri 31 May 2013, 16:41    Post subject:  

rcrsn51 wrote:
@step: No reply?
Sorry, I was out of town with no internet access. I just got back. Thanks for the saluki package pointer. I wasn't aware that it's incomplete. I will install that package tomorrow and report back here my findings. I certainly owe you feedback at least.
As for using another puppy, I love saluki but since it isn't going anywhere anymore, I might switch to precise soon.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9040
Location: Stratford, Ontario

PostPosted: Sat 01 Jun 2013, 07:13    Post subject:  

To get your Samsung printer working in Saluki, you don't need the full printer-scanner SFS package. Just install Ghostscript.
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 123

PostPosted: Sat 01 Jun 2013, 07:56    Post subject:
Subject description: saluki 023 samsung 2165W
 

Thanks! After installing saluki's printer-scanner-001.sfs and your pet I can print to my samsung 2165W printer. In the future I might test replacing the sfs with the ghostscript pet you linked to, but first I want to see if I can also scan, so I think I need the sfs installed.

Fyi, in addition to the sfs link you posted, there's also http://smokey01.com/saluki/sfs/printer-scanner-drivers.sfs, which jemimah describes as:
jemimah Sat 14 Apr 2012, 12:43 wrote:
scabz wrote:

A quick question what is the differences between printer-scanner-core.pet, printer-scanner-001.sfs and printer-scanner-driver.sfs ?

The new printer-scanner-driver sfs has every printer driver I know about, including the big lexmark ones. Also it was built with the sfs-builder so it should integrate into the ppm so dependency checking will work correctly. (I should do this with the DevX too, but not for the first release.)
It should be possible now to install printer drivers through the ppm so you can get just the drivers you need.
Or there may be a situation where you don't know what kind of printer you will need the drivers for, and you want all drivers, so use the sfs in that case.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9040
Location: Stratford, Ontario

PostPosted: Sat 01 Jun 2013, 08:42    Post subject:  

jemimah wrote:
The new printer-scanner-driver sfs has every printer driver I know about...

There were many other drivers that Jemimah knew about, like all the Brother and Canon models. But they exist as individual packages and it would have been too cumbersome to include them all. So instead she added a bunch of drivers that 99.9% of Saluki users would never need.

All the drivers in her sfs package are now well out of date.
Back to top
View user's profile Send private message 
p310don

Joined: 19 May 2009
Posts: 691
Location: Brisbane, Australia

PostPosted: Fri 23 Aug 2013, 20:46    Post subject:  

I'm trying to use the new CMS drivers for my samsung clp-315 and am not having great success.

I can get the printer to work using the standard driver, but if I use the CMS driver, I just get a failed to print. Is there something I'm doing wrong? I'm not quite sure how to use the CMS anyway.

I modify printer, browse for PPD, find the clp310 file in the CMS directory and then nothing works.

Is this what I'm supposed to be doing?
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9040
Location: Stratford, Ontario

PostPosted: Sat 24 Aug 2013, 08:16    Post subject:  

I really don't understand what you are doing.

What do you mean by the "standard driver"? Are you talking about the samsung_print-4.01.17.pet?

There is no CMS driver. From Page 1: "Samsung colour laser printers have an optional CMS colour correction database.".

Quote:
I modify printer, browse for PPD, find the clp310 file in the CMS directory and then nothing works.

There are no PPD files in the CMS directory.

The intent of CMS is to give you better colour quality than the basic driver. All you need to do is install the PET.

Is this the first time you have installed your CLP-315 in Puppy? How did you do it before?
Back to top
View user's profile Send private message 
p310don

Joined: 19 May 2009
Posts: 691
Location: Brisbane, Australia

PostPosted: Sat 24 Aug 2013, 09:35    Post subject:  

Sorry, I'll try to clarify what I've done.

I have my printer installed, no problems, has been in numerous puppies over time.

The colour from this printer in Linux has never been great. To do colour printing, I use windows in virtualbox. Gives perfect results. I saw the CMS post you put on the first page here, and thought I'd give that a go. But, I don't know what to do with it.

I have installed the samsung_print-4.01.17.pet and the printer works ok. The colour for photos isn't right. Everyone looks jaundiced, too much orangey yellow.

Installing the cms pet does nothing to change it for that printer. I don't know what I might need to do beyond installing the pet from page one of this thread.

Quote:

There are no PPD files in the CMS directory.


I know. But you click the "browse for PPD button" is what I meant. Doing this doesn't find a PPD, so that's kind of where I was coming unstuck.

Perhaps this is feedback for the CMS database. It doesn't seem to help much for the clp-315, or I'm doing it wrong.[/quote]
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9040
Location: Stratford, Ontario

PostPosted: Sat 24 Aug 2013, 10:00    Post subject:  

p310don wrote:
I have my printer installed, no problems, has been in numerous puppies over time.

Using which driver? Foo2xxx?

How does the colour quality for this Samsung driver compare to your previous Puppy installs?

Quote:
Perhaps this is feedback for the CMS database. It doesn't seem to help much for the clp-315, or I'm doing it wrong.


In the discussion here, Andym1 was satisfied with the driver. Perhaps you could contact him.
Back to top
View user's profile Send private message 
p310don

Joined: 19 May 2009
Posts: 691
Location: Brisbane, Australia

PostPosted: Sat 24 Aug 2013, 17:43    Post subject:  

I'm sorry for derailing this thread with what I've said in the past couple of posts.

The colour was not working very well for photo quality printing, regardless of using the drivers and CMS database provided at the beginning of this thread.

However, in CUPS the setting for colour printing was set to draft. (I may have done that at some point to save toner) Upon changing the setting to best, it works flawlessly.

I have tested this is both Precise 5.71 and Saluki 021.

To summarise, to get a Samsung CLP-315 printer to print nicely in Puppy Linux

Download the 2 pets under section 3 on page one of this thread:

samsung_print-4.01.17.pet

and

samsung_cms-4.01.17.pet

Install the printer in CUPS and then change the default settings to BEST quality and you will have printing just as nice as under windows.

Thanks again rcrsn51 for your patience, help and continued support for this community.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 5 [68 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1242s ][ Queries: 13 (0.0095s) ][ GZIP on ]