Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 25 May 2015, 07:43
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Did Fatdog 601 brick my Motorola razr xt890?
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 04 Aug 2013
Posts: 3

PostPosted: Sun 04 Aug 2013, 18:38    Post_subject:  Did Fatdog 601 brick my Motorola razr xt890?  

Connected my daughter's new Motorola XT890 (Android 4.04) to computer running fatdog 6.0.1 (from usb stick no savefile). Phone was on.

System saw a drive - I seem to remember a cd type icon - clicked on that and file manager opened with 4 files.- 1 .exe and 1 other binary neither of which I clicked on and 2 text files - I think one was .ini. I looked at both of those in geaney and quit without changing anything or saving. It looked like some sort of windows autorun and installer.

No other files visible. Removed the phone and it seemed ok. My daughter thinks I did not unmount before disconnecting. I can't remember.

Switched off the phone and it will not switch back on. I seem to have bricked it. I tried reconnecting but phone off and no drive seen

Anyone any ideas what went wrong? Fix?
Back to top
View user's profile Send_private_message 

Joined: 29 Jan 2006
Posts: 3570
Location: Sydney Australia

PostPosted: Mon 05 Aug 2013, 03:43    Post_subject:  

Take the battery out.

Hold the power button down for >>> 30 seconds...

to discharge any latent power.

Pop battery in and power up.

You could get lucky.

Back to top
View user's profile Send_private_message 

Joined: 03 Dec 2006
Posts: 18

PostPosted: Mon 05 Aug 2013, 15:02    Post_subject: Fatdog 601- Motorola razr xt990
Sub_title: Unbricking a Motorola razr xt890

Re: the bricked Motorola XT890 (or is it really a Motorola razr xt990 as shown in the title)

Perhaps this might help (however, note the specific description of the "power on" behavior):

Unbricking XT890 when it is dead: http://forum.xda-developers.com/showthread.php?t=2390507

I also suggest reading the other Motorola XTxxx forum entries at that same web site before trying anything software wise!

Hope this helps.
Back to top
View user's profile Send_private_message 

Joined: 04 Aug 2013
Posts: 3

PostPosted: Mon 05 Aug 2013, 16:43    Post_subject:  

Yup, you're right - it an xt890 not 990. It was late here in London when I posted and did not notice the error. Thanks for the info - I'll have to study that site.

Problem for me is I've only got one legacy box at the moment - running windows 98se crashmatic. I would not dare to try that machine even if the script would run on it. Too unstable. Tried new drivers, 2 reinstalls, lucky if it stayed up for an hour or so. Marvellous os though - drove me to Linux. Tried an early version of Mandrake - rock steady. The rest is history.

Looks like I'll have to repair the power socket on the old Acer lapdog ASAP. That's still got xp on it. Been meaning to set the brute up to dual boot so I can actually use the thing.

What intrigues me is what did I or fatdog do that the phone did not like? I only opened 2 text files, decided it was an install for some sort of windows driver and backed off. I'm usually v careful to unmount before disconnecting, but my daughter, who was watching and whose new phone it is (oops) thinks I forgot this time. Perhaps that corrupted something?
Back to top
View user's profile Send_private_message 

Joined: 22 Nov 2010
Posts: 3834
Location: Everybody knows this is nowhere...

PostPosted: Mon 05 Aug 2013, 16:47    Post_subject:  

My experience with unplugging without unmounting is that it seems to corrupt the partition table on the device I just yanked. While it doesn't actually wipe the drive, the effect is the same -- because the computer no longer knows where to find anything. BTW, creating a new partition table in gparted wipes everything anyways (or so gparted tells me).

Back to top
View user's profile Send_private_message 

Joined: 04 Aug 2013
Posts: 3

PostPosted: Thu 15 Aug 2013, 20:20    Post_subject: Did Fatdog 601 brick my Motorola razr xt890?  

Thanks for the info -I have had a look at the XDA site - most interesting - but seems largely about rooting the phone and the consequences of doing so. Nothing specific about my situation. Don't want to make the situation worse than it already is.

Starhawk - I think you may well be right- I was leaning to that conclusion myself. Unless of course the problem is completely unrelated. There's a fundemental law of physics about coincidences of this sort.

My daughter and I both think its best if we send the brute back to Mota and let them sort it.

Now here's the weird bit:

Ruth and I had both tried switching it on many times, including multiple tries at factory reset start - hold down vol down button and press on button - in each case all that happened is the little green led at the top came on and stayed on until the on button was pressed again.

Then after about 20 tries she presses the on button by accident and the beast boots. All seems to be ok and the phone is stable - did not try calls / data as she had removed the sim to put it in another phone and we have no wifi here at home - use ethernet for security. She tried to do a reset from the menu and all went ok until the phone came to reboot. Back to refusing to start.

Another 20 or so tries and it boots. None of the contact info etc that should have been deleted had been. She's managed to boot it 3 times now each time after about 20 goes. Not sure yet if its exactly 20.

I wonder if the phone does something every 20 boots? fsck or something? All I know is its Android 4.0.4 on intel not arm. Know nothing about android, file system etc.
Back to top
View user's profile Send_private_message 

Joined: 14 Oct 2005
Posts: 4986
Location: Earth

PostPosted: Fri 16 Aug 2013, 01:59    Post_subject:  

Hi @Busydog.

What you describe may be a hardware problem with the phone which happened coincidental to the FATDOG connection. I say "may".

You might want to call the Telco (if the phone is still under warranty) or you may also want to contact Moto (they have a reasonable tech support group) for their advice. They may have seen this problem before, as, the problem may be unrelated to FATDOG.

Hoping you get the phone back to behaving.

Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send_private_message 

Joined: 19 May 2009
Posts: 801
Location: Brisbane, Australia

PostPosted: Sat 17 Aug 2013, 07:57    Post_subject:  

If you can get the phone to start, it might be worth plugging it in, either in win or fatdog, and mounting it and then safely unmounting.

If that has no affect, try mounting it, and running a fsck or chkdsk on the phone's storage.

I had a similar problem a number of times with phones that I didn't unmount, and found I could fix it with a file system check.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0604s ][ Queries: 12 (0.0041s) ][ GZIP on ]