Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Nov 2014, 12:41
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Solved - Soundcard problem when using savepup for first time
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
Bit_of_a_Wag


Joined: 08 Aug 2013
Posts: 6

PostPosted: Thu 08 Aug 2013, 22:33    Post subject:  Solved - Soundcard problem when using savepup for first time
Subject description: (Slacko 5.5) Recovers sound when save file is deleted
 

After creating and saving my personal file there is a soundcard problem upon rebooting. I have found that deleting the personal save file and rebooting brings the sound back after rebooting.

I have been unsuccessful in finding a solution on this forum. However Barry's Blog http://bkhome.org/blog/?viewDetailed=02623 seemed to suggest a possible answer:

Quote:
The solution for the first (after trying not to save the devices) was to eliminate devices from the main sfs all together, and trust the kernel-udev to do the job in every boot.


Would this solve my issue? If so, can anyone explain how to do this?

Barry's suggestion was intended for advanced users - I am a beginner.

Other than this problem Slacko Puppy is great - thanks for all the work everyone has put into it.

Best,

Richard

Last edited by Bit_of_a_Wag on Mon 12 Aug 2013, 00:14; edited 1 time in total
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 638

PostPosted: Fri 09 Aug 2013, 00:32    Post subject:  

Try at first booting to rename /usr/sbin/alsawizard as /usr/sbin/alsawizard.old to get rid of it at second boot. When you want to run your slackosave on another machine go back and rename /usr/sbin/alsawizard.old as /usr/sbin/alsawizard. Let me know if it works.
Back to top
View user's profile Send private message 
Bit_of_a_Wag


Joined: 08 Aug 2013
Posts: 6

PostPosted: Fri 09 Aug 2013, 09:54    Post subject:  

Many thanks Watchdog.

Have I followed your instructions correctly?

[Context booted with personal file deleted - sound present]

    Then I followed your instructions (after localising settings (keyboard, time-zone, etc)

    Renamed /usr/sbin/alsawizard.old as /usr/sbin/alsawizard

    Rebooted (saved to file upon rebooting)


Did I follow your instructions correctly? If so, the problem still remains. However, thanks for your suggestion.

Any more suggestions?

Best,

Rich
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8664

PostPosted: Fri 09 Aug 2013, 10:25    Post subject:  

hmmm my experience of this was when a netbook I have was fitted with a faster cpu.
This suggested that the sound hardware was not ready when previous settings were applied.

My action was to decrap the sound setup which seems to be spread all over the place and remove the modprobe config to prompt module insertion so udev handles it every time, but I believe the 'cure' was to move restoring previous sound settings (asoundrc) to the far end of rc.sysinit so giving time for the hardware to settle and have not had a problem since.

hope that sheds some light.

mike
Back to top
View user's profile Send private message 
Bit_of_a_Wag


Joined: 08 Aug 2013
Posts: 6

PostPosted: Fri 09 Aug 2013, 18:52    Post subject:  

Hi MikeB,
Thanks for your input.

To help clarify the situation, may I add the further details of my Dell C400 (PP03L) Laptop:

Audio Adapter: Intel 82801CA-ICH3
Chip: Cirrus Logic CS4205 rev 5

Processor: Mobile Intel P3 CPU-M 1200MHz

I feel that the laptop is pretty old (10+ years) so I'm not sure if your workaround would work for me...

The laptop's sound works fine before a personal slackosave file is saved. It fails when using slackosave; but works again when rebooted after slackosave file is deleted. With this in mind may I suggest that perhaps mounting and editing the slackosave file might be one way to find the answer?

Best,

Rich

PS Best to walk me through things as I am a beginner
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 638

PostPosted: Sat 10 Aug 2013, 01:22    Post subject:  

I'm not expert as programmer. I just had success in some editings of scripts just done. Try this if someone else does not give you new suggestions. Open as a text in geany /etc/init.d/10alsa and add a line at the begin to retard its execution as suggested. I just give you some code as example:

Code:
#!/bin/sh
sleep 10 #Line added
#Barry Kauler april 2009, puppylinux.com
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8664

PostPosted: Sat 10 Aug 2013, 05:00    Post subject:  

Hmm the sounds startup sequence seems to change all the time so its hard to give specific suggestions, only an idea of what may be happening unfortunately. In the version i 'fixed' it did not even run rc.alsa!

If there is a file to try to delete from the save it would be
/etc/asound.state (sorry its not asoundrc...my bad)
..this is created at shutdown and saves the previous audio settings though without it a generic setup is supposed to be used to avoid muted sound. It would have to be removed when puppy is not running/using the save.
Removing the sound card alias from modprobe.conf/modprobe.d would test to see if module loading sequence was affecting matters.

Age is no barrier though onboard intel sound has been known to be stubborn at times. I have a 13 year old machine which hates audacity Very Happy ..or portaudio to be more specific...onboard intel jobbie.

mike
Back to top
View user's profile Send private message 
Bit_of_a_Wag


Joined: 08 Aug 2013
Posts: 6

PostPosted: Sat 10 Aug 2013, 10:41    Post subject:  

Thanks Mike B. That has solved it!

For clarification:

    I started the laptop (running without a save file so that the audio was working)
    Found the file asound.state and deleted it
    Shut down agreeing to save a personal file.
    Rebooted, sound working


Thanks to MikeB and Watchdog for your patience. Puppy can now be used to the full.


Best,

Rich
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8664

PostPosted: Sat 10 Aug 2013, 11:11    Post subject:  

Ah good...

asound.state is created by /usr/sbin/alsactl store found in /etc/rc.shutdown (or it was) you could comment it out with #

mike
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2479
Location: near here

PostPosted: Sat 10 Aug 2013, 12:52    Post subject:  

Glad you found a solution. Would be interesting to know the contents of

/etc/asound.state

...before you deleted, to know what is causing the problem. Sometimes its caused by the wrong module being loaded, or loaded in the wrong order.

I can't use Slacko since alsaconf was removed. So I'm stuck on 5.3.1 at the moment. (the thread regarding this problem is here http://www.murga-linux.com/puppy/viewtopic.php?t=86679)

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
Bit_of_a_Wag


Joined: 08 Aug 2013
Posts: 6

PostPosted: Sat 10 Aug 2013, 18:02    Post subject:  

Thanks MikeB, I'll give it a go.

Darkcity, I copied the file to thumbstick before deleting and have attached the file to this post.

Thanks again,

Best wishes,

Rich
asound.state.zip
Description  Zipped file
zip

 Download 
Filename  asound.state.zip 
Filesize  1.03 KB 
Downloaded  127 Time(s) 
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2479
Location: near here

PostPosted: Sat 10 Aug 2013, 18:36    Post subject:  

thanks, I can't tell what the precise error was. I understand the files in the /etc/modprobe.d/ directory more clearly.

Cool

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
Bit_of_a_Wag


Joined: 08 Aug 2013
Posts: 6

PostPosted: Mon 12 Aug 2013, 00:28    Post subject:  

Deleting /etc/asound.state fixed it only temporarily. Therefore not really fixed. Ferreting around for hours and searching countless forums for similar problems helped me do the following:

Menu>Setup>ALSA Sound Wizard
Clicked adjust levels button to open alsamixer
raised each level to max and unmuted each level
(use left and right arrows to move to each level, up arrow key to raise levels; press m key to unmute)

Rebooted and (finally) I have the pup bark each time.

I think I had read this solution to a similar sound problem on a forum - it worked for me also. I think the difficulty was in finding how to unmute - using the M key (muted levels show a the letters MM). I hope this helps any newcomers such as myself. Thanks to all who gave their time.

I just keep pressing that sound test button - what a relief!

Now my pup's tail is wagging.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0741s ][ Queries: 13 (0.0048s) ][ GZIP on ]