Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 31 Jul 2014, 11:50
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Upup Raring 3.9.9.2 with non-PAE 3.9.9 kernel. 13 July 2013
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 8 of 32 [472 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, ..., 30, 31, 32 Next
Author Message
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Fri 26 Jul 2013, 17:30    Post subject:  

pemasu wrote:
Edoc. /etc/rc.d/MODULESCONFIG
Add in that file to SKIPLIST row those 2 modules more.
ssb and b43

SKIPLIST=" ssb b43 arcfb cirrusfb cyber2000fb ..........

And save. That might be enough. Reboot.


b43 was already in that list once and ssb twice.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 26 Jul 2013, 17:39    Post subject:  

Edoc. Then it looks like that rerwin`s broadcom logistic file wants you to use b43.

Only solution is to remove it:
/lib/modules/all-firmware/b43/etc/modprobe.d/b43.conf

Reboot.
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Fri 26 Jul 2013, 18:00    Post subject:  

OK, deleted b43.conf at that location and rebooted.

No joy.

ssb and wl show in Pup Kview but no more b43.

Still, wifi that works in MS win7 doesn't work in Puppy. Sad

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 26 Jul 2013, 18:30    Post subject:  

Edoc. Well....ssb cant be loaded before wl. I hope that I am right with idea that wl is right module for your wireless. It would help if you would know that wl has worked with that laptop in other Puppy, but you havent at least posted so, I suppose it hasnt.

Last resort. Remove also the wl logistic file:
/lib/modules/all-firmware/wl/etc/modprobe.d/wl.conf

And install this pet and reboot. This pet has logistic file for recognizing your chip and it should unload ssb and then load wl. It has the older logistic mechanism but it should work with your chip id.
remove_ssb_at_start.pet
Description 
pet

 Download 
Filename  remove_ssb_at_start.pet 
Filesize  609 Bytes 
Downloaded  106 Time(s) 
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2778
Location: Everybody knows this is nowhere...

PostPosted: Fri 26 Jul 2013, 18:37    Post subject:  

@pemasu,edoc -- sorry to quite likely add confusion to confusion (I never like doing that), but WikiDevi (a great info source for matching drivers to wifi cards) says that the b43 driver *should* work for that chipset...

I looked at these two cards:
Dell Wireless 1397 WLAN Half Mini-Card
Dell Wireless 1395 WLAN Mini-Card

Both say to use b43.

Dunno if that helps or just adds to the mess, but I thought I'd throw it out there...

_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Fri 26 Jul 2013, 18:50    Post subject:  

pemasu wrote:
Edoc. Well....ssb cant be loaded before wl. I hope that I am right with idea that wl is right module for your wireless. It would help if you would know that wl has worked with that laptop in other Puppy, but you havent at least posted so, I suppose it hasnt.


I just stopped the process and booted from a Lucid Puppy DVD - the wifi works fine.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 26 Jul 2013, 18:51    Post subject:  

Edoc and Starhawk. Well. Yeah. I play with chip id`s solely.

http://wireless.kernel.org/en/users/Drivers/b43

ID: 14e4:4315

14e4:4315 b43 yes (2.6.33+), alternative wl

Both should work, at these situations, I would go for wl. But my reasoning can be faulty.

Edoc. It would help if you could post what driver worked. I suppose it was b43, but reading it from you is better than assuming.
In that case, disabling wl module loading would be the way to go. Which means opposite as we have done, and as Starhawk suggested.
Blacklisting wl, removing its logistic file, etc...

And yes. My wifi works also fine. Lol.
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Fri 26 Jul 2013, 19:30    Post subject:  

Sorry, was called away from my desk.

Lucid is using b43

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Sat 27 Jul 2013, 09:44    Post subject:  

So, since I deleted the b43.conf file ... where do I get a replacement, please?
_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 27 Jul 2013, 09:51    Post subject:  

You have backup of all your distro included files:
/initrd/pup_ro2.
Everything you remove, with frugal installation and savefile usage, are essentially only flagged as deleted. The original files are always there.
But after messing that much, I would recommend fresh start.
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Sat 27 Jul 2013, 11:06    Post subject:  

OK ...

Opened iso and replaced the three Frugal files, also replaced devx, just in case.

Deleted the savefile and rebooted.

I blacklisted wl and added b43 then rebooted again.

Internet Connection Wizard sees the b43 module but will not 'find' the router, neither will Frisbee.

Something in Raring is interfering that is not in Lucid.

Where should I look, please?

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 27 Jul 2013, 11:36    Post subject:  

Edoc. To be sure...I would remove wl logistic file and also wl kernel module. Then reboot. If that does not help....then there isnt much more I can do.

in console.
rm /lib/modules/3.9.9-upup/kernel/drivers/net/wireless/wl.ko
rm /lib/modules/all-firmware/wl/etc/modprobe.d/wl.conf

And then there isnt anymore possibility that wl.ko module interferes.

If this does not help, post pdiag tarball again after unsuccesful trial.

Your b43 chip should be supported without any problems. So...I really dont know what is wrong with this build. I think we will need spiritual session soon....
Back to top
View user's profile Send private message 
Fabio T

Joined: 31 Aug 2007
Posts: 87
Location: Italy

PostPosted: Sat 27 Jul 2013, 12:54    Post subject: resizepfile not working in raring 3.9.9.1  

Hi Pemasu!
FInally i can try raring (only version working is 3.9.9.1). Now it works on my Fujitsu laptop laptop

But.. I have found a bug in resizepfile script (this is 0.14 version). It returns an error whatever size of personal resize file increase.

I have patched this with the script of Don570 or older script from Precise.

Can you correct next release of raring with this?
Thanks
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 27 Jul 2013, 13:06    Post subject:  

Fabio T. Thanks of the feedback. I will check the resizepfile script. I think that I updated it but I admit that I didnt test the update.
Thanks. Will fix....
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Sat 27 Jul 2013, 14:09    Post subject:  

pemasu wrote:
Edoc. To be sure...I would remove wl logistic file and also wl kernel module. Then reboot. If that does not help....then there isnt much more I can do.

in console.
rm /lib/modules/3.9.9-upup/kernel/drivers/net/wireless/wl.ko
rm /lib/modules/all-firmware/wl/etc/modprobe.d/wl.conf

And then there isnt anymore possibility that wl.ko module interferes.

If this does not help, post pdiag tarball again after unsuccesful trial.

Your b43 chip should be supported without any problems. So...I really dont know what is wrong with this build. I think we will need spiritual session soon....


Did it all, rebooted multiple times, no joy. Very odd.

Here's the pdiag output:
pdiag-20130727.tar.gz
Description 
gz

 Download 
Filename  pdiag-20130727.tar.gz 
Filesize  129.28 KB 
Downloaded  109 Time(s) 

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 8 of 32 [472 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, ..., 30, 31, 32 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0802s ][ Queries: 13 (0.0088s) ][ GZIP on ]