Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Sep 2014, 14:18
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to Install Your Printer/Scanner in Puppy
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 14 of 16 Posts_count   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16 Next
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 9123
Location: Stratford, Ontario

PostPosted: Tue 09 Apr 2013, 06:53    Post_subject:  

My original suggestion was to run an install of Slacko, not try to install Slacko's Ghostscript into Precise. You would just need to boot off the Slacko Live CD, install the HPLIP driver and test your printer.

However, we should be able to get an equivalent test in Precise.

1. Download Ghostscript 9.05 from here.

2. Install the CUPS filter upgrade from the PET below.

3. Do a print test.
gstoraster_s533-9.05.pet
Description 
pet

 Download 
Filename  gstoraster_s533-9.05.pet 
Filesize  9.93 KB 
Downloaded  443 Time(s) 
Back to top
View user's profile Send_private_message 
marshman

Joined: 23 Aug 2011
Posts: 4
Location: Ashford, Kent UK

PostPosted: Wed 10 Apr 2013, 15:11    Post_subject: Duplex Printing - Works OK  

@rcrsn51

Quote:
My original suggestion was to run an install of Slacko, not try to install Slacko's Ghostscript into Precise. You would just need to boot off the Slacko Live CD, install the HPLIP driver and test your printer.


I am sorry that I misunderstood your original suggestion. I do not have any spare CD's at present for burning the .iso image to CD.

Anyway, I tried your alternative suggestion and the test print worked fine.

As it appears to be a problem with the installed version of Ghostscript, should I advise Barry Kauler? Obviously in future builds/versions of PuppyLinux, there needs to be a more recent version of Ghostscript.

Thank you again for all your work. It is much appreciated and the time you spent verifying/solving my problem.

Michael
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9123
Location: Stratford, Ontario

PostPosted: Wed 10 Apr 2013, 16:17    Post_subject:  

@marshman: Glad to hear that you solved your duplexing problem. I believe that BarryK has stayed with his old version of Ghostscript because it is very small and works in most situations.

But the issue is gradually resolving itself. Slacko 5.5 has GS 9.0 as does Pemasu's new Upup Raring.

Anyone else can easily upgrade their GS like you did.
Back to top
View user's profile Send_private_message 
bignono1


Joined: 17 May 2009
Posts: 362
Location: New ME

PostPosted: Wed 17 Jul 2013, 03:39    Post_subject:  

Hello rcrsn51 ,
Please help on this HP OfficeJet 4255 all in one ,in win and ubuntu it runs ootb, but no puppy could make it bark,when i run the cups wizard the printer is there but when i choose a driver from the list it is not there , i tried all hplip and fooxx pets but all no go, the hplip driver from HP site ends up saying i need some libs that cant be installed using the installer.
I would like to use this printer with 528 .
Sorry i talk too much with a stupid english also.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9123
Location: Stratford, Ontario

PostPosted: Wed 17 Jul 2013, 08:34    Post_subject:  

I ran some tests in Lupu 528 and I believe that your OfficeJet 4255 should work with the hplip_print-3.13.4.pet from Page 1.

However, once you start installing other driver packages, it's impossible to know what's going on.

I would recommend that you do a clean install of Lucid with the hplip_print-3.13.4.pet .

If that doesn't work, do another clean install and try lluamco's build here. Note the extra instructions for Lucid.
Back to top
View user's profile Send_private_message 
bignono1


Joined: 17 May 2009
Posts: 362
Location: New ME

PostPosted: Thu 18 Jul 2013, 02:45    Post_subject:  

Thank you very much rcrsn51 , printer working now , i did what you said except i did not remove the foo pet because i need it with the other hp lj 1018 , i traced all pets debs and ppd's and removed them then installed the hplip-print pet-3.13.4 and lucid is singing nice with the printer now, thank you again rcrsn51.
Back to top
View user's profile Send_private_message 
Sylvander

Joined: 15 Dec 2008
Posts: 3444
Location: West Lothian, Scotland, UK

PostPosted: Sat 17 Aug 2013, 02:56    Post_subject:  

Printer = HP Deskjet 840c
Puppy = Slacko-5.5.91, booting from CD-RW, with slackosave file.

Normally I have no problem setting up the printer.
The printer is detected, and I can choose it, but...
In this case, my "HP Deskjet 840c" isn't listed when I try to install it. Sad

What to do?
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9123
Location: Stratford, Ontario

PostPosted: Sat 17 Aug 2013, 11:58    Post_subject:  

Sylvander wrote:
In this case, my "HP Deskjet 840c" isn't listed when I try to install it

I just checked in Slacko 5.6. Your Deskjet 840C is listed and supported by the Gutenprint driver package.

It should have appeared at the top of the Models list.
Back to top
View user's profile Send_private_message 
Sylvander

Joined: 15 Dec 2008
Posts: 3444
Location: West Lothian, Scotland, UK

PostPosted: Sat 17 Aug 2013, 14:28    Post_subject:  

rcrsn51 wrote:
...in Slacko 5.6. Your Deskjet 840C is listed and supported by the Gutenprint driver package.
It should have appeared at the top of the Models list.

Oops...
Yes indeed, you're right, it IS there. Embarassed
I was looking further down among all the other "Deskjet" versions.
Which is where it was NOT.
My printer is now working.

THANK YOU. Very Happy
Back to top
View user's profile Send_private_message 
gcmartin

Joined: 14 Oct 2005
Posts: 4276
Location: Earth

PostPosted: Wed 28 Aug 2013, 17:12    Post_subject: Lexmark PCL & Postscript drivers  

I think I remembered that you had a Lexmark "bucket" PET lying around somewhere. Is it still available?

Thanks in advance.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9123
Location: Stratford, Ontario

PostPosted: Wed 28 Aug 2013, 17:17    Post_subject: Re: Lexmark PCL & Postscript drivers  

gcmartin wrote:
I think I remembered that you had a Lexmark "bucket" PET lying around somewhere.

??????
Back to top
View user's profile Send_private_message 
Senza Vega

Joined: 13 Aug 2013
Posts: 46

PostPosted: Sun 01 Sep 2013, 12:57    Post_subject: Lexmark S310
Sub_title: "/usr/local/lexmark/legacy/bin/printfilter failed"
 

Hello,
I install manually (socket://192.168.1.23)
my lexmark S300 Wifi in cups 1.5.4 (lighthouse64).

I get the driver and the patch like said here :
http://murga-linux.com/puppy/viewtopic.php?p=701210#701210

Here the result of the mpscan command :
Code:
mpscan -p 9100 192.168.1.23
ip: 192.168.1.23 9100 OK


So, the answer when I try to print a test page is :
"/usr/local/lexmark/legacy/bin/printfilter failed"

Can you help me, please ?
Best regards
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9123
Location: Stratford, Ontario

PostPosted: Sun 01 Sep 2013, 13:15    Post_subject:  

Quote:
lighthouse64

The lexmark_inkjet_legacy-1.0.1.pet is a 32-bit driver. In Fatdog, there is a mechanism for running CUPS in 32-bit mode. I don't know if it exists in Lighthouse.

As a first step, you should try to install your S300 in a regular Puppy.
Back to top
View user's profile Send_private_message 
Senza Vega

Joined: 13 Aug 2013
Posts: 46

PostPosted: Sun 01 Sep 2013, 13:24    Post_subject:  

rcrsn51 wrote:
Quote:
lighthouse64

The lexmark_inkjet_legacy-1.0.1.pet is a 32-bit driver. In Fatdog, there is a mechanism for running CUPS in 32-bit mode. I don't know if it exists in Lighthouse.

As a first step, you should try to install your S300 in a regular Puppy.


ho, ok ! Very Happy
I'll try,
thanks you !
Back to top
View user's profile Send_private_message 
LeithR

Joined: 24 Jan 2011
Posts: 109
Location: Kemnay, Aberdeenshire/Scotland

PostPosted: Tue 03 Sep 2013, 06:55    Post_subject:  

Hi there rcrsn51,
I have recently had to move of my old reliable compaq presario and am now using an HP Pavilion zv6000. I have loaded Slacko 5.3.3 and its working fine, I'm using cups 1.4.6. I've been browsing the forum and note that the current printer drivers suggested for my HP Deskjet F2480 are
HPLIP_print-3.13.7.pet and HPLIP_scan-3.13.7.pet, I've downloaded these files and tried to set up the printer without success. I've also tried to find reference to the original HPLIP_print-3.12.10a.pet and its scan equivalent. All references take me back to your post indicating that 3.13.7 is the current version - but its not working for me I can find no reference on the CUPS drop down to my F2480 printer.

Can you help please - again!!, thanks in anticipation.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 14 of 16 Posts_count   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0908s ][ Queries: 13 (0.0089s) ][ GZIP on ]