Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 14:56
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
hplip and hpliplite packages
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 10 of 10 Posts_count   Goto page: Previous 1, 2, 3, ..., 8, 9, 10
Author Message
Frank Cox

Joined: 01 Nov 2009
Posts: 381

PostPosted: Thu 02 Jun 2011, 23:21    Post_subject: Problem with HP C3140  

I installed the cups 1.3.9-!486.pet , then linnetsnmp-15.pet , then hplite-3.11.5.pet.

When I ran the cups wizard on USB one was a 3100 series HP . it did not come up as a C3140 as I expected but since it was on the correct port I had to assume it was the correct one. The only HP Photosmart drive was also a 3100 series. I noticed it was displaying the serial number so it must be correct.

The error message i get is /usr/libs/cups/filter/hpcups failed

Also in Textmaker it shows Default Printer Queue {System} instead of the name of the printer as it should. Perhaps i need a ppd file?

Any help would be appreciated.
Back to top
View user's profile Send_private_message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Fri 03 Jun 2011, 05:18    Post_subject:  

Frank, what version of puppy are you using? If it is 4.3.1, I would recommend uninstalling the hpliplite-3.11.5 pet and try the version
at the first message of this thread, hpliplite-3.10.5.
Back to top
View user's profile Send_private_message 
Frank Cox

Joined: 01 Nov 2009
Posts: 381

PostPosted: Fri 03 Jun 2011, 14:12    Post_subject: Thanks  

lluamco wrote:
Frank, what version of puppy are you using? If it is 4.3.1, I would recommend uninstalling the hpliplite-3.11.5 pet and try the version
at the first message of this thread, hpliplite-3.10.5.


Thanks, I am using 431. What is the best method of uninstaling? My puppy package manager is fried
Back to top
View user's profile Send_private_message 
Frank Cox

Joined: 01 Nov 2009
Posts: 381

PostPosted: Sat 04 Jun 2011, 04:19    Post_subject: Error Message  

I uninstalled the other package and installed 10.5 as was suggested.
It seemed to install but I got this error message
Filter "hpcups" for printer "HP_C3140" not available: No such file or directory"

Thanks
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Mon 06 Jun 2011, 10:00    Post_subject:  

Here are two strategies.

1. Reinstall Puppy 4.3.1 from scratch.
2. Keep the original CUPS 1.1.23.
3. Install hpliplite-3.10.5 from the start of this thread.

1. Reinstall Puppy 4.3.1 from scratch.
2. Go here and update CUPS.
3. Install the foomatic-filters-4.0.4-i486.pet.
4. Install the hpijs-3.10.6-dynppd.pet.

From lluamco's new hpliplite thread:
Quote:
The dynamical packages have been compiled and tested either in Quirky or Wary and should also be suited for Wary/Quirky and lupu. Please note that they are NOT functional for standard puppy's, up to and including 4.3.1. Those versions REQUIRE STATIC hpliplite packages, obtainable from http://murga-linux.com/puppy/viewtopic.php?p=184635&search_id=133786018#184635
Back to top
View user's profile Send_private_message 
mini-jaguar

Joined: 13 Nov 2008
Posts: 462

PostPosted: Fri 12 Jul 2013, 08:59    Post_subject:  

Is the information in the original post correct?

I tried installing to 4.3.2, exactly as mentioned, first lipnetsnmp-15.pet, then hpliplite-3.9.8, then restarted cups like it mentioned, then configured CUPS. Installed correctly but the test print "stopped" and did not print, nor did the printer move at all.

Printer works fine with other o.s.es.

Do I need tk and tlc and Python too? The original post seems to say no for 3.9.8, but maybe the post is badly structured.

Also tried 3.9.8 and 3.10.5 with Lucid. Same problem.

Also tried with FatDog64 with 32-bit libs. Same problem.

Any recommendations for different Puppies or different installing strategies? 4.3.1 with KDE wouldn't work at all. I have a bunch of other Puppies installed, two Slacko versions, Exprimo, Precise, etc.

Printer is HP LaserJet P1006.
Back to top
View user's profile Send_private_message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Fri 12 Jul 2013, 09:49    Post_subject:  

Hi mini-jaguar,
the post you mention is rather old, and it may well be outdated.
In addition, your HP LaserJet P1006 printer requires plugins.
I can suggest two possible alternatives:

1) Try the foo2xxx driver, as explained by rcrsn51 in this post http://murga-linux.com/puppy/viewtopic.php?p=444080&sid=f0d959ffab9623af9fb2c6b9e5112ae2#444080
The foo2xxx_rcrsn.pet is available at http://www1.datafilehost.com/d/ce2c9afa.

The second option is:

2) Try using more modern versions of puppy and hpliplite, as explained in http://murga-linux.com/puppy/viewtopic.php?p=439468&sid=3c2dfcf3aa7a5783bfa700d361bb7085#439468, making attention to the plugin installation.

I hope that helps.
Back to top
View user's profile Send_private_message 
mini-jaguar

Joined: 13 Nov 2008
Posts: 462

PostPosted: Fri 12 Jul 2013, 12:11    Post_subject:  

Not sure it was outdated because I also tried it on some pretty old Puppies and the printer appeared in the lists.

Although you're probably right and it probably required plugins, because it didn't work.

Anyways, the foo2xxx driver worked, and I'm really glad because it was the easiest solution.

Thanks.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 10 of 10 Posts_count   Goto page: Previous 1, 2, 3, ..., 8, 9, 10
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0692s ][ Queries: 13 (0.0133s) ][ GZIP on ]