Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 13:57
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
white screen of death with xfce and compiz
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
fresnofred

Joined: 04 Mar 2009
Posts: 15

PostPosted: Sun 12 May 2013, 23:41    Post_subject:  white screen of death with xfce and compiz
Sub_title: white screen shows up
 

Probably an old topic but here it be: I have installed xfce4 and compiz on puppy 5.2 on a flash drive. when i change from jwm to xcfe it looks like it will load but instead just get a white screen with the mouse active, but no picture. hoping someone would have found an answer to this prob that has been bugging me for over a year.
Back to top
View user's profile Send_private_message 
8-bit


Joined: 03 Apr 2007
Posts: 3387
Location: Oregon

PostPosted: Mon 13 May 2013, 01:56    Post_subject:  

I have got it working once, but cannot remember what steps I took with Puppy Lucid 5.20.
I also had it working with Puppy Slacko 5.3.3 as to xfce4 with compiz.
I tried with Slacko 5.5.2, but never got it working right with a black desktop instead of white.
So I really do not know the secret to getting the combination to work every time.
There is a download called compiz helper that is supposed to help in setting things up though.
A search of the forum may find it as I cannot remember the link.
Back to top
View user's profile Send_private_message 
rg66


Joined: 23 Jul 2012
Posts: 551
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Mon 13 May 2013, 05:04    Post_subject:  

I believe compiz needs compositor enabled in window manager tweaks for it too work. And, according to the Carolina package manager it needs python and pyrex.

Can you open a terminal in XFCE? Does the desktop right click work, there may be an option to "open terminal here". If you can get a terminal type: "xfwm4 --compositor=on --replace" without the quotes and see if that does anything.

Or try to get XFCE running without compiz installed first.

_________________
Carolite-1.2 / Carolina-1.2 / X-precise-2.4 / X-slacko-2.2
Carolina
X-precise/X-slacko
Back to top
View user's profile Send_private_message 
CatDude


Joined: 03 Jan 2007
Posts: 1488
Location: UK

PostPosted: Mon 13 May 2013, 15:02    Post_subject:  

Hi

I just set up a fresh frugal install of Lupu-520,
then did the following:

Using the Quickpet installer, i installed my graphics card driver: ATI_fglrx-10.10-Lucid.pet
I believe this is the most important step as Compiz requires acceleration.
After installing that i did as indicated and rebooted.

Next (via the PPM), i installed: xfce4-4.6.2-519-beta-Lucid.pet
after which i cheated a little and simply used: Menu > Desktop > Desktop Settings > WM Switcher Switch between windowmanagers
to switch to Xfce4

Next i installed this: Compiz-0.8.4-Lucid.pet
which complained about a missing file:
Code:
File /usr/bin/wnckprop has these missing library files:
 libxcb-xlib.so.0

For now i just ignored that and re-ran the WM Switcher again,
which is now found here: Menu > Applications > Settings > WM Switcher Switch between windowmanagers

OK so i now see the Compiz Logo whilst getting back to the desktop,
and as a quick test i open up a Thunar window to see if i can 'wobble' it about.
Well, surprise surprise, it has no decorations (titlebar),
so from past experience i just rebooted to rectify that little problem.

Upon getting back to the desktop i tried to start the CCSM (CompizConfig Settings Manager) via the menu and failed,
so i opened a console and tried that way.
Here is the output:
Code:
# ccsm
bash: /usr/bin/ccsm: /usr/bin/python: bad interpreter: No such file or directory
#


So i installed this: Python-2.6-Lucid.pet
which also complained about missing files:
Code:
File /usr/lib/python2.6/lib-dynload/_sqlite3.so has these missing library files:
 libsqlite3-3.6.12.so.0
File /usr/lib/python2.6/lib-dynload/_tkinter.so has these missing library files:
 libtk8.5.so libtcl8.5.so
File /usr/lib/python2.6/lib-dynload/_bsddb.so has these missing library files:
 libdb-4.4.so
File /usr/lib/python2.6/site-packages/goocanvasmodule.so has these missing library files:
 libgoocanvas.so.3
File /usr/lib/python2.6/site-packages/_mlt.so has these missing library files:
 libmlt++.so.3 libmlt.so.3 libpython2.7.so.1.0


It would probably be a good idea to sort out those missing files,
but as i have no intention of keeping this install i didn't bother.

Even so, at least i can now start up the CCSM,
so let's see if i can get a few things happening.

Before doing that though, i changed the keyboard model to: pc104 Generic 104-key PC
Menu > Applications > Accessories > Mouse/keyboard wizard > Advanced Xorg keyboard cofiguration (click OK) > Keyboard Model

The reason for doing this is because a lot of the default Compiz key bindings inlcude the use of the <Super> key,
which is the lefthand Twisted Evil Windows Twisted Evil key.
You could of course change the key bindings, but it's proably easier to just change the keyboard model.

The screeny shows both the 'Snow' and 'Paint fire on the screen' running.

Hope this helps
CatDude
.
snow-and-fire.png
 Description   
 Filesize   169.7 KB
 Viewed   424 Time(s)

snow-and-fire.png


_________________

Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0790s ][ Queries: 13 (0.0240s) ][ GZIP on ]