Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 28 Nov 2014, 03:18
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Where can I get SDL libraries for Flare? (Solved)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [23 Posts]   Goto page: 1, 2 Next
Author Message
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Thu 11 Apr 2013, 05:52    Post subject:  Where can I get SDL libraries for Flare? (Solved)  

There is a Diablo clone called Flare, with a pet for download available - supposed to work fine in Slacko. I downloaded and installed it in Lucid 5.2.8. Didn't seem to be any problem and there was a Menu entry for it. Clicked the Menu entry (in Fun, no less) and ,,,,,, nothing. One would have thought that, if it wasn't going to work, the installation would have complained about missing dependencies, libs etc.
Anyway, I found the exec file in /usr/local/games and ran it from a terminal. This time it said it was missing a SDL tft file, which could be a font one. Presumably, some of the.other SDL files required have been added by applications, which I have installed in the past. Is there a complete package of SDL files (in a pet) which will only install any libs not already present?
Any help would be appreciated.

_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal

Last edited by wimpy on Wed 24 Apr 2013, 12:49; edited 3 times in total
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 641

PostPosted: Thu 11 Apr 2013, 07:03    Post subject:  

Try from here:

http://dotpups.de/dotpups/Games/
Back to top
View user's profile Send private message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Thu 11 Apr 2013, 08:18    Post subject:  

Thanks for the reply. Will Lucid handle dotpups or do I need a dotpup handler?
_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 641

PostPosted: Thu 11 Apr 2013, 08:35    Post subject:  

I don't know, it's some time I abandoned lucid but I have another link:

http://www.murga-linux.com/puppy/viewtopic.php?t=68875
Back to top
View user's profile Send private message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Thu 11 Apr 2013, 10:26    Post subject:  

Thanks for the link. I'll see if I can get SDL loaded up.

EDIT It still doesn't run. I now get "/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/local/games/flare)".
I feel that I am well out of my depth and to mix metaphors have decided to bail out. I will remove flare as best I can, but will leave this as unsolved - in case it helps someone else.

_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send private message 
Monsie


Joined: 01 Dec 2011
Posts: 633
Location: Kamloops BC Canada

PostPosted: Sat 13 Apr 2013, 15:10    Post subject: Games and SDL libraries  

wimpy,

I found a Mirror with packages for Slacko. There is a pet listed for SDL 1.2.14 I have not tested this package in Wary Puppy yet, but since Flare is reported to work in Slacko 5.4 then this version may be the solution.

Monsie

_________________
My username is pronounced: "mun-see". Derived from my surname, it was my nickname throughout high school.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Sat 13 Apr 2013, 20:37    Post subject:  

@wimpy,

try downloading this sfs:

flare-0.18.sfs (155.65Mbytes)

Save to /mnt/home, then load using sfs_load.

N.B. It already contains needed SDL libraries.
Back to top
View user's profile Send private message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Sun 14 Apr 2013, 03:36    Post subject:  

Thank you. Monsie and muggins. I decided to go with muggins' suggestion and downloaded the sfs file. I moved it to /mnt/home and it ran perfectly from sfs_load.
Looks quite good.
My thanks, once again, for everybody's help and especially muggins.
I'll mark this thread as "Solved"
EDIT . I've removed the "Solved" (for the moment) since I now have another problem with the sfs file

_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal

Last edited by wimpy on Wed 24 Apr 2013, 12:56; edited 1 time in total
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Sun 14 Apr 2013, 05:24    Post subject:  

Glad to hear it's working wimpy.

For cross-references I also just posted in additional software, games section, here.
Back to top
View user's profile Send private message 
Monsie


Joined: 01 Dec 2011
Posts: 633
Location: Kamloops BC Canada

PostPosted: Mon 15 Apr 2013, 05:12    Post subject: Games and SDL libraries - SOLVED  

Just for the record, I did some testing in Wary Puppy. It turns out that Flare needed four SDL packages: SDL-1.2.14-i486.pet, SDL_image-1.2.10-i486.pet, SDL_mixer-1.2.11-i486.pet, and SDL_ttf-2.0.9-i486.pet in order to meet its dependencies. That said, I was still unable to get Flare-0.17.1 to run in Wary... Question Maybe I will ask Christos since he compiled this for Slacko, but did indicate to me that he would try it out in Wary.

I did however, try Flare-0.18 in Wary, and I am pleased to report that (so far) it appears to be running nicely, so thanks very much muggins --nice to see that you are still putting some games together. Smile

Monsie

_________________
My username is pronounced: "mun-see". Derived from my surname, it was my nickname throughout high school.
Back to top
View user's profile Send private message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Wed 24 Apr 2013, 12:48    Post subject:  

Sorry to come back on this. When I used sfs-load before on the flare*.sfs file, it said it was updating the menu file. Everything worked fine. I proceeded to remove the previous version of flare - the one with the SDL libraries. Now when I use sfs-load , it still says that it is going to update the menu,,,, but it doesn't.. So I don't have a menu entry (in Fun) to actually run it. How do I get it to run?
_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send private message 
Keef


Joined: 20 Dec 2007
Posts: 646
Location: Staffordshire

PostPosted: Wed 24 Apr 2013, 14:47    Post subject:  

It always helps to remove old versions before installing new ones. Otherwise you are likely to remove elements that were common to both.
Try unloading and reloading the sfs.
Or try typing 'flare' in terminal (assuming that's what the binary is called).

Re-reading your post: Did you try rebooting after removing the other version? Sometimes it is needed to 'clean up' properly.
Back to top
View user's profile Send private message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Wed 24 Apr 2013, 15:45    Post subject:  

Yes. I've rebooted a number of times since I removed the previous flare.. I may have been deluding myself into thinking I was running off the sfs file, when I thought it was working. The menu entry may well have been the previous flare (which didn't work).. I had to remove most of the previous flare manually, since the uninstall left loads of files behind. I did a pfind and it says that there are now no files with flare in the name, although I have flare-0.18.sfs in /mnt/home and sfs_load says it is loaded OK.
_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Thu 25 Apr 2013, 11:39    Post subject:  

wimpy,

i tried to replicate your problems, by rebooting a fresh p528, creating a save file, then installing the pet from this thread. (I'm assuming this is the one you first installed).

After uninstalling, via the package manager, there were still many parts remaining. After manually deleting these, then installing my sfs, it ran without problems.

The only thing i can think that could be causing you problems is possible leftover whiteout files. If you go to /initrd/pup_rw directory, then click the "eye" to reveal hidden files, are there any whiteout remnants?
Back to top
View user's profile Send private message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Thu 25 Apr 2013, 12:04    Post subject:  

Thanks for the reply. There are 2 empty directories and one file in /intrd/pup_rw.- .wh..wh.orph
,.wh..wh.pink, (directories), and the file ,wh..wh.aufs. I presumhttp://murga-linux.com/puppy/images/icons/icon9.gife the file is one of the whiteout files you mention. It looks empty anyway in geany. I'll delete it and report back.
EDIT 1: Didn't work. Still no launch entry in Fun. Do I have to delete the directories as well?
EDIT 2: FWIW I also have a Lucid 5.2.8 minimal setup which I use for test purposes. The only application installed is Firefox. I loaded the sfs file through Sfs-load and this time a Menu entry for flare appeared in Fun. Unfortunately that didn't seem to work either. Clicking on it doesn't work.
EDIT 3. I tried once more with a completely standard Lucid 5.2.8 ( no applications added). This time sfs-load said that I was trying to load without pup_save (whatever that is). I could go back (and install pup_save) or continue on an experimental basis. I decided to continue. The menu system was updated but it still didn't work. As before, clicking on the menu item in Fun did nothing. I'm a fairly impatient guy - how long should I have waited?
EDIT 4. Works fine in Slacko 5.5.

_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [23 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0758s ][ Queries: 12 (0.0036s) ][ GZIP on ]