Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 14:31
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
No WLAN detected
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [19 Posts]   Goto page: Previous 1, 2
Author Message
jojobear9

Joined: 18 Apr 2013
Posts: 7

PostPosted: Tue 23 Apr 2013, 08:09    Post subject:  

Not yet receiving an answer from AVM, but very interesting is the fact that I only looked for the driver in Hardinfo, and it did not appear there. Now as advised, which I call a good idea, I looked in the lsusb and promptly found the right one.

Code:
Bus 002 Device 004: ID 057c:6201 AVM GmbH WLAN USB v1.1

I hope that this info helps to find the correct driver.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Tue 23 Apr 2013, 10:04    Post subject:  

Thanks jojobear9 for your help.
It should be noted for anyone following this thread that jojobear9 already has a working solution under Slacko 5.5 using ndiswrapper.
This additional diagnosis is a development issue - we want to improve Puppy so that native Linux drivers are pre-installed and working, and having to resort to something like ndiswrapper will (and should) be unnecessary.

Newer models of FRITZ!WLAN dongles have USB device ID's of either 8401, 8402, or 8403, and these contain the Atheros AR9170 wifi chipset, supported in recent kernels by the carl9170 driver (kernel module) ...

jojobear9 wrote:
Code:
Bus 002 Device 004: ID 057c:6201 AVM GmbH WLAN USB v1.1

OK, that's obviously not one of the new dongles, it's the older model which contains the Texas Instruments TNETW1450 wifi chipset.
Slacko 5.5 does not contain a native Linux driver for this device.
There's a third-party driver called "acx-mac80211" available here -
http://acx100.git.sourceforge.net/git/gitweb.cgi?p=acx100/acx-mac80211;a=summary
but no one has (to date) compiled this for Slacko. So ndiswrapper is the only solution at this point ...

... however if jojobear9, or anyone else with the same device, finds themselves using Puppy Lucid 5.2.x then there is a compatible acx-mac80211 driver available as a dotpet here -
http://www.murga-linux.com/puppy/viewtopic.php?p=443985#443985
I just checked this driver now, and it definitely supports USB ID 057c:6201
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Tue 23 Apr 2013, 10:08    Post subject:  

Oh damn. I just tested that link to the acx-mac80211 driver, and it's broken!
It appears that the forum has been upgraded to not accept (or retain) attachments larger than 256MB.
What a mess.
Back to top
View user's profile Send private message 
jojobear9

Joined: 18 Apr 2013
Posts: 7

PostPosted: Tue 23 Apr 2013, 14:33    Post subject:  

Thanks for trying that hard!!! I'm going to use the ndiswrapper until someone has an useful idea that helps to get rid of that issue.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [19 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0472s ][ Queries: 12 (0.0053s) ][ GZIP on ]