Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 25 Jul 2014, 16:38
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Can xdebug work in puppy?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [27 Posts]   Goto page: Previous 1, 2
Author Message
Semme

Joined: 07 Aug 2011
Posts: 3557
Location: World_Hub

PostPosted: Tue 23 Apr 2013, 08:13    Post subject:  

That's the wrong devx champ.

XAMPP you missed answering..

autoconf, good..

Struct.pm? Yes- search deeper..

Here's the other thing: php-config --version

And those other deps, including libssl-dev ARE in PPM. Update it!

If that's truly the devx that's been loaded, no wonder compiles have failed.
Back to top
View user's profile Send private message 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Tue 23 Apr 2013, 08:19    Post subject:  

Semme wrote:
That's the wrong devx champ.

Wait a minute, one by one.
Which devx file should I use?
Back to top
View user's profile Send private message 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Tue 23 Apr 2013, 08:22    Post subject:  

Semme wrote:


And those other deps, including libssl-dev ARE in PPM. Update it!

Ok, I found libssl-dev_1.0.1 installed! I had to tick' the check box 'DEV" in PPM to show up!
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3557
Location: World_Hub

PostPosted: Tue 23 Apr 2013, 08:26    Post subject:  

Is your Precise 5.4.. 5.4.3.. which? You need to be exact!

Furthermore- it sounds like you'll need the dev pkg too..
Back to top
View user's profile Send private message 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Tue 23 Apr 2013, 08:33    Post subject:  

Ok, now don't laugh.
How shall I find my version of puppy?


Should I unload lupu_devx_528-3.sfs?
Back to top
View user's profile Send private message 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Tue 23 Apr 2013, 08:38    Post subject:  

Ok, I installed dev_pkg from xampp site.
Should I unload lupu_devx_528-3.sfs?
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3557
Location: World_Hub

PostPosted: Tue 23 Apr 2013, 08:38    Post subject:  

Very Happy For, ah.. version >> cat /etc/DISTRO_SPECS

If you're run'n Precise, you sure don't need Lupu's devx.
Back to top
View user's profile Send private message 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Tue 23 Apr 2013, 08:40    Post subject:  

Ok: DISTRO_VERSION=5.4.3
I uloaded lupu_devx_528-3.sfs.
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3557
Location: World_Hub

PostPosted: Tue 23 Apr 2013, 08:44    Post subject:  

As long as your 5.4.3's not the retro build, you want the devx from here.

Then I'd go about trying to build xdebug.

And I'd say remove any of it's earlier stuff before proceeding..
Back to top
View user's profile Send private message 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Tue 23 Apr 2013, 08:59    Post subject:  

Ok, I tried to run phpize:
sh-3.00# /opt/lampp/bin/phpize-5.4.7
Code:
Configuring for:
PHP Api Version:         20100412
Zend Module Api No:      20100525
Zend Extension Api No:   220100525
Cannot find autoconf. Please check your autoconf installation and the
$PHP_AUTOCONF environment variable. Then, rerun this script.


Wait a minute, I haven't loaded new devx from the link you posted Embarassed .
I'll load it and retry.
Back to top
View user's profile Send private message 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Tue 23 Apr 2013, 09:30    Post subject:  

It compiled! It seems to be working!!!
I only had to change the path for php-config:
./configure --with-php-config=/opt/lampp/bin/php-config-5.4.7
as suggested here.

Semme thank you VERY MUCH my friend!
If it weren't you I wouldn't have made it!
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3557
Location: World_Hub

PostPosted: Wed 01 May 2013, 16:42    Post subject:  

Sorry I'm sooo late responding but- discovery is often laborious. You made it cause you Wink HUNG IN THERE!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [27 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0582s ][ Queries: 13 (0.0050s) ][ GZIP on ]