Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 30 Aug 2015, 10:05
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Latest evince pet for latest puppy? (SOLVED)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
vicmz

Joined: 15 Jan 2012
Posts: 1208

PostPosted: Sun 21 Apr 2013, 22:54    Post subject:  Latest evince pet for latest puppy? (SOLVED)
Subject description: existing pets won't work
 

SOLVED: the evince-2.32-wheezy.pet pet from Dpup Wheezy works in Precise puppies, too:

http://mirror.internode.on.net/pub/puppylinux/pet_packages-wheezy/

----------------------------

Could anyone compile the latest evince for precise or wary 5.5?

I've tried existing pets:
http://murga-linux.com/puppy/viewtopic.php?t=57276
http://www.murga-linux.com/puppy/viewtopic.php?p=472483#472483


But all of them display an error message when I open a pdf, saying "File type Document PDF not supported". Shocked Shocked Shocked

I can't install evince from the PPM, it throws a lot of dependencies too large for my slow connection, and I'm able to use Puppy at my computer only -- I'd have to hunt all dependencies one by one from a windblows computer.
image-2.png
 Description   
 Filesize   69.74 KB
 Viewed   975 Time(s)

image-2.png


_________________
OB Precise 15.01 kernel 3.17.7|Puppy Linux en español

Last edited by vicmz on Tue 26 May 2015, 13:49; edited 1 time in total
Back to top
View user's profile Send private message 
CosmiCat


Joined: 30 Nov 2010
Posts: 12
Location: Italy

PostPosted: Fri 04 Oct 2013, 09:50    Post subject: Evince  

Hi, vicmz

You need the right version of the poppler library to open pdfs.
Make a "Check dependencies installed pkg" to find the version you need.
Then you can find it even in a debian repository (Try here: www.pkgs.org)
Back to top
View user's profile Send private message 
joaomcteixeira

Joined: 08 Jul 2013
Posts: 42
Location: Portugal

PostPosted: Mon 27 Jan 2014, 11:39    Post subject:  

I there,

I am having the same problem,

any clues?

Smile
Back to top
View user's profile Send private message 
slavvo67

Joined: 12 Oct 2012
Posts: 721
Location: The other Mr. 305

PostPosted: Sun 17 May 2015, 20:23    Post subject:  

Has anyone resolved this with actual steps? I find this thread at this point to be of little help. BTW- I am experiencing this problem with Barry's Quirky April (Evince).

Best,

Slavvo67
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 5772
Location: Gatineau (Qc), Canada

PostPosted: Sun 17 May 2015, 22:43    Post subject:  

Hi, slavvo.

The best solution that I have found for this problem runs under java! Smile

jpdfbookmarks is not only useful to create and edit bookmarks in a pdf file.
It is also an excellent pdf reader. To change pages, use arrows at top right
of menu section, or use Ctl-Alt-Right_Arrow or Ctl-Alt-Left_Arrow.

If you want the whole "nine-yards", you may want to try MasterPDFEditor.
Used as a PDF reader, it allows you to follow footnotes, etc.

If you have wine installed, the best PDF Reader is without question
SumatraPDF. It leaves all competitors in the dust, IMO.

I hope this helps.

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
joaomcteixeira

Joined: 08 Jul 2013
Posts: 42
Location: Portugal

PostPosted: Mon 18 May 2015, 06:22    Post subject:  

Nice post,
Thanks!
Back to top
View user's profile Send private message 
slavvo67

Joined: 12 Oct 2012
Posts: 721
Location: The other Mr. 305

PostPosted: Tue 19 May 2015, 20:45    Post subject:  

Hi Musher0:

Thank you for the nice response. jpdfbookmarks seems nice but doesn't seem to handle some of the more advanced PDF's well. At least, not yet. Perhaps a future version.

I having the same exact problem as Vicmz, above and I'm trying to fix the evince problem. I'm having the problem in Quirky April 32 bit, which may have occurred by installing something (no other April user is seeing this problem). Perhaps I'll need to make a new April and track each installation to identify the issue.

Anyway, a long winded thanks!

Slavvo67
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 5772
Location: Gatineau (Qc), Canada

PostPosted: Wed 20 May 2015, 05:46    Post subject:  

Hi slavvo.

If you're not happy with the above suggestions, maybe try a
ready-made Sysyphus or ArchLinux evince package on your Vivid Puppy?

Why re-compile an already good package, eh? Smile

BFN.

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
slavvo67

Joined: 12 Oct 2012
Posts: 721
Location: The other Mr. 305

PostPosted: Thu 21 May 2015, 22:50    Post subject:  

Ok. I believe that I fixed my problem.

I thought my Evince issue was with Enscript, however it turns out that one of my Open SSL patches broke Evince. It appears Barry has patched April pretty well, to my patch wasn't needed and broke something.

Thanks everyone for your help...

Slavvo67
Back to top
View user's profile Send private message 
vicmz

Joined: 15 Jan 2012
Posts: 1208

PostPosted: Tue 26 May 2015, 13:56    Post subject: Latest evince pet for latest puppy? (SOLVED)  

I had completely forgot about this. In fact, I got used to ePDFview. Now I've tested evince-2.32-wheezy.pet from Dpup Wheezy and it works well in Precise 571:

http://mirror.internode.on.net/pub/puppylinux/pet_packages-wheezy/

I didn't have to install additional dependencies. I haven't tested printing, though (printer issues).

Thank you all.

_________________
OB Precise 15.01 kernel 3.17.7|Puppy Linux en español
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0454s ][ Queries: 13 (0.0056s) ][ GZIP on ]