Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 02 Aug 2014, 01:04
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Mageia 2-Based Puppies - LAST BETA RELEASE
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 13 of 15 [211 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14, 15 Next
Author Message
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Sat 09 Mar 2013, 03:13    Post subject:    

.
Last edited by simargl on Sun 01 Sep 2013, 10:50; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Puppyt

Joined: 09 May 2008
Posts: 561
Location: Gatton, Queensland

PostPosted: Sat 09 Mar 2013, 16:40    Post subject:  

Hmm yeah I can't seem to grasp the difference between "Puppy derivative" and "Puppy projects" either (and many developers post their work in 'Announcements' I miss them entirely). There seems to be a bit of overlap in definition somehow. Is there an estimation of percentage-difference on whatever official Puppy version before a novel pupplet is moved from 'Derivative' to 'Project'? How else do developers decide where to lodge their derivative/project? Does Flash or Murga etc have an executive call on the home of the post etc? Reckon the advent of woof/woof2 has helped blur the definition too, somewhat...

EDIT: aha - I see I'm trampling over old ground - much discussion here http://www.murga-linux.com/puppy/viewtopic.php?t=70081 (Derivatives - a full list), and http://puppylinux.org/main/Puplet%20for%20special%20features.htm clusters pupplets together from their respective fora.

_________________
Toowoomba Linux Community
http://groups.google.com/group/toowoombalinux
Back to top
View user's profile Send private message Visit poster's website 
scsijon

Joined: 23 May 2007
Posts: 1026
Location: the australian mallee

PostPosted: Sat 09 Mar 2013, 20:00    Post subject:  

Well, to me (and the way I have always understood it to be was) a derivative is a puppy built on top of another major distribution, using where possible that distributions component packages.

While, a project was when someone took that a stage further by modifying or adding to the origonally built derivative with a 'pile' of apps etc. that did not come from that distribution or puppy's own apps package sets.

However I do agree it's got a little 'stuffed-up' and would rather not extend the OT further.

ON to business, the next version will be delayed a little while why I work out why I am having a problem building with the latest woof. The changes have all worked, I am just having problems with the shutdown routines!
Back to top
View user's profile Send private message Visit poster's website 
infromthepound

Joined: 12 Jun 2009
Posts: 131

PostPosted: Sun 10 Mar 2013, 01:49    Post subject:  

scsijon wrote:

ON to business, the next version will be delayed a little while why I work out why I am having a problem building with the latest woof. The changes have all worked, I am just having problems with the shutdown routines!


Now if you were working for MS, that would be an advantage...
JB
Back to top
View user's profile Send private message 
scsijon

Joined: 23 May 2007
Posts: 1026
Location: the australian mallee

PostPosted: Sun 10 Mar 2013, 19:52    Post subject:  

infromthepound wrote:
scsijon wrote:

ON to business, the next version will be delayed a little while why I work out why I am having a problem building with the latest woof. The changes have all worked, I am just having problems with the shutdown routines!


Now if you were working for MS, that would be an advantage...
JB


Especially with 8, I believe there is a note somewhere that once started it should not be shutdown except in an emergency. But not having a copy I can't verify that!

However, BarryK has confirmed for me that the problem is not woof2's as is and how to check the two builds. So I will have to find what package I've updated is causing it, and hope it doesn't stuff up the rest. Somehow I don't think that will be quick! Good thing I only work part-time nowadays!
Back to top
View user's profile Send private message Visit poster's website 
futwerk

Joined: 07 May 2011
Posts: 261

PostPosted: Tue 02 Apr 2013, 17:55    Post subject:  

new backgrounds
mageja12,1.png
 Description   http://www.mediafire.com/?a11d30ws1dhr96n,7r2bwwhk1a4d2hj,ekgvi7wq45ek0z3
 Filesize   55.37 KB
 Viewed   677 Time(s)

mageja12,1.png

mage12,2a.png
 Description   http://www.mediafire.com/?a11d30ws1dhr96n,7r2bwwhk1a4d2hj,ekgvi7wq45ek0z3
 Filesize   47.73 KB
 Viewed   673 Time(s)

mage12,2a.png

mage12,2.png
 Description   http://www.mediafire.com/?a11d30ws1dhr96n,7r2bwwhk1a4d2hj,ekgvi7wq45ek0z3
 Filesize   74.7 KB
 Viewed   674 Time(s)

mage12,2.png

Back to top
View user's profile Send private message 
scsijon

Joined: 23 May 2007
Posts: 1026
Location: the australian mallee

PostPosted: Wed 03 Apr 2013, 01:06    Post subject:  

thank you futwerk, nicely timed as i've (I hope) sorted out my problem and will be building a beta of mage2-0012 for large group testing this coming weekend as it's passed all my local group's tests.

The problem in the end had me going back and forth over the last two versions and my new ones and chasing a 'white rabbit'. In the end it was a updated package that I really didn't want updated as the new one was systemd and the old init-script controlled.

mage2-0012 should appear on page 1 early in the new week.

I have also updated JWM to the latest (naturally) with mick's jwmconfig2 config package.

And also updated PPM with the extra Selection Filtering, you will be suprised what is available in the gtk3 groups, but don't use them in other puppy's unless they are also gtk3 aware (including lib's) or you will have a good chance of a permanent crash.

_________________
Puppy T290 - BarryK's Racy but with T2 Version 9.0 is under development.
http://www.murga-linux.com/puppy/viewtopic.php?t=94575
Back to top
View user's profile Send private message Visit poster's website 
scsijon

Joined: 23 May 2007
Posts: 1026
Location: the australian mallee

PostPosted: Wed 10 Apr 2013, 04:12    Post subject:  

Final beta mage2-00.12.07 will appear early next week if nothing new appears in the problem lists, I have built it and we are doing local testing until monday.

I have two problem work-arounds inbuilt and five 'nusance' problems at present, hopefully no more will appear!
Back to top
View user's profile Send private message Visit poster's website 
scsijon

Joined: 23 May 2007
Posts: 1026
Location: the australian mallee

PostPosted: Tue 16 Apr 2013, 07:07    Post subject: mage2-00.12.07  

final beta mage2-00.12.07 is now released for testing.

links at top of page 1

It has the latest JWM, thunor's gtk3dialog and a few 'goodies'.

I have received a INNO3D card (nivida geoforce) to test with, thanks to one of their local whole salers I did a favour for, so I am able to test their video driver again although I still prefer to use the onboard Intel when available.

Problems and reports to appear in messages below, please ensure that you have 'mage2-00.12.07' in the subject field so I know the version under discussion.

have fun folks

scsijon
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 2063
Location: Ontario Canada

PostPosted: Tue 16 Apr 2013, 11:45    Post subject: Mageia 2-Based Puppies - LAST BETA RELEASE  

I'm running from the live dvd with a savefile, computer is a Mac Mini
with intel HD4000 graphics.
Mage2, version 0.12.07 on Tue 16 Apr 2013
Chip description:
oem: Intel(R) Sandybridge/Ivybridge Graphics Chipset Accelerated VGA BIOS
product:Intel(R) Sandybridge/Ivybridge Graphics Controller Hardware Version 0.0
X Server: Xorg
Driver used: intel
X.Org version: 1.11.4
dimensions: 1920x1080 pixels (507x285 millimeters)
depth of root window: 24 planes

I downloaded Firefox 20 and installed it in /mnt/home, also downloaded
and installed the latest flashplayer plugin from Adobe.com.
I install lxterminal from ppm, I tried to install vlc from ppm but it
said the files weren't available.I updated ppm first which took quite
a while.
Sound,wireless network (used network manager to setup), and screen resolution
all good on first bootup.
I compiled htop-1.0.2.

That's it so far.

EDIT:I've been able to compile quite a few applications from source code
without problems,vlc-2.0.6,ffmpeg-1.2,mplayer-1.1,audacious-3.3.4,mc-4.8.8,
xinelibs-1.2.2,xineui-0.99.7, and a few others.
I added glxinfo from ppm and it shows more info in the hardinfo report:
OpenGL
Vendor Tungsten Graphics, Inc
Renderer Mesa DRI Intel(R) Ivybridge Mobile x86/MMX/SSE2
Version 2.1 Mesa 8.0.2
Direct Rendering Yes

The beta is working very well on this hardware, thanks.
screenshot.jpg
 Description   
 Filesize   37.87 KB
 Viewed   490 Time(s)

screenshot.jpg

Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5687
Location: Kentucky

PostPosted: Wed 17 Apr 2013, 01:01    Post subject: mage2-00.12.07  

Attempted to run on my trusty Athlon XP box but despite trying every trick I know X refused to start.Black screen with "monitor out of range" message.

Code:
VGA compatible controller      : nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev c1) (prog-if 00 [VGA controller])


Tomorrow I'll try with Intel graphics and possibly newer Nvidia chip..
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 1571

PostPosted: Wed 17 Apr 2013, 10:45    Post subject:  

Tried it on my VM and went through the old puppy console setup sequence (keyboard, timezone, xorgwizard etc) and when the desktop came up went through the "modern" first boot windows. Is this by design?

Works fine though with the exception of abiword that has a black background and crashes if you try to open the preferences. Reinstalling 2.9.2 from the Mageia repo solves the crash issue but the black background remains.

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2063
Location: Ontario Canada

PostPosted: Thu 18 Apr 2013, 00:33    Post subject: Mageia 2-Based Puppies - LAST BETA RELEASE  

Frugal install on a 5+ year old Acer Desktop.
It used the nouveau driver at first.
# report-video
Mage2, version 0.12.07 on Wed 17 Apr 2013
Chip description:
oem: NVIDIA
product: G84 Board - p402h00 Chip Rev
X Server: Xorg
Driver used: nouveau
X.Org version: 1.11.4
dimensions: 1440x900 pixels (380x238 millimeters)
depth of root window: 24 planes
------------------------------------------------------------------
I downloaded and installed the proprietary nvidia driver for this
Geforce 8600 GT card.
I installed glxinfo from ppm.

OpenGL
Vendor NVIDIA Corporation
Renderer GeForce 8600 GT/PCIe/SSE2
Version 3.3.0 NVIDIA 319.12
Direct Rendering Yes
------------------------------------------------------------------
It seems that you can't install mage2 beta to sda1, I tried and it always wants
to save to sda2 so I gave in and copied the mage folder to sda2,deleted the old
folder reran grub4dos and rebooted, then made my savefile on sda2.

I installed all the programs that I made earlier and everything is working
well.
screenshot2.jpg
 Description   
 Filesize   42.48 KB
 Viewed   303 Time(s)

screenshot2.jpg

Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5687
Location: Kentucky

PostPosted: Sat 20 Apr 2013, 17:42    Post subject: Re: mage2-00.12.07  

James C wrote:
Attempted to run on my trusty Athlon XP box but despite trying every trick I know X refused to start.Black screen with "monitor out of range" message.

Code:
VGA compatible controller      : nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev c1) (prog-if 00 [VGA controller])


Tomorrow I'll try with Intel graphics and possibly newer Nvidia chip..


A bit late but......

Working fine (frugal install) on an old P4 with Intel graphics.

# report-video
Mage2, version 0.12.07 on Sat 20 Apr 2013

Chip description:

oem: Intel(r)865G Graphics Chip Accelerated VGA BIOS
product: Intel(r)865G Graphics Controller Hardware Version 0.0

X Server: Xorg
Driver used: intel

X.Org version: 1.11.4
dimensions: 1024x768 pixels (270x203 millimeters)
depth of root window: 24 planes

...the above also recorded in /tmp/root/ as report-video,
and archived with xorg.conf and Xorg.0.log as report-video-full.gz
#

-Computer-
Processor : Intel(R) Pentium(R) 4 CPU 2.80GHz
Memory : 2551MB (161MB used)
Machine Type : Physical machine
Operating System : Mage2 - 0.12.07
User Name : root (root)
Date/Time : Sat 20 Apr 2013 04:46:51 PM CDT
-Display-
Resolution : 1024x768 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : ICH4 - Intel ICH5
Back to top
View user's profile Send private message 
scsijon

Joined: 23 May 2007
Posts: 1026
Location: the australian mallee

PostPosted: Sat 20 Apr 2013, 21:20    Post subject: mage2-00.12.07 replies  

sorry all, been a bit busy with other things.

@#James C > Try picking vesa in the xorgwizard and see if that comes up ok. If it does, reboot without saving and try again but manually picking the driver and TEST it before accepting, maybe you will need to set the frequency down so take your time. If that doesn't work you may need to choose the nv driver in the non-free ppm group, download it and xorgwizard again as there are a few boards that will only work with that driver for some reason, it's a mageia thing and I can't change it.

Also check if there is a clue in the /tmp/xerrs.log on the box when you get it up.

And your second message is not late, it's nice to have all extra confirmations that things are ok or not.

@mavrothal > I always build with both starting processes runing, the release will go through to first boot setup bypassing the manual setup.

I shall play with the mageia abiword, maybe the one I have been using has a problem and needs rebuilding. It works ok here from the iso on one of my testboxes so something is wierd somewhere.

EDIT: Apparently there is a woof2 problem with abiword and also gnumeric which has been fixed since my build. The next pre-release build will have it fixed and All apps will be tested rather than just the problem ones.

@Billtoo > mage2 won't allow installation on a drive partition that's too small to take the install and leave sufficent space for a savefile. It installs ok here, so I suspect that maybe the problem, otherwise I don't know why, sorry.

Last edited by scsijon on Tue 23 Apr 2013, 01:23; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 13 of 15 [211 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14, 15 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1080s ][ Queries: 13 (0.0141s) ][ GZIP on ]