Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 17 Apr 2014, 00:48
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Date & Heure: Au secours! [RÉSOLU]
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 4 [50 Posts]   Goto page: 1, 2, 3, 4 Next
Author Message
Argolance


Joined: 06 Jan 2008
Posts: 1774
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 13 Apr 2013, 09:15    Post subject:  Date & Heure: Au secours! [RÉSOLU]
Subject description: A la bonne heure!
 

Hello,
UTC, temps local, GMT + ou - xxx, Europe/Villexxx, horloge matérielle, horloge logicielle, fuseau horaire, synchronisation avec un serveur distant...
Aïe!
J'ai eu le malheur d'essayer de remettre ma pendule à l'heure une fois, et sur mes deux machines (en plus!). J'ai dû m’égarer sur du GMT Confused et comme ça ne me donnait pas la bonne heure, en désespoir de cause, j'ai tripatouillé tout le reste! Crying or Very sad ). Résultat, je ne parviens absolument plus à avoir l'heure correctement avec mes deux Puppies. Il arrive même que lorsque je tente de faire un réglage avec le simple Date et Heure de base, Puppy se fige carrément et que je sois obligé d'y aller du ctrl alt backspace, c'est dire combien je suis dans la m...!

Quelqu'un saurait-il comment il est possible de sortir de l'impasse dans laquelle je me suis fourré Cool ... et tout remettre en ordre? Very Happy

Merci!
Cordialement.

Last edited by Argolance on Wed 17 Apr 2013, 18:59; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
lerustre

Joined: 28 Jan 2010
Posts: 66

PostPosted: Sat 13 Apr 2013, 12:53    Post subject:  

hello argolance
pour moi avec la tooppy béta et maintenant la nouvelle , impossible d'avoir l'heure juste , pas de plantage mais des heures differentes à chaque demarrage , et heure juste sur mes autres distirb sur le même pc (quadruple boot )
jai essayé differentes façon (trop de choix presque ) et chaque fois pareil !!
à plus
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1774
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 13 Apr 2013, 19:40    Post subject:  

Hello,
Je n'ai eu ce problème qu'après avoir tripatouillé. Je viens de tester sur une installation toute neuve, et il ne semble pas que ça recommence...
Sinon, je ne vois pas du tout ce qui peut en être la cause!
EDIT: ben si, ça recommence...

Cordialement.

Last edited by Argolance on Sat 13 Apr 2013, 20:01; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
Médor


Joined: 26 May 2011
Posts: 1322

PostPosted: Sat 13 Apr 2013, 19:51    Post subject:  

Bonsoir,

Pour régler l'heure :
1) Dans Puppy : faisceau horaire Europe/Paris et non pas GMT+1 ... ! :
- /etc/@localtime -> /usr/share/zoneinfo/Europe/Paris

2) NTPDATE ou un autre utilitaire pour maintenir la synchro de l'heure et passage automatique heure d'hiver / d'été.
La synchro peut être automatisée au démarrage.

Si on utilise (encore) Windows :
Pour ne pas faire abusivement deux fois un changement d'heure, il vaut mieux que ce dernier effectue le basculement en premier et consigne l'opération !

Pour Toutou 4.1.2 et 4.3.1 j'ai proposé un Correctif-Services-NTP.pet les versions de TTL 3.01.4 et antérieure ne sont pas affectées, ce correctif est présent dans l'Asri-300...
Lien du paquet fr : ntpdate-4.2.4p4_m-fr.pet
D'autres utilitaires sont maintenant présents dans Puppy, cependant voici ce que dit le fichier d'aide :
Code:
IMPORTANT: Remember to set your computer to the correct time zone before setting the time.
Menu > Desktop > Set Timezone

Setup your timezone, for puppy to auto-adjust for DST selct your correct time zone, if your time zone is not listed then select one of the GMT zones.  The GMT zones do not auto-adjust for DST, if you use a GMT zone, set it back ONE hour. (puppy does things a little differently and must be set back not ahead.) (If you timezone is listed, then puppy will auto-adjust for DST.)
---------------------

If you are booting windows and linux, then localtime is to be used.
If you are just booting linux, then UTC is be used.


To Change from LocalTime to UTC, go to the file:
/usr/sbin/NTPDATE-sync_clock

and change:
TF=localtime

to:
TF=utc

----------------------
To enable the program to sync to the time server you must go to /etc/services and add the following two lines at the bottom of the file in a new line:

ntp         123/tcp      # Network Time Protocol
ntp         123/udp      # Network Time Protocol

----------------------
More time servers are avaliable at http://www.pool.ntp.org

To change time server, go to the file:
/usr/sbin/NTPDATE-sync_clock

and change:
TS=0.north-america.pool.ntp.org

to whatever server you have chosen.



Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1774
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 13 Apr 2013, 20:03    Post subject:  

Merci bien Médor! Tu m'as l'air d'un sacré puppyiste noctambule toi aussi, hein!
Je verrai ça demain...

Cordialement.
Back to top
View user's profile Send private message Visit poster's website 
Argolance


Joined: 06 Jan 2008
Posts: 1774
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 14 Apr 2013, 13:08    Post subject:  

Hello Médor,
Quote:
Pour ne pas faire abusivement deux fois un changement d'heure, il vaut mieux que ce dernier effectue le basculement en premier et consigne l'opération !
C'est justement à ce moment-là que j'ai voulu remettre l'heure exacte et que mes soucis ont commencé!
Quote:
/etc/@localtime -> /usr/share/zoneinfo/Europe/Paris
/etc/localtime (sans @) est bien présent mais vide! même chose pour le deuxième, à moins qu'ils ne soient pas éditables?

EDIT: je viens de tester le correctif, rien n'y fait! Mais j'aimerai savoir si ça c'est propre seulement à Puppy Precise 5.4.3 ou à ToOpPy!

Cordialement.

Last edited by Argolance on Sun 14 Apr 2013, 13:35; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Médor


Joined: 26 May 2011
Posts: 1322

PostPosted: Sun 14 Apr 2013, 13:27    Post subject:  

Bonsoir Argolance,

Ici /etc/@localtime est un lien, il est normalement créé par l'assistant du premier boot...
Comme tu n'as qu'un fichier vide il n'y a donc pas de "localtime", supprime le fichier pour pouvoir faire un lien car il risque de ne pas pouvoir être créé par l'assistant Wink

Cordialement,
Médor

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1774
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 14 Apr 2013, 13:46    Post subject:  

Hello,
/usr/share/zoneinfo/posix/Europe/Paris ainsi que tous les fichiers de ce dossier sont vides! Shocked
Est-ce normal?

Cordialement!
Back to top
View user's profile Send private message Visit poster's website 
Médor


Joined: 26 May 2011
Posts: 1322

PostPosted: Sun 14 Apr 2013, 14:48    Post subject:  

Non ce n'est pas normal !
Que ce soit sur Lucid-528, Wary ou Slacko 5.5, tous les répertoires dans /zoneinfo sont peuplés, le répertoire /posix n'existe que sur la Slacko-5.5 !
Mais le fichier : Paris, est dans /usr/share/zoneinfo/Europe/ et pas dans /posix...

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
oui

Joined: 20 May 2005
Posts: 1845
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Sun 14 Apr 2013, 16:06    Post subject:  

bonjour Argolance,

l'heure et Linux, c'est un calvaire, à cause des compromis...

(un peu comparable à un forum commun puppy moderne / toutou 4etdesbriques)...

Unix ne connaissait que UTC Exclamation

puis vinrent les windowiens pleurnicheurs et voulurent garder leur horloge à la windows dans le clone de Unix Rolling Eyes

et chaque Linux a, malheureusement le pouvoir de re-régler l'heure lui-même (en plus des actions individuelles personnelles des propriétaires du PC, nantis de leur pouvoir d'administrateur).

donc comme Médor l'indiquait un windowien auquel le virus linux fut inoculé réglera son horloge différemment du puriste.

moi je règle sur

- UTC (méthode linux)
- hardware: to match software,

dans Set-HW-Clock Type,

- je fais la mise à l'heure précise

dans PSynchrone

et en général cela suffit (car PSynchrone tient déjà compte du continent en cherchant l'horloge à distance).

Parfois, il faut mettre un offset en plus (zone horaire), cela dépend aussi des Puppys (où et comment ils prennent en considération la base UTC... et de l'incidence des horaires d'hiver et d'été) et de l'état préalable de l'horloge avant ces opérations!

MAIS...

si on redémarre en pfix=RAM (ou du quirky tout kernel, où je suis dedans actuellement, il me change effectivement l'heure sur la base de ses paramètres par défaut), il se peut que de nouvelles différences réapparaissent malgré que les deux options Set-HW-Clock + PSynchrone fassent très bien le travail.

(Puppy n'est pas favorable à UTC mais se rapproche là de Windows... Nous sommes tous des migrants ou renégats de Windows...)

bonne chance
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1322

PostPosted: Sun 14 Apr 2013, 16:37    Post subject:  

Bonsoir,

Ce qui est sûr c'est qu'ici ça fonctionne Wink

Cordialement,
Médor.
Synchro de l'heure.jpg
 Description   
 Filesize   91.08 KB
 Viewed   183 Time(s)

Synchro de l'heure.jpg


_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1774
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 14 Apr 2013, 17:07    Post subject:  

Hello lerustre,
D'après ce fil, c'est un problème propre au moins à Puppy Precise 5.4.3: ça me rassure. En attendant d'aller voir plus en profondeur, j'ai fait ce que gzer conseille, et j'ai l'heure qui s'affiche correctement. Very Happy
Donc, pour ToOpPy: MENU/SERVICES/Configuration/Quicksetup Paramètres Accueil. Choisir votre fuseau horaire (Europe/Paris pour moi) et cocher "Établir l'heure à partir d'Internet". Psync s'ouvre. Choisir la zone appropriée (en l'occurence Europe). Choisir "Autostart". Redémarrer le serveur X. La mise à l'heure se fait quelques secondes après l'affichage du bureau et ça tient après redémarrage de l'ordinateur.

Cordialement.
EDIT: Nos posts se sont croisés!
Merci Médor!
Back to top
View user's profile Send private message Visit poster's website 
Argolance


Joined: 06 Jan 2008
Posts: 1774
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 14 Apr 2013, 17:15    Post subject:  

PS: Je viens de jeter un œil à Psync. C'est un script éditable/"gettextable": Du coup, je vais le faire au cas où il n'y aurait pas moyen de régler le problème autrement pour que les utilisateurs qui ne pigent pas l'english s'y retrouvent. Dans ce cas je pense que je configurerai quicksetup avec la case "Établir l'heure à partir d'Internet" cochée par défaut.

Cordialement.
Back to top
View user's profile Send private message Visit poster's website 
Argolance


Joined: 06 Jan 2008
Posts: 1774
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 14 Apr 2013, 17:20    Post subject:  

Hello oui,
Merci pour les précisions. Excuses: je n'avais pas vu ton post.
Good night à vous, fidèles Puppyistes. Wink

Cordialement.
Back to top
View user's profile Send private message Visit poster's website 
Argolance


Joined: 06 Jan 2008
Posts: 1774
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 14 Apr 2013, 17:24    Post subject:  

Suite:
Quote:
Que ce soit sur Lucid-528, Wary ou Slacko 5.5, tous les répertoires dans /zoneinfo sont peuplés, le répertoire /posix n'existe que sur la Slacko-5.5 !
Mais le fichier : Paris, est dans /usr/share/zoneinfo/Europe/ et pas dans /posix..
J'avais pas vu ce post-là non plus Embarassed et je crois Médor que tu as mis le doigt sur la solution... que je vais me permettre de répercuter sur le fil anglais si ça marche!
Verrai ça demain.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 4 [50 Posts]   Goto page: 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0732s ][ Queries: 13 (0.0046s) ][ GZIP on ]