Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 20 Apr 2014, 07:07
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
PHATSlacko - March 2013
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 8 of 10 [140 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10 Next
Author Message
James C


Joined: 26 Mar 2009
Posts: 5445
Location: Kentucky

PostPosted: Sat 06 Apr 2013, 15:27    Post subject:  

01micko wrote:
James C wrote:
Back in Windows 7 ..... submitted the above post,opened Hardinfo to add more hardware info and had an instant freeze with distorted display and no keyboard input.Hard poweroff.
Might have to await 3.9 James before you can have any fun with f2fs! BTW, I did read about PV's avoidance of 3.8x. What gets me is how the kernel devs get some things so wrong when in previous versions they were stable . Confused .


Update from the nVidia Corporation C61 [GeForce 7025 / nForce 630a] box.

Adding nouveau.noaccel=1 to the kernel line solves the freezing problem ... at least on this particular Nvidia chip.

# report-video
VIDEO REPORT: PHATSlacko Puppy, version 5.5.02

Chip description:
VGA compatible controller: nVidia Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)

Requested by /etc/X11/xorg.conf:
Resolution (widthxheight, in pixels): 1024x768x16
Depth (bits, or planes): 24
Modules requested to be loaded: dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
Driver loaded (and currently in use): nouveau
Loaded modules: dbe dri dri2 exa extmod fb glx kbd mouse record shadowfb

Actual rendering on monitor:
Resolution: 1366x768 pixels (361x203 millimeters)
Depth: 24 planes

...the above also recorded in /tmp/report-video
# glxgears
2423 frames in 5.0 seconds = 484.588 FPS
2443 frames in 5.0 seconds = 488.485 FPS
2710 frames in 5.0 seconds = 541.905 FPS
2722 frames in 5.0 seconds = 544.268 FPS
2709 frames in 5.0 seconds = 541.800 FPS

Also got rid of the error messages when running "glxgears".

-Computer-
Processor : 4x AMD Athlon(tm) II X4 620 Processor
Memory : 3883MB (219MB used)
Machine Type : Physical machine
Operating System : PHATSlacko Puppy - 5.5.02
User Name : root (root)
Date/Time : Sat 06 Apr 2013 02:31:42 PM CDT
-Display-
Resolution : 1366x768 pixels
OpenGL Renderer : Gallium 0.4 on llvmpipe (LLVM 0x300)
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : HDA-Intel - HDA NVidia
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7547
Location: qld

PostPosted: Sat 06 Apr 2013, 16:30    Post subject:  

Interesting James, thanks for the info.

I did experiment rolling back to 3.7.10 and 3.6.11 but f2fs was a failure on those. I couldn't see any other advantage of those over 3.4.17 in slacko-5.5 proper.

I'll see if I can compile the latest nvidia proprietary driver so that cards like yours can at least have full acceleration, although I do notice you do seem to get some with those glxgears numbers. Do you happen to have any 3d games to test acceleration under your stated setup?

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5445
Location: Kentucky

PostPosted: Sun 07 Apr 2013, 00:53    Post subject:  

Further testing with the troublesome Nvidia chips.

Tested several of Pemasu's earlier releases with k-3.7.x or k-3.8.x kernels that also froze up and by adding "nouveau.noaccel=1" to the kernel line all freezing has stopped.

Don't recall exactly when the problem started but it seems like it was about the area of k-3.5.x or k-3.6.x......... never noticed a problem with Slacko until PHATSlacko though.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7547
Location: qld

PostPosted: Sun 07 Apr 2013, 01:19    Post subject:  

Ok, I might add "nouveau.noaccel=1" to the iso, I'll just test it works ok on my nvidia which works fine (pfix=ram)..

Just for reference, here's my glxgears numbers with the default as it stands now:

# glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
3941 frames in 5.0 seconds = 788.146 FPS
4117 frames in 5.0 seconds = 823.320 FPS
4147 frames in 5.0 seconds = 829.196 FPS
# export vblank_mode=0
# glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
4974 frames in 5.0 seconds = 992.166 FPS
5085 frames in 5.0 seconds = 1016.974 FPS
5031 frames in 5.0 seconds = 1004.453 FPS
5098 frames in 5.0 seconds = 1019.527 FPS

GS8400 nvidia

-------------------------------------------------------

More here in a moment...

..back already

Seems perfectly acceptable Smile

# report-video
VIDEO REPORT: PHATSlacko Puppy, version 5.5.02

Chip description:
VGA compatible controller: nVidia Corporation G98 [GeForce 8400 GS] (rev a1)

Requested by /etc/X11/xorg.conf:
Resolution (widthxheight, in pixels): 1024x768x16
Depth (bits, or planes): 24
Modules requested to be loaded: dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
Driver loaded (and currently in use): nouveau
Loaded modules: dbe dri dri2 exa extmod fb glx kbd mouse record shadowfb

Actual rendering on monitor:
Resolution: 1366x768 pixels (361x203 millimeters)
Depth: 24 planes

...the above also recorded in /tmp/report-video
# glxgears
1982 frames in 5.0 seconds = 396.294 FPS
2055 frames in 5.0 seconds = 410.982 FPS
2155 frames in 5.0 seconds = 430.972 FPS
# export vblank_mode=0
# glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
1762 frames in 5.0 seconds = 352.383 FPS
1717 frames in 5.0 seconds = 343.355 FPS
1736 frames in 5.0 seconds = 347.096 FPS


Thanks for that James

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5445
Location: Kentucky

PostPosted: Mon 08 Apr 2013, 01:11    Post subject:  

Went ahead and did a frugal install of PHATSlacko on the dual-core with the troublesome Nvidia chip.No problems after adding nouveau.noaccel=1.

# report-video
VIDEO REPORT: PHATSlacko Puppy, version 5.5.02

Chip description:
VGA compatible controller: nVidia Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)

Requested by /etc/X11/xorg.conf:
Resolution (widthxheight, in pixels): 1024x768x16
Depth (bits, or planes): 24
Modules requested to be loaded: dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
Driver loaded (and currently in use): nouveau
Loaded modules: dbe dri dri2 exa extmod fb glx kbd mouse record shadowfb

Actual rendering on monitor:
Resolution: 1440x900 pixels (380x238 millimeters)
Depth: 24 planes

...the above also recorded in /tmp/report-video
# glxgears
1376 frames in 5.0 seconds = 275.070 FPS
1510 frames in 5.0 seconds = 301.832 FPS
1535 frames in 5.0 seconds = 306.827 FPS
1508 frames in 5.0 seconds = 301.493 FPS
1495 frames in 5.0 seconds = 298.953 FPS

-Computer-
Processor : 2x AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
Memory : 3888MB (230MB used)
Machine Type : Physical machine
Operating System : PHATSlacko Puppy - 5.5.02
User Name : root (root)
Date/Time : Mon 08 Apr 2013 12:13:00 AM CDT
-Display-
Resolution : 1440x900 pixels
OpenGL Renderer : Gallium 0.4 on llvmpipe (LLVM 0x300)
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : HDA-Intel - HDA NVidia

Code:
# free
             total         used         free       shared      buffers
Mem:       3888008       915720      2972288            0        66776
-/+ buffers:             848944      3039064
Swap:      6211580            0      6211580
#
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 1925
Location: Ontario Canada

PostPosted: Tue 09 Apr 2013, 20:58    Post subject: PHATSlacko - March 2013  

I have a computer with intel 4000 graphics, it's working well in
PHATSlacko.
video-info-glx 1.5.3 Tue9Apr 2013onPHATSlacko Puppy 5.5.02 Linux 3.8.5.1 i686
2.0 VGA compatible controller: Intel Corporation Device 0166 (rev 09)
oem: Intel(R) Sandybridge/Ivybridge Graphics Chipset Accelerated VGA BIOS
product: Intel(R) Sandybridge/Ivybridge Graphics Controller Hardware
Version 0.0
X Server: Xorg Driver: intel
X.Org version: 1.12.3
dimensions: 1920x1080 pixels (507x285 millimeters)
depth of root window: 24 planes
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile x86/MMX/SSE2
OpenGL version string: 2.1 Mesa 8.0.4
# glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
303 frames in 5.0 seconds = 60.441 FPS
301 frames in 5.0 seconds = 60.001 FPS
301 frames in 5.0 seconds = 60.000 FPS
#
Nexuiz works great Smile

EDIT: after using this for a few hours it's working great, thanks.
Back to top
View user's profile Send private message 
jenom

Joined: 04 Jun 2013
Posts: 8

PostPosted: Tue 04 Jun 2013, 21:14    Post subject:  Skype 4.0 in Phat is 423 MB download ?  

Downloaded and installed Phat on a Lenovo T61.....works very well
However, when I tried to install SKYPE 4.0 with pkg manager from slackware repositories......checked fro dependencies.....it will be a huge 423 MB download !!!
Anybody can verify this ?
Thanks!
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1273
Location: Malvern, Worcs, UK

PostPosted: Wed 05 Jun 2013, 02:06    Post subject: Re: Skype 4.0 in Phat is 423 MB download ?  

jenom wrote:
Downloaded and installed Phat on a Lenovo T61.....works very well
However, when I tried to install SKYPE 4.0 with pkg manager from slackware repositories......checked fro dependencies.....it will be a huge 423 MB download !!!
Anybody can verify this ?
Thanks!


Try Skype 4.2 - about 50MB for the 2 sfs's - should work fine on PhatSlacko

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7547
Location: qld

PostPosted: Wed 05 Jun 2013, 08:27    Post subject: Re: Skype 4.0 in Phat is 423 MB download ?  

peebee wrote:
Try Skype 4.2 - about 50MB for the 2 sfs's - should work fine on PhatSlacko


Well and good to try skype-4.2 but there is skype-4.1 in the Sfs Manager from the Setup menu.

Be aware too that Qt (the other sfs peebee mentions in the post linked) is already on the PHATSlacko Adrive (ie: is part of the system). Only the skype sfs is needed. Getting the other Qt sfs linked won't do any harm but will waste valuable resources on your system.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 1273
Location: Malvern, Worcs, UK

PostPosted: Wed 05 Jun 2013, 10:03    Post subject: Re: Skype 4.0 in Phat is 423 MB download ?  

01micko wrote:
Be aware too that Qt (the other sfs peebee mentions in the post linked) is already on the PHATSlacko Adrive (ie: is part of the system). Only the skype sfs is needed.


I've edited my Skype thread to make this clear (I hope).

P.

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
jenom

Joined: 04 Jun 2013
Posts: 8

PostPosted: Wed 05 Jun 2013, 17:26    Post subject:  

thanks for the info
I am going to try first 4.0 without qt....to see what happens
I am not familiar (yet), what to do with sfs files
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2445
Location: Texas, USA

PostPosted: Thu 20 Jun 2013, 17:17    Post subject:    

Hi mick,

My health has kept me from my computer, however, I finally got around to checking out your PHATSlacko. It's a super distribution with everything checked working great Very Happy on my hardware except for the nvidia driver.

PPM NVIDIA driver installation did not work so I had to revert back to nv. When trying to compile the latest driver '319.23', I get an error: "Unable to find the system utility 'ldconfig'; make sure you have the package 'glibc' installed." This usually indicates that the devx or kernel source is not loaded. I was under the impression that they are contained in the adrive. Also, I haven't found the scripts used to edit the adrive. Is there a pet utility available for edit of the adrive?

Thanks for continuing to support Bibletime which installed fine using the PPM. Very Happy

Thanks again, Very Happy
Jim

Equipment: BFG NVIDIA Geforce 8400 GS 512MB, Asus P6T Motherboard, Intel core i7-920 (8MB Cache, 2.66 GHz), DDR3 3GB 1333MHz ram, Pioneer DVR-2910 DVD+-RW Dual Layer Burner, Realtek ALC1200 Audio, HP Photosmart C5280 All-in-One Printer
Back to top
View user's profile Send private message 
Colonel Panic


Joined: 16 Sep 2006
Posts: 1443

PostPosted: Sat 28 Sep 2013, 12:30    Post subject:  

I've not long ago downloaded 5.5.02 and am happy to say that it's working well. I also like the fact that it can install programs with .deb and .rpm extensions.
_________________
Compaq Deskpro Pentium III (866 MHz), 512 MB of RAM, 30 GB hard drive running Puppy Fire Hydrant Inferno, Puppy Precise 5.71 Retro, Puppy 5.5 Wary, Puppy Deeper Thought 4.20 and Puppy Legacy OS2.1 LTS.
Back to top
View user's profile Send private message 
umair

Joined: 25 Dec 2010
Posts: 200
Location: KUST Kohat, Pakistan

PostPosted: Sat 12 Oct 2013, 14:01    Post subject:  

Refer to my post regarding Jitsi (VOIP Protocol)
http://murga-linux.com/puppy/viewtopic.php?search_id=710012937&t=82679
Jitsi working Nicely without any issue in PHAT Slakco Smile.
UMAIR
capture2.jpg
 Description   
 Filesize   85.65 KB
 Viewed   210 Time(s)

capture2.jpg

Back to top
View user's profile Send private message Yahoo Messenger 
toronado

Joined: 04 Sep 2013
Posts: 94

PostPosted: Tue 05 Nov 2013, 02:28    Post subject:  installing PHATSlacko
Subject description: what is the correct method?
 

So after using the universal installer to frugal install and finding that there was no Menu>Network>Samba Simple Management, and that several of the desktop icons do nothing when you click them, I found this thread and manually copied the adrv_slacko_5.5.02.sfs to the install directory. This gave me the Menu>Network>Samba Simple Management but the "write" and "calc" desktop icons still do nothing.

What is the correct method to install this? Boot from the CD and use the Universal Installer and then manually copy the adrv_slacko_5.5.02.sfs from the CD, or do not run the universal installer at all and instead just manually copy each of these files from the CD to the install directory:
vmlinuz
initrd.gz
puppy_slacko_5.5.05.sfs
adrv_slacko_5.5.02.sfs

???
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 8 of 10 [140 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0887s ][ Queries: 13 (0.0071s) ][ GZIP on ]