Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Jul 2015, 13:06
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
D-Link wireless adapter
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 15 May 2005
Posts: 112
Location: Sydney, Australia

PostPosted: Mon 01 Apr 2013, 17:57    Post_subject:  D-Link wireless adapter  

I just posted the message below to Users forum - just realised it should be here:

I'm desperate! Frugal-installed Lucid Puppy 528 can't see the D-Link DWA125 wireless adapter. I checked the web to see if there was a linux driver for it - but no luck. I also tried the drivers listed in the network wizard.
Before, I had a Netcomm adapter that worked OK using ndiswrapper, (until it conked out!), but ndiswrapper seems unable to use the Windows XP D-Link driver.
Any help would be greatly appreciated.
Back to top
View user's profile Send_private_message 

Joined: 24 Aug 2005
Posts: 1614
Location: Maine, USA

PostPosted: Sat 06 Apr 2013, 14:36    Post_subject:  

Thanks for posting your request. I consider myself to be a maintainer of lucid pup 528, so am interested in resolving your driver problem, as a possible update to lupuplus. There are 2 linux drivers available, at least one of which should work for you. They were omitted from lupuplus due to the complexity of interaction/interference among several drivers for the same device types.

I would like you to try both drivers on lupuplus 528, but as separate installs because they might conflict if installed together. The result of your testing might be my integration of these drivers into lupuplus via an upgrade pet package.

The preferred driver would be this, if it works for you:
at http://www.murga-linux.com/puppy/viewtopic.php?p=481085#481085
(Ignore the other 2 drivers there, because they are already part of lupuplus.)

If that is unsuccessful, uninstall it, then install the older driver:
at http://www.murga-linux.com/puppy/viewtopic.php?p=513360#513360

Please report back what happens. If you succeed, I hope you will consider assisting me while I integrate the drivers into an upgrade package, by testing the end product.

I just posted the message below to Users forum - just realised it should be here:
I think the Users forum is the best place to post a request for assistance, because more people look there. The "Additional Software" forum is for solutions, so that people can find them without having to ask. R
Back to top
View user's profile Send_private_message 

Joined: 10 Jun 2005
Posts: 5376
Location: Australia

PostPosted: Mon 08 Apr 2013, 21:41    Post_subject:  

The D-Link DWA-125 has been discussed on this forum as far back as May 2011 -
and since the kernel under discussion in that thread is the same as in Marcel's Lucid Puppy 528, the rt3070sta driver discussed there is compatible ... assuming Marcel's USB device ID is the same.

... however, any attempt to configure ndiswrapper will most likely have the startup scripts load the ndiswrapper kernel module - and this will conflict with the Linux (rt3070sta) driver.
ndiswrapper must be uninstalled, or failing that, a fresh installation of Lucid 528 will be required.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0462s ][ Queries: 12 (0.0037s) ][ GZIP on ]